15:00:48 <ad_rien_> #startmeeting massively_distributed_clouds
15:00:49 <openstack> Meeting started Wed Jul 19 15:00:48 2017 UTC and is due to finish in 60 minutes.  The chair is ad_rien_. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:54 <openstack> The meeting name has been set to 'massively_distributed_clouds'
15:01:15 <ad_rien_> #chair ad_rien_
15:01:16 <openstack> Current chairs: ad_rien_
15:01:54 <jamemcc> Hello
15:02:01 <ad_rien_> #topic roll call
15:02:20 <ad_rien_> Hi folks, please remind to add you nick in the pad
15:02:48 <ad_rien_> #link https://etherpad.openstack.org/p/massively_distributed_ircmeetings_2017  agenda line 924
15:03:22 <ad_rien_> so I don't know how many guys will attend today the meeting. From Inria we are only me and dpertin if I'm right
15:03:44 <ad_rien_> #chair parus
15:03:45 <openstack> Current chairs: ad_rien_ parus
15:04:01 <ad_rien_> ok so let's start
15:04:08 <ad_rien_> #topic announcements
15:04:23 <ad_rien_> I added a couple of information in the pad.
15:04:52 <ad_rien_> Regarding the sydney submissions, I am aware of three proposals
15:04:58 <ad_rien_> is there any other?
15:05:13 <jamemcc> I added that there is one from LCOO as well
15:05:17 <parus> I also made a proposals about use cases.
15:05:32 <parus> I have not heard back
15:05:39 <ad_rien_> ok sorry jamemcc (I just saw that now)
15:05:46 <jamemcc> I know that this question/overlap of the LCOO work on Extreme Testing had come up here before
15:05:54 <jamemcc> So I just added those links as well
15:06:00 <ad_rien_> great thanks
15:06:33 <jamemcc> When we can get either SamP or Gautam Divgi here - would be a better time for Q&A
15:06:45 <ad_rien_> ok
15:06:48 <jamemcc> I'll work on that and getting it into the main agenda ahead of time
15:06:55 <ad_rien_> thanks
15:07:02 <ad_rien_> can you please add an action in the pad ;)
15:07:03 <ad_rien_> thanks
15:07:15 <ad_rien_> So regarding the first cross WG meeting.
15:07:35 <ad_rien_> it took place this morning (quite early or quite lately depending where you are worldwide :-P)
15:08:01 <jamemcc> Yes - I feel badly for not getting to it after working to set it up
15:08:07 <ad_rien_> While we didn't define any concrete action, I think it is a good way to share information between WGs/teams
15:08:32 <jamemcc> But you and the other 2 WG Chairs and UC lead MRHillsman really did a great example of what it can be like
15:08:33 <ad_rien_> For instance, the Scientific WG is intensively working on Federation issue
15:08:38 * ad_rien_ is looking for the URL
15:09:08 <ad_rien_> #link https://review.openstack.org/#/c/400738/3/user-stories/proposed/federated-identity.rst Federation use-case described by Scientific WG
15:11:08 <ad_rien_> the UC opened a new irc chat room where you can ask any kind of questions.
15:11:42 <ad_rien_> so do not hesitate to join this channel if you want further information
15:12:13 <ad_rien_> Last but not the least, We talked a few weeks ago about a possible opendev event next september. I received an email two days ago about the foundation
15:12:24 <ad_rien_> (I put information within the pad, line 952)
15:12:50 <mrhillsman> that channel is #openstack-uc btw :)
15:13:10 <ad_rien_> So this is not an open event like the summit but if you are interested by attending it. Please put your name/email in the pad. I should forward those emails to the foundation.
15:13:13 <ad_rien_> mrhillsman:  thanks
15:13:18 <ad_rien_> it is in the pad ;)
15:13:32 <mrhillsman> aha :)
15:13:51 <ad_rien_> From Inria, we will try to send one or two persons at least (we are currently checking who is available)
15:14:12 <ad_rien_> that's all for the announcement from my side.
15:14:24 <ad_rien_> Any news/comments from your side guys?
15:14:26 <jamemcc> This seems to me to be related to the Use Case discussion
15:15:05 <parus> jamemcc: what is related to Use Case?
15:15:11 <jamemcc> I had a verbal conversation with Kandan of AT&T who indicated that a significant part of that conference will be to go through various Use Cases
15:15:32 <ad_rien_> jamemcc:  Yes at the first sight but actually if you dive into details it seems that they want to have technical and specific discussions.
15:15:33 <jamemcc> RElated to: https://docs.google.com/presentation/d/1sBczuC2Wu1d_misBmPahLPdvyhOI4QuVy129EHunuUM/edit?usp=sharing
15:16:01 <parus> jamecc: Will Kandan be at the opendev event?
15:16:20 <ad_rien_> he is in the PC.
15:16:25 <ad_rien_> If I'm correct.
15:16:40 <jamemcc> @parus - the conference in September:  http://www.opendevconf.com/
15:16:52 <jamemcc> Yes
15:16:58 <jamemcc> Yes - he is in the PC
15:17:14 <ad_rien_> Can we move to the next topic (unless there is other news to share)?
15:17:18 <parus> OK! I will plan to attend.
15:17:33 <mrhillsman> agree with ad_rien_ from my discussion with Lauren Sell, it will be focused on what work to do for edge/fog in open tech and i assume who will do what
15:18:49 <ad_rien_> so next topic :) (sorry but the more time we have for discussing on-going actions, the better it is ;))
15:18:51 <ad_rien_> ?
15:19:02 <mrhillsman> ++
15:19:22 <ad_rien_> #topic on-going action: AMP alternatives
15:19:30 <kgiusti> hey
15:19:33 <ad_rien_> ansmith:  kgiusti:
15:19:34 <ad_rien_> :)
15:19:36 <ad_rien_> thanks
15:19:53 <kgiusti> slow progress - some external issues (customers, bugs etc)
15:20:15 <kgiusti> updated epad.  Still 2 outstanding kolla-ansible reviews
15:20:24 <kgiusti> but not much else to report.
15:20:43 <kgiusti> ansmith: anything I missed?
15:20:58 <ansmith> that is it
15:21:12 <ad_rien_> ok from Inria, Matthieu is on vacations. He sent me an email this morning, telling me that he will spend some times on synchronizing enos with the kolla master after August, the 15th.
15:21:32 <ad_rien_> so nothing more from our side too
15:21:37 <kgiusti> 8/15 - understood, thanks.
15:21:55 <ad_rien_> if there is nothing to add let's move to  Cockroach
15:22:08 <kgiusti> +1
15:22:20 <ad_rien_> #topic on-going action: cockroachDB
15:23:20 <ad_rien_> So we made concrete actions from our side that enabled us to unfortunately discover lot of issues regarding the compliance between cockroach and SQLalchemy
15:24:21 <parus> ad_rien_: Have you documented those issues somewhere?
15:24:27 <ad_rien_> Ronan and Antoine are offline today but basically they faced a lot of issue that prevents OpenStack to use directly sqlachemy on top of cockroach. They should make a point with cockroach folks by beginning of august
15:25:17 <ad_rien_> Ronan is working on a long email If I correctly understood. He wants to send this email and arrange another meeting with the cockroach guys
15:25:47 <ad_rien_> they suceeded to start a keystone on top of cockroach but they had to do a lot of hack to do it
15:26:11 <ad_rien_> that's all
15:26:34 <ad_rien_> unless there are questions/remarks, we can move to the next topic?
15:27:42 <ad_rien_> seems we can :)
15:28:02 <ad_rien_> #topic on-going action: use-case specifications
15:28:30 <parus> We have made good progress on  use cases. I have updated the slides per my action.
15:28:46 <ad_rien_> thanks parus
15:28:50 <parus> And we received a great deck from Daniele.
15:28:59 <ad_rien_> I went through the two presentations and I put some comments from my side
15:29:07 <ad_rien_> maybe we can go through them shortly
15:29:14 <parus> Please.
15:29:30 <ad_rien_> we can spend 15 min on this action if everyone agrees?
15:29:43 <dsantoro> ok for me
15:29:45 <ad_rien_> so let's start with the FBK presentation
15:29:54 <ad_rien_> #link  https://docs.google.com/presentation/d/1FLCjUx1xiQxRcgTG78vg255g6N2RRp8_W0B0Sz0bJH8/edit#slide=id.p46
15:30:22 <dsantoro> @ad_rien_: I ve jsut replied to comments but if you have any other question or details I am here
15:30:22 <ad_rien_> so first of all thanks dsantoro for those slides
15:30:26 <ad_rien_> quite helpfull
15:30:51 <ad_rien_> so in the first use case.
15:30:54 <ad_rien_> Slide 10
15:31:07 <ad_rien_> you do not use Compute 1 and 2
15:31:28 <ad_rien_> you put them just to because they are there but they are not used. Did I understand correctly ?
15:31:33 <dsantoro> no this is a baseline use-case and we need it mostly to be able to do a comparison between
15:31:46 <dsantoro> having application on the cloud VS having them on the edge
15:31:52 <ad_rien_> ok
15:32:06 <ad_rien_> so in this baseline use-case everything is executed in the cloud
15:32:08 <dsantoro> in that UC1 we just put application on compute 0 which is located somewhere in the cloud
15:32:09 <ad_rien_> right?
15:32:18 <ad_rien_> ok
15:32:25 <dsantoro> and is charaterized by low bandwidth and high latency
15:32:43 <dsantoro> yes you are right
15:32:48 <ad_rien_> ok
15:33:26 <ad_rien_> thanks regarding low bandwidth (and actually this is also a question I have for parus). Once you are in the backhaul, the bandwith is generally large.
15:33:47 <ad_rien_> (it depends obviously if you have a DSL connexion or a fiber one)
15:34:18 <ad_rien_> so maybe it would be usefull to mention what kind of connexions you have between Compute 1/2 and Compute 0
15:35:16 <dsantoro> I agree, we can specify it. We suppose to have a WANWide connection between those computes
15:35:26 <ad_rien_> yes but WANwide means so many things
15:35:30 <ad_rien_> if you are an operator (a telco)
15:35:43 <dsantoro> in the links we put just some example of bandwidth in Mbit
15:35:48 <ad_rien_> once you are in the backhaul the bandwidth is rather 10gbps (and sometimes even more)
15:36:16 <parus> ad_rien_: I do not have precise data on backhaul BW. But sometimes it is scarce.
15:36:19 <ad_rien_> if you are an end-users we a xDSL connexion, you're right having a couple of Mbits is the maximum you can have
15:36:54 <ad_rien_> parus:  +1,  that's why we should clarify that point I think
15:37:02 <dsantoro> I agree but I think it also depends on the kind of connection that the infrastructure provider has towards the backhaul. right ?
15:37:12 <ad_rien_> yes
15:37:38 <ad_rien_> so it is better to specify it. some people also consider that edge devices will be connected through WIFI connexions to fiber POPs
15:37:40 <parus> It depends on the Backhaul Technology. It depends if the operator owns the backhaul or needs to lease it.
15:37:44 <ad_rien_> (POP, network point of presence)
15:37:49 <ad_rien_> exactly
15:38:12 <ad_rien_> don't get me wrong, I didn't say you are wrong, just say that we should explain that.
15:38:24 <ad_rien_> that, i.e. these differences viewpoint.
15:38:35 <ad_rien_> s/differences/different
15:38:36 <ad_rien_> sorry
15:38:44 <parus> Point Taken!
15:39:04 <ad_rien_> ok I do not have additional remarks on those first slides from my side.
15:39:17 <ad_rien_> does anyone want to add something?
15:39:51 <ad_rien_> … yes, dsantoro I forgot to mention that it would be nice that you explain why you are leveraging OpenStack
15:39:54 <dsantoro> we envision a scenario in which the municipality is the infrastructure owner (owner of the sensor network) so the bandwidth depends on the type of connection it has with the rest of the world
15:39:57 <ad_rien_> and not simply k8S
15:40:13 <dsantoro> ok
15:40:18 <parus> There are a number of things identified in slide 15
15:40:19 <jamemcc> I can speak to backhaul from the large mobile provider point of view in general
15:40:20 <dsantoro> we can add a slide pointing this out
15:40:22 <ad_rien_> you already explained me in a previous exchange but I think it would be valuable for everyone to know why
15:40:24 <ad_rien_> thanks
15:41:01 <ad_rien_> jamemcc:  I think it would be great if you can work with parus on one dedicated slide to explain the different viewpoints for the network bandwidth/latency challenges
15:41:34 <dsantoro> @parus: https://github.com/cockroachdb/cockroachvation on slide 15 but we could add other if valuable
15:41:59 <parus> #action jamecc and parus to work on a Backhaul slide
15:42:03 <dsantoro> @parus: yes we added some motivation on slide 15 but we could add other if valuable
15:42:39 <ad_rien_> ok let's move to the second deck
15:42:40 <ad_rien_> ok ?
15:42:50 <dsantoro> ok
15:42:51 <parus> ok?
15:42:52 <ad_rien_> #link 1sBczuC2Wu1d_misBmPahLPdvyhOI4QuVy129EHunuUM
15:43:08 <ad_rien_> sorry my bad
15:43:16 <ad_rien_> #link https://docs.google.com/presentation/d/1sBczuC2Wu1d_misBmPahLPdvyhOI4QuVy129EHunuUM/edit?usp=sharing use-case slides
15:44:00 <ad_rien_> so my comments on slide 5 and 6 will be addressed ;) so no need to discuss them
15:44:14 <ad_rien_> Slide 11.
15:44:38 <ad_rien_> I think we can add one item regarding network partitionnng issue
15:44:52 <parus> What do you mean?
15:44:58 <ad_rien_> what does happen if we lose the connexion between some control services and compute nodes?
15:45:14 <ad_rien_> if the disconnection lasts a couple of seconds/minutes this should be ok
15:45:17 <ad_rien_> for the control plane
15:45:32 <parus> That is a good point.
15:45:33 <ad_rien_> but what does happen if it lasts one hour
15:46:05 <ad_rien_> and obviously these questions are relevant for each of the deployment scenarios you illustrate (central control services/remote computes, regions, cells)
15:46:21 <ad_rien_> (thanks BTW for the slides once again really helpful)
15:46:49 <ad_rien_> Regarding the 4th question, not sure I correctly understood. Can you please elaborate a bit parus?
15:47:02 <dsantoro> that is an important topic also for us. We would like to address decentralization in our UCs in the future (see FBK slide 15 point 3)
15:47:25 <parus> item 4 is about VLAN.
15:48:02 <parus> Depending if we have a L2 or a L3 network implementation, the solutions to separate control, management and user traffic would be different.
15:48:12 <ad_rien_> ok
15:48:13 <ad_rien_> thanks
15:48:54 <ad_rien_> Slide 13.
15:49:04 <ad_rien_> can you clarify the relations to slicing issue?
15:49:35 <parus> There is a lot of activity around Network Slicing in particular in relation to 5G.
15:50:01 <parus> Network slices, affect RF, RAN, Core.
15:50:07 <parus> Shoudl it affect Edge too?
15:51:14 <ad_rien_> so it is 5G related ?
15:51:22 <parus> It is really a wireless use case question in relation to 5G.
15:51:25 <ad_rien_> I mean here also if you are considering WIFI links
15:51:53 <ad_rien_> or if you consider edge clouds that are interconnected with other clouds through wired cables?
15:52:26 <ad_rien_> maybe you can put a link/reference in the slide to help the reader
15:52:40 <parus> good point.
15:52:49 <dsantoro> I suppose network slicing affects Edge ie: If you have many tenants running application on edge nodes and they have each one special network requirements…
15:53:42 <ad_rien_> 8 min left
15:53:49 <ad_rien_> let's move to the slide 15
15:53:52 <ad_rien_> I really like it :)
15:54:06 <ad_rien_> I think it gives an excellent overview of all the questions we should answer.
15:54:39 <parus> We also had an email exchange on things with FBK on things that might be needed from Openstack and Kubernetes.
15:54:40 <ad_rien_> so a general comment. It would be great if we can have one slide for each entry
15:54:56 <ad_rien_> as the slide 16 for Entry 1
15:55:12 <dsantoro> Why not add also storage capabilities on edge nodes on slide 15 ?
15:55:14 <ad_rien_> and then we will be able to idenfity concrete actions to move forward on each entry
15:55:24 <ad_rien_> we can dsantoro
15:55:26 <ad_rien_> I think
15:55:32 <ad_rien_> this is also a good comment
15:55:39 <ad_rien_> SWIFT is distributed by default
15:56:06 <ad_rien_> but deploying SWIFT on top of a fog/edge infrastructure can highlight possible issues/performance degradations ....
15:56:36 <ad_rien_> So I think we can try to explain in details each entry and what is/are the challenges related to each one
15:56:49 <ad_rien_> We already discussed with dpertin Entry 1
15:57:05 <parus> this would be the goal.... Help would be welcome in expanding that.
15:57:28 <ad_rien_> and we will conduct preliminary experiments to see whether there is/are real challenges or ''just'' technical issues
15:57:35 <ad_rien_> parus:  I can help you by exchaning by mail
15:57:45 <ad_rien_> if it can help
15:57:57 <parus> Great!
15:58:12 <ad_rien_> (I will ask also one of my colleague here that can be interested to take part in this action) I will get back to you by the end of the week
15:58:30 <ad_rien_> but please keep in mind that the period is not really the best one in France (summer vacations)
15:58:34 <ad_rien_> ok two min left
15:58:54 <ad_rien_> #topic open discussion
15:59:18 <ad_rien_> ok who plan to attend the sydney summit
15:59:26 <parus> I will.
15:59:29 <ad_rien_> from my side it is still unclear whether I can go or not
15:59:36 <ad_rien_> dpertin will represent Inria
15:59:51 <dsantoro> We will be there, probably two people from FBK
16:00:08 <ad_rien_> ok great
16:00:22 <ad_rien_> ok we have to end the meeting
16:00:26 <ad_rien_> thanks you folks
16:00:30 <parus> thx
16:00:35 <ad_rien_> #endmeeting