15:00:08 <ad_rien_> #startmeeting massively_distributed_clouds
15:00:09 <openstack> Meeting started Wed Oct 11 15:00:08 2017 UTC and is due to finish in 60 minutes.  The chair is ad_rien_. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:13 <openstack> The meeting name has been set to 'massively_distributed_clouds'
15:00:24 <ad_rien_> #chair ad_rien_ parus
15:00:25 <openstack> Current chairs: ad_rien_ parus
15:00:44 <ad_rien_> #topic roll call
15:00:46 <parus> Good Morning / Afternoon :-)
15:00:47 <ad_rien_> Hi guys
15:00:51 <dancn> hi!
15:00:53 <ansmith> o/
15:01:04 <georgk> hi
15:01:30 <kgiusti> hey!
15:01:33 <ad_rien_> Please do not forget to add your name in the pad
15:01:58 <ad_rien_> #info agenda
15:01:58 <ad_rien_> #link https://etherpad.openstack.org/p/massivfbely_distributed_ircmeetings_2017  (line 1314)
15:02:12 <jamemcc_> Hi
15:02:45 <ad_rien_> Hi jamemcc_
15:02:50 <ad_rien_> anyone else?
15:03:16 <ad_rien_> ok so let's start
15:03:29 <ad_rien_> So today I would like to change a bit the way we manage the announcement
15:03:41 <ad_rien_> (just to try to be as fruiftull as possible)
15:03:45 <ad_rien_> So latest news are on the pad.
15:03:55 <ad_rien_> if you have questions / comments , please feel free ;)
15:04:09 <ad_rien_> The same, please if you want to add some elements
15:04:19 <ad_rien_> do not hesitate to complete the current items
15:04:20 <ad_rien_> thanks
15:05:10 <jamemcc_> ok, good approach s we usually use up all the time
15:05:11 <ad_rien_> ok any comments
15:05:33 <ad_rien_> ok so let's focus on the on going activities
15:05:38 <ad_rien_> #topic announcement
15:05:42 <ad_rien_> please see the pad
15:05:49 <ad_rien_> #topic on-going activities
15:06:05 <ad_rien_> Who starts ?
15:06:08 <ad_rien_> Daniele?
15:06:18 <ad_rien_> could you please tell us a few words regarding your presentation?
15:06:20 <dancn> I will add a recap on behalf of dsantoro on the ehterpad
15:06:28 <rcherrueau> o/ (sorry I am late)
15:06:43 <Alexvk> Hi everyone
15:06:48 <ad_rien_> dancn:  ACK ;)
15:07:14 <dancn> point that may require a discussion:
15:07:32 <dancn> somebody will be at https://www.fogworldcongress.com/ ?
15:08:00 * ad_rien_ is looking for dates/locations
15:08:13 <dancn> October 30 - November 1, 2017 | Santa Clara, CA
15:08:38 <ad_rien_> not from Inria
15:09:04 <dancn> This setup is enough stable for our demo, we do not plan to work aggressively on those issues, but if you have suggestion please go ahead!
15:09:07 <ad_rien_> will someone from FBK attend this event?
15:09:33 <dancn> yes Silvio Cretti and Domenico Siracusa
15:10:16 <dancn> they are currenly "area head" of a couples of areas (cloud and networking) here in FBK
15:10:30 <ad_rien_> ok
15:10:41 <ad_rien_> will you (FBK) present something?
15:10:58 <ad_rien_> ok
15:11:00 <ad_rien_> sorry
15:11:06 <ad_rien_> forget my question
15:11:13 <ad_rien_> the answer is on the text you copied/pasted
15:11:13 <dancn> sorry, maybe I pasted too much info in the ehterpad
15:11:20 <ad_rien_> :)
15:11:34 <pramchan_> #info pramchan
15:11:50 <ad_rien_> dancn:  sorry should we discuss one particular point?
15:12:04 <ad_rien_> there is indeed several informations in the text you pasted
15:12:10 <pramchan_> #is there a Audio call to connect to link please?
15:12:17 <ad_rien_> no pramchan_
15:12:22 <dancn> only this point:
15:12:23 <pramchan_> OK
15:12:27 <dancn> This setup is enough stable for our demo, we do not plan to work aggressively on those issues, but if you have suggestion please go ahead!
15:12:43 <ad_rien_> pramchan_:  https://etherpad.openstack.org/p/massively_distributed_ircmeetings_2017 line 1313
15:13:31 <parus> dancn: question
15:13:39 <ad_rien_> dancn:  regarding the issue line 1362. Are you in touch with Neutron developpers?
15:13:52 <parus> at line 1354 you say default is to route to controller.
15:13:55 <ad_rien_> it may make sense to contact them
15:14:14 <parus> But if I read this right when you installed DVR, you did route directly?
15:14:52 <dancn> ad_rien_: no contact, maybe somebody here can introuce us, or maybe we can have a joint talk in person in sydney
15:15:24 <dancn> parus: the dvr_snat was installed on the edge node
15:16:00 <dancn> it seems to be possile to have different dvr_snat in different nodes
15:16:25 <parus> Yes
15:16:26 <dancn> but we werent able to configure them in a progammatical way
15:16:47 <dancn> .
15:16:55 <msimonin> Since it's kolla based deployment, maybe there's something missing in Kolla ?
15:17:00 <ad_rien_> dancn:  my proposal is to try to isolate those issues (i.e. the one line 1365)
15:17:43 <ad_rien_> and if you can isolate them (i.e. ensure that those issues do not come from an external third party software). Then those bugs should be discussed with Neutron folks
15:17:52 <dancn> msimonin: the conf were done manually after the kolla setup
15:18:30 <dancn> for sure we need some reproducible environment to advance the debug
15:18:37 <rcherrueau> dancn: l.1363, did you mean you have to change the configuration file manually ?
15:19:14 <ad_rien_> ok unfortunately I don't think we can help you now…
15:19:15 <dancn> rcherrueau: yes, after the deploy, to move the snat to the edge node
15:19:26 <rcherrueau> Because, kolla offer a patch mechanism to change configuration file in programmatic manner
15:19:42 * rcherrueau looking for the doc
15:20:01 <dancn> sure, if you have a pointer welcome! thanks, this end my presentation.
15:20:18 <msimonin> dancn: thanks for the feedback :)
15:20:39 <ad_rien_> ok thanks
15:20:40 <rcherrueau> https://docs.openstack.org/kolla-ansible/latest/admin/advanced-configuration.html#openstack-service-configuration-in-kolla
15:20:54 <ad_rien_> next point OpenStack ++ Presentation
15:20:59 <rcherrueau> search for `node_custom_config`
15:21:19 <ad_rien_> ok maybe I can wait a bit more…. sorry rcherrueau please go ahead
15:21:30 <rcherrueau> note that you can leverage this into enos
15:22:00 <dancn> rcherrueau: tnx, I will forward this to dsantoro that unfortunatly is not here and is the main developer
15:22:09 <ad_rien_> ok
15:22:16 <ad_rien_> anything else gentlemen?
15:22:25 <ad_rien_> can I move to the next point?
15:22:33 <dancn> for me no more, move to next
15:22:39 <pramchan_> #did the inwinstack team provide link to updates OpenStack++ for Ocata?
15:22:52 <ad_rien_> ok so let's move to OpenStack//
15:22:54 <ad_rien_> ++
15:22:55 <ad_rien_> sorry
15:23:18 <ad_rien_> so last week a few of them took part to a presentation made by Satya (from CMU, contact in the pad).
15:23:53 <ad_rien_> The main difference with all the discussions we had in this WG up to now is related to the fact that one of the assumption in the OpenStack ++ work
15:23:56 <pramchan_> OK will follow it offline, rying to catch up, please proceed
15:24:01 <rcherrueau> dancn: OK, good. Tell him to go back to me through the gitter channel if he gets issues with enos
15:24:20 <ad_rien_> is that each edge DC is not linked to the Internet
15:24:58 <ad_rien_> so the issue is mainly how you can use an edge DC when the connectivity is only limited between the mobile device (i.e. a smartphone) and the edge DC (called the cloudlet)
15:25:29 <ad_rien_> Such a strong limitation implies to revise the way end-users use the cloud servers
15:26:01 <ad_rien_> Satya presented several contributions (He gave a few links to academic papers that present the contributions).
15:26:14 <ad_rien_> I will put the link towards his web page later in the pad
15:26:26 <pramchan_> #we need Inter DC connectivity or even within DC nodes i clusters to be able to use cloudlet fully
15:26:38 <ad_rien_> as pramchan_ mentioned inwinstack folks have ported some contributions in the OpenStack
15:27:06 <ad_rien_> when I'm saying in the OpenStack I should rather say through libraries that you can use on top of OpenStack.
15:27:29 <ad_rien_> The meeting was fruitfull
15:28:08 <parus> Anything that influences what we do here?
15:28:10 <ad_rien_> but we should arrange another telco to see how this integration can be done deeper in the OpenStack code (for instance there is an optimization for provisioning the VM image that might be more efficient if it is integrated with the Glance module)
15:28:20 <ad_rien_> thanks parus for the questions
15:28:45 <ad_rien_> From the contributions Satya presented, the work is definitely complementary, meaning that AFAIK we did not address those challenges.
15:29:04 <ad_rien_> The only drawback I saw
15:29:11 <ad_rien_> is the same we have at Inria:
15:29:19 <ad_rien_> This is research work
15:29:46 <ad_rien_> concrete discussions with OpenStack core-developpers didn't start
15:30:15 <ad_rien_> Inwinstack folks are interested to go deeper but I do not have more information on this aspect
15:30:26 <ad_rien_> (not sure I was clear enough…. I hope it is clear)
15:30:41 <pramchan_> yes the cloudlet is focussed on application devlopment and integration with back end cluster or Inter DC nocdes for mobility woll need migration approach
15:31:12 <parus> Very clear thanks. I wonder if there is something we can do to address their prposed architecture. Is there a performance aspect we can investigate?
15:32:13 <ad_rien_> parus:  …
15:32:17 <ad_rien_> this is a good question
15:32:22 <pramchan_> I mean by migration you can develop servral smat apps for AR/VR, SmarCity etc, but to scale we need to migrate them to Service Provider approach to staging and delivering service ona Reliable Scalabile platform, that I will try address in my presenation at OpenStack at Sydney
15:33:14 <ad_rien_> pramchan_:  any link ?
15:33:29 <ad_rien_> I mean one big assumption is that the cloudlet should be self-content
15:33:38 <pramchan_> #plus we need to measure use of resource both compute, storage, and network bandwidth to bill
15:33:40 <ad_rien_> i.e. you may have a limited connections to the internel
15:34:07 <ad_rien_> but this is not critical as the cloudlet (i.e. the VM deployed by the end-user into the edge DC)
15:34:19 <ad_rien_> already have most of the content its need.
15:34:28 <ad_rien_> s/have/has most
15:34:29 <ad_rien_> sorry
15:34:34 <pramchan_> #link Yes Joseph had declared along with Prof Satya at OpenDev and am trying to get the github link for that
15:34:57 <ad_rien_> ok pramchan_ can you please put the link in the pad
15:35:02 <ad_rien_> when you will find it ;)
15:35:11 <pramchan_> #link https://www.openstack.org/summit/sydney-2017/summit-schedule/speakers/1662
15:35:27 <parus> pramchan_: Let's make this a point of discussion for our f2f in sydney.
15:35:48 <ad_rien_> parus:  +1
15:36:24 <ad_rien_> ok let's move forward
15:36:34 <ad_rien_> as it is already XX:35
15:36:42 <ad_rien_> so next point Ericsson presentation
15:37:18 <ad_rien_> georgk:  not sure whether you are in touch with Joao, are you?
15:37:29 <parus> It was a very enjoyable presentation !
15:37:41 <ad_rien_> indeed parus
15:37:48 <ad_rien_> good to see such actions
15:37:56 <ad_rien_> efforts
15:38:09 <georgk> ad_rien_: sorry, I haven´t been in contact with him recently
15:38:13 <ad_rien_> so briefly the idea was to use a P2P agent based approach to use distinct openstacks
15:39:02 <ad_rien_> when a tenant wants to submit a request, he/she is redirected to one agent of the P2P overlay. This agent is in charge of managing the request by communicating with the different openstacks
15:39:13 <ad_rien_> They have a PoC
15:39:18 <georgk> ad_rien_: I will ping him
15:39:31 <ad_rien_> By developping this PoC, they faced several challenges we also faced at Inria
15:40:00 <ad_rien_> We identified a couple of opportunities to collaborate and move forward
15:40:17 <ad_rien_> Joao is not there unfortunately today
15:40:28 <ad_rien_> but there will be another meeting too.
15:40:55 <ad_rien_> (still the same, If you are interested to take part to those exchanges, please add your contact mail below the item in the pad).
15:41:29 <ad_rien_> from my side, I will ask whether Joao can send us a link to the presentation
15:41:39 <ad_rien_> that's all from my side
15:41:42 <ad_rien_> comments/remarks ?
15:42:10 <parus> I liked how ad_rien_ described different approaches to the distribution:  Low layer effort (below openstack, Cockroack), Mid Layer efforts (e.g. regions, cells openstack++ ...), high layer efforts (above openstack e.g. ONAP). But where does P2P fit?
15:42:50 <ad_rien_> that's exactly where we are I think
15:43:02 <ad_rien_> and some discussions we should definitely plan to have soon
15:43:29 <ad_rien_> even yesterday we spent a couple of hours trying to understand whether a distributed DB such as cockroach will be relevant for all services
15:43:34 <ad_rien_> the same for the AMQP bus
15:43:53 <ad_rien_> should we have a distributed one at the higher level and keep the cells appraoch
15:43:57 <ad_rien_> at the low level.
15:44:10 <ad_rien_> I think that is a really interesting and complex discussions
15:44:48 <ad_rien_> but we will have to address it soon and to take notes to be able to advance (right now, at least at Inria, we are going back and forth between our different conclusion).
15:44:56 <parus> We are getting to a point where there are many possible implementations.
15:45:08 <ad_rien_> yepp
15:45:20 <ad_rien_> it would be nice if we can identify pros/cons of each approach
15:45:29 <msimonin> +1 to that ad_rien_
15:45:29 <parus> It would be good to lay down the use cases and do some comparison.
15:45:38 <ad_rien_> this can be a valuable document
15:45:41 <parus> +1
15:46:20 <parus> The use case presentation should help with the comparison.
15:46:30 <ad_rien_> #action start an action to try to identify pros/cons of different solutions: openstack fully distributed, cells/regions, broker based (i.e. onap)
15:46:46 <parus> e.g. What implementation is good at live migration.... what implementation is good at doing rolling upgrades ....
15:47:09 <ad_rien_> maybe we can define a matrix
15:47:16 <ad_rien_> of expected features
15:47:38 <ad_rien_> and see the development effort to be able to deliver those features
15:47:51 <parus> I could see this as a great analysis to present in Vancouver.
15:47:56 <ad_rien_> one more ;)
15:48:03 <ad_rien_> So many challenges for Vancouver ;)
15:48:12 <ad_rien_> but yes definitely
15:48:20 <ad_rien_> Let's take some notes in the pad
15:48:41 <ad_rien_> meanwhile, kgiusti ansmith and msimonin can update us regarding AMQP
15:48:47 <ad_rien_> Guys the floor is yours
15:49:11 <msimonin> so
15:49:22 <msimonin> #link https://review.openstack.org/#/c/491818
15:49:25 <msimonin> is ready for review
15:49:44 <msimonin> it would be great of some of you can go and review it :)
15:50:03 <kgiusti> and the ombt test tool has been updated to provide the proper metrics for the described tests
15:50:26 <kgiusti> msimonin: I've provisionally +1'd it
15:50:45 <msimonin> kgiusti: I made some initial tests, didn't see anything wrong with your patch, so far
15:50:52 <ansmith> msimonin: I will review it next
15:51:11 <msimonin> thanks guys from the performance WG will review it as well
15:51:22 <kgiusti> msimonin: +1 - haven't pushed the new ombt2 to large scale so let me know if you hit anything
15:51:24 <msimonin> ansmith: thanks :)
15:51:36 <pramchan_> #info is there a comparison with MQTT, Kafka etc with AMQP?
15:52:00 <kgiusti> pramchan_: right now openstack does not have MQTT capabilities
15:52:16 <kgiusti> pramchan_: and Kafka is under development but not complete
15:52:28 <pramchan_> #please refer to edgent of Apache projetcs worth looking at
15:52:41 <ansmith> pramchan_: further, kafka will be supported for notifications only
15:52:53 <kgiusti> edgent - will do, thanks
15:53:01 <ad_rien_> kgiusti:  ansmith I just added a question in the pad (line 1395)
15:53:16 <ad_rien_> we would be happy to know some information regarding that point (at least if you have some ;))
15:54:06 <kgiusti> ad_rien_: I don't have those metrics - we'll have to open a dialog with the project's devs
15:54:40 <parus> ad_rien_: I would add one question. How much is AMQP used between projects (e.g. nova to neutron) and how much is it used withing project (neutron client to neutron server)?
15:54:52 <ad_rien_> maybe there can be a way to collect such informations (i.e. not sure whether we have to discuss with all core-devs). Maybe this can be a relevant information for them too.
15:54:58 <kgiusti> ad_rien_: it may be that no one's really spent the time to collect it
15:55:10 <ad_rien_> kgiusti:  +1
15:55:17 <ad_rien_> this is a discussion we had yesterday
15:55:19 <ad_rien_> ok
15:55:28 <ad_rien_> Let's iscuss that point next time (only a few minutes left for parus)
15:55:34 <kgiusti> +1
15:55:35 <ad_rien_> parus:  ?
15:55:48 <ad_rien_> please let's talk about your deck
15:55:49 <ad_rien_> ?
15:55:52 <parus> Very quickly then. I have been working on Use case presentation for Sydney.
15:56:07 <parus> I have a very draft deck that I shared on the etherpad.
15:56:15 <parus> Please provide any comment you can.
15:56:33 <parus> I would like to conclude the deck with an invitation for people to join FEMDC.
15:56:45 <parus> It would be good if someone has material on:
15:56:46 <ad_rien_> sounds good
15:56:49 <ad_rien_> thanks
15:56:54 <parus> 1- What does FEMDC do?
15:57:00 <parus> 2- What is next ?
15:57:05 <ad_rien_> parus I will do such a slide
15:57:13 <parus> Please send me comments.
15:57:24 <ad_rien_> ok anything else
15:57:25 <ad_rien_> ?
15:57:29 <jamemcc_> I'll try to help
15:57:30 <parus> All for me.
15:57:33 <ad_rien_> before moving to the open discussions
15:57:35 <ad_rien_> ok thanks
15:57:39 <ad_rien_> #topic open discussion
15:58:01 <ad_rien_> from my side, I can just mention that we will probably move to a SiG
15:58:05 <ad_rien_> instead of being a Team
15:58:07 <ad_rien_> that's all
15:58:11 <ansmith> msimonin: would it help to setup a call with alex, kgiusti to make introductions?
15:58:14 <ad_rien_> from my side.
15:58:45 <parus> +1 to SIG
15:59:00 <ad_rien_> ok time to conclude
15:59:03 <ad_rien_> anything else
15:59:06 <ad_rien_> ?
15:59:12 <ad_rien_> OK thanks all for comming.
15:59:18 <ad_rien_> s/comming/....
15:59:22 <ad_rien_> keep in touch
15:59:24 <ad_rien_> ++
15:59:27 <ad_rien_> #endmeeting