20:01:34 <sarob_> #startmeeting milk
20:01:34 <openstack> Meeting started Mon Mar 10 20:01:34 2014 UTC and is due to finish in 60 minutes.  The chair is sarob_. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:38 <openstack> The meeting name has been set to 'milk'
20:01:47 <sarob_> Roll call
20:03:13 <sarob_> Keyvan and MrJoshua
20:03:14 <sarob_> Ping!
20:03:21 <MrJoshua> hey
20:03:31 <sarob_> Hey
20:03:36 <e-vad> pong
20:03:44 <MrJoshua> I guess the time moved, because of DST.
20:04:12 <sarob_> Yeah, pain
20:04:29 <MrJoshua> So I just updated the wiki and sit out the getting started mail this morning.
20:04:42 <sarob_> All the Openstack mtgs are keyed off GMT
20:04:50 <sarob_> I saw
20:05:06 <nati_ueno> hi!
20:05:18 <sarob_> Hey there
20:05:36 <MrJoshua> I'm in the thick of it with C4, but I'll try to get the updates to the project pushed to github today or tomorrow AM at the latest.
20:05:55 <sarob_> That's good for me
20:06:30 <sarob_> #topic getting milk contributors ready
20:06:37 <MrJoshua> This includes apiary doc, Django project, and freshen requirements.
20:06:50 <sarob_> Sarob like
20:07:06 <MrJoshua> Any notes on the instructions I sent out?
20:07:29 <sarob_> I've been slammed
20:07:41 <sarob_> I'm going to review today
20:08:09 <sarob_> I assume we are targeting devs
20:08:28 <sarob_> So cut to the meat on contributing
20:08:46 <MrJoshua> If anyone's here that hasn't gotten setup for contributing, please give the instructions a try and tell me if anything is wrong about them.
20:09:31 <sarob_> moving on
20:09:35 <MrJoshua> Yeah, I'm not sure how any non-devs could contribute here, but they can post ideas etc, to the mailing list.
20:09:45 <MrJoshua> k
20:10:02 <sarob_> #action sarob review contributors instructions
20:10:20 <sarob_> #action sarob add non Dev contrib
20:10:35 <MrJoshua> ...and the wiki
20:10:55 <sarob_> #topic code
20:12:09 <sarob_> #action MrJoshua will patch req, apiary doc, django park code
20:12:22 <sarob_> Anything missed?
20:12:46 <MrJoshua> As I integrated my template api with the registry stuff, I realized that it made sense to create a index of categories in the initial api.
20:13:20 <MrJoshua> The idea is we may have multiple version / alternate ideas  and approaches
20:13:42 <sarob_> Smart
20:13:45 <MrJoshua> Well the fact is we already do.
20:14:11 <sarob_> And will
20:14:18 <MrJoshua> So if you go to the root  url "/" it will give you a list of the different API interfaces with some version and description information.
20:14:29 <MrJoshua> and the path to that interface
20:14:34 <sarob_> Nice
20:15:43 <MrJoshua> so for example "/registery/v4", "/experemental", "/bobs_version/" etc.
20:16:31 <MrJoshua> That gives us room to do lots of stuff without too much stepping on each other even in a deployment.
20:16:59 <sarob_> We could branch other sub projects
20:17:14 <sarob_> Before they create their own repos
20:18:02 <MrJoshua> Yeah, of course if something is worth while to follow in more detail, but this will allow us to move quickly and have multiple verations of the API operational on the same server at one.
20:18:06 <MrJoshua> ... time
20:18:20 <sarob_> Sarob like
20:18:49 <sarob_> Anything else?
20:19:02 <MrJoshua> Anyway that's the only news/change on my end.
20:19:22 <sarob_> Moving on
20:19:30 <sarob_> #topic timing
20:19:53 <sarob_> Soo april is looming
20:20:31 <sarob_> Do we continue with that as a deadline for something working
20:20:51 <sarob_> Or just present the collaboration so far at nab?
20:21:14 <MrJoshua> Indeed.  We should start taking a look at what is reasonably possible to finish by then.
20:21:53 <sarob_> Is just keyvan
20:21:59 <sarob_> You and me
20:22:14 <sarob_> Enuf to say collaboration?
20:22:31 <sarob_> It's something for sure
20:22:57 <MrJoshua> We will have the basic client and server to do identification and look up services, but I'm not sure how 'exciting' that is.  Perhaps just a slide show is better.
20:23:40 <sarob_> Demo is always exciting
20:23:55 <sarob_> But it's the collaboration
20:24:15 <sarob_> I'm interested in highlighting
20:24:23 <sarob_> To get more devs
20:24:39 <sarob_> On projects plural
20:24:53 <MrJoshua> Do we actually have any collaboration that's noteworthy yet?  haha
20:25:11 <sarob_> Well across all the projects
20:25:20 <sarob_> A lot of discussion
20:25:43 <sarob_> I want to take what we have so far to another
20:25:52 <sarob_> SVP level meeting
20:26:04 <sarob_> And ask for Dev commitments
20:26:25 <sarob_> They joined etc to collaborate
20:26:31 <MrJoshua> It'll no doubt help to have requirements test in place to provide clear marching orders.
20:26:46 <sarob_> Like a FTE per studio
20:27:22 <sarob_> But I think we need a bit if code and a platform to speak from
20:27:38 <sarob_> Spellcheck hmmm
20:27:46 <MrJoshua> haha
20:28:42 <sarob_> #info goal for spring 2014 and NAB is to get Dev commitment from studios
20:29:08 <sarob_> There I said it out LOUD
20:29:50 <MrJoshua> Haha, yeah boy.  And not just the promise, but people actually showing up to meetings and committing revisions.
20:29:54 <sarob_> I'm close to getting a few others to tag along
20:30:14 <sarob_> I'm done soapboxing for now
20:30:41 <sarob_> #topic any other business
20:31:04 <MrJoshua> Actually I have to go, and I can't think of anything else at the moment.
20:31:22 <sarob_> Anyone else?
20:31:37 <sarob_> Then that is a wrap!
20:31:51 <sarob_> Thx mrjoshua
20:31:59 <sarob_> #endmeeting