20:02:41 <sarob_> #startmeeting milk
20:02:42 <openstack> Meeting started Mon Mar 17 20:02:41 2014 UTC and is due to finish in 60 minutes.  The chair is sarob_. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:02:45 <openstack> The meeting name has been set to 'milk'
20:02:54 <sarob_> roll call
20:03:03 <MrJoshua> I'm here.
20:03:10 <MrJoshua> I think that's it though.
20:03:26 <sarob_> good enough for me
20:03:56 <MrJoshua> I did some work last week and checked it in, but I haven't seen it on git hub.
20:04:14 <sarob_> let me check
20:06:34 <sarob_> strange
20:06:50 <sarob_> oh
20:07:24 <sarob_> you went through the check pipe
20:07:45 <sarob_> once its completed check tests
20:08:00 <sarob_> then it needs to be +2 for the gate pipe
20:08:31 <sarob_> you need to select review on #link https://review.openstack.org/#/c/80402/
20:08:46 <sarob_> then +2 and approve
20:08:50 <MrJoshua> Hmm, ok I thought Approved would be enough.
20:09:24 <MrJoshua> So cancel the one I have there now?  There doesn't seem to be a way to +2 now.  So cancel and do it again?
20:09:34 <MrJoshua> Under "Reviewer"
20:10:02 <sarob_> see what I just did
20:10:28 <sarob_> i gave it a +2 and approved
20:10:38 <MrJoshua> It just shows checkmarks in both columns.  I have +1 in both columns.
20:10:54 <MrJoshua> But anyway, I think I get it.  Next time I'll do +2
20:11:36 <sarob_> infra guys can correct me, but i believe we can set the queue to accept +2 as min
20:11:51 <sarob_> default is to ask for both approved and +2
20:12:43 <MrJoshua> That's fine.  I just didn't do that the first time, and then it doesn't give me the option.
20:13:20 <sarob_> i was slammed last week. I read the wiki contribution steps, but didnt go through them
20:13:25 <MrJoshua> (In that case I guess I'd cancel my review, and do it again with +2)
20:13:28 <sarob_> they seem okay
20:13:35 <sarob_> ?
20:14:03 <MrJoshua> It the case that I set the wrong review +1 or not approved etc.
20:14:18 <MrJoshua> It = In
20:14:32 <sarob_> MrJoshua: hmm, i think you just didnt add up to +2
20:14:38 <sarob_> MrJoshua: and approved
20:14:55 <MrJoshua> Yes, I get that, but I'm talking about changing it once it's entered inccorectly.
20:14:55 <sarob_> MrJoshua: i think we can set it to just +2
20:15:38 <MrJoshua> I think I've got it, now.  So no worries.
20:15:38 <sarob_> MrJoshua: right
20:15:57 <sarob_> MrJoshua: zuul believes all is well
20:16:08 <sarob_> MrJoshua: the gatekeeper is never wrong
20:16:32 <MrJoshua> haha
20:16:46 <MrJoshua> Other than that, nothing new on my end.
20:17:12 <sarob_> MrJoshua: so what we do with the apiary in the repo
20:18:16 <sarob_> MrJoshua: use the apiary spec with python service to respond to requests?
20:18:19 <MrJoshua> It's editable and testable, and anyone can build a server that delivers that API.  On the apiary site is a moch server that delivers the static data form the doc for testing.
20:18:55 <sarob_> MrJoshua: so how now brown cow?
20:19:42 <MrJoshua> http://milk.apiary.io
20:19:46 <sarob_> MrJoshua: start with a few to discuss apiary mock server
20:19:56 <MrJoshua> http://docs.milk.apiary.io
20:21:12 <MrJoshua> Changes to the github repo will not automatically get updated at apiary.  For that someone has to have access to the apiary project, which you and I have and I think either of us can share.
20:22:25 <MrJoshua> I also have the C4 API which is much more complete, but had to pull it out because of some syntax error I didn't have time to fix.  I'll put that in this week some time too.
20:23:16 <MrJoshua> Although this should be enough to get anyone starting as a django implementation requirement, I'm hoping to have the test framework incorporated this week as well.
20:24:12 <sarob_> MrJoshua: we need to add get /ServiceRegistry/{service}/metadata
20:24:34 <sarob_> MrJoshua: or would the metadata be returned by a get by defualt
20:24:41 <sarob_> MrJoshua: default
20:25:37 <sarob_> MrJoshua: then i believe first round of API is complete
20:25:41 <sarob_> MrJoshua: design
20:26:09 <MrJoshua> If you click on the GET it shows you what is returned.  Yes I don't think I have medtadata there so I can fix that.
20:27:02 <sarob_> MrJoshua: im good with a separate call to return metadata
20:27:25 <sarob_> MrJoshua: we dont need to start overloading calls from the get go
20:27:57 <MrJoshua> Cool, but it's not there at all at the moment, so I'll add that path and return metadata.
20:28:23 <sarob_> cool
20:28:46 <MrJoshua> Oh, I have metadata under "AssetsServices" and it's included.
20:28:57 <sarob_> MrJoshua: ill start thread on ml to get the discussion going
20:29:12 <MrJoshua> cool
20:30:37 <sarob_> MrJoshua: #action MrJoshua will add separate GET for returning object metadata
20:31:58 <sarob_> #action sarob will ping ML on #link http://docs.milk.apiary.io/ as first revision of milk api
20:32:42 <sarob_> MrJoshua: so i resigned to promote the work so far and the work planned at NAB
20:32:50 <sarob_> MrJoshua: rather than demo anything
20:33:08 <MrJoshua> k
20:33:19 <sarob_> MrJoshua: id like to focus on creating project phases
20:33:28 <sarob_> MrJoshua: in the wiki
20:33:47 <sarob_> MrJoshua: without dates
20:34:10 <sarob_> MrJoshua: until we have at least one full time dev working on this
20:34:26 <sarob_> MrJoshua: we wont be able to commit to any dates
20:34:38 <sarob_> MrJoshua: and no reason to beat ourselves up on it
20:35:14 <MrJoshua> true
20:35:25 <sarob_> MrJoshua: my end state is support for various APIs
20:35:52 <sarob_> MrJoshua: does like still seem like the goal for you too?
20:36:23 <MrJoshua> I'm not sure what you mean by various APIs?
20:36:42 <sarob_> MrJoshua: cineglass, fims, openstack, 5thKind, etc
20:36:59 <sarob_> MrJoshua: aws, gce
20:37:15 <MrJoshua> Ah, yes.
20:37:32 <sarob_> MrJoshua: my vision is that the etcc api is glue
20:37:58 <sarob_> MrJoshua: for all the other stuff to get workflows through
20:38:13 <sarob_> MrJoshua: from beginning state to end state
20:39:03 <sarob_> MrJoshua: so one of the framework/etcc tools will likely be state management
20:39:19 <sarob_> MrJoshua: but i jump ahead
20:39:28 <sarob_> MrJoshua: baby steps here
20:39:44 <MrJoshua> Haha, yeah, but sounds good.
20:40:23 <sarob_> MrJoshua: im good with today
20:40:40 <sarob_> MrJoshua: anything else sir?
20:41:08 <MrJoshua> Good for me.
20:41:31 <sarob_> MrJoshua: then i call a wrap
20:41:42 <sarob_> MrJoshua: or cut or whatever
20:41:42 <MrJoshua> k
20:41:51 <sarob_> #endmeeting