16:00:49 <rakhmerov> #startmeeting Mistral
16:00:50 <openstack> Meeting started Mon Oct 28 16:00:49 2013 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:53 <openstack> The meeting name has been set to 'mistral'
16:01:08 <NikolayM> hi
16:01:24 <rakhmerov> So let's review the action items from the previous week first
16:02:04 <rakhmerov> "rakhmerov, collect use cases and publish them on wiki"
16:02:28 <rakhmerov> it's done
16:02:44 <rakhmerov> #link https://wiki.openstack.org/wiki/Mistral#Use_cases
16:03:26 <rakhmerov> however, it now has a detailed description only for one use case: Cloud Cron
16:03:38 <rakhmerov> others are described really briefly
16:05:01 <rakhmerov> #info rakhmerov and stanlagun are working on detailed description of use cases: Long-running Business Process and Post Deployment Configuration (working name)
16:05:33 <rakhmerov> next item
16:05:49 <rakhmerov> "stanlagun (with rakhmerov's help) to finish Q&A document that covers use cases, relations with other frameworks, existing services, development plans etc"
16:05:52 <rakhmerov> done
16:06:06 <rakhmerov> #link https://wiki.openstack.org/wiki/Mistral#FAQ
16:07:20 <rakhmerov> this section will be populated periodically
16:07:28 <rakhmerov> next item
16:08:09 <rakhmerov> "stanlagun to describe the possible ways of executing particular actions on VMs in the tech specification"
16:08:27 <rakhmerov> this is in progress and, in fact, is a part of the other one
16:08:55 <rakhmerov> "Renat and Stan finish the modified specification and share it with the community" which is in progress too
16:10:08 <rakhmerov> "Renat, Stan, Timur to synchronize DSL and REST API with the latest conceptual changes" was assigned as an ongoing AI since the discussion keeps going on how it all should look like
16:10:29 <rakhmerov> any questions on that?
16:11:51 <rakhmerov> so basically, the team keeps working on DSL/API spec and it will take I believe around 1.5-2 weeks (due to the summit, otherwise it could be done earlier)
16:12:44 <rakhmerov> #action rakhmerov, stanlagun, tsufiev, keep working on DSL/API Mistral specification
16:13:30 <ativelkov> On the summit we'll be able to share some insight with the community and get some feedback )
16:13:46 <rakhmerov> exactly
16:14:05 <rakhmerov> we're hoping to clarify lots of things that may not be clear now for many people
16:14:11 <tsufiev> rakhmerov:  as for me, I currently almost completely occupied with upcoming Murano 0.4 release
16:14:25 <rakhmerov> tsufiev: sure, no problem
16:15:14 <rakhmerov> the fact that I mentioned you in AI doesn't mean you have to forget about everything else :) I would rather hope to get your input on some results
16:15:24 <rakhmerov> it should be valueable for us
16:16:26 <rakhmerov> at the summit we're also planning to talk with harlowja and his team (TaskFlow folks) and use this chance to sync our vision and most of the technical details
16:16:38 <rakhmerov> #topic Advanced use cases
16:17:18 <rakhmerov> I included this agenda item in case some people want to ask additional questions on project mission, use cases
16:17:39 <rakhmerov> if you have some, please fire away :)
16:18:38 <tsufiev> rakhmerov:  ok, I'm keeping an eye all your recent use-case proposals :)
16:18:40 <ativelkov> I don't have any questions, but I've got an idea of a new good use-cases
16:18:46 <tsufiev> rakhmerov:  ok, I'm keeping an eye on all your recent use-case proposals :)
16:18:49 <rakhmerov> Like I said before, we're now intensively working on describing additional use cases and we're going to share this information soon in both mailing lists and wiki
16:19:00 <igormarnat> Renat, I don't have advanced use cases out of top of my head but wanted to ask you about the areas war are going to prototype of beginning
16:19:18 <igormarnat> Are we going to have some part of the meeting for that? Or you can describe this now?
16:19:47 <rakhmerov> we have an item "Start discussing development plans" so let's postpone it for a bit
16:20:11 <rakhmerov> ativelkov: what's your idea? Could you share pls?
16:20:54 <rakhmerov> #action rakhmerov, finish detailed description of "Long-running Business Process" use case
16:21:20 <rakhmerov> #action stanlagun, finish detailed description of "Post Deployment Configuration" use case
16:21:21 <ativelkov> Last several days I was trying to build a murano workflow for advanced networking scenario: I had a network, a router, a subnet, several servers in it. I needed to connect all this stuff into a different network.
16:21:42 <rakhmerov> yep
16:21:53 <ativelkov> This should be done in Heat, but it is unable to do it in one step
16:22:18 <ativelkov> you first have to "unplug" the networks, then create a new configuration
16:22:20 <rakhmerov> what do you mean by "one step"?
16:22:41 <ativelkov> Well, you cannot do a single stack-update command
16:22:50 <rakhmerov> gotcha
16:23:02 <ativelkov> so, you have to first create a "temporary" heat stack
16:23:10 <ativelkov> update an existing stack to this temporary state
16:23:19 <ativelkov> and then update the temporary to the final
16:23:26 <ativelkov> quite a tricky thing
16:23:36 <rakhmerov> yes, I see
16:23:39 <ativelkov> especially if you have some optional steps and parts of the templates
16:23:49 <rakhmerov> do you think Mistral could be useful for that?
16:23:59 <ativelkov> and this is not a bug in Heat or seomthing - that's "as designed" for Heat
16:24:12 <ativelkov> yes, Mistral would be very appropriate for such scenarios
16:24:16 <rakhmerov> is it representable in a form of a task graph?
16:24:21 <rakhmerov> ok, cool
16:24:26 <ativelkov> Yeah, I think so
16:25:11 <rakhmerov> could you prepare a couple of paragraphs containing what you've just told us but a little bit more detailed?
16:25:34 <rakhmerov> it's definitely not urgent but it may be included on our wiki some time later
16:26:08 <rakhmerov> I know you guys are really busy with other things but humbly hoping to get this info from you :)
16:26:31 <ativelkov> Yes, I need to finish this feature in current Murano conductor - and this has to be done before the summit
16:26:40 <rakhmerov> ok
16:26:48 <ativelkov> But I'll try to formalize it on the paper somewhere
16:27:41 <rakhmerov> #action ativelkov, collect the info about use case related to setting up a network (not a high priority)
16:28:09 <rakhmerov> so, let's move on
16:28:28 <rakhmerov> #topic What is left on documentation (use cases, DSL, API)
16:29:05 <rakhmerov> I think we've done some good job since the last meeting on writing docs
16:29:14 <rakhmerov> however, we still have a lot of things to do
16:29:42 <rakhmerov> complete use cases and complete the initial version of DSL/API specification
16:29:53 <rakhmerov> this is in our action items already
16:30:15 <rakhmerov> if you have other things to mention please let us know
16:30:46 <rakhmerov> I would say the crutial thing that is left is the technical spec: DSL/API
16:31:07 <rakhmerov> we'll get it done in a couple of weeks I believe, after the summit
16:31:17 <rakhmerov> *crucial
16:31:57 <rakhmerov> as far as the design and the implementation, it will be populated simultaneously with the corresponding work
16:32:12 <rakhmerov> which I hope will start pretty soon
16:32:45 <rakhmerov> anything else on that?
16:32:51 <katyafervent> Do you update wiki or ether pads?
16:33:17 <rakhmerov> katyafervent: not sure what you mean :)
16:33:38 <katyafervent> do ypu publish docs on openstack wiki?
16:33:44 <katyafervent> *you
16:33:47 <rakhmerov> ooh, yes, sure
16:33:54 <katyafervent> great)
16:34:06 <rakhmerov> #link https://wiki.openstack.org/wiki/Mistral
16:34:15 <rakhmerov> it already has lots of good information
16:35:15 <rakhmerov> I also added a back reference to Mistral from Convection proposal (harlowja was ok with that) so that people know it's started
16:36:10 <rakhmerov> #link https://wiki.openstack.org/wiki/Convection#PROPOSAL_ONLY:_TaskSystem-as-a-Service_.28Convection.29
16:36:34 <rakhmerov> may be we should emphasize it even more clearly
16:36:58 <rakhmerov> so, the next topic
16:37:07 <rakhmerov> #topic Start discussing development plans
16:38:17 <rakhmerov> so, my plan was to start sketching out a Roadmap this week
16:38:29 <rakhmerov> and I actually did start doing that today
16:38:51 <rakhmerov> but don't have too much to share yet, only some fragments
16:39:12 <rakhmerov> however, we have lots of ideas in mind that we need to formalize somewhere
16:40:03 <rakhmerov> first of all, I would suggest we finish DSL/API documentation and polish it out with other interested folks
16:40:33 <rakhmerov> it'll be the most important step towards the beginning of development
16:41:40 <rakhmerov> at the same time we have resources to start prototyping some of our ideas in parallel
16:42:11 <rakhmerov> this is NikolayM
16:42:31 <igormarnat__> Great, now we come back to the topic I was asking:)
16:42:38 <rakhmerov> yes, right :)
16:42:38 <igormarnat__> So what's the plan, what do we prototype first?
16:44:21 <rakhmerov> well, I would suggest we start with the basic things we'll need in ether case. Like very simple DSL grammar and the parser for it
16:44:49 <ativelkov> Hm
16:44:55 <ativelkov> I would suggest to start from the engine
16:44:58 <rakhmerov> in that regard we had an idea of automatic REST APIs clients generation and inclusion into DSL
16:46:02 <rakhmerov> ativelkov: yes, I'm telling now about the things that may become an interesting part of our spec but we're not sure about them yet since it requires some hands-on testing
16:46:42 <rakhmerov> the order of the things may be different
16:46:42 <ativelkov> I mean, we may try testing some things without having DSL
16:46:59 <ativelkov> by just defining the task flows manually
16:46:59 <rakhmerov> sure
16:47:21 <rakhmerov> what do you mean by "manually"?
16:47:40 <ativelkov> Well, by defining tasks by python code in tests
16:47:47 <ativelkov> or something like this
16:47:49 <rakhmerov> yes, sure
16:48:02 <ativelkov> I mean DSL parser is easy to implement - you just need a complete spec
16:48:11 <ativelkov> and you do not need to prototype it )
16:48:34 <rakhmerov> hm.. I guess you didn't get what I told on 100% :)
16:48:44 <ativelkov> while prototyping the engine (context passing and data flow, dependency analysis etc) may require some PoC
16:48:50 <ativelkov> may be )
16:49:08 <rakhmerov> I didn't mean to implement DSL fully
16:49:38 <rakhmerov> only some interesting ideas we have regarding it
16:50:19 <rakhmerov> just to be able to complete the spec
16:50:51 <rakhmerov> overall, I agree with you: we'll start with the engine and the model (tasks, dependencies, actions) as the first serious dev item
16:51:47 <ativelkov> ok :) Thanks for making this clear
16:51:55 <rakhmerov> ok
16:52:22 <rakhmerov> but thanks for this note, it does make sense for sure
16:53:28 <rakhmerov> just wanna repeat: I have just a fragmentary vision on how we're going to approach our development, I just see some risky things I'd try before start the serious work
16:53:33 <rakhmerov> it's all up to discussion
16:53:57 <rakhmerov> and I would like to clarify that by the next meeting actually :)
16:54:06 <igormarnat__> It's fine, I think I've got the idea. Are there topics uncovered yet for today?
16:54:29 <ativelkov> we have a vision sync up with Y! in 5 minutes, don't we&
16:54:31 <ativelkov> ?*
16:54:35 <rakhmerov> #action rakhmerov, prepare the first version of Roadmap and the development plan
16:54:39 <rakhmerov> yes, we do
16:54:48 <rakhmerov> #topic Open discussion
16:54:53 <rakhmerov> anything else guys?
16:55:05 <ativelkov> not from my side
16:55:59 <rakhmerov> ok
16:56:00 <igormarnat__> I'm also done
16:56:09 <rakhmerov> thanks to everyone!
16:56:20 <rakhmerov> see you all soon
16:56:25 <rakhmerov> #endmeeting