16:00:18 <rakhmerov> #startmeeting Mistral
16:00:19 <openstack> Meeting started Mon Feb 17 16:00:18 2014 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:22 <openstack> The meeting name has been set to 'mistral'
16:00:25 <rakhmerov> hi guys
16:01:18 <NikolayM> hi!
16:01:37 <rakhmerov> let's wait for a couple of minutes
16:01:59 <rakhmerov> hopefully other folks will appear soon
16:02:31 <rakhmerov> is there anyone else here except NikolayM?
16:03:03 <NikolayM> hmm
16:04:36 <rakhmerov> ok, let's quickly capture the main things for record
16:04:47 <rakhmerov> #topic previous AIs
16:04:59 <tnurlygayanov> yes
16:05:22 <rakhmerov> ooh, one more team member )
16:05:31 <rakhmerov> it's promising :)
16:05:34 <tnurlygayanov> I write the email about pylint errors )
16:05:34 <rakhmerov> ok
16:05:38 <stanlagun> :)
16:05:50 <rakhmerov> and one more :)
16:05:54 <rakhmerov> cool
16:06:04 <rakhmerov> I was about to wrap up the meeting ))
16:06:21 <rakhmerov> ok, as for AIs we had 4 of them
16:07:07 <rakhmerov> they are all basically related with DSL and can be condensed into one simple sentence "continue discussing DSL in ML"
16:07:13 <rakhmerov> so we're doing it
16:08:01 <rakhmerov> the new team members have lots of ideas so we keep discussing all these things
16:08:03 <stanlagun> ML = Mistral or Markup Language?
16:08:18 <rakhmerov> sorry, ML = Mailing List
16:09:41 <rakhmerov> so, now we're concentrated on development and the progress on forming up DSL is not tremendous but it's moving on anyway
16:09:55 <stanlagun> There is an ongoing thread about DSL in Murano. I think we need to discuss if ther are possibilities to make two DSLs somehow similar
16:10:50 <rakhmerov> yes, today I replied to a Clint Byrum's message about it and wrote the same thing
16:11:07 <igormarnat_> rakhmerov, is there status of PoC in agenda for today?
16:11:19 <rakhmerov> the idea seems to be interesting
16:11:22 <rakhmerov> yes
16:11:36 <rakhmerov> #topic Current status
16:12:17 <rakhmerov> NikolayM has been working on direct transitions (a part of the new requirements)
16:12:56 <rakhmerov> NikolayM, can you please report your status on that? My understanding is that you've almost finished but you may be able to provide more detailes
16:13:07 <NikolayM> I can say that it has been already implemented
16:13:12 <rakhmerov> ok
16:13:51 <rakhmerov> do you see any additional work on that that we might need to do after we get all pieces together? (data flow, conditions etc.)
16:14:08 <NikolayM> and also I work on new internal DSL structure
16:14:35 <rakhmerov> ok
16:14:46 <igormarnat_> rakhmerov, NikolayM, speaking of status, is the roadmap still valid from PoC point of view? https://wiki.openstack.org/wiki/Mistral/Roadmap
16:14:57 <NikolayM> yes, since we have a context here, we can do and test our DataFlow
16:15:59 <rakhmerov> igormarnat_, yes, that's what we're trying to follow
16:16:12 <rakhmerov> NikolayM, ok, I see
16:17:11 <rakhmerov> so, I'm working on Data Flow, made a series of changes and wait for NikolayM's commit to be merged
16:17:28 <rakhmerov> so that I can add my changes on top of it
16:17:31 <rakhmerov> here it is
16:17:35 <rakhmerov> #info https://review.openstack.org/#/c/72347/
16:18:14 <rakhmerov> the new folks on the team are working on the following Blueprints
16:18:46 <rakhmerov> #info https://blueprints.launchpad.net/mistral/+spec/mistral-std-send-email-action - good progress (almost done)
16:19:34 <tnurlygayanov> yes, we have new patch set for the second part of implementation
16:19:53 <rakhmerov> #info https://blueprints.launchpad.net/mistral/+spec/mistral-std-repeat-action - started (there are some issues with design but close to be resolved)
16:20:01 <rakhmerov> aha
16:20:57 <tnurlygayanov> ?
16:20:59 <rakhmerov> so, I believe we have a chance to finish most of the development this week and then we need to finish all the testing and make Demo scenario work
16:21:24 <tnurlygayanov> cool
16:21:35 <tnurlygayanov> what we also should prepare for the demo?
16:21:39 <rakhmerov> tnurlygayanov, did you have questions?
16:22:37 <rakhmerov> well, I already created a simple DSL and a python script to upload it into Mistral that could serve as a Demo application
16:23:17 <rakhmerov> Dmitri Zimine thinks it's too simple for a Demo and he also would like to rip something out of it
16:23:30 <rakhmerov> I mean "requires" clause
16:24:17 <rakhmerov> the second one we can do even though I think it's not a problem to make it work along with direct transitions
16:24:58 <rakhmerov> as for simplicity, I'm ok to do something more complex but first we at least need to make this one work
16:25:12 <tnurlygayanov> ok
16:25:32 <rakhmerov> btw, tnurlygayanov, as I remember you wanted to help with Demo :)
16:25:38 <tnurlygayanov> yes
16:26:02 <tnurlygayanov> and the main issue - what should do the python-based web application
16:26:20 <rakhmerov> you were going to create a simple web app in python that could receive just one HTTP request and return something (i.e. an array of random numbers for now)
16:26:50 <rakhmerov> yes, let's do something simple for now
16:27:04 <tnurlygayanov> but it does not look cool ) ok.
16:27:25 <rakhmerov> like I said, at least we need to make this simple example work :)
16:27:29 <igormarnat_> Let's do a calc as a web app
16:27:31 <tnurlygayanov> just simple, ok, where I can save this demo app?
16:27:37 <rakhmerov> calc?
16:27:51 <igormarnat_> Distributed cloud calculator:)
16:28:04 <tnurlygayanov> as a service
16:28:09 <rakhmerov> yep, we can do that
16:28:14 <rakhmerov> CaaS? :)
16:28:40 <rakhmerov> Timur, please commit it to mistral-extra/examples/vm_job
16:28:50 <tnurlygayanov> ok, thank you.
16:28:55 <rakhmerov> there you can find a DSL example and the script I mentioned before
16:29:21 <rakhmerov> calc is a good idea actially
16:29:57 <rakhmerov> for example, we can send an expression like "2+2" to it and it can return "4" in a response :)
16:30:49 <rakhmerov> but again, my point here: let's not wait much time for it now, we can always complicate the example as we finish our current changes
16:31:07 <rakhmerov> ...let's not spend...
16:32:08 <igormarnat_> +1 for simplicity, but it should be something simple and meaningful
16:32:09 <tnurlygayanov> https://github.com/justinxreese/ajax-calculator-flask/blob/master/hello.py
16:32:11 <tnurlygayanov> )))
16:32:34 <rakhmerov> you can steal it ;)
16:32:40 <rakhmerov> kidding
16:32:55 <rakhmerov> ok, let's continue
16:33:05 <rakhmerov> ok, so overall I would estimate PoC readiness around 80%
16:34:36 <rakhmerov> do you guys have any other topics to discuss?
16:34:57 <rakhmerov> I thought we could discuss DSL again with Dmitri but looks like he's not here today
16:35:31 <dzimine> I am here but no point beating the dead horse, we have enough agreement on DSL for PoC and are marking things to discuss after
16:35:33 <igormarnat_> Are there documented specific open questions about DSL?
16:35:46 <dzimine> I am keeping track of them
16:35:51 <igormarnat_> Cool
16:35:52 <dzimine> will organize and share
16:36:53 <rakhmerov> Dmitry, hey, how's it going?
16:37:01 <rakhmerov> agree with you
16:37:21 <igormarnat_> So we're done, aren't we?
16:37:42 <rakhmerov> like I mentioned in our email exchanges we need to start a new etherpad and try to summarize all our ideas there
16:38:05 <rakhmerov> we are done unless you have anything else to discuss :)
16:38:23 <rakhmerov> dzimine, just one thing I'd like to ask
16:38:42 <dzimine> yes?
16:38:58 <rakhmerov> actually one thing to say and one to ask :)
16:39:05 <dzimine> shoot
16:39:22 <tnurlygayanov> and also we can discuss bugs, for example, https://bugs.launchpad.net/mistral/+bug/1281164
16:39:27 <rakhmerov> to say: your commit (https://review.openstack.org/#/c/73205/) is about to land, good work!
16:39:38 <dzimine> thanks :)
16:40:05 <rakhmerov> to ask: do you know the status of Manas on repeater?
16:40:42 <dzimine> As of Fri last week, he was looking at it and wanted to check with you when closer.
16:40:54 <rakhmerov> ok
16:41:09 <rakhmerov> and as I know he was on vacation till last Fri
16:41:53 <rakhmerov> please let him know I'm ready to discuss with him whatever he needs to make progress on that task
16:41:57 <dzimine> The problem is it he wasn't sure how to map it to the current way the engine works. Discussion needed.
16:42:07 <rakhmerov> ok, sure
16:42:58 <rakhmerov> I know it's a hairy thing, I would encourage to write his thoughts right into openstack-dev so that all the team could start thinking about it
16:43:03 <dzimine> Are we sure to have it for POC? Doing internal actions, like repeater, may shake the engine.
16:43:15 <dzimine> Let's wait for Manas to come back on it. I'll ping him today.
16:43:46 <rakhmerov> as for doing it in POC, I have some concerns, yes
16:44:12 <rakhmerov> the whole question is "what is it going to take to make it work?"
16:44:25 <rakhmerov> so let's discuss first and estimate the efforts
16:45:23 <rakhmerov> #action Manas, summarize all ideas on std:repeater (https://blueprints.launchpad.net/mistral/+spec/mistral-std-repeat-action) and start a discussion with the team
16:45:38 <rakhmerov> alright
16:45:48 <rakhmerov> are we done now?
16:46:26 <rakhmerov> I'm gonna wait for one more minute and then shut the meeting down
16:46:56 <dzimine> just one thing...
16:47:12 <dzimine> How about we set some core hours where we can overlap on IRC
16:47:26 <rakhmerov> #action Timur, create a simple web app in python that can serve one request (e.g. calculator)
16:48:07 <rakhmerov> core hours, hm...
16:48:14 <dzimine> for quick questions. say on our side we can commit to be on openstack-mistral when we are working / avaialbe. If Nikolay/Timur/Renat can do something like this.
16:48:33 <dzimine> Forget the hours, just when you up and working and available for chat.
16:48:43 <dzimine> Just an idea. Sometimes email is too slow.
16:48:55 <rakhmerov> Mostly I'm on IRC in my hours :)
16:49:05 <rakhmerov> but we have a huge time difference
16:49:22 <rakhmerov> ok, I agree we need to establish that
16:49:54 <rakhmerov> folks in Russia all have different availability
16:50:13 <rakhmerov> I'll check everything again and let you know
16:50:51 <rakhmerov> #action Renat, check availability of all the team members and make sure we have overlapping hours with people in the US
16:51:28 <dzimine> Let's not hang up on time, but just be on irc when available.
16:52:05 <rakhmerov> :) sounds like we're not in IRC sometimes
16:52:25 <rakhmerov> ok, let's be more careful on this
16:52:34 <rakhmerov> anything else?
16:53:47 <rakhmerov> ok, let's finish for today
16:54:04 <rakhmerov> thanks to everyone for coming today
16:54:13 <rakhmerov> let's meet in one week
16:54:27 <NikolayM> bye!
16:54:34 <dzimine> by!
16:54:35 <rakhmerov> bye
16:54:37 <rakhmerov> #endmeeting