16:00:09 <rakhmerov> #startmeeting Mistral
16:00:10 <openstack> Meeting started Mon Feb 24 16:00:09 2014 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:13 <openstack> The meeting name has been set to 'mistral'
16:00:15 <rakhmerov> hi guys
16:00:28 <dzimine> hello!
16:00:42 <rakhmerov> hi Dmitry, how are you?
16:01:14 <dzimine> back n kicking, I was time-constrained last week, but will have more time to be on Mistral this week.
16:01:37 <rakhmerov> ok, good
16:02:04 <rakhmerov> is there anyone else here?
16:02:10 <rakhmerov> can we start something? :)
16:02:47 <nmakhotkin> hi!
16:02:51 <rakhmerov> hi
16:03:01 <rakhmerov> ok, let's review action items quickly
16:03:15 <rakhmerov> #topic Previous Action Items
16:03:55 <rakhmerov> 1.  Manas, summarize all ideas on std:repeater (https://blueprints.launchpad.net/mistral/+spec/mistral-std-repeat-action) and start a discussion with the team
16:04:18 <rakhmerov> #info here is the etherpad where he's done it
16:04:34 <rakhmerov> and he keeps thinking on it as far as I'm aware of
16:04:57 <dzimine> correct.
16:05:04 <rakhmerov> I also looked at this etherpad carefully and mostly it looks reasonable to me, I left my comments
16:05:10 <enykeev> hey
16:05:17 <rakhmerov> hi Kirill!
16:05:21 <rakhmerov> team
16:05:34 <rakhmerov> enykeev - is our new member
16:05:41 <rakhmerov> as of today
16:06:00 <rakhmerov> enykeev, welcome to the team!
16:06:26 <enykeev> thanks =)
16:06:32 <rakhmerov> :)
16:06:50 <tnurlygayanov> Hi there )
16:06:58 <rakhmerov> hi Timur
16:07:14 <rakhmerov> So back to the action item. I suggest we postpone the implementation for 2-3 days till we merge ongoing changes in engine
16:07:37 <rakhmerov> it doesn't make sense to start this task before that since it really affects lots of things in engine
16:07:43 <dzimine> all implementations, or any specific?
16:08:09 <rakhmerov> I mean what Manas is doing
16:08:12 <rakhmerov> repeater
16:08:21 <dzimine> agreed.
16:08:24 <rakhmerov> es
16:09:12 <rakhmerov> and one more thing. After the closer look at this I started thinking that it may make sense to introduce keywords representing control flow constructions like this
16:09:48 <rakhmerov> the reason is simple: engine must be aware of them so they are not usual tasks and they must be processed in a special way
16:10:18 <rakhmerov> so we may not want to limit ourselves in how we define them in DSL
16:10:55 <rakhmerov> anyway, nmakhotkin, tnurlygayanov pls take a look at this etherpad and let's start the discussion on it.
16:11:21 <rakhmerov> remember we're not limited by the initial requirements
16:11:41 <rakhmerov> so you should feel free to propose any ideas
16:12:09 <rakhmerov> but at the same time we need to move forward with the implementation so we need to think quickly :)
16:12:10 <tnurlygayanov> ok
16:12:13 <rakhmerov> ok
16:12:27 <rakhmerov> 2.Timur, create a simple web app in python that can serve one request (e.g. calculator)
16:12:39 <rakhmerov> this one is waiting to be reviewed
16:12:59 <rakhmerov> #info https://review.openstack.org/#/c/74094/
16:13:27 <rakhmerov> it's a very simple app in Flask that implements "sum" function as an HTTP endpoint
16:13:43 <rakhmerov> most likely we will use it for the Demo
16:14:09 <rakhmerov> 3. Renat, check availability of all the team members and make sure we have overlapping hours with people in the US
16:14:24 <tnurlygayanov> can you please share the link?
16:14:25 <nmakhotkin> I've looked at it
16:14:25 <tnurlygayanov> ok, I can do this ) https://etherpad.openstack.org/p/std_repeat
16:14:25 <tnurlygayanov> is it correct link?
16:14:25 <tnurlygayanov> yes, application was created.
16:14:25 <tnurlygayanov> need review https://review.openstack.org/#/c/74094/
16:14:53 <rakhmerov> ooh, something is wrong with my IRC client
16:15:14 <rakhmerov> I can't see any incoming messages for a couple of minutes and then they arrive in a batch
16:15:19 <rakhmerov> weird..
16:15:35 <rakhmerov> yes, tnurlygayanov, thanks
16:15:48 <rakhmerov> so as for availability
16:16:12 <rakhmerov> this one is not done since last week was pretty bad for us, I was sick for a couple of days and nmakhotkin was sick too
16:16:34 <rakhmerov> so we can figure out our availability right now :)
16:16:57 <tnurlygayanov> ) ok
16:17:19 <rakhmerov> ok, let's use PST time zone (msk -12)
16:17:44 <rakhmerov> tnurlygayanov, what are your usual business hours?
16:18:15 <rakhmerov> and can you guys all write yours
16:19:07 <tnurlygayanov> 11-19 by Moscow time
16:19:24 <rakhmerov> #info Renat's availability: 6pm - 3am (sometimes longer)
16:20:14 <rakhmerov> #info Timur's availability: 11pm - 7am
16:20:25 <nmakhotkin> As for me - 12 - 20 MSK
16:20:25 <rakhmerov> nmakhotkin?
16:20:29 <enykeev> mine is pretty much the same, 5pm - 3am
16:20:38 <tnurlygayanov> PST: 11:00 PM - 7:00 AM
16:20:53 <rakhmerov> #info Nikolay's availability: 12am - 8am
16:21:08 <tnurlygayanov> ок )
16:21:22 <rakhmerov> #info Kirill's availability: 5pm - 3am
16:21:37 <dzimine> #info Dmitri's availability - any  7-23 on request, usual 7-8 am and 16 to 20 pm, but can make till 24 pm when needed.
16:22:03 <rakhmerov> yes, I noticed you work 24 hr/day :)
16:22:37 <dzimine> no, i am "available" 24 hours != "work" :)
16:22:41 <rakhmerov> ok, so guys, please try to be at #openstack-mistral during your work hours please so that we can discuss something
16:22:50 <rakhmerov> dzimine, sure, just kidding :)
16:23:25 <rakhmerov> ok
16:23:53 <rakhmerov> #topic Current status
16:24:13 <rakhmerov> so, as I said we were sick significant time last week
16:24:26 <rakhmerov> however we sent several patches for review
16:24:59 <rakhmerov> I'm now working on Data Flow prototype and hoping to finish it tomorrow
16:25:29 <rakhmerov> I already sent two patches related to it last week and the third is on its way
16:25:53 <rakhmerov> Nikolay finished changes related with direct transitions and his patch has landed
16:26:30 <rakhmerov> so we're moving forward and hopefully early next week we'll get most of the required things done
16:27:17 <rakhmerov> we are still mostly following this etherpad: https://etherpad.openstack.org/p/mistral-poc
16:27:31 <rakhmerov> but not 100% already
16:27:34 <rakhmerov> which is fine
16:28:23 <rakhmerov> we still have lots of things to discuss on DSL and overall design. But we need to do it in parallel with development
16:28:52 <dzimine> Renat do we need email task as part of POC?
16:29:27 <rakhmerov> well, I thought it would be cool to have it
16:29:33 <dzimine> if so, we'll need 1) add it to mistral extra DSL and 2) run the smtp server somewhere.
16:29:37 <rakhmerov> it's done, isn't it?
16:29:53 <rakhmerov> ooh, yes, I see what you're saying
16:30:07 <dzimine> e.g., make it part of the 'client' application, so that it receives and logs the email
16:30:25 <dzimine> as for "done" - not to production, no, but demonstrable.
16:30:49 <rakhmerov> yes
16:30:57 <dzimine> So I can work on this.
16:31:21 <rakhmerov> #action Add using "email" action into the example and run smtp server (e.g. as a part of the client application)
16:31:32 <rakhmerov> ok, sure
16:31:42 <rakhmerov> it's your thing
16:31:46 <dzimine> This is called as a work item on the blueprint already.
16:31:54 <rakhmerov> yep
16:32:17 <dzimine> Thus I don't mark blueprint complete. For details you can always check what is between now and DONE at the blueprint work items.
16:32:29 <rakhmerov> ok
16:33:09 <rakhmerov> btw, guys, can you please advise when we consider a blueprint done and can mark it correspondingly?
16:33:10 <dzimine> The sucky part is we'll need to define a 'service' in DSL for email even though it's a standard task but ok for now
16:33:19 <rakhmerov> from your experience with OpenStack
16:34:29 <rakhmerov> dzimine, totally agree with you, it's a sucky part :) I think we discussed before that we can make DSL more flexible in this regard
16:34:50 <rakhmerov> so that we can skip "service" declaration if it's something simple to configure
16:35:02 <dzimine> yes we did discuss it let's just postpone this and return past POC.
16:35:08 <rakhmerov> ok
16:35:51 <rakhmerov> so from my side I don't have anything specific left to discuss for now
16:36:14 <dzimine> discuss design prior to implementation?
16:36:28 <dzimine> we / you are sort of doing it already.
16:36:35 <dzimine> Just wonder how can we do it better.
16:36:35 <rakhmerov> yes
16:36:58 <dzimine> Case 1) Renat, your changes - I haven't found any thing on them but assume you and Nicolay have talked about it.
16:37:11 <dzimine> case 2) Winson changes: again, hard to review when we don't know where he is going with it.
16:37:30 <dzimine> Solution 1) write a spec
16:37:35 <rakhmerov> ok
16:37:36 <dzimine> problem: too slow.
16:37:41 <rakhmerov> why?
16:37:42 <dzimine> Solution 2) have a discussion
16:37:48 <rakhmerov> why is it too slow?
16:38:05 <dzimine> problems: exclusive - not everyone can participate, time overlap is a problem
16:38:14 <dzimine> Writing a spec is not slow, discussing it may be.
16:38:27 <dzimine> I am not saying "NO", to it, just calling out the problems :)
16:38:36 <rakhmerov> I see
16:39:01 <rakhmerov> well, I think we should use ML more intensively
16:39:07 <rakhmerov> first of all
16:39:40 <rakhmerov> I know you may have gotten sick of these words already (because I keep repeating it all the time)
16:39:44 <rakhmerov> but I really mean that
16:39:58 <rakhmerov> and we already started doing it but it's not enough IMO
16:40:14 <dzimine> My suggestion: 1) do write a spec (any form, etherpad may be ok) and 2) if it's non-trivial, call a meeting to discuss it, in the overlap time, and who wants to join and can join, joins
16:40:56 <dzimine> RE: openstack-dev - yes, this is not a replacement for specs, but we can use it to share and point to specs, and discuss it.
16:41:11 <rakhmerov> yes
16:41:26 <dzimine> so what do you think of spec/meeting combo?
16:41:30 <rakhmerov> I meant that we can use ML to discuss specs
16:41:35 <rakhmerov> combo :)
16:41:37 <rakhmerov> cool
16:41:43 <rakhmerov> yes, we can try this
16:42:07 <dzimine> and yes we can and should use openstack-dev to discuss the spec, so it will be 1-2-3 (renat, for you ;-))
16:42:28 <dzimine> 1) spec 2) meeting 3) summary and follow-up on openstack-dev
16:42:37 <rakhmerov> but, Dmitri, I think we can do it not very frequently, we already have tons of meetings every day (life is life)
16:43:07 <dzimine> sure, but big ideas like data flow don't come very frequently either ;)
16:43:18 <dzimine> we have one big change a week, we may make time/
16:43:25 <rakhmerov> so I think 1-2 times a week it may be feasible but not more often
16:43:26 <dzimine> what are others think about it?
16:43:45 <rakhmerov> well, I agree, let's try this
16:43:57 <dzimine> yes you're right, renat, it's hard to stick more than 2 extra meetings into the week.
16:44:14 <dzimine> but again, hopefully not everyone needs to be on each.
16:44:44 <dzimine> Nicolay, Timur, what you say?
16:44:50 <rakhmerov> dunno, I would like everyone to participate in the most important design decisions
16:44:53 <rakhmerov> everyone
16:45:43 <rakhmerov> tnurlygayanov, nmakhotkin?
16:46:00 <rakhmerov> they might have gone to bed :)
16:46:05 <dzimine> yes, and with #3 follow-up on openstack-dev everyone will, even if he/she missed the meeting.
16:46:18 <rakhmerov> dzimine, ok
16:47:29 <rakhmerov> dzimine, let me discuss that with Nikolay and Timur tomorrow. I believe they left for today (busy with something else)
16:47:45 <rakhmerov> but generally yes, we need to do this
16:47:57 <rakhmerov> from my side, I'm ready
16:48:34 <rakhmerov> is there anything else to discuss today? I didn't plan anything certain
16:48:57 <rakhmerov> we can finish at this point unless you have anything else
16:49:26 <rakhmerov> ooh, btw, enykeev, do you have any questions/comments?
16:49:42 <rakhmerov> we only have 10 mins
16:50:04 <rakhmerov> but we're in the same timezone so we can chat through the day
16:51:21 <rakhmerov> ok, let's finish then?
16:51:40 <rakhmerov> ok, thanks to everyone for joining today
16:51:44 <rakhmerov> bye-bye
16:51:51 <rakhmerov> #endmeeting