16:00:14 <rakhmerov> #startmeeting Mistral
16:00:14 <openstack> Meeting started Mon Mar  3 16:00:14 2014 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:18 <openstack> The meeting name has been set to 'mistral'
16:00:23 <rakhmerov> hello everyone
16:00:31 <enykeev> Hey
16:00:49 <NikolayM> hi!
16:02:01 <dzimine> hi !
16:02:36 <rakhmerov> ok, let's get started
16:03:22 <rakhmerov> actually I don't have any specific agenda for today since I've been deep in the code for the last few days
16:03:49 <rakhmerov> so I'm gonna take a look at the previous AIs we had and then we'll figure out what to talk about
16:04:01 <rakhmerov> #topic Previous Action Items
16:04:38 <rakhmerov> Alright.. We had just one
16:04:40 <rakhmerov> Add using "email" action into the example and run smtp server (e.g. as a part of the client application)
16:05:07 <rakhmerov> dzimine was able to get it done
16:05:49 <rakhmerov> the commit was approved today
16:06:52 <rakhmerov> so I think we can say a couple of words about the status
16:07:00 <rakhmerov> #topic Current status
16:07:29 <rakhmerov> I sent a patch that covers most of the required things related to Data Flow
16:07:33 <rakhmerov> #info https://review.openstack.org/#/c/77126/
16:07:57 <dzimine> I can report for Manas: he began to look at repeater's simple implantation. Expect to see in a couple of days.
16:08:08 <rakhmerov> it still has some TODOs that I'm going to address tomorrow (more thorough testing, actions etc)
16:08:19 <rakhmerov> ok
16:08:45 <rakhmerov> dzimine, please work with Nikolay on that
16:09:10 <dzimine> on repeater?
16:09:14 <NikolayM> I sent a new commit on review today with object model implementation
16:09:14 <rakhmerov> I think he can help Manas significantly since he knows all the engine details including graphs and so on
16:09:24 <dzimine> ok
16:10:09 <rakhmerov> yes, on repeater. Manas is responsible for that but Nikolay is going to spend some dedicated time to get into the problem deeply and help him
16:10:19 <NikolayM> yes
16:10:23 <dzimine> Also, can we do something to help Nikolay's commit in?
16:10:33 <rakhmerov> which one?
16:11:02 <dzimine> the Model, https://review.openstack.org/#/c/75888/
16:11:11 <rakhmerov> ooh
16:11:17 <rakhmerov> yes, we can review it :))
16:11:37 <rakhmerov> kidding
16:11:43 <rakhmerov> did you mean anything specific?
16:11:55 <rakhmerov> it should look fine now I believe
16:12:20 <rakhmerov> there was a number of conceptual issues with it and Nikolay has been reworking since Friday
16:12:26 <dzimine> Naming, which roots in our thinking of the model. We may need to clarify the diff between persistent data objects and objects which we used to call dsl_
16:12:54 <rakhmerov> we can discuss naming right now
16:13:26 <rakhmerov> so far the only idea I've head in mind is "model" or "domain model"
16:13:35 <rakhmerov> versus "db model"
16:13:59 <NikolayM> agree, but one more - "object model"
16:13:59 <rakhmerov> now Nikolay called it "model" (there is a corresponding package)
16:14:08 <rakhmerov> yeah
16:14:39 <rakhmerov> I feel that I'm not 100% happy with this naming but I just don't have better ideas
16:14:51 <dzimine> You may be already discussed it, can you drop a discussion on etherpad? I need to leave now, and Manas wanted to check it, too.
16:15:17 <rakhmerov> nope, we didn't discuss it much
16:15:25 <dzimine> The short point is we have persistent model stored in database, and may be we want to reserve the 'model' for it?
16:15:30 <rakhmerov> Nikolay, can you please start a discussion in ML?
16:15:46 <rakhmerov> reverse?
16:16:07 <dzimine> May be
16:16:19 <rakhmerov> #action Nikolay, start a ML discussion about model (parsed from DSL) and distinction from db model
16:16:32 <rakhmerov> I mean can you clarify that?
16:16:52 <NikolayM> yes, I'll start it
16:16:57 <rakhmerov> oooh, sorry
16:17:00 <dzimine> The point is if we decide on model, and names, we won't make Nicolay do big renames on review
16:17:04 <rakhmerov> reserve, not reverse
16:17:29 <rakhmerov> no problem, let's discuss it in ML
16:17:39 <rakhmerov> I don't tend to hurry with this commit
16:17:49 <rakhmerov> we should carefully think it through
16:17:58 <rakhmerov> it's a very important commit
16:18:22 <rakhmerov> sounds good?
16:18:23 <dzimine> agree with Renat: this forces us to define the underlying model and helps evolve the shared understanding.
16:18:56 <rakhmerov> ok
16:19:58 <rakhmerov> btw, just reviewd Winson's commit. Looks like it's going to land soon. I had just one question about it
16:20:06 <rakhmerov> overall it looks good
16:20:25 <rakhmerov> Winson, are you here with us today?
16:20:30 <m4dcoder> yes
16:20:34 <rakhmerov> hi
16:20:41 <rakhmerov> glad you're here
16:21:03 <rakhmerov> so could you please remind what's going to be your next step with oslo.messaging?
16:21:30 <m4dcoder> are we doing anything with TaskFlow?
16:21:38 <rakhmerov> not now
16:21:58 <rakhmerov> there's a lot of things to clarify on that
16:22:16 <rakhmerov> I can share the details later
16:22:52 <m4dcoder> for oslo.messaging, i will be doing versioning and removing local engine next
16:23:13 <m4dcoder> and then standalone engine using oslo.messaging
16:23:28 <m4dcoder> but still have to answer the question on context on my last review
16:23:37 <rakhmerov> can you start with removing local engine and introducing the ability to use a fake driver (whatever it's called)?
16:24:11 <rakhmerov> this is specifically important for overall reducing code duplication
16:24:24 <dzimine> Now I need to leave early, sorry folks, I'll catch up with the minutes
16:24:24 <m4dcoder> yes
16:24:46 <rakhmerov> Dmitri, thanks for joining us! Have a wonderful day )
16:24:57 <rakhmerov> we can sync up with you this week
16:25:11 <rakhmerov> m4dcoder, thanks
16:25:53 <rakhmerov> and btw, if you meant execution context by that "cntx" parameter then we don't need it
16:26:02 <rakhmerov> we don't need it explicitly
16:26:58 <rakhmerov> it's going to be a part of task
16:27:02 <m4dcoder> the context jn oslo.messaging is required parameter, it's usually for the storing any request context which includes authN/authZ info
16:27:09 <m4dcoder> but you can also put exec context there
16:27:31 <rakhmerov> ok, if it's required then it's fine
16:27:53 <rakhmerov> but we shouldn't be confusing it with execution context, it's a completely different thing
16:28:09 <rakhmerov> just wanted to make sure we clearly understand that
16:28:41 <rakhmerov> ok, then I would just insert a comment explaining what "cntx" is for and it will be fine
16:28:55 <m4dcoder> ok.  i'll do that
16:29:12 <rakhmerov> thanks, generally good job
16:29:20 <m4dcoder> thanks.
16:29:42 <rakhmerov> #topic Open discussion
16:30:00 <rakhmerov> so do you guys have any questions/topic you would wanna discuss now?
16:30:22 <rakhmerov> I don't :)
16:30:50 <rakhmerov> if you don't either then we can finish earlier today
16:32:00 <rakhmerov> in general I think we started making good progress in development and community activity, let's keep up this style of work
16:32:30 <NikolayM> I don't  too
16:32:39 <rakhmerov> btw, just in case some of you are not aware
16:33:07 <rakhmerov> Kirill (enykeev) has already completed CLI for Mistral client
16:33:17 <rakhmerov> it's a part of python-mistralclient
16:33:20 <rakhmerov> enjoy!
16:33:48 <rakhmerov> it should be useful even in development process
16:34:00 <rakhmerov> thanks to Kirill
16:34:21 * enykeev bows
16:34:24 <enykeev> =)
16:34:32 <rakhmerov> :)
16:34:48 <rakhmerov> alright, let's wrap up then?
16:35:06 <rakhmerov> ok, bye guys
16:35:11 <enykeev> yep, looks so
16:35:26 <enykeev> thanks
16:35:27 <rakhmerov> keep doing what you're doing :) Awesome job!
16:35:28 <NikolayM> bye!
16:35:42 <rakhmerov> (it was addressed to all)
16:35:46 <rakhmerov> bye
16:35:53 <rakhmerov> #endmeeting