16:00:44 <rakhmerov> #startmeeting Mistral
16:00:45 <openstack> Meeting started Mon Mar 10 16:00:44 2014 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:49 <openstack> The meeting name has been set to 'mistral'
16:00:51 <rakhmerov> hi guys
16:00:53 <enykeev> Hey!
16:00:55 <manask> hi
16:01:28 <rakhmerov> manask, it seems to me you're here for the first time, am I right?
16:01:36 <manask> thts correct
16:01:42 <rakhmerov> cool :) Welcome
16:01:47 <manask> thanks!
16:02:02 <rakhmerov> ok
16:02:12 <rakhmerov> do you guys know if Dmitri is coming?
16:02:21 <manask> i dont think so
16:02:27 <manask> he is on the road so may not have access
16:02:50 <rakhmerov> ooh, ok
16:03:06 <rakhmerov> is anybody here from Mirantis?
16:03:13 <m4dcoder> o/
16:03:41 <rakhmerov> today is a holiday in Russia so I'm not sure if all the folks from Mirantis are going to be here
16:03:58 <rakhmerov> ok, let's start
16:04:40 <rakhmerov> as usually, here's the agenda: https://wiki.openstack.org/wiki/Meetings/MistralAgenda
16:04:53 <rakhmerov> let's review previos AIs first
16:05:01 <rakhmerov> #topic Previous Action Items
16:05:40 <rakhmerov> we had the only one from the previous meeting
16:05:43 <rakhmerov> 1. Nikolay, start a ML discussion about model (parsed from DSL) and distinction from db model
16:06:04 <rakhmerov> it was done and looks like we've pretty much agreed on that
16:06:08 <manask> yes.
16:06:12 <rakhmerov> alright
16:06:37 <rakhmerov> here's the patch: https://review.openstack.org/#/c/75888/
16:06:52 <rakhmerov> it now looks fine but needs to be rebased
16:07:29 <rakhmerov> Nikolay will do it on Wed (he doesn't work on Tuesdays)
16:07:37 <manask> k.
16:08:00 <rakhmerov> #topic Current Status
16:08:10 <rakhmerov> I'll start first
16:08:46 <rakhmerov> I've been working on Data Flow, community related things and overall coordination
16:09:05 <rakhmerov> as for Data Flow, my two important patches got merged
16:09:31 <rakhmerov> and another one with additional testing is on its way: https://review.openstack.org/#/c/78599/
16:09:48 <rakhmerov> it's just missing one "+1" vote for now
16:10:01 <manask> i can take a look today
16:10:09 <rakhmerov> sure, thanks
16:10:40 <rakhmerov> tomorrow I'm going to refactor actions, the current design is incomplete and doesn't match the project vision anymore
16:11:14 <manask> is there a bluprint?
16:11:36 <rakhmerov> and I'm also going to review everything what's been done on Data Flow and identify what's left. Overall it's done, maybe I need to test some specific scenarious
16:12:22 <rakhmerov> manask, no, we don't have a BP yet. I think the closest blueprint is the one Dmitri is supposed to work on
16:12:27 <rakhmerov> about pluggable actions
16:12:32 <manask> k
16:12:33 <rakhmerov> they are kinda related
16:12:42 <rakhmerov> I'll create a BP first, right
16:13:06 <manask> sure. Thanks!
16:13:23 <rakhmerov> but just not to loose time I'll also start doing that, so that we can see both the description and the code
16:13:36 <rakhmerov> we can adjust that if we need to
16:13:51 <rakhmerov> ok, I can also say for Nikolay
16:14:32 <rakhmerov> he's finished that important object model thing (still dunno how to call it properly)
16:14:57 <rakhmerov> he's also fixed an important thing in the engine (multiple tasks in on-XXX sections)
16:15:40 <rakhmerov> can you guys quickly describe your status?
16:15:53 <rakhmerov> whoever is ready..
16:16:19 <manask> i can go
16:16:24 <rakhmerov> ok, go ahead
16:16:38 <manask> slow week … apart from looks at changes and some email discussion no progress
16:16:53 <manask> next I am working on std:repeater code today
16:17:04 <rakhmerov> ok, understandable, no worries
16:17:04 <manask> expect to see a review by EOD tomm
16:17:11 <rakhmerov> alright
16:17:27 <rakhmerov> I told Nikolay to help you if needed
16:17:40 <manask> yes i fully expect to need some support
16:17:53 <manask> you said he does not work Tuesday - right?
16:17:55 <rakhmerov> we got familiar with the etherpad you wrote and Nikolay is 100% aware of how engine works
16:18:01 <manask> perfect
16:18:13 <rakhmerov> yeah, unfortunately he doesn't..
16:18:25 <rakhmerov> you can also ping me
16:18:39 <manask> will do;
16:18:52 <m4dcoder> i've started work on removing the local engine.  but i have a few questions which i need to send to dev ML to get opinion.  because the fake driver for oslo.messaging is using an in proc queue, the API and executor need to be running in the same process with a shared transport when it's configured to use the fake driver.
16:18:53 <rakhmerov> alright
16:19:43 <rakhmerov> manask, but what you suggested seems to be ok to me. When implementing that please keep in mind that we'll need to refactor it later when we havev that workflow grouping
16:19:46 <m4dcoder> also, need to rebase my last patch on oslo.messaging...  doesn't help when the rest action is not fully working... i have to modify the test somewhat...
16:19:51 <rakhmerov> workflow1, workflow2 etc..
16:19:56 <rakhmerov> m4dcoder, ok
16:20:04 <manask> rakhmerov : ok
16:21:10 <rakhmerov> m4dcoder, yes, pls send your questions
16:21:26 <rakhmerov> and you can actually ask them here if you think it makes sense now
16:21:40 <m4dcoder> i want to have a proposal first.
16:21:45 <rakhmerov> ok, sure
16:21:46 <m4dcoder> i'm still working thru that.
16:22:07 <rakhmerov> the main requirement for that is that it works just like it does now
16:22:32 <rakhmerov> I mean we should be able to configure engine and transport so that we can run workflows within a single process
16:23:12 <enykeev> I'm hopefully finished with python-mistralclient tests and context serialization (both of them are on review right now https://review.openstack.org/#/c/78539/ and https://review.openstack.org/#/c/79242/) and started digging into TaskFlow. I had also worked on the listeners blueprint, but we decided to postpone this one until we both find a proper use cases for them and finish with object model.
16:23:13 <m4dcoder> yep
16:23:18 <rakhmerov> and ideally it should be easy to do
16:23:19 <rakhmerov> ok
16:24:13 <m4dcoder> rakhmerov: you told us last week you'll email your thoughts on TaskFlow.  did you do that?
16:25:28 <rakhmerov> ooh, I did?
16:25:47 <rakhmerov> enykeev, +1 from me for both patches
16:27:11 <rakhmerov> m4dcoder, as far as I remember I told in ML that we'd get familiar with what's been going in TaskFlow for the last month and see how we can live on with Taskflow together
16:28:01 <rakhmerov> our plan regarding this is digg into TaskFlow (enykeev started doing this) and then try to build a very very simple prototype based on it
16:28:28 <rakhmerov> to be able to see better all the mismatches and problems, if any
16:29:18 <m4dcoder> got it.
16:29:55 <rakhmerov> but, generally, i'd say it's very important for us
16:30:03 <rakhmerov> for a number of reasons
16:30:33 <rakhmerov> ok, my next topic is Repeater
16:30:45 <rakhmerov> but we've already touched it a little bit
16:30:52 <manask> correct
16:30:54 <rakhmerov> manask, do you wanna talk about it more?
16:31:18 <rakhmerov> or it's fine for now and you have no roadblocks?
16:31:19 <manask> I hoep folks get a chance to look at the blueprint and provide any comments
16:31:24 <rakhmerov> at least for the first implementation
16:31:27 <manask> https://blueprints.launchpad.net/mistral/+spec/mistral-std-repeat-action
16:31:34 <manask> no roadblocks
16:31:37 <rakhmerov> ooh, ok
16:32:09 <rakhmerov> enykeev, I think it would be helpful if you could start participating this too
16:32:25 <rakhmerov> it's all actually related with that TaskFlow thing...
16:32:33 <rakhmerov> not directly but anyway
16:32:48 <rakhmerov> mostly conceptually
16:32:52 <manask> yes. It may drive some requirements to that integration
16:33:01 <rakhmerov> it's going to touch the overall engine architecture
16:33:08 <rakhmerov> yep
16:33:11 <rakhmerov> ok, let's move on
16:33:32 <rakhmerov> #topic What's left on Pilot
16:33:46 <rakhmerov> this is an important thing :)
16:34:38 <rakhmerov> according to our Roadmap (https://wiki.openstack.org/wiki/Mistral/Roadmap) we should have finished Pilot a couple of weeks ago
16:35:15 <rakhmerov> which is fine since, apparently, it was too positive estimation
16:36:02 <rakhmerov> so as far what Pilot should contain I'm still thinking about an example described here: https://etherpad.openstack.org/p/mistral-poc
16:36:34 <rakhmerov> it's already outdated in terms of syntax but I'm still targeting to that idea
16:36:47 <rakhmerov> unless we come up with something better
16:36:47 <manask> k. Do you know what is missing?
16:37:10 <manask> as in is there a list we can attack?
16:37:34 <rakhmerov> mostly repeater :)
16:37:46 <rakhmerov> and a series of smaller things
16:38:00 <manask> k.
16:38:23 <rakhmerov> for example, like I said before not everything is ok with actions
16:39:15 <rakhmerov> this week I'm going to switch to more kind of analytic work to identify everything more detailed
16:39:47 <manask> perfect. If you file bugs or create blueprint topics we can systematically go in and finish up
16:39:49 <rakhmerov> we already have this example workflow in mistral-extra so I'll start launching it to see what else is missing
16:40:00 <rakhmerov> so we need to make it work as soon as we can
16:40:07 <rakhmerov> sure
16:40:15 <rakhmerov> but repeater is the major thing
16:40:23 <manask> Ack!
16:40:28 <rakhmerov> ok
16:40:41 <rakhmerov> so please keep us posted on the progress
16:41:00 <manask> yes.
16:41:41 <rakhmerov> one of the important thing that we need to do is to make it work with a real OS installation
16:41:56 <rakhmerov> and I believe we'll face more problems with it
16:42:18 <rakhmerov> one thing is in my head even now
16:42:41 <manask> are you targetting a specific OS?
16:42:49 <rakhmerov> somehow, we need to insert auth token when HTTP actions make requests to Nove, for example
16:43:23 <rakhmerov> manask, you mean specific version?
16:43:30 <rakhmerov> or what?
16:43:38 <manask> yes like ubuntu 12
16:43:46 <rakhmerov> ooh, I meant OpenStack
16:43:58 <rakhmerov> by OS
16:44:06 <manask> got it … sorry!
16:44:13 <rakhmerov> np
16:44:50 <rakhmerov> so as for that auth token thing we have a couple of ideas with Nikolay which aren't captured anyway
16:45:07 <rakhmerov> let me capture a couple of AI
16:45:45 <rakhmerov> #action rakhmerov, create a BP describing insertion of auth token into HTTP action requests
16:46:06 <rakhmerov> #action rakhmerov, create a BP on actions refactoring
16:46:27 <rakhmerov> #action rakhmerov, identify all the things left on Pilot
16:47:41 <rakhmerov> so, once this example completely works we need to record a screencast, update wiki and other sources, complete specs and so on. A lot of work
16:47:54 <rakhmerov> and share the results with community
16:49:13 <rakhmerov> so let's try to do it as quickly as possible
16:49:55 <rakhmerov> after that we'll take a pause and review everything: DSL, API, design and file a bunch of new BPs based on that for the next cycles
16:50:38 <manask> agreed.
16:50:44 <rakhmerov> ok, I don't have any more specific topics for now
16:50:55 <rakhmerov> if you guys have anything let's talk
16:51:07 <manask> quick administrative update
16:51:14 <rakhmerov> ok
16:51:16 <manask> i am now using manas@stackstorm.com
16:51:23 <rakhmerov> ok
16:51:54 <manask> i will do my best to update systems asap but if you need to unicast me then please use the new one.
16:52:06 <rakhmerov> ok, sure
16:52:45 <manask> thts it from me
16:52:53 <rakhmerov> ok
16:52:59 <rakhmerov> can we finish?
16:53:22 <rakhmerov> alright, thanks to everyone!
16:53:23 <enykeev> seems like we can
16:53:28 <rakhmerov> :)
16:53:32 <manask> thanks!
16:53:38 <enykeev> Thanks
16:53:47 <rakhmerov> bye guys, I think we'll be moving faster now
16:53:53 <rakhmerov> I mean development
16:54:12 <rakhmerov> bye guys, have a good day/night )
16:54:19 <rakhmerov> #endmeeting