16:00:06 <rakhmerov> #startmeeting Mistral
16:00:07 <openstack> Meeting started Mon Mar 31 16:00:06 2014 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:10 <openstack> The meeting name has been set to 'mistral'
16:00:16 <enykeev> hey!
16:00:19 <rakhmerov> hello everyone
16:00:20 <manask> hi
16:00:28 <facundom_> hello
16:02:11 <rakhmerov> ok, let's begin
16:03:17 <NikolayM> hi everyone!
16:03:46 <rakhmerov> hi
16:03:58 <rakhmerov> guys, does anyone have a link to the previous meeting minutes?
16:04:14 <igormarnat_> o/
16:04:16 <rakhmerov> I missed it so I don't know if you captured any AI
16:04:17 <dzimine> hi Renat, yet and it's all posted on mistral wiki
16:04:23 <enykeev> http://eavesdrop.openstack.org/meetings/mistral/2014/mistral.2014-03-24-16.03.html
16:04:25 <rakhmerov> :)
16:04:26 <rakhmerov> ok
16:04:42 <aignatov> o/
16:04:49 <dzimine> http://eavesdrop.openstack.org/meetings/mistral/2014/mistral.2014-03-24-16.03.html
16:04:57 <joel_c> .
16:04:58 <dzimine> http://eavesdrop.openstack.org/meetings/mistral/2014/mistral.2014-03-24-16.03.log.html
16:05:03 <rakhmerov> hi Dmitri
16:05:04 <rakhmerov> ok
16:05:08 <rakhmerov> so
16:05:14 <dzimine> sorry I'm late but good to have you back!
16:05:23 <rakhmerov> #topic Review Action Items
16:05:27 <rakhmerov> thanks )
16:05:40 <rakhmerov> 1. (all) review and discuss Kirill's stub on MistralTaskflow prototype https://github.com/enykeev/mistral/pull/1
16:05:49 <rakhmerov> what's on this one?
16:06:16 <rakhmerov> dzimine, I saw an email from you today about that but didn't review fully review it yet
16:06:31 <dzimine> it it pretty big :)
16:06:40 <rakhmerov> may be you guys had a chance to look at it
16:06:43 <rakhmerov> ok
16:06:54 <dzimine> I did review it in details, and discussed briefly with Kirill,
16:06:55 <rakhmerov> so this one is in progress I would say, right?
16:07:00 <rakhmerov> ok,
16:07:09 <rakhmerov> what's the brief feedback?
16:07:10 <manask> i've also taken a look
16:07:14 <rakhmerov> ok
16:07:24 <dzimine> the next step on this is to summarize the learnings (Kirill had started) and define next steps if any.
16:07:32 <rakhmerov> it's pretty important thing for us, I would encourage everyone to look at it
16:07:42 <rakhmerov> I see
16:07:55 <dzimine> +1, and ask Kirill questions (right in the pull request)
16:08:32 <dzimine> I would sum it up as: 1) TaskFlow can be used
16:08:41 <rakhmerov> really? :)
16:08:46 <dzimine> 2) there are few things to make it work inside web servcie
16:09:03 <dzimine> and 3) quite a few features to add to it as a library.
16:09:42 <rakhmerov> what about that passive model that we have now?
16:09:53 <rakhmerov> is it possible to do using taskflow now?
16:10:13 <dzimine> passive is one of the things to ask and change.
16:10:21 <rakhmerov> ok
16:10:29 <rakhmerov> does Josh agree to do that?
16:10:53 <rakhmerov> or is it still the thing to discuss with him?
16:10:58 <dzimine> we didn't sum up the results yet (or Kirill might have overnight I haven't seen it)
16:11:35 <rakhmerov> ok
16:11:41 <dzimine> we began the discussion on the mailing list; now with the prototype we can have it more concrete.
16:11:52 <rakhmerov> awesome
16:12:00 <rakhmerov> so what's the plan?
16:12:26 <enykeev> no, there is quite a few things to add, but i want to hear your feedback first to make sure i didn't miss something important on our side
16:12:28 <rakhmerov> as far as I understand once Kirill finishes that up we need to start a ML discussion and get Josh included? Right
16:12:28 <rakhmerov> ?
16:13:12 <dzimine> re Taskflow? 0) collect your feedback 1) do the summary 2) open discussion on mailing list 3) potentially ask Joshua help with next steps.
16:13:20 <rakhmerov> enykeev, I agree, we first need to research what you did carefully, I'll be able to do that tomorrow, at least mostly
16:13:33 <rakhmerov> ok
16:14:13 <rakhmerov> so, let me keep this AI then
16:14:20 <rakhmerov> #action (all) review and discuss Kirill's stub on MistralTaskflow prototype https://github.com/enykeev/mistral/pull/1
16:14:46 <rakhmerov> 2.  (dzimine): plan to sum up the learning from the prototype for discussion on TaskFlow integration
16:14:53 <gokrokve_> For Taskflow, I suggest you to participate in cross-project sessions and discuss Mistral as a part of the whole OpenStack ecosystem.
16:14:58 <rakhmerov> I think this is pretty much the same
16:15:09 <gokrokve_> Such sessions will be a part of Atlanta summit.
16:15:34 <gokrokve_> Sure. I know that Solum might be interested in Mistral too.
16:15:37 <rakhmerov> gokrokve_, what exact project would you suggest? Except taskflow, of course
16:15:44 <rakhmerov> projects
16:16:04 <gokrokve_> Solum, Heat. They expressed their interest on last summit.
16:16:23 <rakhmerov> how about Climate and Fuel?
16:16:37 <gokrokve_> Sure.
16:16:46 <rakhmerov> Fuel action already has it on their Roadmap afaik
16:17:02 <gokrokve_> That is good.
16:17:45 <rakhmerov> ok, I know Dina was interested in it but she didn't express enough readiness to use it before it gets incubated )
16:18:21 <rakhmerov> so, the 3rd AI
16:18:24 <rakhmerov> 3. (tnurlygayanov) plan to write new tempest tests with execution of the real workflows
16:18:47 <rakhmerov> tnurlygayanov, did you have a chance to start this work?
16:19:25 <rakhmerov> however, it might have been challenging I know since not all the changes were merged in
16:20:17 <rakhmerov> ok, looks like he's not here
16:20:24 <rakhmerov> I'll keep this AI
16:20:30 <rakhmerov> #action (tnurlygayanov) plan to write new tempest tests with execution of the real workflows
16:20:46 <rakhmerov> #topic Current Status
16:21:11 <rakhmerov> guys, let's tell everyone's current status first
16:21:24 <rakhmerov> nmakhotkin?
16:22:01 <NikolayM> I've finished work with trust
16:22:42 <NikolayM> also today do some fix due to changing keystone client
16:23:01 <rakhmerov> ok
16:23:09 <enykeev> polished the prototype for the whole week, tried to summarize the learnings
16:23:44 <rakhmerov> ok
16:23:55 <rakhmerov> enykeev, just to clarify
16:24:11 <rakhmerov> does the codebase of the prototype correspond to the etherpad?
16:24:24 <rakhmerov> mistral-taskflo-prototype?
16:24:46 <enykeev> mostly
16:24:51 <dzimine> Timur: we didn't get any response from you guys on ci-murano failures
16:25:01 <rakhmerov> I mean it would be cool to have a short list of bullet points with what it covers
16:25:07 <rakhmerov> it'd be easier to review
16:25:26 <enykeev> no transitions and workers
16:25:48 <rakhmerov> dzimine, yeah, sorry for that. I let Timur know about it, he was busy all day today
16:25:58 <rakhmerov> ok
16:26:25 <rakhmerov> dzimine, actually I confused it a little bit
16:26:31 <rakhmerov> Timur looked at it
16:27:03 <rakhmerov> the thing is that our scripts changed in the patch that Winson sent, that is a reason why CI fails
16:27:39 <rakhmerov> so I would suggest we review it first (with -1 from murano-ci) and the if it's ok we'll fix murano-ci accordingly
16:27:45 <rakhmerov> to get +1 from it
16:28:23 <ruhe> rakhmerov: (sorry for interruption) wouldn't it be awesome to run all the Mistral tests in devstack gate?
16:28:59 <rakhmerov> yes
16:29:02 <rakhmerov> it would :)
16:29:18 <ruhe> and you have it in your roadmap? :)
16:29:43 <rakhmerov> I believe Timur did already start looking at it
16:29:57 <rakhmerov> yes, it was a part of our plan
16:30:25 <ruhe> rakhmerov: we have basic devstack scripts and tempest tests for murano. we could help to drive the same for mistral
16:30:40 <rakhmerov> #action Timur, make sure to look at running Mistral tests in devstack gate
16:30:56 <rakhmerov> ruhe, perfect, thanks
16:31:03 <rakhmerov> we'll bug you then with that :)
16:31:42 <dzimine> #action review https://review.openstack.org/#/c/81941/ ignoring -1 from murano-ci, change it once we give +1
16:31:47 <rakhmerov> Timur and Sergey already added some basic Tempest tests for Murano, Timur is now working on more advanced ones
16:32:14 <rakhmerov> * ... for Mistral ...
16:32:40 <rakhmerov> ok, my status is really quick: I was absent for a week and a half, today I did a few reviews, had several discussions with team members and processed my inbox
16:33:28 <rakhmerov> is Winson here?
16:34:34 <rakhmerov> looks like he is not
16:34:56 <rakhmerov> I saw there's a patch on review from him
16:35:06 <rakhmerov> but didn't look at it yet
16:35:42 <rakhmerov> this patch is pretty interesting btw: https://review.openstack.org/#/c/81941/
16:36:22 <dzimine> This is the one giving murano-cli -1. I looked at it, it's all right IMO.
16:36:30 <rakhmerov> ok
16:36:33 <rakhmerov> cool
16:37:00 <rakhmerov> so the next topic is
16:37:06 <dzimine> Nicolay was asking for suggestion on this https://review.openstack.org/#/c/83404/
16:37:23 <dzimine> I looked but didn't have any good advice, Renat may be you can help there.
16:37:41 <dzimine> https://review.openstack.org/#/c/83404/2/mistral/engine/data_flow.py
16:38:32 <rakhmerov> yeah, I'm not quite sure I understand the problem though
16:39:16 <NikolayM> first, we resolve all data in service_spec and in task_spec
16:39:38 <rakhmerov> what do you mean by "resolve all data"?
16:39:50 <NikolayM> but we need to ignore service.actions.action.output
16:40:02 <rakhmerov> and what method _modify_item() is generally for?
16:40:37 <NikolayM> I mean replace expressions on real data from context
16:40:45 <rakhmerov> ok
16:41:35 <NikolayM> modify_item just for replacing value-expression on the value-data
16:42:05 <rakhmerov> ok, I see now
16:42:56 <rakhmerov> so, correct me if I'm wrong, the problem is that we need to be able to validate those expressions but we can't do that until a corresponding action runs?
16:42:58 <rakhmerov> right?
16:43:37 <NikolayM> yes :)
16:44:02 <rakhmerov> it feels like we may need to split this functionality
16:44:15 <rakhmerov> expression evaluation and expression validation
16:44:18 <rakhmerov> somehow
16:44:46 <rakhmerov> in this case we could do it easily
16:45:07 <rakhmerov> probably we should have another method validate in evaluator
16:45:52 <rakhmerov> #action Find a solution for the question asked in https://review.openstack.org/#/c/83404/2/mistral/engine/data_flow.py
16:46:23 <rakhmerov> ok, let's think on that one offline
16:46:47 <rakhmerov> #topic PoC scope and readiness
16:47:25 <rakhmerov> I think we're pretty close (as usually :) )
16:47:47 <rakhmerov> Manas was able to finish "repeat" property which is very very good
16:48:01 <rakhmerov> it was the main roadblock IMO
16:48:15 <rakhmerov> and Nikolay finished a few important things too
16:48:34 <dzimine> I recall Nicolay was planning to run POC flow against real OpenStack cluster and see how it goes. Did we try this?
16:48:37 <rakhmerov> trusts and various fixes in Data Flow
16:50:00 <rakhmerov> I saw a patch from Nikolay: https://review.openstack.org/#/c/83737/
16:50:17 <rakhmerov> it is said that it has been tested on a real OpenStack
16:50:22 <NikolayM> I try to create VM and I did it!
16:50:31 <rakhmerov> it's pretty simple (just creates a VM)
16:50:33 <rakhmerov> yeah :)
16:51:01 <rakhmerov> we need to move on and add more complex scenario with repeater
16:51:34 <rakhmerov> I think we can finish it this week, it seems to be possible to me
16:52:17 <rakhmerov> so I would suggest the following plan
16:52:43 <rakhmerov> 1. This week we actively work on getting PoC scenario work
16:53:02 <rakhmerov> 2. Fix whatever prevents it from working correctly
16:53:49 <rakhmerov> 3. At the next community meeting we discuss what we've done and make a conclusion if we're satisfied with it or not (and suggestions on how to improve it)
16:54:12 <rakhmerov> so next meeting could be completely devoted to PoC scenario
16:54:33 <dzimine> so the week is focus on the changes that makes the POC working end-to-end. OK.
16:54:40 <rakhmerov> yes
16:55:36 <rakhmerov> because I'm personally not sure if it's something that we could really make a show of :)
16:55:46 <rakhmerov> like you Dmitri said before
16:55:59 <rakhmerov> and we may find better ideas on how to improve it
16:56:20 <rakhmerov> ok
16:56:31 <rakhmerov> we have about 3 minutes left
16:56:40 <rakhmerov> is there anything else guys?
16:57:31 <rakhmerov> dzimine, I'll carefully review ML discussions with Joshua tomorrow (didn't finish it today) and join the conversation
16:58:14 <rakhmerov> looks like you've done a good job on summarizing these models and differences between them (lazy engine etc.)
16:59:07 <rakhmerov> ok, let's shut the meeting down then
16:59:17 <rakhmerov> thanks to everyone for joining
16:59:22 <enykeev> Thanks!
16:59:25 <rakhmerov> bye-bye
16:59:27 <manask> thank!
16:59:34 <rakhmerov> #endmeeting