16:00:35 <rakhmerov> #startmeeting Mistral
16:00:35 <openstack> Meeting started Mon Jul 21 16:00:35 2014 UTC and is due to finish in 60 minutes. The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:38 <openstack> The meeting name has been set to 'mistral'
16:00:44 <rakhmerov> hi everyone
16:00:45 <xazel> Hey!
16:01:04 <dzimine> hello!
16:01:32 <rakhmerov> hey
16:01:39 <rakhmerov> ok, let's start
16:01:57 <akuznetsova> hi there
16:02:01 <rakhmerov> #topic Review AIs
16:02:13 <rakhmerov> surprisingly, no action items from the last time
16:02:24 <rakhmerov> which is bad
16:02:43 <rakhmerov> they always should be )
16:03:15 <rakhmerov> #topic Current Status (by team member)
16:03:36 <xazel> Fixed a bug related to context calculation for tasks with multiple dependencies, replaced incubator's oslo.db with standalone one and researched the migration mechanics.
16:03:50 <rakhmerov> ok
16:04:20 <rakhmerov> Kirill, did you add a TODO comment about two transactions? I still didn't look at that
16:04:57 <xazel> yep, about 5 hours ago
16:05:12 <rakhmerov> ok
16:05:56 <akuznetsova> I have a little progress, because most of the time I worked with other projects. However I fixed all comments in my patches with client tests and researched how to write tests for console client
16:06:46 <rakhmerov> my status: I keep working on the new engine, last week I effectively had only about 2 days for that. Today I made a few commits and trying to implement reverse workflow handler (since it's the simplest one) and clarify protocol between Engine and WorkflowHandler
16:07:00 <rakhmerov> akuznetsova, ok
16:07:30 <rakhmerov> btw, guys please review Nastya's commits so that she could move forward
16:07:41 <dzimine> ok
16:08:15 <rakhmerov> #action dzimine (and optionally xazel): review commits related to integration testing from akuznetsova
16:08:16 <rakhmerov> ok
16:08:28 <xazel> sure
16:08:56 <dzimine> I didn’t spent time on Mistral last week, this week plan to catch up with Renat’s upcoming changes and discuss if needed.
16:09:18 <rakhmerov> ok, yes
16:09:20 <rakhmerov> sure
16:10:00 <rakhmerov> dzimine, your most important contribution for me now is our meetings every Friday )
16:10:34 <rakhmerov> btw, I looked at your version of speaking proposal, it looks good
16:10:52 <rakhmerov> our writers included your second paragraph in their edited version
16:11:17 <rakhmerov> if you're ok with the current version (I am) then we can submit it
16:11:50 <rakhmerov> xazel, as far as those two TX and sqlite it's worth discussing a little bit here at this meeting (let's do in open discussion)
16:12:14 <rakhmerov> #topic Further Plans
16:13:16 <rakhmerov> my plan for this week is fully figure out the new engine architecture, data models, protocols between different components and implement reverse workflow and cover it with tests
16:13:49 <xazel> I'll have not too much time this week so a couple of reviews per day is all I'll be able to do.
16:13:53 <rakhmerov> of course, I'll reuse the pieces of code that we already have which is supposed to simplify things
16:13:55 <dzimine> BTW Renat may be a linear workflow will be easier & more interesting.
16:14:32 <rakhmerov> It's more interesting, right, but not easier )
16:14:54 <akuznetsova> i am going to finally finish with mistralclient tests and work with tests for console client
16:15:28 <rakhmerov> dzimine, actually not a problem, if you insist I can implement linear first
16:15:42 <rakhmerov> I chose reverse for simplicity only
16:16:16 <rakhmerov> akuznetsova, is there anything we could help with?
16:16:40 <akuznetsova> rakhmerov, no, thanks
16:16:43 <rakhmerov> so that you can finish your client tests
16:16:44 <rakhmerov> ok
16:17:09 <rakhmerov> let me capture what we said
16:17:38 <rakhmerov> #action rakhmerov, fully figure out the new engine architecture, data models, protocols between different components and implement reverse (or linear?) workflow and cover it with tests
16:17:39 <akuznetsova> rakhmerov, btw i also wait for this commit https://review.openstack.org/#/c/107255/
16:18:00 <rakhmerov> yeah, I know
16:18:26 <rakhmerov> the only thing we can do here is try to ping them in IRC
16:18:59 <rakhmerov> #action akuznetsova, ping folks at #openstack-infra about https://review.openstack.org/#/c/107255/
16:19:47 <rakhmerov> #action akuznetsova, finish with mistralclient tests and work with tests for console client
16:20:55 <rakhmerov> #topic Open discussion
16:21:11 <rakhmerov> xazel, as for sqlite
16:21:31 <rakhmerov> I had a discussion with several folks about it
16:21:51 <rakhmerov> they said it's de facto a requirement in OpenStack to support sqlite
16:22:03 <rakhmerov> even though I don't really agree with that requirement
16:23:03 <rakhmerov> so I'm planning to verify that information and if it's true we'll have to find a proper solution
16:23:56 <rakhmerov> one of the solutions I see is to handle parallel queries (which sqlite does not do well on its own) right in Mistral
16:23:59 <rakhmerov> in db api
16:24:07 <xazel> then we would need to find a way to queue the changes somehow instead of trying to perform them simultaneously from different threads. I have not enough experience to say something for sure, but it doesn't seems like an easy task...
16:24:32 <rakhmerov> the simplest way would be just to catch an exception and retry a query multiple times till it succeeds
16:24:41 <rakhmerov> yes
16:24:42 <rakhmerov> right
16:24:59 <rakhmerov> or we could just pile them in a sort of internal queue
16:25:10 <rakhmerov> to serialize them
16:25:56 <rakhmerov> but for now I'm ok with that solution with 2 TXs
16:26:48 <xazel> it actually makes some sense if you think about it long enough =)
16:27:10 <rakhmerov> :)
16:27:20 <dzimine> “long enough” indeed - I just looked at this for 15 min and it doesn’t :)
16:27:30 <rakhmerov> yeah
16:27:42 <rakhmerov> but...
16:28:18 <rakhmerov> pls let's don't be too picky right now with that commit
16:28:26 <xazel> we can always separate each transaction into its own function and it will immediately became less confusing =)
16:28:51 <rakhmerov> because the way how transactions look now may change in the new implementation (most likely will)
16:29:15 <dzimine> readability doesn’t confuse me at all, what confuses me is trying to figure what can go wrong.
16:29:29 <rakhmerov> yes, you can do this but this is just for readability
16:29:55 <rakhmerov> dzimine, I agree
16:30:18 <rakhmerov> It confused me even after we talked about it with Kirill during 20-25 mins :)
16:30:30 <dzimine> in new impl, do you think of queues/locks instead of relying on DB transaction?
16:30:42 <rakhmerov> the next day after that I looked at the code and said "woooow, what's that?" :)
16:30:56 <xazel> it would also limit variable contexts... anyway, I've look at it long enough and it still seems good enough for me.
16:31:25 <rakhmerov> dzimine, it's one of the ideas I'm trying to shape in my head
16:31:42 <rakhmerov> I have an idea but it's a little bit too crazy
16:31:52 <rakhmerov> and it's not shaped on 100%
16:32:13 <rakhmerov> but yes, somehow I would love to be able not to rely on transactions at all
16:32:35 <rakhmerov> generally speaking, transactions are almost not scalable
16:33:04 <rakhmerov> if you have any ideas please share them
16:34:48 <rakhmerov> dzimine, btw, would you be able to talk about the new design on you Tue after our meeting with Angus?
16:35:01 <dzimine> yes.
16:35:10 <dzimine> I’ll be up to date with your changes by than.
16:35:39 <rakhmerov> ok
16:36:11 <rakhmerov> so I'm not going to set any meetings then, I'll just reach you out after the conversation with Angus
16:37:15 <rakhmerov> other than that I don't have anything else from my side
16:37:23 <rakhmerov> for today
16:37:29 <rakhmerov> how about you guys?
16:37:43 <dzimine> rakhmerov you mentioned some new potential contributors, any update on this?
16:38:31 <rakhmerov> yep, he's ready to start. I planned to assign something simple to him early this week
16:38:54 <rakhmerov> #action rakhmerov, assign a couple of tasks to bhavenst
16:40:11 <dzimine> there’s a bug just reported on exectution completing with wrong status, may be a good starting task.
16:40:38 <rakhmerov> just reported?
16:40:40 <rakhmerov> which one?
16:41:23 <dzimine> [Bug 1346356] [NEW] execution-shoud-be-error-in-case-task-errored
16:41:24 <uvirtbot> Launchpad bug 1346356 in mistral "execution-shoud-be-error-in-case-task-errored" [Undecided,New] https://launchpad.net/bugs/1346356
16:42:13 <rakhmerov> ok, thanks
16:43:05 <rakhmerov> done
16:43:08 <rakhmerov> anything else?
16:43:25 <akuznetsova> not from my side
16:43:30 <rakhmerov> let's shut the meeting down then
16:43:37 <rakhmerov> thanks to everyone
16:43:39 <rakhmerov> bye
16:43:48 <rakhmerov> #endmeeting