16:00:15 <rakhmerov> #startmeeting Mistral
16:00:15 <openstack> Meeting started Mon Aug  4 16:00:15 2014 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:18 <openstack> The meeting name has been set to 'mistral'
16:00:28 <rakhmerov> hi
16:00:41 <akuznetsova_> hello)
16:00:55 <rakhmerov> let's wait for a couple of mins for others
16:01:12 <nmakhotkin_> hi!
16:01:24 <rakhmerov> hi
16:02:08 <rakhmerov> #topic Review Action Items
16:02:20 <rakhmerov> 1. rakhmerov, finish reverse workflow implementation
16:03:03 <rakhmerov> it's not done yet but I"m close because I've almost finished all the preparations (specs, handler and db models)
16:03:16 <rakhmerov> #action rakhmerov, finish reverse workflow implementation
16:03:29 <rakhmerov> 2. rakhmerov, get update on integration testing
16:03:30 <rakhmerov> done
16:03:36 <rakhmerov> 3. rakhmerov, let akuznetsova know that devstack gate keeps failing so that she can find the reason
16:03:56 <rakhmerov> done, we've figured out the reason, I'm going to fix it this week
16:04:16 <rakhmerov> #action rakhmerov, fix devstack gate problem (caused by changed in DB layer)
16:04:39 <rakhmerov> #topic Current status (progress, issues, roadblocks)
16:05:50 <rakhmerov> my status: last week I worked on specifications (versioning, v1/v2, tests) and DB layer refactoring (switched from dicts, versioning, v2 models)
16:06:06 <rakhmerov> hoping to get reverse workflow done this week
16:06:36 <dzimine> my status: last week: staying current with Renat’s changes, review, discuss, feedback.
16:06:39 <rakhmerov> most of the code exists, I just need to carefully move it to the new engine
16:07:05 <rakhmerov> hi dzimine
16:07:07 <akuznetsova_> I finished with https://blueprints.launchpad.net/mistral/+spec/mistral-mistralclient-integration-tests and almost done with https://blueprints.launchpad.net/mistral/+spec/mistral-cli-integration-tests (wait for merge my commit in tempest)
16:07:33 <nmakhotkin_> I worked on openstack-action blueprint, main part is finished now - https://review.openstack.org/#/c/111231/
16:07:55 <rakhmerov> dzimine, would be nice to see your feedback on https://review.openstack.org/#/c/111218/ (and Nikolay's too)
16:08:20 <dzimine> This week: look at the yaml syntax for Multiple data blueprint, and may be take a stub on DSL v2 syntax.
16:08:46 <rakhmerov> thanks, that would be really helpful
16:10:20 <rakhmerov> any roadblocks from anyone?
16:10:30 <rakhmerov> issues, questions?
16:11:15 <akuznetsova_> no
16:11:18 <rakhmerov> ok
16:11:40 <rakhmerov> from my side, last week I felt I really got stuck with DB layer refactoring
16:12:16 <rakhmerov> so I would ask everyone to provide an early feedback on https://review.openstack.org/#/c/111218/
16:12:50 <rakhmerov> in fact, I realized that the approach used in there leads to interesting things
16:13:00 <rakhmerov> basically, we need to version almost everything
16:13:22 <rakhmerov> REST API, DSL specs, db models and even tests
16:13:29 <dzimine> renat as for reverse workflow - if it takes a whole week, I’d punt on it’s full implementaion till later and only see how we conceptually support two types of workflow (DSL, and calls). Which may be done with some stub impl. may be.
16:13:53 <rakhmerov> I see, yes
16:13:53 <akuznetsova_> rakhmerov: cli and mistralclient too, i guess)
16:13:55 <rakhmerov> agree
16:14:35 <rakhmerov> dzimine, what I've been doing so far is related with the whole V2 thing, not only reverse workflow
16:14:50 <rakhmerov> it will be needed for direct workflow and whatever else
16:15:20 <rakhmerov> but I agree, we can implement a stub for reverse workflow now and move on to the linear
16:15:24 <dzimine> my comment was on your plans to implement reverse workflow this week
16:15:49 <rakhmerov> akuznetsova, you're absolutely correct :) mistralclient and CLI will have to be versioned as well
16:16:03 <rakhmerov> which scares me a little bit but I just don't see other ways
16:16:12 <rakhmerov> dzimine, ok
16:16:36 <dzimine> keep in mind this refactoring is special, and this time we need to version everythign, after we transition we delete some, right?
16:17:11 <rakhmerov> after we make sure that at least Solum is happy
16:17:11 <rakhmerov> yes
16:17:34 <dzimine> when the transition is complete, we surely want to keep a version of API, but old DSL, engine, DB, tests, etc may be gone?
16:17:44 <rakhmerov> #action rakhmerov, if full reverse workflow takes too long just limit by a stub impl and move on to linear
16:18:32 <rakhmerov> dzimine, this is actually interesting
16:19:08 <rakhmerov> even though it's not going to make too much sense in perspective we can actually keep supporting v1
16:19:14 <dzimine> We can currently have stub impl for both reverse and linear, use DSL with one task in both, and figure out ‘external’ mechanics of creating and managing workflows.
16:19:24 <rakhmerov> because we'll have parallel entities in the code
16:19:48 <rakhmerov> however, I'm not sure about some parts like engine->executor protocol, for instance
16:20:05 <rakhmerov> yes
16:20:28 <rakhmerov> just to make sure... what do you mean by "external" mechanics?
16:21:49 <rakhmerov> you mean all high-level communications like engine->handler?
16:22:12 <dzimine> yes.
16:22:46 <dzimine> use case: dsl has two workflows, each has a task, types are different, just make sure they are instantiated, parsed, etc.
16:23:26 <dzimine> when they are executed, proper sections go to proper handlers.
16:23:53 <rakhmerov> yes, ok
16:24:15 <rakhmerov> np
16:24:45 <rakhmerov> #topic Open Discussion
16:25:21 <rakhmerov> guys, are there any other important things you'd like to discuss?
16:25:36 <rakhmerov> if no, I'd suggest we save our time and finish the meeting earlier
16:26:02 <rakhmerov> we've got plenty of work to do (at least I do :) )
16:26:57 <nmakhotkin_> I have a question
16:27:16 <rakhmerov> sure
16:27:19 <rakhmerov> fire away
16:27:34 <nmakhotkin_> how do we test all openstack actions?
16:27:48 <rakhmerov> ooh, yes
16:27:49 <nmakhotkin_> I guess it can be integrated tests
16:27:52 <rakhmerov> this is a good one
16:28:15 <rakhmerov> yes, IMO it should be implemented as a part of integration tests
16:28:28 <nmakhotkin_> and if yes, we need to extend our devstack
16:28:41 <rakhmerov> the only issue I see is that devstack doesn't have some components like heat
16:28:52 <rakhmerov> (I may be wrong though)
16:29:00 <rakhmerov> yes
16:29:00 <akuznetsova_> probably, we can make a special workflow and run then in integration tests in gate
16:29:08 <akuznetsova_> rakhmerov: it is not true
16:29:22 <rakhmerov> what exactly?
16:29:29 <rakhmerov> heat?
16:29:31 <nmakhotkin_> akuznetsova, yes :)
16:29:33 <rakhmerov> ok
16:29:52 <akuznetsova_> rakhmerov: actually, i am not sure about heat, i will check it
16:30:01 <rakhmerov> please do
16:30:14 <rakhmerov> heat is one of the main things we need to integrate with
16:30:15 <akuznetsova_> rakhmerov: maybe we can install it separatly
16:30:35 <rakhmerov> anyway, we need to understand how to install additional services on devstack
16:30:54 <rakhmerov> I realize it may not be an easy thing to do for every service
16:30:58 <dzimine> IMO: assuming we are using python-clients for heat/nova etc, we don’t need to retest that those clienst work, we need to test that we are invoking them with the right params.
16:30:59 <akuznetsova_> rakhmerov: yes, that's what I said
16:31:38 <dzimine> also: for ideas, check how Heat team is testing nova actions.
16:31:46 <rakhmerov> dzimine, hm... kind of true, but dunno.
16:31:59 <rakhmerov> right
16:32:29 <dzimine> I would just mock up the clients and see if we get to calling them.
16:32:35 <rakhmerov> you know, at least I would have a few integration tests for some typical actions
16:32:45 <rakhmerov> a couple for Nova, a couple for cinder etc.
16:33:08 <rakhmerov> I think it depends on how hard it is to write this kind of test
16:33:31 <dzimine> BTW nikolay do you rely on each client or on python-openstackclient?
16:33:33 <rakhmerov> if it's something hairy to do then yes, it's not worth it
16:33:41 <akuznetsova_> nmakhotkin_: can we discuss you 'openstack action'? I want to know more about your vision and propose how to test it and what to test
16:34:23 <nmakhotkin_> dzimine, on each client
16:34:32 <dzimine> thnx
16:34:40 <rakhmerov> I think at this point it is correct
16:35:17 <rakhmerov> akuznetsova, don't worry about it for now. Firstly, I think Nikolay should write these tests himself
16:35:35 <rakhmerov> at least a few most important
16:35:48 <rakhmerov> then we'll see what it takes and decide if we need more
16:35:58 <rakhmerov> if yes, then you could take them over
16:36:10 <rakhmerov> and write more
16:36:13 <nmakhotkin_> rakhmerov, +1
16:36:23 <akuznetsova_> rakhmerov: nmakhotkin_ ok
16:37:23 <rakhmerov> #action akuznetsova_, figure out whether devstack has heat installed out of the box
16:38:10 <rakhmerov> #action akuznetsova_, figure out how to install additional services (i.e. Sahara) on devstack gate and estimate how hard it is
16:38:25 <rakhmerov> this is good
16:38:30 <rakhmerov> anything else?
16:40:02 <rakhmerov> ok, let's finish for today
16:40:15 <rakhmerov> thanks to everyone
16:40:19 <rakhmerov> bye
16:40:28 <rakhmerov> #endmeeting