16:01:13 <rakhmerov> #startmeeting Mistral
16:01:14 <openstack> Meeting started Mon Sep 15 16:01:13 2014 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:18 <openstack> The meeting name has been set to 'mistral'
16:01:24 <rakhmerov> sorry guys
16:01:32 <rakhmerov> hi all
16:01:38 <akuznetsova_> hi )
16:01:45 <xazel> hey
16:02:35 <rakhmerov> ok
16:03:27 <rakhmerov> a couple of mins guys
16:04:29 <rakhmerov> ok, let's start
16:04:56 <rakhmerov> #topic Review Action Items
16:05:26 <rakhmerov> 1. rakhmerov, nmakhotkin, enykeev: Add action into REST API/Client/CLI
16:05:28 <rakhmerov> done
16:05:45 <rakhmerov> 2. nmakhotkin, we should see action parameters and description (if possible) when calling API
16:06:02 <rakhmerov> nmakhotkin_, how is that going?
16:06:19 <rakhmerov> can you please tell the progress?
16:06:23 <nmakhotkin_> I've added parameters to Action's model
16:06:31 <rakhmerov> ok
16:06:46 <nmakhotkin_> and generation of parameters and description for std actions
16:07:18 <rakhmerov> how about OpenStack actions? Is there any progress on them?
16:07:22 <dzimine> Hi all sorry I'm late
16:07:36 <rakhmerov> I know you were supposed to do some research and see if that's feasible at all
16:07:41 <rakhmerov> hey Dmitri
16:07:59 <nmakhotkin_> it is not well understandable at this moment
16:08:16 <rakhmerov> ok
16:08:33 <rakhmerov> let's make it a low priority task for now
16:08:48 <rakhmerov> because it seems to be a risk
16:09:11 <rakhmerov> let's move on to the next item
16:09:18 <rakhmerov> 3. nmakhotkin, enykeev: Implement filters on REST API endpoints which work with multiple items (such as /tasks, /workbooks etc.)
16:09:41 <rakhmerov> xazel, could you please highlight the progress on that?
16:11:02 <xazel> basically, I'm a little bit stuck here. WSME requires that we define all the parameters we would get, so naive approach like /tasks?state=ERROR would not work
16:12:06 <xazel> I didn't have enough time to dig a bit deeper and for now I've just added /executions/[id]/tasks controller
16:12:23 <rakhmerov> ok
16:12:24 <rakhmerov> yes
16:12:44 <xazel> from what I've seen, I don't like WSME at all =\
16:13:23 <rakhmerov> my suggestion would be to shoot an email to ML to ask how that problem with WSME can be solved. Is it an intentional limitation or it can be configured somehow
16:13:32 <rakhmerov> and for now merge this endpoint
16:13:54 <rakhmerov> xazel, I thought you loved it :)
16:14:12 <rakhmerov> ok
16:14:16 <xazel> yeah, it's probably a best way to handle that, but I won't be around for the next week
16:14:23 <dzimine> The executions/ID/tasks solves the main use case of seeing execution details, the rest is less critical
16:14:38 <rakhmerov> I agree
16:14:41 <rakhmerov> in general )
16:15:03 <rakhmerov> 4. nmakhotkin, rakhmerov: make it possible to use different data types in action/workflow params (None, False/True, numbers, expressions)
16:15:16 <rakhmerov> nmakhotkin_, it's done, correct?
16:15:28 <rakhmerov> or something is still left on that?
16:15:30 <nmakhotkin_> yes :)
16:15:36 <nmakhotkin_> it's done
16:15:45 <rakhmerov> ok, cool
16:16:07 <rakhmerov> 5. bhavenst: start working on Metrics Collector, the first step is to make the requirements more detailed and capture them in a specification document (e.g. etherpad)
16:16:21 <rakhmerov> bhavenst, are you with us today?
16:17:02 <rakhmerov> looks like he's not
16:17:14 <rakhmerov> ok, I know he started working on it
16:18:02 <rakhmerov> he was looking at WFaaS whitepaper that Roshan sent us and was supposead to merge his ideas with the ideas in this document
16:18:20 <rakhmerov> #topic Current status (progress, issues, roadblocks, further plans)
16:18:27 <dzimine> Me: whe
16:18:38 <dzimine> Ups
16:18:53 <xazel> Updated dashboard to work with v2 API.
16:19:13 <rakhmerov> I know we've probably told most of the status. If you have anything to add to it let's do this
16:19:39 <rakhmerov> xazel, did you knock down all the changes we discussed?
16:19:44 <rakhmerov> like date formatting etc.
16:20:13 <xazel> yep, both date and json formatting
16:20:22 <nmakhotkin_> last week I resolved some issues with task parameters, workflow parameters and generation action parameters
16:20:23 <akuznetsova_> i've written tests for CLI v2 and 've refactored API tests and add tests for wfs
16:20:35 <rakhmerov> my status: Almost finished a huge engine refactoring to implement bp/mistral-engine-instructions, planning to finish and commit it today
16:20:39 <nmakhotkin_> also today around 5-6 fixes
16:20:40 <rakhmerov> there's a WIP already
16:21:25 <rakhmerov> ok
16:22:10 <dzimine> I am reviewing our resulting DSL this week.
16:23:10 <rakhmerov> ok
16:23:34 <dzimine> Also while porting a change to accept task data result, found a bug in the V2 API and want to discuss the whole result/output story with Renat
16:23:35 <rakhmerov> guys (especially Dmitri), I would like to ask you to take a look at https://review.openstack.org/#/c/121526/
16:23:43 <dzimine> Ack
16:24:04 <rakhmerov> I left my comments there and I'm really not sure what the right solution should be
16:24:25 <rakhmerov> something that I got stuck with about a month ago and deferred it for better times
16:24:50 <rakhmerov> dzimine, yes, let's discuss it
16:25:13 <rakhmerov> I guess you want to do it personally?
16:25:16 <rakhmerov> not here
16:26:17 <rakhmerov> ok, let's move to the next topic
16:26:23 <rakhmerov> #topic Release 0.1 progress
16:27:13 <rakhmerov> we've already discussed most of the things that were left before we release 0.1
16:27:41 <dzimine> Yes I am sending Renat full agenda on what we cover while he is here
16:27:50 <rakhmerov> so our one of our priority is to finish all the patches hanging now
16:28:02 <rakhmerov> and I'm supposed to finish engine instructions (good progress on that)
16:28:13 <rakhmerov> dzimine, thanks
16:28:28 <rakhmerov> Nikolay, what about testing examples?
16:28:48 <rakhmerov> were you able to test all of them?
16:29:39 <rakhmerov> nmakhotkin_?
16:29:51 <akuznetsova_> Nikolay said that he run main demo scenario and it was successfully
16:30:00 <nmakhotkin_> not yet all
16:30:09 <rakhmerov> ok, what's left?
16:30:19 <nmakhotkin_> but vm_job works fine with my today's patches
16:30:49 <rakhmerov> yeah, I approved most of them already
16:30:53 <nmakhotkin_> the rest I'll test tomorrow, I think
16:30:55 <akuznetsova_> nmakhotkin_: you can share some scenarious with me, i will help you
16:31:04 <dzimine_> whoami
16:31:05 <rakhmerov> the most tricky one is that Data Flow patch
16:31:24 <nmakhotkin_> yes, without it this example fails
16:31:51 <rakhmerov> ok, yes, guys. Please split the examples between you
16:32:00 <nmakhotkin_> ok
16:32:20 <rakhmerov> My prediction is that there won't be serious problems with them
16:32:25 <rakhmerov> they're pretty simple
16:32:36 <rakhmerov> ok, good
16:32:45 <rakhmerov> feels like we're almost there
16:32:50 <rakhmerov> meaning 0l1
16:32:52 <rakhmerov> o.1
16:33:00 <rakhmerov> 0.1 (sorry)
16:34:09 <rakhmerov> anyway I'd like to take a couple of extra days to test everything thoroughly to make sure everything is ok
16:34:37 <rakhmerov> #action akuznetsova, nmakhotkin: split all examples and test them in parallel
16:35:17 <rakhmerov> another thing I'd like to ask you about is walking through all the READMEs and fix whatever you thing is obsolete
16:35:21 <dzimine_> i propose to rename /v2 to /experimental to stress that we have not reached the point to freeze the API just yet.
16:35:47 <rakhmerov> hm...
16:35:51 <dzimine_> Thinking that after 0.1 goes off, we will be trying to use it and learn few things and be free to change the API
16:36:12 <rakhmerov> let's think about
16:36:19 <dzimine_> for some time, and once we are more certain it works, we rename it to V2.
16:36:33 <rakhmerov> but I think it's not how it's usually done in OpenStack
16:36:41 <dzimine_> Yes that’s an idea to think about and decide by the time we do 0.1
16:37:16 <dzimine_> This is a typical approache but you’re right openstack is not doing it this way
16:38:03 <rakhmerov> I would personally announce it as "not final" without real renaming
16:38:26 <rakhmerov> so when we release we emphasize that it might change
16:38:47 <rakhmerov> but only within some reasonable period of time
16:38:51 <rakhmerov> 2-3 weeks
16:39:02 <dzimine_> ok
16:39:25 <rakhmerov> mostly I'm personally concerned about DSL, not API
16:39:44 <rakhmerov> I'm even pretty sure we'll want to change some things in DSL
16:40:24 <rakhmerov> I'm confident about API (except that issue with WSME that I'd like to fix, not asap but anyway)
16:40:24 <dzimine_> the 3rd part is “SDK”, Action interface. Yes.
16:40:45 <rakhmerov> yes
16:41:10 <rakhmerov> btw, one thing that's still bothering me is that we run ALL actions on executors
16:41:47 <rakhmerov> even if it's something like std.echo that takes a couple of microseconds (may be less) to complete
16:42:49 <rakhmerov> so my thought was to introduce another action property like "is_local" to let the engine know it doesn't make sense to send it to an executor
16:43:03 <rakhmerov> and it can be just called immediately
16:43:24 <rakhmerov> this is an optimisation but pretty important one I think
16:43:41 <rakhmerov> so something like this may pop up, you're right
16:44:23 <rakhmerov> #topic Open discussion
16:44:34 <rakhmerov> ok guys, is there anything else you'd like to discuss?
16:46:10 <rakhmerov> ok, let's close the meeting then
16:46:24 <rakhmerov> thanks to everyone for joining!
16:46:28 <xazel> Thanks
16:46:31 <rakhmerov> bye
16:46:35 <akuznetsova_> bye)
16:46:44 <rakhmerov> #endmeeting