16:00:07 <rakhmerov> #startmeeting Mistral
16:00:07 <openstack> Meeting started Mon Nov 17 16:00:07 2014 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:09 <rakhmerov> hi
16:00:11 <openstack> The meeting name has been set to 'mistral'
16:00:19 <nmakhotkin|2> hi !
16:01:02 <rakhmerov> let's wait for others
16:01:30 <akuznetsova_> Hi
16:02:47 <rakhmerov> ok, +1 :)
16:03:01 <rakhmerov> I wonder if SS folks are going to join
16:03:33 <rakhmerov> seems like we didn't see any AI from the previous time
16:03:50 <rakhmerov> so I'm going to skip our usual "Review Action Items" topic
16:03:56 <rakhmerov> #topic Review Action Items
16:04:08 <rakhmerov> #info No previous items.
16:05:01 <rakhmerov> btw, the agenda is here: https://wiki.openstack.org/wiki/Meetings/MistralAgenda
16:05:04 <rakhmerov> as usually
16:05:13 <rakhmerov> #topic Paris Summit results
16:07:20 <tsufiev> hi there!
16:07:36 <akuznetsova_> Hi, Timur
16:08:13 <rakhmerov> hey Timur
16:08:55 <rakhmerov> ok, first of all we had a quick vBrownBag talk: https://www.youtube.com/watch?v=VsGTww7fiLY
16:09:32 <rakhmerov> we also had a design session with the notes captured here: https://etherpad.openstack.org/p/paris-2014-design-summit-mistral
16:09:51 <rakhmerov> you can take a look at them
16:09:58 <rakhmerov> once you have time
16:10:19 <rakhmerov> so as for results:
16:10:57 <rakhmerov> * We gathered a good feedback from StackStorm
16:11:15 <rakhmerov> they started using it weeks ago
16:12:01 <rakhmerov> all this feedback is not sorted out yet, I'm planning to create BPs for each major item tomorrow
16:12:20 <rakhmerov> #action rakhmerov, create all needed BPs based on Paris Summit results
16:13:41 <rakhmerov> * We also got feedback from a number of people outside of StackStorm (just a few names: Angus, Zane, Roshan Agrawal and Adrian from Rackspace)
16:13:57 <rakhmerov> which mostly was very positive
16:14:50 <rakhmerov> * There were a number of conversations with folks from HP who want to use Congress, Murano and Mistral together
16:15:20 <rakhmerov> this week we have a meeting with them to discuss our next steps
16:16:02 <rakhmerov> * Also we discussed Timur's suggestion about Mistral workbook builder
16:17:07 <tsufiev> rakhmerov, thank you for pulling me off during session :)
16:17:27 <rakhmerov> :))
16:17:39 <rakhmerov> that's fine
16:17:41 <rakhmerov> np
16:17:50 <tsufiev> I've got to learn how to improvise ))
16:18:11 <rakhmerov> you're totally fine
16:18:59 <rakhmerov> over time you'll be more comfortable at things like that
16:19:15 <rakhmerov> so here are the most important areas that we'll need to focus on (IMO) in the next cycle:
16:20:01 <rakhmerov> 1. Race-conditions and critical bugs (especially that race condition in engine we discussed last time)
16:20:43 <rakhmerov> 2. Complete 0.2 (fully implemented tested for-each, resume and join)
16:21:15 <rakhmerov> 3. High-load testing & benchmarking using Rally (Anastasia started preparing for this)
16:21:31 <rakhmerov> 4. UI
16:21:52 <rakhmerov> and one ongoing activity: promoting Mistral
16:21:53 <tsufiev> Speaking of Workbook Builder, I have an update as well
16:22:15 <rakhmerov> ...basically we already started this but need to do much more
16:22:23 <rakhmerov> sure Timur, go ahead
16:23:05 <rakhmerov> I was going to ask you about all that effort because I left Paris without talking to you at the end of the summit
16:23:34 <tsufiev> well, building UI for Heat is hot topic :)
16:24:05 <tsufiev> and is a task we definitely should take part in
16:24:58 <rakhmerov> ok
16:25:01 <rakhmerov> so?
16:25:06 <tsufiev> thus in order to complete most part of Merlin/Mistral work in Kilo (and do a decent work on mocking up/implementing Heat UI) I've decided that another member of Horizon team, Paul Karikh will join me in working on Merlin
16:25:06 <rakhmerov> will we? :)
16:25:30 <rakhmerov> ooh
16:25:31 <tsufiev> yes, we will )
16:25:33 <rakhmerov> good
16:25:51 <rakhmerov> is he from Mirantis as well?
16:26:03 <tsufiev> yes, we hired him several months ago
16:26:12 <rakhmerov> ok
16:26:19 <tsufiev> you may have seen while you were in Moscow, he's sitting in front of me :)
16:26:24 <tsufiev> *seen him
16:26:28 <rakhmerov> so is he going to work on Merlin full time?
16:26:40 <rakhmerov> ooh, yes
16:26:45 <rakhmerov> I have seen him :)
16:27:04 <tsufiev> I want him to help with implementing the new UI that Bogdan will design
16:27:16 <rakhmerov> ok
16:27:42 <rakhmerov> so what do you say about Merlin in general?
16:27:59 <rakhmerov> did you see that people were interested in it?
16:28:05 <tsufiev> yep
16:28:10 <rakhmerov> ok, cool
16:28:27 <tsufiev> the good news is that some UX guys are willing to help/provide feedback
16:28:47 <tsufiev> I've talked with Michael Hinnant (HP UX team, working on OpenStack) at Summit
16:28:52 <rakhmerov> ooh, really!
16:28:55 <rakhmerov> that's great!
16:29:27 <rakhmerov> let's discuss that this week, I'd like to know more details about the whole thing
16:29:36 <tsufiev> rakhmerov, okay
16:29:55 <rakhmerov> so guys, let's move on and quickly write our statuses
16:30:04 <rakhmerov> #topic Current Status (by team members)
16:30:34 <akuznetsova_> Me: implemented musty
16:30:42 <akuznetsova_> Oh, sorry
16:31:33 <nikolaym> Last week I fixed some small bugs and worked on blueprint workflow-resume
16:31:36 <rakhmerov> my status: Last week I was on vacation, the week before I was attending the summit and YAC conference at Yandex. Planning to create all needed BPs tomorrow and start fixing that race condition (it requires some redesign, but not too serious)
16:32:09 <rakhmerov> nikolaym, did you face any major issues with "resume"?
16:32:54 <nikolaym> Not yet, but I think it needs to be tested much more
16:33:01 <rakhmerov> ok
16:33:02 <akuznetsova_> Implemented multi tenancy CLI integration tests, reduce number of ignored pep8 codes and fix appropriate pep8 issues in python-mistral client repo. started to look at Rally.
16:33:21 <rakhmerov> ok
16:33:45 <nikolaym> I also fixed "pause" feature
16:33:47 <rakhmerov> #action rakhmerov, akuznetsova: meet and discuss integration test coverage
16:33:56 <rakhmerov> pause?
16:34:01 <rakhmerov> what was wrong with it?
16:34:03 <nikolaym> Yes
16:34:42 <rakhmerov> did you send a patch?
16:34:55 <rakhmerov> for some reason I don't see anything related to 'pause'
16:35:06 <nikolaym> Execution was in the pause state but tasks are continuing to execute
16:35:19 <rakhmerov> ok, it may have been
16:35:31 <nikolaym> I included it in resume patch
16:35:43 <rakhmerov> we didn't really work through it carefully
16:35:48 <rakhmerov> ok
16:36:07 <rakhmerov> guys, do you have any major issues you'd like to discuss?
16:36:30 <rakhmerov> I only have one topic to discuss: Release 0.2 progress
16:36:56 <rakhmerov> so if you don't have anything else I would quickly go over what's left on it
16:37:57 <rakhmerov> #topic Release 0.2
16:38:05 <rakhmerov> so the link to the milestone: https://launchpad.net/mistral/+milestone/0.2
16:38:28 <rakhmerov> good news that Winson started working on event listeners
16:38:42 <rakhmerov> we need to help him with details if needed
16:39:11 <akuznetsova_> We need to update bps' statuses
16:39:25 <rakhmerov> I think they're mostly up to date
16:40:31 <rakhmerov> ok, so we have 4 BPs I would consider done or mostly done
16:40:35 <rakhmerov> including
16:40:36 <akuznetsova_> I know that there are a few already implemented bps
16:40:46 <rakhmerov> data collections (for-each)
16:40:49 <rakhmerov> which ones?
16:41:27 <akuznetsova_> https://blueprints.launchpad.net/mistral/+spec/mistral-task-executor-affinity
16:41:40 <rakhmerov> as for for-each and resume I would hold on for now and keep them in "In progress" state until we make sure they're fully tested
16:41:47 <akuznetsova_> I know that Nikolay worked on it
16:41:57 <akuznetsova_> And tested it
16:42:02 <rakhmerov> yees, it says it's in "Beta available" which is fine IMO
16:42:10 <rakhmerov> yeah
16:42:30 <nikolaym> Recently I updated bps statuses
16:42:31 <rakhmerov> I consider "Beta available" as "Completed" with the only difference that it's not released yet
16:42:45 <rakhmerov> maybe I'm wrong though
16:43:09 <rakhmerov> so we have also 4 BPs that we didn't start working on yet
16:43:46 <rakhmerov> which are basically: "join", "pause-before" and HA & Scalability
16:44:41 <rakhmerov> well, in fact, I already started working on "join" but have to postpone it for a couple of days in order to make changes in the engine
16:44:41 <akuznetsova_> This one https://blueprints.launchpad.net/mistral/+spec/mistral-manual-control-checkpoints looks like duplicate
16:44:46 <akuznetsova_> No?
16:44:51 <rakhmerov> almost
16:45:20 <rakhmerov> it's basically a more high-level BP that includes "pause-before" and "resume"
16:45:44 <akuznetsova_> Hmm, ok
16:45:44 <rakhmerov> we created it just to keep the major user meaningful feature under control
16:46:01 <rakhmerov> but yes, it's not something we have to work on separately
16:46:05 <rakhmerov> in that sense you're right
16:46:13 <rakhmerov> it's a duplicate
16:47:03 <rakhmerov> so overall I think our progress is ok
16:47:07 <rakhmerov> just one comment
16:47:33 <rakhmerov> Engine HA & Scalability I think is not something that we need to do just once and forget about it
16:48:13 <rakhmerov> I think in 0.2 we'll need to do the most important testing and fix the most important bugs that we'll find (I'm sure we will)
16:48:21 <rakhmerov> and then continue this work
16:48:37 <rakhmerov> that's basically why we need to use Rally
16:48:47 <rakhmerov> to automate it
16:48:59 <rakhmerov> and keep creating more tests
16:49:25 <rakhmerov> also I'd like to capture a couple of more screencasts about new features
16:49:36 <rakhmerov> it will take a day or two
16:50:09 <rakhmerov> I think that's it from my side
16:50:18 <rakhmerov> something from yours?
16:50:41 <nikolaym> Nothing from me
16:51:23 <rakhmerov> ok
16:51:42 <rakhmerov> then
16:51:44 <rakhmerov> thank you
16:51:53 <rakhmerov> good bye to all
16:52:00 <akuznetsova_> Bye ;)
16:52:07 <rakhmerov> #endmeeting