16:04:00 <nikolaym> #startmeeting Mistral
16:04:01 <openstack> Meeting started Mon Dec  8 16:04:00 2014 UTC and is due to finish in 60 minutes.  The chair is nikolaym. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:04:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:04:05 <openstack> The meeting name has been set to 'mistral'
16:04:16 <nikolaym> Hi, dzimine!
16:06:22 <nikolaym> Waiting for Renat..
16:06:27 <rakhmerov> hey
16:06:31 <rakhmerov> sorry guys!!
16:06:40 <nikolaym> hi !
16:06:41 <rakhmerov> I went to a wrong channel first ;))
16:06:47 <rakhmerov> really sorry
16:07:08 <rakhmerov> ok, let's quickly go over our items
16:07:27 <rakhmerov> the agenda is here: https://wiki.openstack.org/wiki/Meetings/MistralAgenda
16:07:51 <rakhmerov> #topic Review AI
16:08:18 <rakhmerov> 1. akuznetsova: check if task-defaults work for reverse workflows (policies)
16:08:29 <rakhmerov> Nastya, are you here?
16:09:35 <rakhmerov> I think she's done that
16:09:40 <rakhmerov> let me check real quick
16:10:10 <rakhmerov> ok, not sure
16:10:16 <rakhmerov> so let's leave this item
16:10:21 <rakhmerov> #action akuznetsova: check if task-defaults work for reverse workflows (policies)
16:10:36 <rakhmerov> 2. NikolayM, create new BPs for what's left on "for-each"
16:10:38 <rakhmerov> Nikolay?
16:10:50 <nikolaym> not yet
16:11:25 <nikolaym> I'll do it once I finish work with documentation
16:11:29 <rakhmerov> as far as I know you started this today, right?
16:11:35 <rakhmerov> ooh, ok
16:12:00 <rakhmerov> 3. rakhmerov, get in touch with Bryan to see how his work's going
16:12:18 <rakhmerov> Bryan just replied and said he's going to get something pushed today
16:12:31 <rakhmerov> I mean his work on "pause-before"
16:13:00 <rakhmerov> 4.  dzimine, put information about additional features/requirements for "for-each" in the etherpad
16:13:02 <rakhmerov> Dmitri?
16:13:15 <rakhmerov> #action NikolayM, create new BPs for what's left on "for-each"
16:14:02 <rakhmerov> dzimine, you there?
16:14:25 <dzimine> yes
16:14:51 <dzimine> I linked the etherpad to the blueprint.
16:14:55 <rakhmerov> ok
16:15:01 <rakhmerov> thanks
16:15:14 <rakhmerov> #topic Current progress (by team members)
16:15:38 <rakhmerov> my status: most of the week I worked on join and at this point I consider it done on 99%
16:16:29 <rakhmerov> I'll switch back to rebasing race condition related patch for now (and writing a right test for it) and then I'd like to look at join once again to see how its design can be improved
16:17:13 <nikolayM> Fixed some bugs, bug with duplicating triggers, write documentation
16:18:22 <rakhmerov> ok
16:19:01 <rakhmerov> #topic Release kilo-1 progress
16:19:16 <dzimine> reviews and some input to join design, etc with Renat last week; this week I'll look at how much eng effort we StackStorm  manage to commit to Mistral, will decide by Thu.
16:19:28 <rakhmerov> ok
16:19:39 <rakhmerov> as far as kilo-1. Currently all BPS are being worked on
16:19:54 <rakhmerov> Bryan's "pause-before" and Nastya's HA testing
16:20:06 <rakhmerov> she started getting first numbers and problems
16:20:15 <rakhmerov> so I think we're mostly on track
16:20:37 <rakhmerov> I think we have a good chance to significantly improve our "for-each" thing
16:21:14 <rakhmerov> and there's several bugs that you can feel free to take
16:21:38 <akuznetsova_> Hi there, I am late, sorry
16:22:57 <rakhmerov> np
16:23:04 <rakhmerov> you can briefly report your status
16:25:18 <akuznetsova_> Ok, so, I am working on load mistral testing, I have prepare a couple of simple rally scenarios and started to run them
16:26:00 <akuznetsova_> Today I prepare base for execution scenario and run the simple one
16:26:26 <rakhmerov> ok
16:26:53 <rakhmerov> guys, honestly, I don't have much else to talk about
16:27:31 <rakhmerov> do you have any roadblocks/questions to discuss?
16:27:57 <akuznetsova_> Yes
16:28:05 <rakhmerov> ok, go ahead
16:28:05 <akuznetsova_> I have a question
16:28:36 <dzimine> not on my site; @akiznetsova_: can you share your plans for testing somewhere (etherpad may be), and post to openstack-dev?
16:28:56 <akuznetsova_> Probably I missed it, but Renat did you finish implementation of "join" ?
16:29:27 <rakhmerov> yes
16:30:00 <rakhmerov> I will probably do something else on it (there's a couple of things) but it's done on 99% and tested
16:30:08 <akuznetsova_> dzimine, what exactly do you want to know ? Rally testing plans?
16:30:44 <rakhmerov> yes, Nastya, I think you just need to share what we have in our Google Doc
16:30:55 <rakhmerov> generally, we already have a lot of info
16:31:17 <rakhmerov> so that all the folks could see and provide their feedback
16:31:21 <akuznetsova_> Now I just mete the time
16:31:33 <rakhmerov> ?
16:32:04 <dzimine> the testing process shall be visible outside Mirantis.
16:32:07 <dzimine> that's my point.
16:32:19 <rakhmerov> yes, and this is right
16:32:48 <dzimine> now that there's Alcatel, Ericson, and some other folks, saying "we are testing and we have plans but you won't see them" is not a good touch.
16:32:48 <rakhmerov> so there are two ways: an etherpad or a wiki page
16:32:48 <akuznetsova_> I mean that in current  phase I just measure the request time
16:33:06 <akuznetsova_> Oh, I see. I will prepare some report
16:33:07 <dzimine> etherpad is good enough (google docs is good enough too, format doesn't matter).
16:33:19 <rakhmerov> akuznetsova_, that's fine, we're talking about plans
16:33:26 <dzimine> mainly it's the "what", what are we testing.
16:33:37 <rakhmerov> yes
16:33:52 <rakhmerov> in other words, just make your work visible
16:33:53 <dzimine> and the less effort you put the better -> it will be a jump from 0 to something, anyways :)
16:34:44 <rakhmerov> ok, anything else?
16:34:52 <akuznetsova_> Ok, I got it
16:35:04 <akuznetsova_> Not from me
16:35:10 <rakhmerov> ok
16:35:52 <rakhmerov> so dzimine, as far as I understand we should wait for Thu to see what you (actually Winson) will be able to do with event listeners BP?
16:38:04 <rakhmerov> ok, let's finish for today
16:38:14 <rakhmerov> unless you have some other topics
16:38:36 <rakhmerov> thanks for coming
16:38:37 <rakhmerov> bye
16:38:41 <NikolayM> bye!
16:38:43 <rakhmerov> have a good week
16:38:49 <rakhmerov> #endmeeting
16:39:44 <rakhmerov> Nikolay please send #endmeeting
16:39:48 <rakhmerov> NikolayM
16:39:51 <rakhmerov> pls
16:39:56 <rakhmerov> because you started the meeting
16:45:46 <NikolayM> #endmeeting
16:45:56 <rakhmerov> thanks!
16:51:52 <NikolayM> #endmeeting
16:55:20 <nikolaym> #endmeeting