16:00:57 <rakhmerov> #startmeeting Mistral
16:00:58 <openstack> Meeting started Mon Mar 2 16:00:57 2015 UTC and is due to finish in 60 minutes. The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:03 <openstack> The meeting name has been set to 'mistral'
16:01:09 <rakhmerov> hi
16:02:23 <NikolayM> hi !
16:02:47 <rakhmerov> let's wait for a couple of mins
16:05:47 <dzimine> Hi all, bit late, apps.
16:06:15 <rakhmerov> hi
16:06:25 <rakhmerov> ok, let's skip action items review
16:06:40 <rakhmerov> because we haven't had meetings for a while
16:06:51 <rakhmerov> #topic Current status (by team members)
16:07:40 <rakhmerov> my status: keep working on engine refactoring, a few patches are waiting to be reviewed and we need to wait for Dmitri when he says "ok" to merge them in
16:08:02 <rakhmerov> also worked with Nikolay on finding a solution for the bug with 'join'
16:09:30 <NikolayM> status: worked on new YAQL related changes, added YAQL in policies and tried to fix 'join' bug. Also almost fixed bug with incorrectly finishing workflow when we have delayed task
16:11:10 <rakhmerov> yep, pls see a minor comment from me in 30 sec
16:11:27 <dzimine> my status: along with w4dcode and lakshmi, worked on deploying mistral on munti-node environment and doing stress tests.
16:11:57 <rakhmerov> :)
16:12:08 <rakhmerov> ok
16:12:17 <dzimine> NikolayM, rakhmerov thank you very much for quick turnaround on those irritating bugs we found.
16:12:30 <rakhmerov> no problem
16:12:49 <rakhmerov> we need to do it even faster
16:13:14 <rakhmerov> ok, I wanted to bring up a couple of things up to discussion
16:13:16 <dzimine> as for loadtests: we deployed Mistral on ngnix and apache and run it at the load of 100 complex parallel workflows.
16:13:34 <rakhmerov> yes
16:13:45 <NikolayM> cool
16:13:59 <dzimine> At ~500 parallel workflows, it begins to break down both on a single vm and on distr env.
16:14:06 <rakhmerov> btw, dzimine, we started seeing that issue with oslo.messaging again after Winson's patch
16:14:21 <dzimine> More details on breaking points to come.
16:14:28 <rakhmerov> ok, good
16:14:47 <dzimine> hm... often or intermittent? in tests?
16:15:57 <rakhmerov> intermittent
16:16:12 <rakhmerov> yes, in test
16:16:36 <rakhmerov> so looks like placing monkey patching into tests/__init__.py doesn't help
16:17:10 <dzimine> ok let's find a place for it so that it doesn't mess apache deployment. a bug?
16:17:13 <dzimine> to track?
16:17:15 <rakhmerov> it's not a critical urgent issue though but anyway we need to get more details from Winson about what was wrong before
16:17:37 <rakhmerov> I guess we don't have a bug yet
16:17:55 <rakhmerov> #action rakhmerov, create a bug for oslo.messaging & monkey patching issue
16:18:13 <rakhmerov> ok
16:18:21 <rakhmerov> let's move on
16:18:36 <rakhmerov> #topic A bug with 'join'
16:18:54 <rakhmerov> so now we agreed to merge in a temporarily solution
16:19:01 <rakhmerov> I already +2ed it
16:19:23 <rakhmerov> so, dzimine, you can take a look and approve it if you and Winson find it ok
16:19:39 <rakhmerov> Nikolay also added a test that's skipped for now
16:19:45 <dzimine> it's already in.
16:19:49 <rakhmerov> ooh, ok
16:20:17 <rakhmerov> so, my question is: do we need to think about it more or we agreed on the solution suggested today?
16:20:23 <rakhmerov> with versioning
16:20:39 <rakhmerov> if yes, then I think we could knock it down this week
16:21:30 <rakhmerov> dzimine, maybe we you could just discuss it with Winson
16:21:35 <rakhmerov> that's what comes to my mind
16:21:45 <rakhmerov> because he may have some other ideas
16:22:24 <dzimine> rakhmerov: can you just repost your comment to mailing list so it's easier do dig out...
16:22:34 <rakhmerov> ok, I will
16:22:57 <rakhmerov> #action rakhmerov: repost our discussion about how to fix 'join' bug into ML
16:23:06 <rakhmerov> ok
16:23:23 <rakhmerov> #topic Changing team meeting time
16:23:29 <dzimine> thanks! it was convincing to me last night but I was a bit brain-tired.
16:23:36 <rakhmerov> yes!
16:23:57 <rakhmerov> that's why I think it makes sense to think about it a little bit longer
16:24:01 <rakhmerov> :)
16:24:30 <rakhmerov> not because I don't trust you but because it seems like too important decision to make it in a rush
16:24:46 <rakhmerov> ok
16:25:05 <rakhmerov> another thing that I wanted to bring up is changing our team meeting time
16:25:39 <rakhmerov> from now on it'll be difficult for me to attend meetings on Mondays at 16 UTC
16:26:20 <rakhmerov> so I just want you guys maybe to propose time frames convenient for you
16:26:36 <dzimine> 1 hour later will be fantastic.
16:26:46 <rakhmerov> for me as well
16:27:01 <dzimine> ah, but it WILL become 1 hour later with daylight saving time.
16:27:04 <rakhmerov> but as far as I understand for Nikolay it's not so good, is it?
16:27:22 <dzimine> so for me 1 hour earlier will work, too (although not so convinient :))
16:27:25 <dzimine> but I am ok.
16:27:41 <NikolayM> yes, for me a hour later is not very good
16:28:17 <rakhmerov> regardless of day of week, right?
16:28:20 <akuznetsova> let's move meeting for other day
16:28:32 <NikolayM> Tuesday?
16:28:35 <rakhmerov> yes, the best day for me is Tuesday
16:28:37 <rakhmerov> yes
16:29:06 <rakhmerov> same time would be good for me but the problem is we'll have to find another channel
16:29:22 <rakhmerov> because looks like this channel is occupied on Tuesdays
16:29:50 <rakhmerov> or, the other alternative is just to have shorter meetings on Mondays
16:30:10 <rakhmerov> say, from 16.20 till 17.00 UTC
16:30:13 <rakhmerov> 40 mins
16:30:22 <rakhmerov> if we don't find more convenient time
16:30:47 <rakhmerov> ok, let me search for available slots and suggest some options
16:31:10 <rakhmerov> #action rakhmerov: suggest some time slots for a new time of team meetings
16:31:22 <rakhmerov> #topic Open Discussion
16:31:39 <rakhmerov> any more topics/questions?
16:31:50 <akuznetsova> just fyi, for me and Nikolay time after16 UTC is not good
16:32:00 <rakhmerov> yes, I got it
16:32:14 <akuznetsova> thanks
16:32:38 <rakhmerov> it's a challenge because we are all in different time zones
16:32:39 <rakhmerov> :)
16:32:55 <rakhmerov> ok
16:33:33 <rakhmerov> so, I don't have any more topics for today
16:33:47 <rakhmerov> I'm too deep in coding )
16:34:05 <rakhmerov> from your side?
16:35:05 <NikolayM> none from my
16:35:25 <rakhmerov> dzimine?
16:36:56 <rakhmerov> ok, let's finish then
16:37:00 <rakhmerov> thanks for coming
16:37:06 <rakhmerov> bye
16:37:36 <rakhmerov> #endmeeting