16:20:44 <rakhmerov> #startmeeting Mistral
16:20:45 <openstack> Meeting started Mon Apr  6 16:20:44 2015 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:20:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:20:49 <openstack> The meeting name has been set to 'mistral'
16:20:50 <rakhmerov> hi
16:20:55 <m4dcoder> hey
16:21:02 <akuznetsova> hello
16:21:44 <NikolayM> hi all !
16:22:49 <rakhmerov> hey Wiinson, how's it going?
16:23:29 <m4dcoder> pretty good.  back in the US.  thanks for asking.
16:24:03 <rakhmerov> :)
16:24:08 <rakhmerov> ok, let's start
16:24:14 <rakhmerov> #topic Review Action Items
16:24:47 <rakhmerov> ok, we just have one item
16:24:49 <rakhmerov> rakhmerov: file LP bugs for concurrent issues in data flow and join tests
16:25:14 <rakhmerov> hm.. and it's not done actually, I still need to do this
16:25:25 <rakhmerov> #action rakhmerov: file LP bugs for concurrent issues in data flow and join tests
16:25:27 <dzimine> hi all
16:25:32 <rakhmerov> hi dzimine
16:25:45 <rakhmerov> #topic Current status (by team member)
16:26:46 <rakhmerov> my status: was busy with demo preparations and fixing some small bugs, today I sent a patch to get rid of all v1 stuff
16:26:48 <dzimine> sorry to jump out of context, want to bring m4dcoder's idea re putting more load on functional tests for complex flows.
16:27:04 <rakhmerov> ok
16:27:09 <dzimine> because we are using sqlite, etc, some complex flows are difficult to test.
16:27:17 <rakhmerov> agree
16:27:32 <rakhmerov> you're talking about complex workflows or high load?
16:27:34 <rakhmerov> or both?
16:28:15 <m4dcoder> i'm addressing the comments for https://review.openstack.org/#/c/170633/.  also, i'll be adding the validate commands to mistral client.  also another patch to add YAQL eval to the DSL validation.
16:29:07 <dzimine> rakhmerov: complex workflows. Adding high load is just running the complex workflows under rally.
16:29:13 <NikolayM> my status: Fixed a set of bugs: 'with-items', task API, action exec API, implemented blueprints: task implicit access and keep-result property
16:29:15 <rakhmerov> ok
16:29:22 <rakhmerov> dzimine, I got it
16:30:28 <rakhmerov> we need to create a plan what workflows we'd like to see in these tests and when we're going to start adding these tests
16:30:56 <rakhmerov> #action rakhmerov, dzimine: figure out a plan for adding complex workflows into integration tests
16:31:14 <rakhmerov> ok
16:32:20 <rakhmerov> #topic RC1 progress
16:32:46 <rakhmerov> So as far as RC1, just a reminder that it's scheduled for Apr 17
16:33:31 <rakhmerov> we're now fixing lots of bugs and working on blueprints based on that refactoring that was done in March
16:33:44 <rakhmerov> what I would like to do right now is to look at https://blueprints.launchpad.net/mistral/kilo
16:34:20 <rakhmerov> and decide what's feasible to complete till Apr 17
16:34:25 <dzimine> looking.
16:34:25 <rakhmerov> and we want to complete
16:34:48 <rakhmerov> please look at those that are not assigned to any milestones
16:35:05 <dzimine> I am pushing to do the DSL changes, the CERTAIN ones, as outlined in the doc https://docs.google.com/a/stackstorm.com/document/d/1Gy6V9YBt8W4llyErO_itHetkF1oNYv4ka-_5LdFKA18/edit#
16:35:39 <rakhmerov> yes
16:35:50 <rakhmerov> and btw, we don't have all the BPs for that
16:35:55 <rakhmerov> we need to create them
16:36:16 <rakhmerov> #action dzimine, rakhmerov: create necessary BPs for changes described in https://docs.google.com/a/stackstorm.com/document/d/1Gy6V9YBt8W4llyErO_itHetkF1oNYv4ka-_5LdFKA18/edit#
16:36:30 <rakhmerov> it's not going to take long though to implement those changes
16:36:33 <rakhmerov> ok
16:36:50 <rakhmerov> so, what about https://blueprints.launchpad.net/mistral/+spec/mistral-task-concurrency ?
16:37:01 <rakhmerov> dzimine, how important is it for you?
16:37:30 <dzimine> imo we can live without it once we ensure the order of results match the order of input.
16:37:31 <rakhmerov> it's not so hard to implement I guess, it needs really thorough testing
16:37:40 <dzimine> I am ok to push it out.
16:38:05 <rakhmerov> ok, then I would not hurry with this BP, let's move it to Liberty
16:38:19 <rakhmerov> done
16:38:32 <rakhmerov> the next one: https://blueprints.launchpad.net/mistral/+spec/mistral-default-input-values
16:38:38 <rakhmerov> I feel like doing it
16:38:59 <rakhmerov> because 1) it's related to DSL 2) it's simple and may be useful
16:39:36 <rakhmerov> thoughts?
16:39:56 <NikolayM> +1
16:40:48 <dzimine> +1
16:40:59 <dzimine> alghough to be fair it's additive to DSL.
16:41:18 <dzimine> I am more concerned of the DSL changes, which we want to nail in Kilo.
16:41:25 <rakhmerov> yeah, I agree but it's just half an hour to implement and test
16:41:28 <m4dcoder> can someone take that one from me?
16:41:40 <dzimine> Our kilo story is - DSL is done, next is API adjustments and reliability / performance.
16:41:46 <rakhmerov> ooh, it's assigned on you
16:41:47 <rakhmerov> ok
16:41:49 <rakhmerov> np
16:42:01 <rakhmerov> yes, dzimine, I agree
16:42:17 <m4dcoder> thx. i'll be busy with the DSL validatio.
16:42:27 <rakhmerov> sure
16:42:42 <rakhmerov> we'll assign someone to it later
16:42:52 <dzimine> I only need one in DSL before KIlo - getting rid of "policy" keyword.
16:42:59 <rakhmerov> ok, how about https://blueprints.launchpad.net/mistral/+spec/mistral-workflow-constants ?
16:43:00 <dzimine> The rest are additive, and we can do them later.
16:43:12 <rakhmerov> dzimine, can you file a BP for policies?
16:43:38 <dzimine> oh, and another one - another small one - one liner for on-success/on-error, etc.
16:43:41 <rakhmerov> so what about workflow constants, it's a part of that Google doc as well
16:43:49 <dzimine> will do, for both I just mentioned.
16:43:55 <rakhmerov> ok, thank you
16:44:03 <dzimine> they're additive, and we can deal with them later.
16:44:10 <dzimine> same with extra conditions.
16:44:18 <rakhmerov> I'd be ok with that too
16:44:24 <rakhmerov> any objections from anyone?
16:44:34 <rakhmerov> on workflow constants (variables)
16:45:09 <rakhmerov> ok, moved to Liberty as well
16:45:37 <rakhmerov> this one is what I really want to do https://blueprints.launchpad.net/mistral/+spec/mistral-explicit-task-parameters
16:45:44 <rakhmerov> but may be not now
16:46:07 <rakhmerov> because we still need to think it over more detailed and carefully
16:46:14 <dzimine> this will be rocking a boat too much,
16:46:19 <rakhmerov> yes
16:46:32 <dzimine> just like with extra conditios, it's not complex on implementation, but on convinient syntax and model.
16:46:34 <rakhmerov> and it's additive too, right?
16:46:47 <rakhmerov> it seems like
16:46:50 <dzimine> I believe so
16:47:00 <dzimine> but you never know till you designed it :)
16:47:05 <dzimine> conditions seem to be additive.
16:47:11 <rakhmerov> ok, let's move to Liberty
16:47:15 <dzimine> I please invite you to comment on condition syntax.
16:47:18 <rakhmerov> wait a second
16:47:28 <rakhmerov> what do you mean by "conditions"?
16:47:37 <rakhmerov> what exactly are you talking about?
16:48:46 <dzimine> https://docs.google.com/a/stackstorm.com/document/d/1Gy6V9YBt8W4llyErO_itHetkF1oNYv4ka-_5LdFKA18/edit#heading=h.n1jc8i9qhikt
16:48:54 <dzimine> "Invent better conditions" section.
16:49:23 <dzimine> I recently added a proposal there but didn't get too much comments yet.
16:49:32 <dzimine> move to Libery?
16:50:10 <dzimine> cut-out-v1 - do it now?!
16:50:23 <dzimine> https://blueprints.launchpad.net/mistral/+spec/mistral-cut-out-v1
16:50:42 <rakhmerov> ooh, it's almost done! :)
16:50:51 <rakhmerov> https://review.openstack.org/#/c/170837/
16:51:18 <rakhmerov> it actually works in my local environment but is failing on Jenkins, need to figure out the problem
16:52:22 <rakhmerov> so as far as conditions, let me look at this section again, looks like I forgot what you suggested or this section didn't exist in the doc when I was looking at it
16:52:49 <rakhmerov> #action rakhmerov: make sure to look at "Invent better condition" section in https://docs.google.com/a/stackstorm.com/document/d/1Gy6V9YBt8W4llyErO_itHetkF1oNYv4ka-_5LdFKA18/edit#heading=h.n1jc8i9qhikt
16:53:26 <rakhmerov> ok, I'm pretty sure that what's left will be done till Apr 17
16:54:12 <rakhmerov> ok, let's now move to open discussion
16:54:18 <rakhmerov> #topic Open Discussion
16:54:25 <rakhmerov> any more topics guys?
16:54:55 <rakhmerov> Winson, sorry for not being able to review your patch today, I'll do it tomorrow the first thing
16:55:03 <dzimine> so rakhmerov the two BP I'll create (get rid of policies, one-liner for conditions) I assign to kilo-3, right?
16:55:13 <rakhmerov> no-no
16:55:17 <rakhmerov> RC-1
16:55:21 <dzimine> rc1. ok.
16:55:24 <rakhmerov> kilo-3 is closed
16:55:35 <dzimine> got it.
16:56:17 <m4dcoder> np
16:56:41 <rakhmerov> ok, so let's close the meeting then unless you have something else?
16:56:50 <dzimine> if we're done with technical, I have a small non-tech item
16:56:57 <rakhmerov> sure, go ahead
16:57:06 <rakhmerov> 3 mins left
16:57:13 <rakhmerov> before the next meeting
16:57:31 <dzimine> Given @m4dcoder is doing more and pretty much assigned to Mistral from StackStorm, is it good time to propose him to core_team?
16:57:40 <dzimine> We can follow-up on the mail list.
16:57:49 <rakhmerov> yes, I'm 100% for it
16:57:49 <dzimine> just what's your thoughst?
16:58:02 <rakhmerov> please go ahead and shoot an email in ML
16:58:17 <dzimine> ok.
16:58:20 <rakhmerov> I'll support his candidacy with the great pleasure :)
16:58:29 <m4dcoder> thx. :D
16:58:38 <rakhmerov> you deserve it :)
16:58:40 <dzimine> also, we need to market our meeting with new contributors somehow.
16:58:51 <rakhmerov> thanks to you for your amazing work!
16:59:00 <dzimine> ok, good talking to you folks, till later now!
16:59:06 <rakhmerov> yeah
16:59:14 <rakhmerov> thanks everyone for joining us today
16:59:16 <NikolayM> bye
16:59:23 <rakhmerov> I hope it'll become a good tradition :)
16:59:24 <rakhmerov> bye
16:59:27 <rakhmerov> #endmeeting