16:00:20 <rakhmerov> #startmeeting Mistral
16:00:21 <openstack> Meeting started Mon Jul 13 16:00:20 2015 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:25 <openstack> The meeting name has been set to 'mistral'
16:00:31 <rakhmerov> hi
16:00:32 <NikolayM> hi everyone!
16:00:48 <gpaz> Hi
16:00:54 <^Gal^> Hello
16:01:18 <rakhmerov> hi guys
16:01:28 <xylan_kong> hi
16:02:11 <rakhmerov> ok, I think there's enough people to start
16:02:33 <rakhmerov> so the agenda is at https://wiki.openstack.org/wiki/Meetings/MistralAgenda
16:02:49 <rakhmerov> #topic Review action items
16:03:22 <rakhmerov> 1. rakhmerov, others: review and discuss Lingxian's proposal about removing wf_trace module
16:03:36 <rakhmerov> I haven't done this yet, sorry
16:03:44 <xylan_kong> :-)
16:03:48 <rakhmerov> so I'll keep it for myself
16:03:57 <rakhmerov> #action rakhmerov: review and discuss Lingxian's proposal about removing wf_trace module
16:04:13 <rakhmerov> 2. rakhmerov: start working on deadlock problem in scheduler
16:04:44 <rakhmerov> on this one, I decided to postpone it
16:05:02 <rakhmerov> because there's a couple of things that seem to be even more annoying
16:05:08 <xylan_kong> hi, rakhmerov, is there any detailed info abou this topic
16:05:19 <rakhmerov> for example: https://bugs.launchpad.net/mistral/+bug/1469926
16:05:19 <openstack> Launchpad bug 1469926 in Mistral liberty "task with ERROR doesn't post any result" [Critical,In progress] - Assigned to Renat Akhmerov (rakhmerov)
16:05:29 <rakhmerov> xylan_kong: what do you mean?
16:05:34 <rakhmerov> which one? deadlock?
16:05:42 <xylan_kong> yes
16:06:12 <xylan_kong> i even don't know that, want to know the context
16:06:15 <rakhmerov> well, before the last Winson's patch our Scheduler (scheduler.py) seemed to have a deadlock
16:06:19 <m4dcoder> hi
16:06:24 <rakhmerov> hi m4dcoder!
16:07:13 <rakhmerov> so something was wrong with transactions in it and we need to investigate it
16:07:45 <rakhmerov> because the way how it was done in our opinion was correct but it turned to be not
16:08:18 <rakhmerov> right now what we have in scheduler doesn't provide a guarantee that a delayed call will be eventually made
16:08:29 <rakhmerov> it doesn't have that deadlock
16:08:54 <rakhmerov> so next one
16:08:55 <rakhmerov> 3. NikolayM, akuznetsova: finish fixing http://logs.openstack.org/35/193435/4/check/gate-mistral-devstack-dsvm/39237fd/logs/devstacklog.txt.gz
16:09:00 <rakhmerov> this is done
16:09:07 <rakhmerov> NikolayM, akuznetsova: well done!
16:09:26 <rakhmerov> 4. rakhmerov, xylan_kong, NikolayM: review https://blueprints.launchpad.net/mistral/+spec/mistral-dashboard-executions-screen BP on Tue
16:09:37 <rakhmerov> done (at least by myself)
16:09:42 <xylan_kong> me too
16:09:47 <rakhmerov> ok
16:09:48 <xylan_kong> leave my comments
16:09:53 <rakhmerov> yep
16:09:55 <rakhmerov> 5. rakhmerov, tsufiev: provide all initial links on Merlin and Workbook Builder
16:10:21 <rakhmerov> I'm not sure this is done but I guess ^Gal^ already started communicating with Timur
16:10:28 <rakhmerov> ^Gal^: is this correct?
16:10:51 <melisha1> It is correct
16:10:55 <rakhmerov> ok
16:11:03 <^Gal^> yep
16:11:12 <^Gal^> I'm working on executions atm
16:11:23 <^Gal^> were starting to work on tasks tomorrow
16:11:27 <rakhmerov> so on Merlin and WB Builder Timur is basically the only one proved source of information :)
16:11:32 <rakhmerov> ok
16:11:48 <rakhmerov> 6. rakhmerov: make sure to create a BP about integrating WB Builder into Mistral Dashboard project
16:13:04 <rakhmerov> https://blueprints.launchpad.net/mistral/+spec/mistral-integrate-wb-builder
16:13:13 <rakhmerov> as you may guess, I just created it :)
16:13:18 <rakhmerov> so this is done
16:13:35 <xylan_kong> hehe
16:13:45 <melisha1> :-)
16:13:45 <rakhmerov> :)
16:13:53 <rakhmerov> 7. [1]melisha: review Lingxian's patches
16:14:08 <rakhmerov> I don't remember which exact patches though
16:14:20 <xylan_kong> maybe the service api
16:14:34 <rakhmerov> so it's up to Moshe, I guess he knows what it means
16:14:35 <melisha1> I hadn't done it yet. Sorry
16:14:38 <rakhmerov> yeah
16:14:41 <rakhmerov> no problem
16:14:52 <rakhmerov> me too :)
16:15:33 <rakhmerov> sorry xylan_kong, if you're going to Tokyo a beer for you at my expense )
16:15:43 <xylan_kong> rakhmerov: np
16:15:46 <rakhmerov> anyway, I'll do this this week
16:16:00 <rakhmerov> ok
16:16:16 <xylan_kong> rakhmerov: I'll remember what you said :-)
16:16:24 <xylan_kong> abou the beer
16:16:26 <rakhmerov> sure, you should!
16:16:27 <melisha1> A beer pm me as well
16:16:38 <xylan_kong> ok, sounds good
16:16:43 <rakhmerov> ok, let's continue
16:16:43 <rakhmerov> #topic Current status (progress, issues, roadblocks, further plans)
16:16:56 <rakhmerov> as usually, let's quickly tell our statuses
16:17:48 <melisha1> Creating BPs for all CRUD screens
16:17:57 <xylan_kong> my status: i am still working on service api implementation, have discussed with Winson heavily. not very productive last week, so many internal meetings, prepare for slides, etc.
16:18:10 <rakhmerov> my status: mostly doing reviews, participating in email and etherpad discussions, started working on https://bugs.launchpad.net/mistral/+bug/1469926 (sent a starting patch today)
16:18:10 <openstack> Launchpad bug 1469926 in Mistral liberty "task with ERROR doesn't post any result" [Critical,In progress] - Assigned to Renat Akhmerov (rakhmerov)
16:18:37 <melisha1> LimorS is finalizing puppet installation and will start to work on Mistral Qpid NO soon
16:18:58 <m4dcoder> still working on error-resume
16:19:02 <rakhmerov> ok
16:19:20 <xylan_kong> melisha1: about the mistral puppet work, will you contribute back to upstream?
16:19:22 <^Gal^> I'm on execution screen on mistral-dashboard, we're also getting Liat (the fellow member to join) up to speed
16:19:31 <rakhmerov> xylan_kong: yeah, internal stuff is ok, I have to spend some time on it too
16:19:33 <NikolayM> my status: fixed issues in patches related to new RPC, fixed bugs with tests and one related to API
16:19:48 <rakhmerov> ok
16:19:55 <melisha1> Liat will start the tasks screen
16:20:04 <rakhmerov> m4dcoder: how is that pause-resume thing going?
16:20:26 <rakhmerov> I saw that there was non WIP patch about a week ago but then you made it WIP again
16:20:32 <m4dcoder> still working on the internal mechanism, not at the interface yet.
16:20:48 <rakhmerov> would you like to discuss anything?
16:20:49 <m4dcoder> but i can resume from error, with-items, at join.
16:20:55 <rakhmerov> we can have a meeting if you want
16:20:59 <rakhmerov> ok
16:21:07 <m4dcoder> i'm roadblocked for a particular use case but working thru that. no need to meet just yet.
16:21:23 <rakhmerov> ooh, ok, I see
16:21:37 <rakhmerov> just keep us posted pls and let us know if you need any help
16:21:52 <gpaz> I started to work on expiration-policies there is a new BP for that  https://blueprints.launchpad.net/mistral/+spec/expiration-policies-for-executions
16:21:52 <rakhmerov> I clearly understand that it's not an easy thing at all
16:22:04 <m4dcoder> ok. you'll see some WIP patches this week. i promise.
16:22:14 <rakhmerov> ok, Winson :)
16:22:16 <rakhmerov> thanks
16:22:34 <m4dcoder> np
16:22:37 <rakhmerov> gpaz: I started looking at your spec and left a couple of comments, need to finish though
16:22:38 <melisha1> gpaz is working on expiration policy for executions
16:22:54 <xylan_kong> gpaz, please see my comments in the etherpad
16:22:56 <rakhmerov> #action rakhmerov: completely review https://blueprints.launchpad.net/mistral/+spec/expiration-policies-for-executions
16:23:08 <rakhmerov> ^Gal^: a question to you
16:23:14 <^Gal^> yeah
16:23:23 <gpaz> rakhmerov, xylan_kong, I will, thanks
16:23:49 <rakhmerov> how are you now with Django? Still on the learning curve or technically skilled to do something?
16:24:23 <^Gal^> it is going well now, took me some time to get things going
16:24:45 <rakhmerov> because my understanding is that you're mostly an AngularJS guy so I was a little bit concerned about how easy it was for you to switch to Django
16:25:00 <rakhmerov> ooh, ^Gal^, that's great
16:25:02 <^Gal^> still not sure I'm familiar with all the debug capabilities though
16:25:07 <rakhmerov> good to hear that
16:25:20 <^Gal^> yeah, lots of new stuff
16:25:27 <rakhmerov> ping zhenguo, he seems to be very experienced in it
16:25:33 <^Gal^> yeah we talk daily
16:25:34 <rakhmerov> he can help
16:25:38 <rakhmerov> cool
16:25:50 <^Gal^> yeah he is
16:25:55 <^Gal^> he's great
16:26:20 <rakhmerov> ok, next topic
16:26:23 <rakhmerov> #topic Dashboard progress
16:26:53 <rakhmerov> I don't have a detailed agenda but would like to find out how it is going
16:27:51 <rakhmerov> from what I saw (from installed Dashboard) it's now functional and ready to be worked on further
16:28:03 <rakhmerov> I mean it's completely repaired
16:28:10 <rakhmerov> thanks to zhenguo, great work
16:28:14 <xylan_kong> rakhmerov: really a good news! i think we could do a mistral demo in Tokyo, through Horizon.
16:28:24 <rakhmerov> yeah
16:28:31 <^Gal^> yeah he fixed the whole thing
16:28:50 <^Gal^> i had some progress with the execution list table
16:28:52 <rakhmerov> but I didn't actually test all the features myself (e.g. I didn't try to run a wf so far) so please first make sure it works )
16:29:09 <rakhmerov> ^Gal^: ok, good
16:29:36 <rakhmerov> so you're moving on according to https://blueprints.launchpad.net/mistral/+spec/mistral-dashboard-executions-screen ?
16:29:53 <^Gal^> yep
16:29:53 <rakhmerov> any roadblocks, challenges that the rest of the team could help with?
16:29:57 <^Gal^> it is my workplan
16:30:14 <^Gal^> hmmm none that I can think of atm
16:30:36 <^Gal^> when I come up with something I usually ask Zhenguo
16:30:36 <rakhmerov> ok, do you have any estimations on when it can be completed?
16:31:02 <rakhmerov> maybe not on 100% but at a state when it's useable enough
16:31:46 <rakhmerov> I'm not pushing you at all, just thinking on how to plan/coordinate our further work
16:31:47 <^Gal^> I'll think until the next meeting I'll have the main table pretty solid-ish
16:31:47 <rakhmerov> :)
16:31:51 <^Gal^> yeah yeah I know :)
16:32:02 <rakhmerov> ooh, that would be great
16:32:19 <^Gal^> still hard for me to estimate stuff cause I'm not sure of the whole django thingy flow to the ebd
16:32:19 <rakhmerov> ok
16:32:20 <^Gal^> end
16:32:40 <rakhmerov> yeah-yeah, but the thing is that we have to provide some estimates
16:32:45 <^Gal^> sure np
16:32:55 <rakhmerov> even if we make mistakes
16:33:42 <rakhmerov> so once this is done, do you think it'll be pretty easy to take executions screen and apply most of its tech solutions to other screens?
16:34:05 <^Gal^> yep
16:34:13 <rakhmerov> by asking this I'm trying to understand what we count for say in a month
16:34:15 <rakhmerov> ok
16:34:17 <^Gal^> i need to get the notion of how filtering work in horizon
16:34:25 <^Gal^> and it sort most of the stuff there
16:34:36 <rakhmerov> yes, filtering is actually a problem
16:34:41 <melisha1> We also try to do them in parallel with Liat
16:34:53 <rakhmerov> let me write a couple of words about it
16:34:55 <rakhmerov> right now
16:35:04 <rakhmerov> so that you keep it in mind when working on it
16:35:25 <^Gal^> sure that would be great thanks
16:35:34 <rakhmerov> right now in Mistral API v2 we don't have a capability to flexibly do server-side filtering
16:35:43 <rakhmerov> unfortunately
16:36:37 <^Gal^> so guess I'll write me some ajax
16:36:49 <rakhmerov> ideally we should be able to do something like: /tasks?from_date=123123&to_date=12312423&name=task1
16:37:05 <rakhmerov> but our endpoints can't do this atm
16:37:43 <rakhmerov> I wanted to do this but the technology we're now using in for REST endpoints does not allow it easily
16:38:08 <^Gal^> k
16:38:10 <rakhmerov> so what I'm going to is that you'll probably have to do filtering on a client side somehow
16:38:14 <^Gal^> syep
16:38:24 <^Gal^> I'll come up with something
16:38:26 <rakhmerov> but I"m not even sure how it's supposed to be done
16:38:30 <rakhmerov> yeah
16:38:40 <^Gal^> yeah usually its a json file you play with
16:38:43 <rakhmerov> the obvious downside is performance
16:38:57 <rakhmerov> server-side filtering would work much faster
16:39:55 <rakhmerov> but the good news is that it's not forever and we're planning to implement API v3 which will support such capabilities and fix some other problems too
16:40:06 <melisha1> The biggest issue I see here now is the execution list
16:40:21 <rakhmerov> my best hope is that it'll happen in the beginning of Sept
16:40:34 <rakhmerov> melisha1: yes, you're 100% right
16:40:35 <melisha1> After a few weeks the list will be huge and takes a long time to load
16:40:40 <rakhmerov> yes
16:41:02 <melisha1> Tasks had a filter by execution id so it is okay
16:41:10 <rakhmerov> what I'm thinking is that we'll probably have to come up with some server-side workaround for now
16:41:13 <^Gal^> I guess I would write some patch
16:41:17 <rakhmerov> dunno exactly what it will be
16:41:24 <rakhmerov> yeah
16:41:36 <^Gal^> ill post some json and do it on the clientside
16:41:40 <melisha1> It must probably need to be server side
16:41:48 <rakhmerov> so, just letting you know in advance cause I see it as one of the biggest issues
16:41:54 <rakhmerov> from UI perspective
16:42:04 <^Gal^> yeah I guess so
16:42:32 <^Gal^> I'll be smarter when I'll get to that
16:42:37 <^Gal^> sooner than later
16:42:49 <rakhmerov> ^Gal^: yes, that's fine but as melisha1 said imagine hundreds of thousands executions (maybe millions?) that you'd have to fetch over the net every time and process at the client side
16:42:49 <rakhmerov> :)
16:42:52 <^Gal^> will update asap
16:42:55 <rakhmerov> doesn't sound funny
16:43:07 <^Gal^> yeah I know
16:43:12 <rakhmerov> ^Gal^: ok
16:43:12 <^Gal^> hmmm
16:43:43 <rakhmerov> so once you will get to that point we'll need to discuss it again and think how to fix it in the server
16:44:01 <rakhmerov> otherwise it won't be usable in production
16:44:17 <rakhmerov> ok
16:44:26 <^Gal^> k sure
16:44:48 <rakhmerov> alright, let's move forward
16:44:49 <melisha1> True. We will also try to think of ideas to present
16:45:05 <rakhmerov> yes, please do
16:45:19 <rakhmerov> #topic Liberty 2 progress
16:46:32 <rakhmerov> so on this topic I don't have much to say except "please update the statuses of all bugs and BPs you happen to be working on"
16:47:13 <rakhmerov> so Liberty-2 milestone is scheduled for July 29 (~2 weeks left)
16:47:32 <rakhmerov> so I think most of the BPs will be implemented on time
16:47:57 <rakhmerov> please also go over a list of bugs and see if you could take some of them
16:48:40 <melisha1> Okay
16:48:51 <rakhmerov> btw, just to let you know: I'll be on vacation from July 20 till Aug 2
16:48:57 <rakhmerov> NikolayM will be replacing me
16:49:06 <xylan_kong> rakhmerov: ok
16:49:15 <rakhmerov> so ping him any time, even at night
16:49:15 <m4dcoder> have fun
16:49:16 <rakhmerov> :)
16:49:25 <rakhmerov> m4dcoder: yeah, thanks
16:49:26 <melisha1> :-)
16:49:28 <^Gal^> lol
16:49:50 <xylan_kong> maybe i'll stay at home when you are on vacation
16:50:14 <rakhmerov> so I'll do my best to complete things assigned to me this week and I'll get back for just one day to release Liberty-2 on July 29
16:50:52 <rakhmerov> NikolayM: please be in touch with the team on a daily basis and keep LP up to date
16:51:12 <NikolayM> yes, sure
16:51:19 <rakhmerov> xylan_kong: what do you mean at home? :) why?
16:51:51 <xylan_kong> rakhmerov: paternity leave
16:52:03 <rakhmerov> :))
16:52:05 <m4dcoder> congrat!
16:52:13 <rakhmerov> !!
16:52:13 <openstack> rakhmerov: Error: "!" is not a valid command.
16:52:15 <xylan_kong> m4dcoder: thanks
16:52:27 <rakhmerov> :)
16:52:28 <rakhmerov> cool
16:52:48 <rakhmerov> #topic Open discussion
16:53:15 <rakhmerov> we have ~7 mins so please go ahead if you have other questions
16:53:22 <^Gal^> congrats!!
16:53:30 <rakhmerov> if not we can shut down the meeting
16:53:40 <xylan_kong> ^Gal^  :)
16:54:00 <rakhmerov> xylan_kong: I have a question actually
16:54:14 <rakhmerov> do you have a boy or girl?
16:54:15 <rakhmerov> :)
16:54:26 <xylan_kong> rakhmerov: i don't know
16:54:29 <xylan_kong> :-)
16:54:33 <rakhmerov> ooh really!
16:55:09 <rakhmerov> is it a chineese tradition not to find out a gender in advance?
16:55:10 <rakhmerov> :)
16:55:12 <melisha1> Cool. A surprise
16:55:20 <xylan_kong> no, just depends on you
16:55:29 <rakhmerov> ok :) I see
16:55:44 <rakhmerov> so no more questions?
16:55:44 <xylan_kong> melisha1: yes
16:56:27 <xylan_kong> no from me
16:56:35 <rakhmerov> ok guys, have a good week! Come to our channel #openstack-mistral whenever you want to discuss something
16:56:46 <rakhmerov> thanks a lot for coming
16:56:54 <xylan_kong> ok, nice meeting, see you
16:56:58 <^Gal^> bye all
16:57:01 <NikolayM> bye!
16:57:04 <rakhmerov> bye
16:57:06 <rakhmerov> #endmeeting