16:01:24 <NikolayM> #startmeeting Mistral
16:01:25 <openstack> Meeting started Mon Jul 27 16:01:24 2015 UTC and is due to finish in 60 minutes.  The chair is NikolayM. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:28 <openstack> The meeting name has been set to 'mistral'
16:01:46 <NikolayM> hi everyone!
16:02:24 <akuznetsova> hi there
16:02:36 <melisha> Hi
16:03:07 <NikolayM> let's wait a few minutes for others
16:04:05 <gpaz> Hi everyone
16:04:21 <^Gal^> hi
16:04:45 <NikolayM> so, let's start
16:04:55 <NikolayM> first topic is review action items
16:04:58 <NikolayM> #topic Review action items
16:05:18 <NikolayM> 1. NikolayM: review and discuss Lingxian's proposal about removing wf_trace module
16:05:36 <NikolayM> particially done
16:05:46 <NikolayM> reviewed but not discussed yet
16:06:06 <NikolayM> so, I absolutely support this idea
16:06:31 <NikolayM> xylan_kong is not with us today
16:06:58 <NikolayM> next item
16:07:00 <melisha> NikolayM: I am not familiar enough with this to have an opinion
16:07:04 <melisha> OK
16:07:29 <NikolayM> melisha, I can send a link on the document to you
16:07:40 <NikolayM> 2. NikolayM: map what we have and what we don't have in our docs and next week at the meeting discuss plan for it
16:08:01 <akuznetsova> I've worked on it )
16:08:10 <NikolayM> we have an etherpad with docs plan at https://etherpad.openstack.org/p/mistral-docs-plan
16:08:16 <NikolayM> thanks to akuznetsova
16:08:21 <akuznetsova> and prepared etherpad ^
16:08:29 <NikolayM> well done :)
16:09:45 <NikolayM> guys, you are welcome to look at it and write comments
16:09:55 <melisha> akuznetsova: Very good starting point. Thanks!
16:10:04 <NikolayM> next topic is current status
16:10:06 <NikolayM> #topic Current status
16:10:09 <akuznetsova> as far as we agreed this scheme we can start moving articles to our official site with docs
16:10:23 <^Gal^> I'm on the execution list table, started working on the action buttons, update, and shorten the output sectioמ
16:10:27 <^Gal^> section*
16:10:30 <NikolayM> let's tell our status
16:11:09 <melisha> I am just about to finish BP: Support large datasets for execution objects - https://review.openstack.org/#/c/205190/
16:11:14 <gpaz> expiration-policies-for-executions, I m ready for the first push ...
16:11:15 <NikolayM> my status: worked on with-items-concurrency blueprint, it is fully implemented now and is no review now
16:11:37 <akuznetsova> I've prepared etherpad with scheme for our future docs and also I've started work on new gates (run unit tests against postgresql)
16:11:38 <NikolayM> on review*
16:12:02 <melisha> Updating for LimorS - She is at the process of contributing the Mistral Puppet Module and she started working on qpid support
16:12:31 <NikolayM> yes, I've seen that patch to puppet-mistral
16:12:38 <melisha> Updating for LiatFried - She will start working on the tasks screen soon
16:13:43 <NikolayM> So, we haven't any more specific topic for this meeting
16:13:49 <NikolayM> #topic Open discussion
16:14:14 <^Gal^> I would love you guys taking a look at the 2 blueprints we suggested, need to get them reviewd
16:14:14 <^Gal^> https://blueprints.launchpad.net/mistral/+spec/tasks-screen-improvments
16:14:15 <^Gal^> https://blueprints.launchpad.net/mistral/+spec/mistral-dashboard-cron-trigger-screen
16:14:31 <NikolayM> ok, good
16:14:41 <akuznetsova> NikolayM, as far as I know L2 is coming, will we release Mistral on this week ?
16:14:56 <NikolayM> #action NikolayM, all: look and review https://blueprints.launchpad.net/mistral/+spec/tasks-screen-improvments
16:14:59 <melisha> ^Gal^: I reviewed them and it looks good to me
16:15:06 <NikolayM> #action NikolayM, all: look and review https://blueprints.launchpad.net/mistral/+spec/mistral-dashboard-cron-trigger-screen
16:15:17 <NikolayM> melisha, that's fine
16:15:27 <akuznetsova> ^Gal^, UI improvements, super!
16:15:30 <NikolayM> thanks, melisha
16:15:34 <NikolayM> yes
16:15:36 <^Gal^> thanks :)
16:16:17 <NikolayM> ^Gal^, appreciate your contribution :)
16:16:28 <NikolayM> Winson, are you here?
16:16:45 <^Gal^> sure, np. the whole team helps :)
16:17:16 <melisha> all: I know we have a workflow builder coming up. Are there plans for Workflow execution graph (that shows the definition / runtime status)?
16:17:32 <akuznetsova> seems like he it not here, that's pity, cause I have a question for him
16:17:45 <NikolayM> hmm, it seems Winson is not with us, I have a question to him...
16:17:45 <akuznetsova> melisha, yes
16:18:20 <NikolayM> melisha, yes, we have this plans
16:18:41 <melisha> akuznetsova, NikolayM: Is there a BP? Did someone started it yet?
16:18:44 <m4dcoder> What's up
16:18:46 <NikolayM> but I'm sure we don't finish this work even in next cycle
16:18:57 <NikolayM> ooh, hi, m4dcoder!
16:19:06 <m4dcoder> hey!
16:19:14 <akuznetsova> melisha, nobody has started it
16:19:19 <akuznetsova> m4dcoder, hi
16:19:31 <melisha> akuznetsova: OK. Thanks.
16:19:50 <m4dcoder> @NikolayM: you've a question for me?
16:20:00 <NikolayM> m4dcoder, yes
16:20:18 <akuznetsova> m4dcoder, me too
16:20:22 <NikolayM> I saw your patch for running tests on postgres again and have a question
16:20:57 <akuznetsova> do you plan to continue on it and add ability to run tests against mysql ?
16:21:03 <akuznetsova> m4dcoder, ^
16:21:15 <akuznetsova> *to continue to work
16:21:25 <NikolayM> aah, yes, that's the question
16:22:36 <NikolayM> so, and why you refused of mysql there? I remebered it was there :)
16:22:43 <m4dcoder> for postgresql, it's done from a unit test standpoint. i was hoping you can add the devstack gate for it.
16:23:01 <m4dcoder> as for mysql, it's a lower priority for me. but i can continue to work on it.
16:23:21 <akuznetsova> melisha, ^Gal^  http://horizon-merlin.mirantis.com/horizon/auth/login/?next=/horizon/project/mistral/edit/
16:23:34 <akuznetsova> here is what we have for the current moment
16:23:39 <m4dcoder> mysql requires some more work, especially around the timestamp fields.
16:23:44 <akuznetsova> creds: demo / demo
16:24:15 <akuznetsova> melisha, ^Gal^  I mean this is a prototype of Workbook Builder
16:24:21 <^Gal^> nice!!!!
16:24:26 <^Gal^> that's sweet!!
16:24:40 <melisha> akuznetsova: Thanks! I saw it on the Vancuvouer Summit. It is very nice.
16:24:45 <m4dcoder> you guys want me to separate the mysql and postgresql changes. mysql just requires more work and it's a lower priority for me currently.
16:24:48 <^Gal^> "Here will be a fancy Graph View as soon as we implement it!" :D :D
16:25:06 <NikolayM> m4dcoder, ok, got you
16:25:12 <melisha> akuznetsova: I was asking more about an execution graph for viewwing and less about a builder
16:25:30 <NikolayM> Can we continue work with it without editing datetime fields?
16:26:13 <m4dcoder> the unit tests will fail because lacking fractional seconds.
16:26:21 <akuznetsova> melisha, I know, I just wanted to show you where we are now, how we can build wb)
16:26:33 <m4dcoder> so either we hack the unit test or we add a utility to normalize the timestamp values
16:27:07 <melisha> akuznetsova: OK. Thanks. It is very cool.
16:27:52 <NikolayM> m4dcoder, ok, we can do it separately
16:27:59 <m4dcoder> +1
16:28:50 <akuznetsova> melisha, as far as I understand there are should be two graphs: one that shows wb structure and another is for wf execution process
16:29:17 <NikolayM> akuznetsova, yes. Static picture and dynamic one
16:29:35 <melisha> akuznetsova: I tend to agree. These two views are different.
16:29:38 <akuznetsova> NikolayM, ok, thanks
16:29:52 <melisha> Maybe in the future - the static one will also be a visual builder
16:30:10 <akuznetsova> m4dcoder, one more question about run_tests
16:30:31 <NikolayM> melisha, yes, we have the blueprint for that!
16:30:53 <m4dcoder> akuznetsova: ok, go ahead
16:31:11 <akuznetsova> m4dcoder, I tried to run it in devstack gate  and got following error: sudo: unknown user: postgres sudo: unable to initialize policy plugin
16:31:32 <melisha> NikolayM: Thanks. Can you please share the BP?
16:31:37 <m4dcoder> what distro is the test running on?
16:32:01 <akuznetsova> m4dcoder, am I right that there are should be 2 "postgres" user: system and db
16:32:12 <m4dcoder> just the system
16:32:20 <m4dcoder> the test creates a db user called mistral
16:32:28 <akuznetsova> m4dcoder, ubuntu
16:32:43 <m4dcoder> if on ubuntu, it's automatically setup for trust for postgres user
16:32:45 <NikolayM> melisha, it seems that it was deleted by someone
16:32:56 <NikolayM> it was on LP
16:33:05 <NikolayM> but now I can't find it
16:33:24 <melisha> NikolayM: OK. Thanks.
16:33:51 <akuznetsova> m4dcoder, hmm
16:33:57 <m4dcoder> akuznetsova: probably will need to troubleshoot
16:34:14 <m4dcoder> have you tried locally on your own system?
16:34:42 <melisha> <dependency>
16:34:43 <melisha> <groupId>org.codehaus.jackson</groupId>
16:34:43 <melisha> <artifactId>jackson-jaxrs</artifactId>
16:34:43 <melisha> <version>1.9.0</version>
16:34:43 <melisha> </dependency>
16:34:52 <melisha> Sorry :-)
16:35:13 <melisha> I should not work while chatting :-)
16:36:05 <melisha> all: I noticed that the workflow pagination BP was merged - that is great! Do you know if someone is already working on adding it to the executions API?
16:36:09 <akuznetsova> m4dcoder, not yet) cause I decided to make test commit and run this tests on our gate
16:36:49 <NikolayM> melisha, I guess xylan_kong will work on this
16:37:06 <NikolayM> now it can be implemented significantly faster
16:37:38 <melisha> NikolayM: OK. Cool. Yes. I believe so to.
16:39:53 <akuznetsova> m4dcoder, I will continue to debug it, if I come to a standstill, I will write to you
16:40:58 <m4dcoder> akuznetsova: thanks. feel free to reach out. i'll also run the test on my system again today to make sure it's alright.
16:41:20 <akuznetsova> m4dcoder, btw how did you test this script ? devstack + postgresql installation or just vm with ubuntu + manual postgresql installation ?
16:41:33 <m4dcoder> ubuntu + manual postgresql
16:41:42 <m4dcoder> on a vm
16:43:19 <akuznetsova> m4dcoder, ok, thanks
16:43:53 <m4dcoder> np
16:43:55 <NikolayM> guys, do you have any more questions?
16:44:02 <NikolayM> any more topic to discuss?
16:44:17 <^Gal^> I would like to ask in behalf of us Alcatel-Lucent guys whether could we find an earlier time for the weekly?
16:44:17 <^Gal^> and is such thing good on everyone else's timezone?
16:44:17 <^Gal^> #openstack-meeting-3 seems quite vacant regularly
16:45:12 <NikolayM> ^Gal^, ok, I discuss this with our PTL
16:45:29 <^Gal^> thanks, appreciate that :)
16:45:40 <akuznetsova> as far as I know, current time is not suitable for xylan_kong and rakhmerov too
16:45:48 <^Gal^> yeah and Niu
16:46:06 <NikolayM> #action NikolayM: talk to rakhmerov about moving weekly meeting to earlier time
16:46:49 <melisha> For us - earlier will be better as well. It is now 19:45
16:47:11 <akuznetsova> melisha, like in our timezone (me and NikolayM )
16:47:25 <m4dcoder> then please don't do meet on a monday AM if earlier... it's brutal
16:47:57 <akuznetsova> m4dcoder, what's time is it in your location ?
16:48:27 <m4dcoder> it's 9:47 AM US pacific. please don't make it any earlier on a Monday AM.
16:49:07 <^Gal^> lol monday morning
16:49:13 <^Gal^> worst time ever :D
16:49:25 <melisha> m4dcoder: If it will be ealier on a different day - is it OK?
16:49:44 <NikolayM> m4dcoder, we'll take it into account :)
16:50:07 <m4dcoder> yep, different day ok.  evening after 10 PM PST is also ok for me.
16:50:13 <NikolayM> I suggest to create a doc on google or etherpad for this
16:50:39 <melisha> Or a doodle - http://doodle.com/en_GB/
16:50:49 <akuznetsova> NikolayM, firstly let's find free slots
16:52:35 <NikolayM> ok, yes
16:52:48 <NikolayM> so, let's end our meeting
16:52:58 <^Gal^> k bye all
16:53:04 <akuznetsova> bye-bye
16:53:06 <NikolayM> thanks to all who come us today
16:53:08 <melisha> Bye
16:53:09 <NikolayM> bye!
16:53:09 <m4dcoder> alright. thx!
16:53:15 <NikolayM> #endmeeting