16:03:14 <akuznetsova> #startmeeting Mistral
16:03:15 <openstack> Meeting started Mon Aug 3 16:03:14 2015 UTC and is due to finish in 60 minutes. The chair is akuznetsova. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:19 <openstack> The meeting name has been set to 'mistral'
16:03:26 <akuznetsova> Hi there
16:03:39 <^Gal^> hi!
16:03:45 <gpaz> Hello everyone
16:03:54 <melisha> Hi
16:04:23 <akuznetsova> let's wait a couple of minutes
16:04:44 <NikolayM> hi everyone!
16:04:51 <NikolayM> sorry I'm late
16:05:52 <akuznetsova> NikolayM, no problem, I've started meeting
16:06:09 <akuznetsova> Renat has to skip today's meeting
16:06:14 <gpaz> Gal, Moshe & I here
16:06:23 <rakhmerov> hey guys, good to be back with you again after vacation. I bring my apologies: I won't be able to be here with you cause I need to get ready for my flight to Israel through Moscow
16:06:41 <rakhmerov> so Nikolay and Anastasia will drive the meeting
16:06:44 <NikolayM> gpaz, ok
16:07:05 <^Gal^> rakhmerov: have a good flight!
16:07:20 <akuznetsova> I guess, that we can start
16:07:38 <NikolayM> yes. let's start
16:07:44 <akuznetsova> Let's review items from previous meeting
16:08:01 <akuznetsova> NikolayM, all: look and review https://blueprints.launchpad.net/mistral/+spec/tasks-screen-improvments
16:08:15 <NikolayM> so, basically done
16:08:22 <NikolayM> looks good
16:08:37 <^Gal^> Liat started working on that screen
16:08:43 <^Gal^> she's doing good
16:08:46 <NikolayM> I just want approving from Renat
16:09:04 <akuznetsova> ok, next one: NikolayM, all: look and review https://blueprints.launchpad.net/mistral/+spec/mistral-dashboard-cron-trigger-screen
16:09:15 <NikolayM> done too
16:09:17 <akuznetsova> the same status ?)
16:09:23 <rakhmerov> ^Gal^: thanks ) I guess I'll see you tomorrow in person :)
16:09:35 <NikolayM> akuznetsova, yes :)
16:09:36 <^Gal^> rakhmerov: You bet :)
16:10:13 <akuznetsova> and the last one: NikolayM: talk to rakhmerov about moving weekly meeting to earlier time
16:10:15 <melisha> NikolayM: cron-trigger was not started yet. We don't think we will be able to do it for L-3
16:10:41 <NikolayM> akuznetsova: not done yet
16:11:18 <NikolayM> melisha, oh, ok
16:12:06 <akuznetsova> ok, I hope we will find appropriate time for all of us
16:12:09 <melisha> NikolayM: We have 2 UI persons - one on Executions and one on Tasks. The learning curve is quite big
16:13:32 <NikolayM> melisha, ok, not a big problem
16:13:32 <^Gal^> yeah, the two trouble makers are myself and Liat
16:13:50 <akuznetsova> that's all from previous meeting
16:13:59 <akuznetsova> #topic Current Status
16:14:45 <^Gal^> Current status: JUST FIGURED OUT HOW TO DEBUG DASHBOARDS!!!!
16:14:45 <^Gal^> Spent recent time trying to figure out how to debug Mistral-Dashboard or Horizon or any other Openstack dashboard - using PyCharm.
16:14:46 <^Gal^> Encountered many different problems.
16:14:46 <^Gal^> Think we should add it to our docs, I would happily do the PyCharm part.
16:14:57 <NikolayM> my status: Fixed tests (and actually algorythm of with-items-concurrency), thanks to xylan_kong
16:15:22 <NikolayM> ^Gal^: that's awesome :)
16:15:38 <^Gal^> NikolayM: lol tnx :D
16:15:39 <gpaz> my status: Expiration-executions-policy , in progress, pushed and reviewed with Nikolay, I discussed with Moshe and we think it will be better currently (L-3) we will only use a “counter” in minutes (time period) and next phase maybe we will and the cron pattern.
16:15:49 <akuznetsova> my status: prepared commit to openstack-infra with addition of new gate for running unit tests against postgresql
16:15:50 <NikolayM> also I reviewed almost all the patches
16:15:50 <melisha> I published the http://yaqluator.com :-)
16:16:38 <akuznetsova> melisha, awesome name for project)
16:16:56 <NikolayM> melisha, the yaqluator is very-very useful tool!
16:17:11 <melisha> akuznetsova: Thanks. How would have thought that the domain would be free?! :-)
16:17:18 <melisha> NikolayM: Thanks.
16:17:35 <melisha> Gal was also in my Hackathon group
16:17:38 <akuznetsova> melisha, :-)
16:17:50 <^Gal^> yeah, yaqluator ftw!
16:18:38 <akuznetsova> ok, thanks for status update
16:19:08 <akuznetsova> so, let's go to the next topic
16:19:26 <akuznetsova> #topic Open Discussion
16:19:55 <akuznetsova> guys, any topics for today's discussion ?
16:21:01 <akuznetsova> NikolayM, what about migration to yaql 1.0.0 ?
16:21:51 <m4dcoder> +1 on the yaqluator. good job.
16:21:52 <NikolayM> I spoke with murano folks and they said that they are ready to move right at this week
16:22:04 <akuznetsova> Hi, m4dcoder
16:22:10 <m4dcoder> :D
16:22:11 <melisha> m4dcoder: Thanks :-)
16:22:43 <akuznetsova> NikolayM, ok
16:23:44 <akuznetsova> NikolayM, seems like L-3 has started, what are we going to do in this iteration ?
16:23:53 <NikolayM> so, they will releasy the final version of YAQL and then fully integrate it to Murano
16:24:13 <NikolayM> akuznetsova, need to think
16:24:17 <NikolayM> and plan
16:24:56 <akuznetsova> #action NikolayM provide a plan of what we are going to do in L-3 iteration
16:25:19 <NikolayM> #action NikolayM, all: look through the blueprints and think about what do we need in L-3
16:26:04 <akuznetsova> BTW, Renat just said that he will release Mistral l-2 tomorrow or day after tomorrow
16:26:40 <NikolayM> akuznetsova, ok
16:27:03 <NikolayM> we are a bit late with our L-2 release :(
16:28:17 <akuznetsova> ^Gal^, gpaz, melisha , m4dcoder any questions? roadblocks ?
16:28:57 <akuznetsova> maybe you have suggestions of what we need to do in the l-3
16:29:00 <gpaz> well its not a block but
16:29:18 <gpaz> maybe for now we will not use cron pattern for expiration policy
16:29:41 <gpaz> it will be more easy to push that with only use counter in minutes and pass that to the periodic task
16:29:50 <melisha> NikolayM, akuznetsova: In order for the UI screens to work properly we need to implement the pagination/sorting in the server
16:30:00 <gpaz> This will be good enough I think for now
16:30:40 <^Gal^> Hmm the only thing I can think of UI-wise for l-3 it to have some draft or implementation of a table using AngularJS
16:30:54 <NikolayM> melisha, ok, need to chat to xylan_kong
16:31:16 <gpaz> In order to have that for L-3. next pahse I think we can improve that. using only counter is good enough for ower customer requirements
16:31:20 <gpaz> our*
16:31:24 <NikolayM> gpaz, why not using the scheduler?
16:32:21 <NikolayM> we can calculate the next execution time right in run_expiration_policy method
16:35:10 <gpaz> NikolayM, I think it will take more time now change everything since the current implementation almost done
16:36:50 <gpaz> from the first place using a cron it wasn’t a requirement just something that “nice to have” I think
16:36:50 <NikolayM> oh, ok
16:37:04 <NikolayM> btw, you want to see it in current release?
16:38:32 <gpaz> NikolayM, Yes
16:41:01 <akuznetsova> anything else to discuss ?
16:41:27 <NikolayM> nothing from my side
16:42:32 <gpaz> NikolayM, We can discuss about the expiration-policy offline, also Renal should be here tomorrow so we can close that
16:42:40 <gpaz> Renat*
16:42:59 <NikolayM> gpaz, ok, sure
16:43:38 <akuznetsova> so, let's wrap the meeting
16:45:06 <akuznetsova> bye to all !)
16:45:12 <melisha> Bye
16:45:24 <^Gal^> bye, have a good one
16:45:44 <gpaz> Have a safe flight Renat ...
16:45:49 <NikolayM> bye!
16:45:55 <akuznetsova> #endmeeting