16:02:06 <akuznetsova> #startmeeting Mistral
16:02:07 <openstack> Meeting started Mon Aug 17 16:02:06 2015 UTC and is due to finish in 60 minutes.  The chair is akuznetsova. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:10 <openstack> The meeting name has been set to 'mistral'
16:02:17 <akuznetsova> hi there
16:02:23 <^Gal^> hellllo
16:02:26 <m4dcoder> hi
16:02:37 <LimorStotland> hi
16:02:51 <akuznetsova> Renat said, that he would be a little bit late
16:02:55 <gpaz> Hi
16:03:11 <akuznetsova> so, let's wait a little bit)
16:03:54 <akuznetsova> how are you, guys?)
16:04:44 <m4dcoder> doing good.  how about yourself?
16:04:55 <^Gal^> all's good, except the weather :D
16:05:28 <gpaz> Better than that and I ll get crazy ;)
16:05:33 <akuznetsova> m4dcoder, I am fine and ready for work)
16:05:44 <m4dcoder> :D
16:05:53 <akuznetsova> ^Gal^, what's the problem with the weather? rainy?
16:06:04 <akuznetsova> gpaz, ))
16:06:05 <^Gal^> akuznetsova: I wish!
16:06:14 <^Gal^> akuznetsova: too hot, way too hot!
16:06:28 <akuznetsova> ^Gal^, oh, last summer days)
16:06:51 <rakhmerov> hi everyone
16:06:57 <rakhmerov> sorry for being late
16:07:07 <akuznetsova> rakhmerov, hi
16:07:27 <m4dcoder> rakhmerov, hi! it's been awhile.
16:07:36 <rakhmerov> ok, have you already discussed anything?
16:07:47 <rakhmerov> m4dcoder: yeah, how are you? :)
16:07:49 <akuznetsova> rakhmerov, the weather)
16:08:03 <m4dcoder> rakhmerov: doing good
16:08:08 <m4dcoder> thx
16:08:17 <rakhmerov> ooh, weather is always a good topic :)
16:08:22 <rakhmerov> ok, let's start then?
16:08:33 <akuznetsova> yes
16:08:51 <rakhmerov> the agenda is at https://wiki.openstack.org/wiki/Meetings/MistralAgenda
16:09:13 <rakhmerov> #topic Review action items
16:09:29 <rakhmerov> let me see what items we have (I missed the previous meeting)
16:10:10 <rakhmerov> 1. akuznetsova create meeting for l-3 roadmap discussion
16:10:10 <rakhmerov> done
16:10:14 <akuznetsova> yes
16:10:31 <rakhmerov> akuznetsova start a discussion in the ml about new community meeting time
16:10:43 <akuznetsova> I redirected it to you)
16:10:46 <rakhmerov> we will discuss it today a little later
16:10:47 <rakhmerov> yes
16:10:57 <rakhmerov> 3. m4dcoder take a look at problem with postgresql unit tests running
16:11:09 <rakhmerov> m4dcoder: did you have a chance to look at it?
16:12:08 <m4dcoder> rakhmerov: sorry, i didn't get to it last week
16:12:14 <rakhmerov> ok
16:12:21 <rakhmerov> we can discuss it later too
16:12:26 <m4dcoder> it's still on my list of things to do.
16:12:33 <rakhmerov> Anastasia just sent an email today about it
16:12:37 <rakhmerov> ok, np
16:12:50 <m4dcoder> ok. i'll take a look.
16:13:05 <rakhmerov> #topic Current status (progress, issues, roadblocks, further plans)
16:13:34 <rakhmerov> my status: finally released l-2 last week, with 2 weeks delay. Sorry for that
16:13:57 <rakhmerov> was involved in internal company activities so was not able to do a lot on Mistral
16:14:07 <rakhmerov> also drove a meeting about l-3 planning
16:14:22 <^Gal^> Current status: working on execution screen: 1. execution update modal 2. main execution screen - shortage of i/o columns when there's a lot of code
16:14:28 <akuznetsova> my status: sent a mail about problems with unit tests + real db, created corresponding bugs, plans: reanimate ./run_functional_tests.sh script
16:14:32 <rakhmerov> planning to take a couple of engine bugs and fix them
16:14:58 <rakhmerov> akuznetsova: good, please do
16:15:06 <gpaz> Currently Limor and I working on inner Alcatel tasks (I m doing some Murano) . We have bugs that we will start to work I think after l-3
16:15:08 <rakhmerov> I'd like to be able to use it when needed
16:15:29 <rakhmerov> ^Gal^: how is it going with executions screen? do you see any roadblocks? need any help?
16:15:41 <akuznetsova> rakhmerov, ok, will try to fix it as soon as possible
16:15:45 <rakhmerov> gpaz: ok
16:15:55 <gpaz> Some bugs = mistral bugs that assign on us
16:16:10 <^Gal^> rakhmerov: it is going good, don't see any roadblocks atm - will update if something comes up
16:16:11 <m4dcoder> planning to revisit the postgresql unit test
16:16:14 <rakhmerov> gpaz: the only thing I'd really like to ask you is finish https://review.openstack.org/212080
16:16:24 <rakhmerov> please try to allocate some time to finish it
16:16:27 <nikolaym> My status: worked on with-items concurrency and with-items retry policy
16:16:35 <rakhmerov> ^Gal^: good, thanks
16:17:06 <gpaz> rakhmerov, I pushed a fix but I need to think how to test it...
16:17:21 <rakhmerov> m4dcoder: I'd recommend to run Mistral engine tests and observe what's going on with a number of DB connections using some DB UI
16:17:41 <rakhmerov> I guess something devours DB connections, but I have no idea what exactly
16:18:02 <rakhmerov> theoretically there shouldn't be serious growth during tests' execution
16:18:45 <rakhmerov> gpaz: we'll take a look at your patch and provide some recommendation about testing, sounds ok?
16:18:49 <m4dcoder> rakhmerov: i'm not sure i have a lot of bandwidth this week to go deep on the problem. i was planning just running the unit tests and see if there're any obvious items i can fix.
16:19:23 <rakhmerov> #action rakhmerov, nikolaym: provide recommendations on how to test https://review.openstack.org/212080
16:19:32 <^Gal^> btw, think we had a previous action item that we haven't talked about recently which is the documentation
16:19:45 <rakhmerov> m4dcoder: no problem, I'm not pushing at all
16:19:49 <gpaz> rakhmerov, yes, sounds good. but didnt we say that bugs could handled after L-3 ? since currently I need to finish something in other project before code freez (Murano)
16:19:50 <rakhmerov> up to you
16:20:32 <rakhmerov> gpaz: no, I didn't mean that we need to stop fixing bugs :) I was just saying we're much more flexible on bugs
16:20:54 <rakhmerov> because we have to finish all new functionality and serious changes in L-3
16:21:01 <gpaz> rakhmerov, ok. np...
16:21:02 <rakhmerov> but we should keep fixing bugs anyway
16:21:52 <rakhmerov> gpaz: anyway, I'm not pushing (sorry if it felt like), we'll provide our recommendations and you'll choose the right time to get to working on it yourself
16:21:53 <rakhmerov> :)
16:22:23 <gpaz> rakhmerov, np, I want to fix that ASAP too. thanks
16:22:30 <rakhmerov> thanks
16:22:38 <rakhmerov> ok, let's move on
16:22:52 <rakhmerov> #topic Liberty-3 progress
16:23:06 <rakhmerov> release page: https://launchpad.net/mistral/+milestone/liberty-3
16:23:41 <rakhmerov> so overall feeling is that it looks good
16:24:08 <rakhmerov> one BP needs review, 4 has marked as "good progress" and two have been started
16:24:39 <rakhmerov> I talked to Nikolay that https://blueprints.launchpad.net/mistral/+spec/mistral-documentation has to be broken down into more concrete BPs
16:24:53 <rakhmerov> #action nikolaym break down https://blueprints.launchpad.net/mistral/+spec/mistral-documentation into smaller BPs
16:25:24 <^Gal^> about the documentation - sounds good
16:25:33 <rakhmerov> and one more thing that I'm not sure about is https://blueprints.launchpad.net/mistral/+spec/mistral-execution-origin
16:25:50 <rakhmerov> ^Gal^: yes :) Mistral's docs are really bad now, I recognize that
16:26:14 <m4dcoder> rakhmerov: what are you unsure of?
16:26:31 <rakhmerov> so as for this BP, I think it's really important and I would love to have it done this cycle but I would think more about what exactly we want to achieve
16:26:50 <m4dcoder> same with YAQL docs.  we can't use Mistral w/o YAQL.
16:27:02 <rakhmerov> I'm not sure about what we should do, what would be the best approach
16:27:11 <rakhmerov> m4dcoder: yep
16:27:38 <rakhmerov> so on https://blueprints.launchpad.net/mistral/+spec/mistral-execution-origin I suggest we brainstorm how to do it
16:27:47 <m4dcoder> +1
16:27:50 <rakhmerov> not here probably, we can take it to ML
16:27:56 <LimorStotland> +1
16:28:17 <rakhmerov> #action rakhmerov start ML discussion about the best approach for https://blueprints.launchpad.net/mistral/+spec/mistral-execution-origin
16:28:28 <rakhmerov> so any ideas are very welcome
16:28:43 <rakhmerov> especially from those who is using Mistral all the time
16:28:53 <rakhmerov> (Winson and Alcatel) ;)
16:29:25 <rakhmerov> other than that I don't have much on L-3 topic
16:29:30 <rakhmerov> so let's move on
16:29:51 <rakhmerov> any questions on this part?
16:29:59 <rakhmerov> before we jump to the next one?
16:30:08 <m4dcoder> rakhmerov: since i registered that bp, i can start the ML thread with some initial thoughts.
16:30:22 <rakhmerov> m4dcoder: ok, please do
16:30:30 <rakhmerov> appreciate that
16:30:34 <m4dcoder> np
16:30:43 <rakhmerov> ok
16:30:48 <rakhmerov> #topic New meeting time
16:31:08 <rakhmerov> so Alcatel folks asked to consider a different weekly meeting time
16:31:11 <rakhmerov> is that right?
16:31:50 <gpaz> its 7pm for us ... and we thought to check if we can do that earlier
16:31:56 <rakhmerov> if yes could you please share your concers about the current time?
16:32:05 <rakhmerov> ok
16:32:11 <gpaz> Depend off course with all others
16:32:21 <rakhmerov> so you have to have long hours, I see
16:32:54 <rakhmerov> so the challenge is that looks like we can't really satisfy all the members
16:33:06 <rakhmerov> because we all are from completely different time zone
16:33:17 <rakhmerov> for example, for me it's now 22.33 :)
16:33:29 <rakhmerov> for Winson it's 9.33 am
16:33:38 <gpaz> oh ok
16:33:47 <rakhmerov> in Israel it's 7.33 pm
16:33:48 <gpaz> I didnt know that someone in the morning
16:33:50 <gpaz> :)
16:33:57 <rakhmerov> so
16:33:58 <rakhmerov> :)
16:34:00 <rakhmerov> yes
16:34:24 <rakhmerov> if we want to have it, for example, one hour earlier the only option for me is Tue
16:34:25 <^Gal^> think we should have some sort of days of the week and times table
16:34:38 <^Gal^> and everyone would check their best blocks
16:34:40 <gpaz> So I guess this time is good for everyone (the current time)
16:34:42 <rakhmerov> but I checked all the timeslots and there are no available ones, unfortunately
16:34:50 <gpaz> From where is Wilson ? :)
16:34:52 <rakhmerov> and for US folks it will be too early
16:35:02 <rakhmerov> SF Bay area
16:35:12 <m4dcoder> i can do an 8 am, just don't do it on Mon. :D
16:35:23 <rakhmerov> m4dcoder: I see
16:35:53 <rakhmerov> so another option is to have it on mornings for me and folks in Israel
16:35:57 <m4dcoder> how about US PM time?  10 PM PST?
16:36:11 <rakhmerov> then for Winson it will be late evening
16:36:23 <m4dcoder> probably prefer that then early AM.  lol
16:36:26 <rakhmerov> m4dcoder: you're sure it would be ok for you?
16:36:34 <rakhmerov> ooh, I see
16:36:47 <rakhmerov> gpaz: how about that? what do you think?
16:36:50 <m4dcoder> we can try that for a release cycle.
16:37:01 <rakhmerov> for example, if it was at 8 or 9 am your time?
16:37:21 <m4dcoder> maybe start with M cycle and we can revisit the meeting time for N.
16:37:36 <gpaz> So after all that I think the current time is ok “Lesser of Two Evils” :)
16:37:49 <m4dcoder> so i'm ok with 8 AM (no Mondays) or 10 PM PST.
16:38:13 <rakhmerov> m4dcoder: ooh, we have about 3 months in L cycle, it's a little bit too much :)
16:38:38 <rakhmerov> ok, so
16:38:40 <rakhmerov> thinking...
16:39:12 <^Gal^> there must be an online gmt tool to get everyone to vote on their time slots
16:39:12 <rakhmerov> how about that? I'll suggest 3-4 timeslots and we'll vote in ML
16:39:29 <LimorStotland> ok i think it's a bit complicated just lets leave it  as it is
16:40:14 <gpaz> I do not think that choosing according to the majority is correct. Everyone should be comfortable and current time seems right to me.
16:40:15 <rakhmerov> hm
16:40:37 <rakhmerov> m4dcoder: is the current time ok for you?
16:41:09 <m4dcoder> i'm ok as is. but can change if convenient for others.
16:41:51 <rakhmerov> ok, then let's leave it as it is for now unless someone has strong objections
16:42:07 <rakhmerov> is everyone ok with that?
16:42:44 <rakhmerov> ok
16:42:47 <rakhmerov> then
16:42:52 <rakhmerov> #topic Open Discussion
16:42:55 <gpaz> I do. we can discussed that in Tokyo ;)
16:43:02 <rakhmerov> yeah :)
16:43:09 <rakhmerov> gpaz: will you be there?
16:43:37 <gpaz> Apparently..
16:43:45 <rakhmerov> cool
16:44:09 <rakhmerov> do you drink beer? :)
16:44:31 <rakhmerov> I wonder what kind of beer Japanese have )
16:44:36 <gpaz> Not too much ...
16:44:47 <gpaz> they have : Asahi
16:44:50 <gpaz> very good
16:45:13 <rakhmerov> alright, I'll buy you beer :)
16:45:26 <rakhmerov> to all of the members who comes :)
16:45:48 <gpaz> https://www.asahibeer.com/index.psp.html
16:46:31 <rakhmerov> ok :)
16:46:31 <rakhmerov> good
16:46:33 <gpaz> I hear they make great jellyfish and octopuses ;)
16:46:43 <rakhmerov> yeah, I bet :)
16:46:58 <akuznetsova> sake
16:47:04 <rakhmerov> so, do you guys have anything else to discuss?
16:47:09 <rakhmerov> sake! :)))
16:47:24 <rakhmerov> or I can buy you all sake :)
16:47:28 <rakhmerov> at your choice
16:48:05 <rakhmerov> ok, let's finish the meeting
16:48:15 <rakhmerov> thanks for coming
16:48:18 <rakhmerov> bye!
16:48:22 <m4dcoder> thanks!
16:48:37 <gpaz> thanks.. bye bye
16:48:38 <rakhmerov> akuznetsova: can you please end the meeting?
16:48:42 <rakhmerov> (you started it)
16:48:49 <akuznetsova> sure)
16:48:55 <akuznetsova> bye!
16:49:02 <akuznetsova> #endmeeting