16:01:06 <NikolayM> #startmeeting Mistral
16:01:07 <openstack> Meeting started Mon Aug 24 16:01:06 2015 UTC and is due to finish in 60 minutes. The chair is NikolayM. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:11 <openstack> The meeting name has been set to 'mistral'
16:01:14 <NikolayM> hi everyone!
16:01:20 <akuznetsova> hi !
16:01:23 <gpaz> Hi everyone
16:01:26 <^Gal^> hello
16:02:08 <xylan_kong> hi, guys
16:02:23 <NikolayM> let's start
16:02:48 <NikolayM> #topic Review action items
16:03:24 <NikolayM> 1. rakhmerov, nikolaym: provide recommendations on how to test https://review.openstack.org/212080
16:04:04 <NikolayM> it seems it wasn't done
16:04:22 <NikolayM> gpaz, could you comment on that?
16:04:36 <gpaz> provided... I think ... Renat comment in the ticket..
16:04:37 <NikolayM> the patch is related to ctx in expiration policy
16:04:51 <NikolayM> ooh, ok, I didn't know
16:04:55 <gpaz> I didnt have a chance to work on that probably start doing that this week
16:05:21 <gpaz> (in the last few day we had some demo - that include Mistral by the way)
16:05:48 <NikolayM> cool :)
16:06:02 <gpaz> the buttom line renat wrote some comment I will take a look and try to use that
16:06:34 <m4dcoder> hi
16:06:36 <NikolayM> thanks for explanation
16:06:44 <NikolayM> 2. nikolaym break down https://blueprints.launchpad.net/mistral/+spec/mistral-documentation into smaller BPs
16:06:54 <NikolayM> this one is done
16:07:24 <NikolayM> now there are about 8 BPs about documentation
16:07:33 <^Gal^> nice :)
16:08:05 <NikolayM> 3. rakhmerov start ML discussion about the best approach for https://blueprints.launchpad.net/mistral/+spec/mistral-execution-origin
16:08:28 <NikolayM> I don't exactly know status of this
16:08:59 <NikolayM> but anyway, I didn't see a thread with that topic in ML
16:09:15 <xylan_kong> neither do I
16:10:33 <NikolayM> so, let's schedule it for the next meeting
16:10:42 <NikolayM> #action rakhmerov: start ML discussion about the best approach for https://blueprints.launchpad.net/mistral/+spec/mistral-execution-origin
16:11:16 <NikolayM> next topic - current status
16:11:22 <NikolayM> #topic Current status
16:11:47 <NikolayM> guys, let's tell current status
16:12:02 <^Gal^> I'm on mistral dashboard execution screen - execution update, doing good
16:12:29 <xylan_kong> I'm working on the pagination support in Mistral, have it supported on workflow and action, do some review and bug fix
16:12:29 <^Gal^> ill start the pagination thing tomorrow
16:12:37 <gpaz> As I wrote in the pass days I was working on internal Alcatel stuff . I need to complete the fix for bug (add test)
16:12:58 <xylan_kong> ^Gal^: if you need help, or you have question about execution pagination, please contact me
16:13:00 <m4dcoder> I've started working on the postgresql tests again. No resolution yet.
16:13:07 <rakhmerov> hi all
16:13:09 <NikolayM> my status: working on the documentation, install guide and config guide are already on the review
16:13:10 <^Gal^> xylan_kong: thanks appreciate
16:13:14 <NikolayM> hi rakhmerov!
16:13:14 <rakhmerov> sorry for being late
16:13:19 <xylan_kong> rakhmerov: hi
16:13:41 <rakhmerov> NikolayM: please continue
16:14:05 <rakhmerov> btw, I didn't start ML discussion yet about execution origin
16:14:20 <rakhmerov> but I have an email draft about that )
16:14:41 <rakhmerov> my status: made several patches to fix cycles in direct workflow
16:14:56 <rakhmerov> and a couple of patches to openstack requirements and infra
16:15:24 <rakhmerov> planning to continue with refactoring and testing workflow cycles (there are still some issues in it)
16:16:09 <NikolayM> btw, I fixed all patches related to with-items concurrency and they were merged last week
16:16:23 <xylan_kong> NikolayM: good job
16:16:45 <NikolayM> xylan_kong: thx :)
16:17:32 <NikolayM> next topic
16:17:41 <m4dcoder> NikolayM, I posted a bug on with-items concurrency last Friday. apparently if the concurrency is YAQL, it doesn't work.
16:18:09 <rakhmerov> ooh, interesting
16:18:25 <NikolayM> m4dcoder, yep, I saw that bug
16:18:31 <m4dcoder> good
16:18:46 <NikolayM> and it can really take place here
16:19:03 <NikolayM> ok, I'll fix it this week
16:19:07 <m4dcoder> thx
16:19:11 <NikolayM> #topic Liberty-3 progress
16:20:33 <^Gal^> Ui-wise, we have some schedule problems with task screen
16:21:04 <rakhmerov> task screen?
16:21:15 <^Gal^> yeah Liat's blueprint
16:21:20 <rakhmerov> you mean you don't seem to have time for it?
16:21:49 <rakhmerov> till the end of l-3
16:21:57 <^Gal^> it the screen I talk to you about earlier, Liat's on vacatyion
16:22:04 <rakhmerov> ooh
16:22:08 <rakhmerov> I see
16:22:16 <rakhmerov> thanks for letting us know
16:22:25 <^Gal^> sure np
16:22:29 <rakhmerov> I'll reassign it to someone else then
16:22:54 <^Gal^> sure, she had the task overview page done
16:23:02 <^Gal^> i would commit it tomorrow
16:23:17 <rakhmerov> good
16:23:54 <rakhmerov> so on that topic (L-3 progress) I exactly wanted to ask you all if you see any issues with getting your BPs/bugs done
16:24:12 <rakhmerov> should you have any concerns let us know
16:24:41 <rakhmerov> NikolayM: I see that you assigned all documentation BPs to L-3
16:24:57 <rakhmerov> is it by mistake you're really planning to get them all done?
16:25:17 <rakhmerov> ..or you're..
16:25:33 <NikolayM> I'll try to do them all
16:25:43 <rakhmerov> hm... you feel brave! :)
16:25:45 <rakhmerov> it's good
16:25:49 <rakhmerov> ok
16:26:11 <^Gal^> :D
16:26:22 <rakhmerov> NikolayM: please update their statuses
16:26:31 <rakhmerov> they are now all marked as "Unknown"
16:27:04 <rakhmerov> and assign all you're planning to work on to yourself
16:27:29 <NikolayM> I reassign all on which I don't have much time
16:27:48 <NikolayM> yep, I mark only ones I am starting to work on
16:28:35 <rakhmerov> ok, great
16:28:50 <rakhmerov> I just went over the BPs and it seems like we're mostly fine
16:29:05 <rakhmerov> we have one and a half weeks
16:29:10 <rakhmerov> it's ok
16:29:16 <xylan_kong> rakhmerov: i found some of my bps were 'lost'...
16:29:23 <rakhmerov> we need to try to push most of the patches this week
16:29:28 <^Gal^> btw, post code freeze, we don't currently have any bugs on mistral-dashboard (correct me if I'm wrong) so what should we work on after?
16:29:35 <rakhmerov> xylan_kong: which ones?
16:29:37 <xylan_kong> rakhmerov: the service api on server side and client side
16:30:00 <rakhmerov> as far as server side I guess they were assigned to l-2
16:30:33 <xylan_kong> i just can't find them among all the bps
16:30:40 <rakhmerov> ^Gal^: yeah, we can keep fixing bugs till the very end of Liberty
16:30:49 <rakhmerov> xylan_kong: it's weird
16:30:59 <xylan_kong> rakhmerov: yeah
16:30:59 <rakhmerov> let me check that later offline
16:31:05 <xylan_kong> rakhmerov: ok
16:31:43 <rakhmerov> #action akhmerov, xylan_kong: figure out the destiny of Service API blueprints (server and client side)
16:32:16 <xylan_kong> thanks
16:33:11 <rakhmerov> I actually don't have anything else to discuss
16:33:16 <rakhmerov> :)
16:33:23 <rakhmerov> does anyone have?
16:33:42 <xylan_kong> https://bugs.launchpad.net/mistral/+bug/1488157
16:33:42 <openstack> Launchpad bug 1488157 in Mistral "Executions and action_executions remain unremoved after functional testing" [Undecided,In progress] - Assigned to Lingxian Kong (kong)
16:33:47 <xylan_kong> i found this bug
16:33:52 <xylan_kong> and i'm working on that
16:34:05 <xylan_kong> for execution, i have already uploaded a patch
16:34:16 <xylan_kong> but for action execution i think i need a bp to have it done
16:34:32 <xylan_kong> bp: support action execution deletion
16:34:48 <xylan_kong> want to have it discussed
16:34:55 <rakhmerov> mm
16:34:55 <xylan_kong> to see your opinion
16:34:59 <rakhmerov> yes
16:35:17 <rakhmerov> please do discuss it
16:35:32 <xylan_kong> NikolayM: you here?
16:35:39 <rakhmerov> isn't action execution deletion supported yet?
16:35:44 <xylan_kong> rakhmerov: no
16:35:49 <rakhmerov> really?
16:35:52 <NikolayM> xylan_kong, yep
16:36:02 <rakhmerov> but we have an endpoint for action executions, right?
16:36:09 <xylan_kong> rakhmerov: yes
16:36:18 <xylan_kong> but without deleting action
16:36:19 <rakhmerov> with no "delete" method?
16:36:28 <rakhmerov> hm...
16:36:46 <xylan_kong> NikolayM: what do you think
16:36:49 <NikolayM> I think they should be deleted within task execution which they belongs to
16:37:07 <xylan_kong> NikolayM: but for ad-hoc actions, you can't do that
16:37:07 <NikolayM> and the same for the task executions and workflow executions
16:37:21 <xylan_kong> ad-hoc action_execution
16:37:22 <NikolayM> ooh, yes, correct
16:37:29 <rakhmerov> aha
16:37:30 <rakhmerov> yep
16:37:37 <NikolayM> need to delete them separately
16:37:50 <xylan_kong> without that feature, we can't purge them all during functional test
16:37:53 <rakhmerov> I'm ok with adding "delete" method
16:38:21 <xylan_kong> ok, i'll continue to do this
16:38:24 <rakhmerov> ok
16:38:31 <NikolayM> ok
16:39:05 <rakhmerov> it's weird that we don't have this method
16:39:11 <rakhmerov> but have it for workflow executions
16:39:18 <rakhmerov> ok, it's not a serious issue
16:39:22 <rakhmerov> just need to fix it
16:39:30 <rakhmerov> alright
16:39:36 <rakhmerov> thanks for bringing this up
16:39:40 <xylan_kong> ad-hoc action execution was added just a month ago
16:40:32 <rakhmerov> xylan_kong: just small clarification, we usually use 'ad-hoc action' term for a little bit different thing
16:40:49 <xylan_kong> rakhmerov: for testing?
16:40:52 <rakhmerov> although it may be used for separate action executions as well I think :)
16:40:52 <xylan_kong> debuging?
16:41:04 <xylan_kong> rakhmerov: oh
16:41:06 <xylan_kong> rakhmerov: i got you
16:41:20 <rakhmerov> no, we call "ad-hoc actions" those actions that we created purely in Mistral DSL
16:41:23 <rakhmerov> in YAML
16:41:33 <xylan_kong> so, i change it to 'ad-hoc action exeuction' :0(
16:41:36 <rakhmerov> it refers to action definition rather
16:41:42 <rakhmerov> yes :)
16:41:50 <rakhmerov> that's ok, I'm just clarifying
16:41:58 <xylan_kong> rakhmerov: ok
16:42:00 <rakhmerov> it can really be used like you said
16:42:08 <rakhmerov> ad-hoc action execution
16:42:19 <rakhmerov> it really means that
16:42:21 <rakhmerov> :)
16:42:31 <NikolayM> I'd like to name it 'single action execution'
16:42:39 <rakhmerov> yeah
16:42:45 <rakhmerov> just not to confuse
16:43:37 <rakhmerov> anything else guys?
16:43:46 <NikolayM> nothing from my side
16:44:02 <^Gal^> same as for me
16:44:08 <xylan_kong> nothing from me
16:44:13 <NikolayM> let's end the meeting
16:44:17 <rakhmerov> m4dcoder?
16:45:05 <m4dcoder> nothing from me.
16:45:14 <rakhmerov> ok, let's end the meeting
16:45:17 <NikolayM> thanks guys for attending!
16:45:20 <rakhmerov> NikolayM: cay you do this pls?
16:45:21 <m4dcoder> thx
16:45:22 <rakhmerov> thanks!
16:45:23 <xylan_kong> thanks
16:45:24 <rakhmerov> bye
16:45:25 <NikolayM> #endmeeting