16:00:54 <NikolayM> #startmeeting Mistral
16:00:55 <openstack> Meeting started Mon Sep  7 16:00:54 2015 UTC and is due to finish in 60 minutes.  The chair is NikolayM. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:58 <openstack> The meeting name has been set to 'mistral'
16:01:03 <NikolayM> hi everyone!
16:01:07 <gpaz> Hello
16:01:16 <NikolayM> hi, gpaz
16:01:18 <^Gal^> hellllo
16:01:21 <LimorStotland> hi all
16:01:26 <akuznetsova> hi there !)
16:02:35 <NikolayM> the meeting seems to be a bit shorter, we have no action items
16:03:01 <xylan_kong> hi, all
16:03:02 <NikolayM> let's start
16:03:17 <NikolayM> #topic Review Action items
16:03:23 <NikolayM> no action items
16:03:28 <^Gal^> :D
16:03:33 <xylan_kong> hehe
16:03:33 <NikolayM> #topic Current status
16:03:36 <LimorStotland> Nice :-)
16:03:38 <NikolayM> yes :)
16:04:10 <NikolayM> guys, let's tell our status for last week
16:04:24 <^Gal^> I'm on execution update, haven't got much time to work on that last week
16:04:40 <^Gal^> no technocal barriers though
16:04:45 <^Gal^> technical*
16:05:26 <xylan_kong> my status: complete action-execution-deletion blueprint before l-3, have a 3-days holiday, :-)
16:05:35 <NikolayM> my status: still working on the docs, already done with terminology, quickstart, architecture and CLI, next - 'how to write workflow'
16:05:47 <gpaz> Fix for expiration policy was merged. I wanted to work on the Docs for that but unfortantly I was busy with internal stuff here
16:06:21 <LimorStotland> working on internal stuff
16:06:27 <akuznetsova> my status: fix devstack gates twice :) made commit to openstack-infra to add gate that will build our docs
16:06:34 <xylan_kong> NikolayM: how about the progress of doc work?
16:06:44 <xylan_kong> akuznetsova: thanks very much for your work!
16:07:00 <^Gal^> NikolayM: I want to write further documentation on how to to debug mistral-dashboard, just appeared to me that I missed some keynotes
16:07:04 <akuznetsova> xylan_kong, you are welcome)
16:07:24 <NikolayM> xylan_kong: It is almost completed, only a few articles remain
16:07:38 <xylan_kong> NikolayM: greate
16:08:08 <NikolayM> ^Gal^, sure, you are free to write it
16:08:23 <^Gal^> :P
16:08:44 <NikolayM> one thing: please, write it to main mistral repo, in doc/source
16:09:09 <NikolayM> there is existent docs on dashboard, could you edit it?
16:09:19 <^Gal^> NikolayM: ok, sure. what about mistral dashboard github readme?
16:09:35 <^Gal^> NikolayM: sure
16:09:45 <rakhmerov> hi guys
16:09:51 <NikolayM> it is partly moved to that article
16:09:55 <NikolayM> hi rakhmerov
16:09:59 <akuznetsova> NikolayM, ^Gal^  I think that you are working on different 'parts' of docs, so your commit should not conflict
16:10:15 <NikolayM> akuznetsova, yep
16:10:16 <rakhmerov> my status: I was working on the patch: https://review.openstack.org/220439
16:10:26 <^Gal^> Ok, so should I update both repos?
16:10:34 <rakhmerov> it's about fixing a bug with cyclic workflows and refactoring specifications
16:10:37 <^Gal^> both mistral and mistral dashboard readme?
16:10:55 <NikolayM> ^Gal^, there is another article (currently is not started yet) - troubleshooting
16:11:11 <akuznetsova> ^Gal^, NikolayM also I think that it will be cool to add user guide with screenshots )
16:11:21 <^Gal^> akuznetsova: +1
16:11:37 <rakhmerov> +2 :)
16:11:43 <rakhmerov> (as a core :))) )
16:11:47 <^Gal^> lol
16:11:49 <^Gal^> :P
16:11:52 <NikolayM> ^Gal^, I think no, it is enough to have docs at the main doc source (docs.openstack.org)
16:11:55 <NikolayM> haha :)
16:12:17 <^Gal^> NikolayM: ok :)
16:12:21 <LimorStotland> I agree with NikolayM
16:12:37 <^Gal^> LimorStotland: ok, thanks!
16:12:40 <LimorStotland> and the rest :-)
16:12:55 <^Gal^> I agree with Limor
16:12:59 <^Gal^> :P
16:13:08 <NikolayM> akuznetsova has submitted the patch to the infra recently and docs soon starts to build on docs.openstack.org
16:13:21 <rakhmerov> yep
16:13:33 <xylan_kong> good job
16:13:33 <NikolayM> for every merged patch in mistral
16:13:39 <akuznetsova> hope so)
16:13:39 <rakhmerov> here it is: https://review.openstack.org/220226
16:13:45 <NikolayM> thanks, akuznetsova!
16:13:54 <rakhmerov> :)
16:15:02 <rakhmerov> so folks, I'll be annoying again and talking about L-3
16:15:19 <rakhmerov> #topic Wrapping up L-3
16:15:37 <rakhmerov> as you know, we're a couple of days behind with L-3 release
16:15:49 <rakhmerov> technically, it's a couple of hours to make a release
16:15:50 <rakhmerov> but..
16:15:58 <NikolayM> #topic Wrapping up L-3
16:16:16 <rakhmerov> ooh, thanks! I forgot you're a host
16:16:17 <rakhmerov> :)
16:16:29 <NikolayM> do you want some patches to get merged?
16:16:32 <rakhmerov> I just want that we have a chance to finish planned BPs
16:16:40 <rakhmerov> yes
16:17:04 <LimorStotland> do we still have open bp (not in the ui)?
16:17:13 <rakhmerov> ^Gal^: I know you're busy with internal stuff but I have to ask you about https://blueprints.launchpad.net/mistral/+spec/mistral-dashboard-executions-screen
16:17:23 <rakhmerov> is there a chance you'll finish it tomorrow?
16:17:29 <^Gal^> nope
16:17:36 <^Gal^> :(
16:17:41 <rakhmerov> ok, honest answer )
16:17:45 <^Gal^> lol
16:17:46 <rakhmerov> let's move it to RC-1
16:18:14 <^Gal^> rakhmerov: thanks! and sorry
16:18:48 <rakhmerov> that's ok
16:18:55 <rakhmerov> another one is https://blueprints.launchpad.net/mistral/+spec/mistral-action-execution-deletion
16:19:04 <xylan_kong> rakhmerov, NikolayM: https://review.openstack.org/#/c/216509/ need +1 for workflow, but i found there is devstack failure which has nothing to do with my patch
16:19:17 <rakhmerov> xylan_kong: yes, I just wanted to say this
16:19:35 <NikolayM> yes, something with changing execution states
16:19:36 <rakhmerov> are you sure it has nothing to do with it?
16:19:44 <rakhmerov> give me a sec
16:20:03 <xylan_kong> NikolayM: you met with this failure?
16:20:42 <rakhmerov> yeah, it's NegativeCLITests.test_ex_invalid_status_changing
16:20:47 <rakhmerov> hm.. weird
16:20:56 <akuznetsova> ooo
16:21:13 <rakhmerov> akuznetsova: do you know what's going on?
16:21:13 <NikolayM> xylan_kong, I just see an error in gate
16:21:35 <akuznetsova> I have a theory
16:21:35 <xylan_kong> seems like the calling goes well, no exception is raised
16:22:06 <akuznetsova> seems like it can be related to https://review.openstack.org/#/c/219870/2
16:22:47 <xylan_kong> if it's not so urgent issue, i can figure it out tomorrow
16:22:57 <akuznetsova> there wasn't such problem in previously merged patch, but here this test failed
16:23:04 <rakhmerov> yes, I think akuznetsova is right
16:23:13 <rakhmerov> I think I even know what the problem is
16:23:29 <rakhmerov> xylan_kong: yes, please look at it tomorrow
16:23:34 <xylan_kong> rakhmerov: ok
16:23:40 <xylan_kong> rakhmerov: i'll cover it
16:24:04 <rakhmerov> #action xylan_kong: look at the failing test NegativeCLITests.test_ex_invalid_status_changing, it may be related with https://review.openstack.org/#/c/219870/2
16:24:13 <rakhmerov> xylan_kong: thnx, appreciate
16:24:17 <akuznetsova> yes, thanks
16:24:24 <rakhmerov> then let's merge Lingxian's patch now
16:24:24 <xylan_kong> np
16:24:50 <xylan_kong> rakhmerov: and this one, https://blueprints.launchpad.net/mistral/+spec/mistral-pagination-support, needs your approval and consider it as completed
16:25:02 <xylan_kong> for now
16:25:20 <rakhmerov> already done
16:25:25 <rakhmerov> I did it today
16:25:49 <xylan_kong> rakhmerov: really? I see no aprover
16:26:05 <rakhmerov> I usually mark BPs as "Beta available" before it's released
16:26:12 <rakhmerov> there is an approver )
16:26:25 <rakhmerov> so it's been taken care of
16:26:46 <xylan_kong> ok
16:26:55 <rakhmerov> let's see what else we have..
16:27:47 <rakhmerov> xylan_kong: I also wanted to find out the status of https://review.openstack.org/216729
16:27:53 <rakhmerov> but zhenguo is not here
16:28:00 <rakhmerov> do you happen to know his plans on it?
16:28:29 <xylan_kong> rakhmerov: yeah, i believe he want it to be merged in l-3
16:28:46 <rakhmerov> right, but now jenkins votes -1
16:28:55 <rakhmerov> I guess it needs to be rebased or something..
16:29:04 <rakhmerov> ok, we need to ask him tomorrow
16:29:19 <xylan_kong> rakhmerov: I'll contact him tomorrow
16:29:24 <rakhmerov> #action rakhmerov, xylan_kong: remind zhenguo about https://review.openstack.org/216729
16:29:26 <rakhmerov> yes
16:29:34 <rakhmerov> so, just to let you know
16:29:34 <xylan_kong> let him finish it ASAP
16:29:44 <rakhmerov> yes
16:29:50 <xylan_kong> if there is not tech debate on that
16:29:57 <rakhmerov> I'm going to make a release tomorrow evening anyway
16:30:15 <rakhmerov> if something is not in then we'll have to move it to RC1
16:30:34 <xylan_kong> ok, good, do what you think is right :-)
16:30:50 <rakhmerov> akuznetsova: I know you had comments on this patch so please try to participate tomorrow
16:31:43 <xylan_kong> akuznetsova: yeah, need your insight and expertise
16:31:57 <akuznetsova> rakhmerov, xylan_kong ok
16:32:29 <rakhmerov> xylan_kong: and I need your review on https://review.openstack.org/220439 :))
16:32:38 <rakhmerov> you should like this patch )
16:32:59 <xylan_kong> np, leave another action item for me
16:33:01 <xylan_kong> :-)
16:33:11 <akuznetsova> if zhenguo won't be available, I can rebase/send new patch set for this patch
16:33:27 <xylan_kong> i'll do them all tomorrow
16:33:29 <rakhmerov> #action xylan_kong: review https://review.openstack.org/220439 and Nikolay's documentation patches
16:33:49 <rakhmerov> akuznetsova: yes, we can do it
16:33:57 <rakhmerov> ok
16:34:21 <rakhmerov> NikolayM: I guess we can move https://blueprints.launchpad.net/mistral/+spec/mistral-documentation to RC1?
16:34:26 <rakhmerov> this is a grouping BP
16:34:39 <NikolayM> yep, I also think so
16:34:46 <rakhmerov> not all docs will be ready by the EOD tomorro, right?
16:34:48 <rakhmerov> ok
16:34:50 <NikolayM> some of bps are not completed
16:35:32 <xylan_kong> i can't wait to see our doc listed on website :-)
16:35:37 <rakhmerov> yep
16:35:40 <rakhmerov> me too )
16:35:46 <xylan_kong> it's really useful for new comers
16:36:02 <rakhmerov> guys, we need to make our docs shine during Sept
16:36:06 <rakhmerov> yes
16:36:20 <rakhmerov> we've been hearing much complaints about our docs
16:36:35 <rakhmerov> now it's high time we made them good and useful
16:36:36 <^Gal^> mistral dashboard tasks screen bp - assigend to Liat, not finished either
16:36:44 <xylan_kong> rakhmerov: yes, i did this when i came to mistral the first day
16:37:09 <^Gal^> same for cron trigger on mistral-dashboard
16:37:18 <rakhmerov> ^Gal^: I know, I promised to help her with it but didn't find time today. Will do tomorrow, either me or zhenguo
16:37:38 <^Gal^> rakhmerov: oh ok, didn't know she contacted you
16:37:40 <rakhmerov> #action rakhmerov, zhenguo: help Liat with her patch on tasks screen
16:37:59 <rakhmerov> ^Gal^: cron trigger screen has been moved to RC1
16:38:08 <rakhmerov> which is ok
16:38:32 <rakhmerov> like I said there's no time tension on UI work, we have more flexibility on it
16:38:48 <rakhmerov> but I just want to have some discipline anyway
16:39:02 <^Gal^> aggree
16:40:00 <rakhmerov> guys, one more thing I'd love to be able to push into L-3 is a new YAQL function for extracting task result
16:40:20 <rakhmerov> [openstack-dev] [mistral][yaql] Addressing task result using YAQL function
16:40:40 <rakhmerov> you can look at this thread and express your opinion
16:40:43 <xylan_kong> yes, i saw the email, didn't have time to reply. i like the idea
16:40:57 <xylan_kong> task(name)
16:40:59 <rakhmerov> nobody is against it so far
16:41:00 <rakhmerov> yes
16:41:12 <rakhmerov> and there's a strong technical reason to do so
16:41:20 <rakhmerov> you can read my explanations if you want
16:41:52 <rakhmerov> so, me or Nikolay will try to get it knocked down tomorro
16:41:59 <rakhmerov> xylan_kong: please be ready to review
16:42:08 <xylan_kong> rakhmerov: np
16:42:19 <xylan_kong> always in the position for help
16:42:31 <rakhmerov> #action rakhmerov or NikolayM: implement task() yaql function
16:42:35 <rakhmerov> ok
16:43:06 <rakhmerov> so this is all I wanted to discuss on L-3
16:43:14 <rakhmerov> do you have anything else?
16:43:49 <xylan_kong> rakhmerov: don't forget the client release
16:43:57 <rakhmerov> yes
16:44:08 <rakhmerov> ooh, btw, is gpaz here?
16:44:24 <gpaz> yes
16:44:46 <rakhmerov> can you please carefully look at the patch https://review.openstack.org/#/c/218544/ ?
16:44:50 <gpaz> hi, I saw your changes for the test
16:45:02 <rakhmerov> it's already merged and it actually looks slightly weird
16:45:14 <rakhmerov> it's because looks like expiration policy doesn't run as expected
16:45:17 <rakhmerov> for some reason
16:45:36 <gpaz> I was a critical issue in some production that still a lot of my time this week :(
16:45:49 <rakhmerov> so Winson says it may not run every minute as configured for some reason
16:45:50 <gpaz> I m not sure I understand why it is failing
16:45:59 <rakhmerov> yes
16:46:17 <rakhmerov> no urgency but pls try to investigate once you have time
16:46:30 <gpaz> I hope tommorow I ll have time
16:46:45 <rakhmerov> #action gpaz: try to investigate what may be wrong with expiration policy (look at https://review.openstack.org/#/c/218544/)
16:46:49 <gpaz> last days were realy busy here for me with customers
16:46:51 <rakhmerov> ok
16:47:07 <rakhmerov> it's understandable, no need to explain
16:47:08 <rakhmerov> thanks
16:47:30 <gpaz> where you saw it is failing by the way ?
16:47:47 <rakhmerov> it even happens on my local dev machine
16:47:53 <rakhmerov> once in a while
16:48:03 <gpaz> Ok
16:48:09 <gpaz> I will take alook
16:48:10 <^Gal^> #action ^Gal^: make mistral-dashboard debug shine
16:48:11 <rakhmerov> approximately every third or forth time
16:48:21 <rakhmerov> :)
16:48:25 <rakhmerov> haha ))
16:48:27 <gpaz> weired, never failed for me ..
16:48:48 <gpaz> Ok, taking that
16:49:02 <rakhmerov> yeah, it looks like a concurrency problem
16:49:19 <rakhmerov> it behaves differently on different machines
16:49:33 <rakhmerov> so now I really don't have anything else to discuss
16:49:46 <rakhmerov> let's go to open discussion
16:49:52 <rakhmerov> or end the meeting
16:49:56 <xylan_kong> rakhmerov: do you already have a plan for Tokyo Summit? I'm very interested in it
16:50:19 <rakhmerov> xylan_kong: no detailed plan
16:50:44 <rakhmerov> of course, I know major topics that we need to discuss
16:51:04 <xylan_kong> rakhmerov: all right, so we can discuss face to face if there's a chance
16:51:17 <rakhmerov> btw, please share your suggestion for the fishbowl session (with larger audience and projector)
16:51:23 <rakhmerov> xylan_kong: yes
16:51:52 <rakhmerov> at fishbowl session, for example, you could tell about your experience using Mistral or something like that
16:52:05 <xylan_kong> rakhmerov: no problem
16:52:18 <rakhmerov> sort of a promo actually
16:52:23 <rakhmerov> ok
16:52:39 <xylan_kong> rakhmerov: i can share story with HWS using workfow (but it's not mistral)
16:53:09 <rakhmerov> ok, let's talk about it in a few days
16:53:15 <xylan_kong> sure
16:53:48 <xylan_kong> so, nothing need to discuss for me
16:54:12 <rakhmerov> ok
16:54:23 <rakhmerov> NikolayM: let's end the meeting?
16:54:34 <rakhmerov> you are in charge today )
16:55:00 <NikolayM> sure
16:55:06 <NikolayM> #endmeeting