16:00:42 <rakhmerov> #startmeeting Mistral
16:00:43 <openstack> Meeting started Mon Sep 14 16:00:42 2015 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:46 <openstack> The meeting name has been set to 'mistral'
16:00:52 <NikolayM> hi everyone!
16:00:56 <xylan_kong> hi
16:01:11 <akuznetsova> hi there
16:01:31 <rakhmerov> hi
16:01:52 <xylan_kong> other guys?
16:02:18 <rakhmerov> not today most likely, maybe Winson will join but not folks from ALU, they have a holiday
16:02:22 <rakhmerov> so let's start
16:03:13 <rakhmerov> the agenda is at: https://wiki.openstack.org/wiki/Meetings/MistralAgenda
16:03:20 <rakhmerov> #topic Review Action Items
16:03:57 <rakhmerov> 1. xylan_kong: look at the failing test NegativeCLITests.test_ex_invalid_status_changing, it may be related with https://review.openstack.org/#/c/219870/2
16:04:02 <rakhmerov> I know it's done )
16:04:07 <xylan_kong> yeah
16:04:20 <rakhmerov> 2. rakhmerov, xylan_kong: remind zhenguo about https://review.openstack.org/216729
16:04:40 <xylan_kong> done
16:04:47 <rakhmerov> done but there's still some work to merge a patch into infra
16:04:56 <rakhmerov> it's on review now
16:05:07 <rakhmerov> 3. xylan_kong: review https://review.openstack.org/220439 and Nikolay's documentation patches
16:05:10 <rakhmerov> this is done
16:05:12 <rakhmerov> thank you!
16:05:22 <rakhmerov> 4. rakhmerov, zhenguo: help Liat with her patch on tasks screen
16:05:38 <rakhmerov> this is, honestly, something that I still didn't find time for
16:05:57 <rakhmerov> zhenguo may have found though but I don't have info about it
16:06:09 <rakhmerov> xylan_kong: do you know?
16:06:30 <xylan_kong> maybe zhenguo is busy with some PoC these days
16:07:03 <xylan_kong> did'nt have enough time for upstream work
16:07:04 <rakhmerov> ok, I'll try to catch Liat and talk to her about her patches
16:07:06 <rakhmerov> ok
16:07:08 <rakhmerov> I see
16:07:26 <rakhmerov> #action rakhmerov: talk to Liat about her patches
16:07:35 <rakhmerov> 5. rakhmerov or NikolayM: implement task() yaql function
16:07:36 <rakhmerov> done
16:08:13 <rakhmerov> although this workstream is not finished, we need to remove deprecated stuff so that we can't use "$.task_name" to access task result
16:08:35 <rakhmerov> #action rakhmerov: finish all that's left after adding task() yaql function
16:08:45 <rakhmerov> 6. gpaz: try to investigate what may be wrong with expiration policy (look at https://review.openstack.org/#/c/218544/)
16:08:53 <rakhmerov> he is still looking at it
16:09:03 <rakhmerov> #action gpaz: try to investigate what may be wrong with expiration policy (look at https://review.openstack.org/#/c/218544/)
16:09:10 <rakhmerov> 7. ^Gal^: make mistral-dashboard debug shine
16:09:48 <rakhmerov> same
16:09:56 <rakhmerov> #action ^Gal^: make mistral-dashboard debug shine
16:10:08 <rakhmerov> this is the patch: https://review.openstack.org/221685
16:10:19 <rakhmerov> ok, let's move to the next topic
16:10:28 <rakhmerov> #topic Current status
16:10:38 <NikolayM> my status: worked on documentation, fixed dsl docs, checked bug related to env evaluation  in with-items, start to work on some bugs
16:11:16 <rakhmerov> my status: released L-3 last week, this time the delay was about 3 days which I consider ok but we definitely can do better
16:11:53 <xylan_kong> :-)
16:12:19 <rakhmerov> also implemented a couple of things: refactored specifications (polymorphic specs, separate validation etc.), fixed a bug with wf cycles, implemented task() function
16:12:39 <rakhmerov> xylan_kong: what does your smile mean? :)
16:12:53 <xylan_kong> My status: I have been busy with censor summit topics internally for almost the whole last week, and did some review work in spare time
16:13:13 <xylan_kong> just for 'we can do it better'
16:13:22 <rakhmerov> yes, we can :)
16:13:26 <xylan_kong> sure
16:13:30 <rakhmerov> we're learning how to
16:13:33 <rakhmerov> :) alright
16:13:40 <akuznetsova> I am working on python34 gate, try to make it "green"
16:13:47 <rakhmerov> cool
16:14:03 <rakhmerov> I'd suggest we make it in separate patches so that they are not so big
16:14:13 <rakhmerov> this gate is non-voting anyway
16:14:27 <rakhmerov> but it would be really cool if we finally did that
16:14:41 <rakhmerov> akuznetsova: than you very much for volunteering )
16:14:48 <rakhmerov> .. thank ...
16:15:50 <rakhmerov> guys, 2 questions: 1) any roadblocks that you see? 2) xylan_kong: what your availability is going to be for the next couple of weeks?
16:16:03 <akuznetsova> rakhmerov, no problem)
16:16:14 <NikolayM> +1
16:16:49 <xylan_kong> rakhmerov: I'll be on business trip next week
16:17:19 <xylan_kong> but I think I have at least 2 hour per day for upstream work
16:18:11 <rakhmerov> ok, good
16:18:20 <rakhmerov> next topic
16:18:31 <rakhmerov> #topic Scoping RC releases
16:19:04 <rakhmerov> so since we released L-3 we now started working on RC1 release
16:19:54 <rakhmerov> as far as RC releases, we're not adding any new functionality, especially API changes, and mostly fixing bugs
16:20:08 <rakhmerov> what I think is ok is to continue with docs and UI
16:20:30 <rakhmerov> because it doesn't break any compatibility by any way
16:20:33 <rakhmerov> so
16:21:09 <xylan_kong> agreed, we can bring new features to discuss at the summit
16:21:20 <rakhmerov> I've tried to arrange all the bugs that we have and assign the most important ones (IMO) to RC1 and some to RC2
16:21:25 <rakhmerov> yes
16:22:20 <rakhmerov> again, this bug<->release assignment is mostly my vision of what we need to be focused on
16:23:02 <rakhmerov> and hence I'd like to ask you to look through the list of bugs and let me know what you agree/disagree with
16:23:30 <rakhmerov> in other words, feel free to make your sugguestions
16:23:38 <akuznetsova> btw, here is a link https://launchpad.net/mistral/+milestone/liberty-rc1
16:24:00 <rakhmerov> thanks, yes
16:24:54 <rakhmerov> the main criteria that I was guided is "does it prevent using Mistral in production?"
16:25:26 <rakhmerov> for example, this one does: https://bugs.launchpad.net/mistral/+bug/1337268
16:25:27 <openstack> Launchpad bug 1337268 in Mistral liberty "Security issue: passwords are not hidden in logs" [Critical,New] - Assigned to Lingxian Kong (kong)
16:25:50 <xylan_kong> yes, this is the one I'm struggling with
16:25:51 <rakhmerov> I know it's a hard one but we have to provide a solution
16:25:56 <rakhmerov> yep
16:26:18 <rakhmerov> xylan_kong: I left a comment there, please look at it and let me know your thoughts
16:26:31 <xylan_kong> rakhmerov: thanks
16:26:32 <xylan_kong> np
16:26:32 <akuznetsova> maybe we should change the title of this bug?
16:26:34 <rakhmerov> even if you agree with the solution it will take pretty long to implement
16:26:43 <rakhmerov> at least a week
16:26:50 <xylan_kong> I'll try
16:27:16 <rakhmerov> akuznetsova: yes, do you have a suggestion?
16:27:38 <xylan_kong> and I need NikolayM's help as well, NikolayM please also take a look
16:28:19 <akuznetsova> passwords -> user-specific secure data
16:28:26 <akuznetsova> ?
16:28:57 <NikolayM> yep, How can I help you?
16:29:03 <rakhmerov> ok
16:29:36 <xylan_kong> NikolayM: need you input for this problem :)
16:30:04 <rakhmerov> check this out: https://bugs.launchpad.net/mistral/+bug/1337268
16:30:06 <openstack> Launchpad bug 1337268 in Mistral liberty "Security issue: user secure info is not protected properly (logs, API, DB)" [Critical,New] - Assigned to Lingxian Kong (kong)
16:30:12 <rakhmerov> is this title ok?
16:30:36 <xylan_kong> about how can we solve it elegantly
16:30:36 <akuznetsova> yes, sounds more 'english' )
16:30:38 <xylan_kong> rakhmerov: perfect
16:31:06 <rakhmerov> akuznetsova: will take it as a compliment :)
16:31:13 <rakhmerov> ok
16:31:42 <xylan_kong> rakhmerov: about pagination support at client, we can do it in RC-1?
16:31:45 <xylan_kong> or leave it to M?
16:31:58 <rakhmerov> let's try to push it
16:32:14 <rakhmerov> honestly, I thought it was done when I was going thru the list of bugs
16:32:28 <xylan_kong> since it's new feature for mistralclient, so it break our rule
16:32:31 <rakhmerov> xylan_kong: would you like to take it?
16:32:32 <xylan_kong> no, I just missed it
16:32:47 <rakhmerov> it's a bug rather
16:32:49 <xylan_kong> rakhmerov: sure, let me finish my work
16:32:55 <rakhmerov> it's not new functionality
16:33:18 <xylan_kong> rakhmerov: ok, I will file a new bug for that
16:33:22 <rakhmerov> and it may actually be done in a backwards compatible way
16:33:30 <rakhmerov> yes, please
16:34:04 <rakhmerov> one thing I'd ask you is to always assign the current milestone for a bug if it's completed
16:34:32 <xylan_kong> can I?
16:34:44 <rakhmerov> it's mostly my fault, I know, but I found lots of fixed bugs without milestones
16:35:14 <rakhmerov> xylan_kong: I mean even if you can't (please check if you can) you can ask me
16:35:21 <akuznetsova> rakhmerov,  I think that xylan_kong doesn't have enough permissions
16:35:24 <xylan_kong> rakhmerov: ok, sure
16:35:24 <rakhmerov> xylan_kong: btw, you should be able to
16:35:33 <rakhmerov> hmm...
16:35:38 <xylan_kong> rakhmerov: yes, I wish I have
16:36:24 <xylan_kong> I don't belong to mistral driver team
16:37:08 <xylan_kong> https://launchpad.net/~mistral-drivers
16:37:17 <xylan_kong> right there?
16:39:31 <rakhmerov> ok, let me figure out that
16:39:47 <rakhmerov> I think it's actually because of the different group
16:39:51 <rakhmerov> Mistral Bug Team
16:40:07 <akuznetsova> yes, this one https://launchpad.net/~mistral-bug-team
16:41:53 <rakhmerov> yes, I'm generally not against of giving you a permission but I think it doesn't work right now in our project
16:42:06 <xylan_kong> rakhmerov: it's ok
16:42:10 <rakhmerov> let me figure out something
16:44:10 <rakhmerov> #action akhmerov: figure out if it's ok to include xylan_kong into Mistral Bug Team
16:44:24 <rakhmerov> xylan_kong: I'll do it tomorrow. I think it's ok to do it
16:44:37 <rakhmerov> just need to read a couple of wiki pages :)
16:44:55 <rakhmerov> alright
16:44:57 <xylan_kong> rakhmerov: ok, it's not so urgent
16:45:53 <rakhmerov> guys, any suggestions now on bugs for RC releases?
16:46:12 <rakhmerov> and you can look at them offline and make your suggestions then
16:47:28 <akuznetsova> do not forget about bugs here https://bugs.launchpad.net/python-mistralclient
16:49:05 <rakhmerov> yes, however, we don't have any RC releases for client and we can just release minor versions if needed
16:49:20 <rakhmerov> assuming that we don't break compatibility, of course
16:49:29 <rakhmerov> but yes, let's not forget them
16:49:36 <rakhmerov> ok
16:49:44 <rakhmerov> #topic Open Discussion
16:50:59 <rakhmerov> usual question: anything else?
16:51:12 <akuznetsova> nothing from my side
16:51:15 <rakhmerov> ok
16:51:16 <xylan_kong> no
16:51:19 <NikolayM> no
16:51:23 <rakhmerov> please don't forget to review patches
16:51:39 <NikolayM> sure :)
16:51:40 <rakhmerov> remember: core member is primarily core reviewer
16:51:43 <rakhmerov> not committer
16:51:59 <xylan_kong> I always call my self core reviewer :-)
16:52:08 <xylan_kong> and keep reviewing every day
16:52:16 <rakhmerov> ok, cool
16:52:36 <rakhmerov> I actually wish we had more good reviewers (don't want to offend anyone)
16:52:59 <rakhmerov> ok, let's end the meeting
16:53:02 <rakhmerov> #endmeeting