16:00:27 <rakhmerov> #startmeeting Mistral
16:00:27 <openstack> Meeting started Mon Oct 12 16:00:27 2015 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:30 <openstack> The meeting name has been set to 'mistral'
16:01:08 <rakhmerov> hello
16:01:09 <^Gal^> hi
16:01:15 <_gryf> hi
16:01:21 <akuznetsova> hi
16:01:23 <LimorStotland> Hi
16:01:25 <rakhmerov> ^Gal^: welcome back :)
16:01:32 <rakhmerov> to you all )
16:01:33 <^Gal^> Hi :) thanks!
16:01:52 <rakhmerov> let's start
16:02:07 <xylan_kong> hi, guys
16:02:09 <rakhmerov> by the time we get to interesting things I hope all people will join
16:02:11 <rakhmerov> hi!
16:02:24 <rakhmerov> #topic Review Action Items
16:02:41 <rakhmerov> 1. rakhmerov, NikolayM: review https://review.openstack.org/#/c/230237/
16:02:43 <rakhmerov> done
16:03:00 <rakhmerov> #topic Current status (progress, issues, roadblocks, further plans)
16:03:15 <rakhmerov> let's report the status quickly, if you have something
16:03:26 <^Gal^> I'm back in work after a vacation at Vietnam which was great.
16:03:26 <^Gal^> Last week I encountered many problems with my Ubuntu VM, so I've reinstalled the entire partition from scratch (5 times .....)
16:03:26 <^Gal^> Sadly I've lost every of execution update code
16:03:49 <rakhmerov> oooh, gosh!!
16:03:51 <rakhmerov> really??
16:04:02 <^Gal^> yeah :(
16:04:10 <rakhmerov> F...k
16:04:25 <^Gal^> yeah it sucks, no sectors nothing
16:04:26 <rakhmerov> ok, let it be the worst problem in your life )
16:04:49 <rakhmerov> ok, let's go on
16:04:56 <xylan_kong> ^Gal^: maybe you can create you own branch in github :-)
16:05:10 <^Gal^> I could even use our git :)
16:05:20 <^Gal^> have me some remote brances
16:05:33 <akuznetsova> I was looking through our updated docs and filed bug for remarks, also I've tested UI and I've prepared list of things which I don't like, I am going to file bugs
16:05:41 <rakhmerov> yes, you can actually just send WIP patches
16:05:46 <rakhmerov> this is a solution as well
16:05:48 <^Gal^> akuznetsova: sounds great
16:06:01 <rakhmerov> ok, be careful moving forward
16:06:34 <xylan_kong> my status:
16:06:34 <xylan_kong> * Fix the error message displayed when authentication failed with auth_enabled=True
16:06:34 <xylan_kong> * thinking about what Mistral could do in M dev cycle(or later), wrote all my thoughts in the etherpad
16:06:36 <rakhmerov> my status: getting Launchpad into order (Liberty series, BP statuses etc.), sent a few simple patches, reviewed a bunch of patches and was 50% involved into internal things
16:07:08 <xylan_kong> I'm about to write the doc for service api in next couple days, but i am not sure whether i can finish it before release day
16:07:09 <rakhmerov> xylan_kong: I saw what you wrote, looks good. Looking forward to discuss all this in person at the summit
16:07:21 <xylan_kong> rakhmerov: ok, i hope so
16:07:30 <akuznetsova> ^Gal^, here is a list http://paste.openstack.org/show/476036/, any objections ?
16:07:59 <rakhmerov> xylan_kong: it would be great if you completed this doc before release
16:08:13 <^Gal^> akuznetsova: I'm taking a look
16:08:37 <rakhmerov> btw, I'm planning to make the release approximately on Wed just so we have a couple of days for QA
16:08:40 <xylan_kong> rakhmerov: i'll try, i hope i won't be interrupted by internal issues :-)
16:08:55 <^Gal^> akuznetsova: looks great!!
16:09:07 <rakhmerov> :)
16:09:09 <^Gal^> in my eyes all of these are bugs
16:09:18 <akuznetsova> ^Gal^, ok, will file bugs for every item))
16:09:31 <xylan_kong> ^Gal^: seems our UI guys will be busy
16:09:40 <^Gal^> lol :D
16:09:42 <rakhmerov> :))
16:09:48 <rakhmerov> hope so
16:09:58 <^Gal^> hehe :)
16:10:00 <rakhmerov> ok
16:10:09 <xylan_kong> akuznetsova: thanks for the testing
16:10:15 <NikolayM> hi everyone
16:10:22 <rakhmerov> any roadblocks, issues in your work you'd like to discuss?
16:10:23 <xylan_kong> hi, NikolayM
16:10:33 <NikolayM> sorry, I'm late
16:10:34 <LimorStotland> hi NikolayM
16:10:36 <rakhmerov> ^Gal^: not asking you :) I got your issue
16:10:48 <^Gal^> rakhmerov: lol
16:10:48 <rakhmerov> NikolayM: what's your status?
16:11:35 <NikolayM> my status: Finished working on ssh connectivity problem (now it is possible using proxy VM)
16:12:00 <NikolayM> Fixed hardcoded mistralclient version
16:12:08 <rakhmerov> ok, btw there's an agenda item to discuss your patch
16:12:13 <xylan_kong> NikolayM: do you have use case to use proxy VM?
16:12:17 <rakhmerov> ok
16:12:20 <xylan_kong> for ssh
16:12:37 <rakhmerov> xylan_kong: yes, let's talk about it tomorrow, I'll explain you
16:12:43 <NikolayM> xylan_kong, yes
16:12:51 <xylan_kong> rakhmerov: ok, all right
16:12:53 <NikolayM> ok
16:13:33 <rakhmerov> in two words: it's one of the ways to solve the problem with accessing guest network from management network
16:13:44 <rakhmerov> we just have a proxy VM with a floating IP
16:13:57 <LimorStotland> ooh it's what we talk about in vancouver?
16:14:10 <rakhmerov> I'm not saying it's the best way (there others that we're planning to explore) but we need it for our internal stuff
16:14:12 <xylan_kong> hmm, sounds like something Zaqar does
16:14:15 <rakhmerov> LimorStotland: yes
16:14:22 <LimorStotland> I know it sound familiar :-)
16:14:40 <rakhmerov> xylan_kong: exactly, Zaqar is another possible way
16:15:32 <rakhmerov> but we need it fast whereas we don't have a nice integration with Zaqar now and I'm not really aware of Zaqar status at this point
16:15:43 <rakhmerov> but we will implement Zaqar way as well
16:15:55 <rakhmerov> ok, I'm actually getting into details ))
16:15:59 <rakhmerov> let's continue
16:16:04 <xylan_kong> :-)
16:16:16 <rakhmerov> it's ok
16:16:23 <rakhmerov> #topic Official Liberty Release health
16:16:46 <rakhmerov> so I think we're mostly ok, in short
16:17:33 <xylan_kong> rakhmerov: seems there are some mistralclient bugs still not set milestone
16:17:34 <rakhmerov> there are still some bugs in progress but I need to clarify their status
16:17:41 <xylan_kong> e.g. https://bugs.launchpad.net/python-mistralclient/+bug/1502840
16:17:41 <openstack> Launchpad bug 1502840 in python-mistralclient "Http Response is shown, In case of 'OS_AUTH_URL' is not set." [Undecided,Fix committed] - Assigned to hardik (hardik-parekh047)
16:18:06 <rakhmerov> yep, it's because there's not an open milestone at client LP
16:18:18 <rakhmerov> I'll fix it tomorrow
16:18:24 <xylan_kong> ok
16:18:42 <rakhmerov> #action rakhmerov: make sure client bugs are assigned to milestones
16:19:14 <rakhmerov> btw, this is a Liberty-rc2 page: https://launchpad.net/mistral/+milestone/liberty-rc2
16:19:40 <rakhmerov> Documentation is mostly fine, akuznetsova fully reviewed it and created a bug with all the remarks about the doc
16:19:51 <rakhmerov> so doc BP is going to be closed
16:20:40 <akuznetsova> rakhmerov, correct, here is a link https://bugs.launchpad.net/mistral/+bug/1504582, let's assign it to corresponding milestone
16:20:40 <openstack> Launchpad bug 1504582 in Mistral "Remarks to updated documentation" [Undecided,New]
16:21:06 <rakhmerov> so my plan is to have 1 day (tomorrow) make final bugfixes/adjustements, then backport needed patches made after RC1 into stable/liberty and release RC2 which we're planning to test via QA
16:21:20 <rakhmerov> akuznetsova: yep, thanks
16:21:53 <rakhmerov> done
16:21:56 <akuznetsova> thanks
16:22:25 <rakhmerov> ^Gal^: btw, is https://blueprints.launchpad.net/mistral/+spec/mistral-docs-troubleshooting done?
16:22:49 <rakhmerov> we recently merged your patch which was related to this but I wasn't sure if it covers this BP completely
16:23:09 <^Gal^> hmm
16:23:18 <^Gal^> what I covered was mistral-dashboard stuff
16:23:58 <^Gal^> by mistral-dashboard side, yep we're done
16:24:18 <rakhmerov> ok, then I need to check that BP again
16:24:26 <^Gal^> ok
16:24:47 <rakhmerov> #action rakhmerov: check if https://blueprints.launchpad.net/mistral/+spec/mistral-docs-troubleshooting is completed (it's finished from UI side)
16:25:19 <rakhmerov> ^Gal^: what about UI BPs? Moving to Mitaka?
16:25:33 <^Gal^> yeah
16:25:39 <rakhmerov> I guess they won't be completed in 1 day
16:25:41 <rakhmerov> ok
16:26:29 <rakhmerov> so, generally I'm planning to have official Liberty release on Thu or Friday
16:26:34 <rakhmerov> most likely Fri
16:27:06 <rakhmerov> guys, do you have any concerns or questions? Or anything you want to do before the release?
16:27:10 <^Gal^> wooohoo congrats
16:27:28 <rakhmerov> it's high time you said if you need something
16:28:18 <akuznetsova> rakhmerov, what about this bp https://blueprints.launchpad.net/mistral/+spec/mistral-async-actions-doc ?
16:28:40 <rakhmerov> akuznetsova: it's on my TODO list for this week
16:29:15 <akuznetsova> rakhmerov, ok, please, set status, assignee and priority
16:29:32 <rakhmerov> yes, just did
16:29:34 <rakhmerov> thanks
16:29:50 <rakhmerov> will do my best to get it done
16:29:58 <rakhmerov> anything else?
16:30:09 <rakhmerov> counting to 5 and go the next topic
16:30:10 <rakhmerov> 1
16:30:12 <rakhmerov> 2
16:30:14 <rakhmerov> 3
16:30:16 <rakhmerov> 4
16:30:19 <rakhmerov> 5
16:30:21 <rakhmerov> sold!
16:30:24 <rakhmerov> ok
16:30:26 <NikolayM> :D
16:30:34 <LimorStotland> :-)
16:30:40 <rakhmerov> #topic Discuss https://review.openstack.org/232507
16:31:08 <rakhmerov> NikolayM, xylan_kong: let's dicuss it
16:31:25 <NikolayM> Yes, I want to discuss this patch
16:31:27 <xylan_kong> yeah, ok
16:31:32 <rakhmerov> so, xylan_kong, looks like NikolayM addressed most of your concerns
16:31:48 <NikolayM> I think we could get rid of tempest at all
16:31:53 <rakhmerov> except one: these tests can't work w/o OpenStack as long as we use tempest
16:32:09 <NikolayM> or we won't be able to run tests w/o OpenStack
16:32:14 <rakhmerov> NikolayM: get rid of tempest? what's the alternative?
16:33:00 <akuznetsova> rakhmerov, there were a couple of reasons why these tests were write using tempest
16:33:09 <rakhmerov> as far as I understand, if we set auth to false then we can run these tests w/o OpenStack, right?
16:33:12 <rakhmerov> isn't it enough?
16:33:22 <NikolayM> alternative is to create our own library for requests (like tempest)
16:33:28 <rakhmerov> akuznetsova: I know, yes
16:33:29 <xylan_kong> NikolayM: no, if we continue to be in OpenStack big tent, we should use Tempest for our functional testing
16:33:34 <NikolayM> no, it is just kind of workaround
16:33:52 <akuznetsova> xylan_kong, that's not quite right
16:33:56 <xylan_kong> especially, one day, if we want mistral test case to be included in DefCore :-)
16:34:05 <NikolayM> yep, then we don't need to get rid of tempest
16:34:25 <rakhmerov> I agree with xylan_kong here, we should try to be aligned with OpenStack practices
16:34:36 <rakhmerov> unless it conflicts with common sense :)
16:34:36 <NikolayM> yes
16:35:02 <akuznetsova> rakhmerov, as far as I know, heat and sahara do not use tempest for real functional tests
16:35:02 <NikolayM> xylan_kong, what about your question about running tests without OpenStack?
16:35:11 <xylan_kong> for mistral functional tests, if it must work with OpenStack, we should define skip_check method
16:35:32 <xylan_kong> if OpenStack is not installed, then just skip the tests
16:35:57 <rakhmerov> xylan_kong: how does a test know that?
16:36:05 <rakhmerov> if OS is installed or not
16:36:09 <rakhmerov> just a config option?
16:36:13 <xylan_kong> via configuration
16:36:15 <xylan_kong> yes
16:36:16 <xylan_kong> right
16:36:24 <rakhmerov> ok
16:36:24 <xylan_kong> like tempest does now
16:36:27 <akuznetsova> tempest does not work without Openstack
16:36:52 <xylan_kong> but tempest can work without a perticular service
16:37:00 <rakhmerov> akuznetsova: you mean there's no config option to disable OpenStack in tempest?
16:37:20 <rakhmerov> hm.. sorry guys, I'm not that familiar with tempest
16:37:23 <rakhmerov> can you clarify this?
16:37:24 <NikolayM> tempest is created for OpenStack tests :)
16:37:42 <akuznetsova> rakhmerov, correct, tempest can't work with OS, it authorize in keystone
16:37:46 <rakhmerov> akuznetsova says tempest can't be used w/o OpenStack, xylan_kong says somehow we can do it
16:37:48 <akuznetsova> *without
16:37:52 <rakhmerov> where is the truth? :)
16:38:02 <xylan_kong> akuznetsova:let me make it clear
16:38:12 <rakhmerov> yes, please do
16:38:14 <LimorStotland> I and i think this flug can be useful not only for testing but for all the stand alone feather
16:38:21 <NikolayM> tempest has config options meaning that one or another service is available
16:38:39 <xylan_kong> if we want to run mistral functional tests, we must install tempest first, right
16:38:46 <rakhmerov> LimorStotland: I didn't quite understand you
16:39:53 <rakhmerov> xylan_kong: ok, and?
16:40:25 <xylan_kong> then we got tempest configuration, and we can config items to decide if the services mistral needs is there, if no, we just skip the tests which need OpenStack installed
16:40:51 <xylan_kong> am I right? akuznetsova NikolayM ?
16:41:14 <LimorStotland> if i am following this conversation (and i am not so sure i am any more :-) )  xylan_kong  want to add fulg for the config if we have openstack or not
16:41:23 <LimorStotland> is this correct?
16:41:26 <xylan_kong> take https://review.openstack.org/232507 for example, you need nova and neutron
16:41:28 <rakhmerov> ok
16:41:49 <xylan_kong> if anyone of them is not installed, then we skip the tests
16:41:56 <NikolayM> neutron is not necessary here, I think
16:42:16 <NikolayM> Can you imagine OpenStack without compute service?
16:42:48 <NikolayM> or, that is correct case?
16:43:16 <rakhmerov> xylan_kong: ok, when we use this decorator we just need to specify a dependency on particular services, right?
16:43:31 <xylan_kong> rakhmerov: yes
16:43:35 <rakhmerov> LimorStotland: yes, sort of )
16:43:36 <xylan_kong> NikolayM: hmm, let me think
16:44:30 <xylan_kong> NikolayM: so, you just want to decide whether OpenStack is installed or not, right? don't care about the specific service?
16:44:53 <NikolayM> xylan_kong, generally yes
16:45:05 <akuznetsova> as far as I understand such flags work only for tests which located in tempest repo
16:45:12 <rakhmerov> then we can just set a dependency from Nova, right?
16:45:31 <rakhmerov> meaning that Nova always exists if OpenStack is installed
16:45:32 <NikolayM> if you want to run tests just without OpenStack (even without auth), take a look at run_functional_tests.sh script
16:45:36 <rakhmerov> can we do this?
16:46:34 <akuznetsova> guys, our main problem is not nova, neutron, etc, keystone - tempest always use authorization
16:47:10 <rakhmerov> I'm confused. Someone of you told that auth can be disabled
16:47:26 <rakhmerov> if so we can disable it and run w/o OpenStack, no?
16:47:26 <akuznetsova> rakhmerov, yes, using some hacks
16:47:32 <rakhmerov> what hacks?
16:47:44 <akuznetsova> we can disable auth in api tests
16:48:02 <rakhmerov> can we make it configurable?
16:48:05 <akuznetsova> but how we can disable auth in tests for openstack actions ?
16:48:17 <LimorStotland> but keystone should always be installed because all services are using authorization.so i don't understand the problems kuznetsova
16:48:45 <rakhmerov> LimorStotland: that's exactly what we're trying to agree on
16:48:59 <LimorStotland> akuznetsova sorry google translate :-)
16:49:03 <akuznetsova> xylan_kong, what tests you want to skip ?
16:49:05 <rakhmerov> we need to be able to run tests w/o OpenStack
16:49:12 <rakhmerov> we're just trying to understand how
16:49:19 <akuznetsova> rakhmerov, which tests ?
16:49:33 <LimorStotland> sorry i am behind  :-(
16:49:35 <rakhmerov> functional tests
16:49:43 <akuznetsova> api / cli / tests for actions ?
16:50:19 <xylan_kong> akuznetsova: i mean, if we have test case needs openstack installed, and we want to run the tests without openstack, there must be a mechanism to skip
16:50:24 <rakhmerov> ok, guys, we're running out of time so let me please drive the following conversation
16:50:43 <rakhmerov> the goal we're trying to achieve:
16:50:49 <NikolayM> xylan_kong, rakhmerov, we have run_functional_tests script
16:50:59 <rakhmerov> wait a sec
16:51:05 <NikolayM> which can run API functional tests without auth at all
16:51:09 <rakhmerov> 1. We have functional tests
16:51:23 <rakhmerov> 2. Part of the func tests are not related logically with OpenStack
16:51:34 <rakhmerov> 3. Part of them are related with OpenStack
16:52:03 <NikolayM> yes, API tests generally are not related to OpenStack
16:52:20 <akuznetsova> xylan_kong, problem is that now we should skip all tests ) because they use tempest, tempest uses authorization in keystone before tests running
16:52:23 <rakhmerov> 4. We want to be able to run functional test with OpenStack (full set of tests) and without OpenStack so that in this case all test dependent on OpenStack are just skipped
16:52:46 <rakhmerov> xylan_kong, akuznetsova, NikolayM: do you all agree with my points?
16:52:50 <rakhmerov> is this our goal?
16:53:45 <akuznetsova> rakhmerov, yes, but I don't see now how we can run tests which use tempest without auth and without hacks
16:53:52 <NikolayM> for me 'run_functional_tests' is fine
16:53:59 <xylan_kong> rakhmerov: it's aslo my understanding, akuznetsova NikolayM we can discuss this in another time
16:54:15 <rakhmerov> NikolayM: how does it work? that script
16:54:32 <rakhmerov> how does it bypass the problem that akuznetsova describes
16:54:40 <NikolayM> as akuznetsova said, with some kind of hacks
16:54:52 <akuznetsova> rakhmerov, using that https://github.com/openstack/mistral/blob/master/mistral/tests/functional/base.py#L220
16:55:33 <akuznetsova> overring and mocks
16:55:36 <rakhmerov> NikolayM: if we run this script what happens tests that depend on OpenStack?
16:55:59 <akuznetsova> rakhmerov, script runs only api tests
16:56:07 <NikolayM> It doesn't run tests depending on Openstack
16:56:13 <NikolayM> only API tests
16:56:20 <rakhmerov> how does it distinguishes them?
16:56:20 <NikolayM> yes, thanks akuznetsova
16:56:28 <NikolayM> by tests path
16:56:46 <NikolayM> only tests/api directory
16:57:00 <rakhmerov> oooh...
16:57:04 <rakhmerov> I see now
16:57:13 <rakhmerov> xylan_kong: do you think it's acceptable for us?
16:57:23 <xylan_kong> NikolayM: how our gate distinguishes them?
16:57:25 <rakhmerov> or you disagree with this approach?
16:57:50 <rakhmerov> xylan_kong: he just told about it, it just looks at their path
16:58:11 <NikolayM> gate does not run them
16:58:28 <akuznetsova> our dsvm gate run all tests
16:58:57 <rakhmerov> https://github.com/openstack/mistral/blob/master/run_functional_tests.sh#L17
16:58:58 <NikolayM> yep, but it runs all tempest tests (without this script)
16:59:03 <akuznetsova> rakhmerov, xylan_kong we do not use run_functional_tests in our gates
16:59:10 <rakhmerov> I know, yes
16:59:35 <rakhmerov> I am just asking Lingxian if this is ok to run this script if we need to run func tests w/o OpenStack
16:59:37 <_gryf> maybe the question is: are there any tests which are not run on the gate, but ran by the sctipt?
16:59:55 <akuznetsova> _gryf, no
16:59:56 <rakhmerov> _gryf: now
16:59:58 <rakhmerov> no
17:00:01 <xylan_kong> akuznetsova, NikolayM you mean OpenStack related tests won't be run in our gate?
17:00:11 <rakhmerov> brrrr....
17:00:13 <rakhmerov> :)))
17:00:15 <rakhmerov> no
17:00:26 <rakhmerov> they run at our gate
17:00:35 <rakhmerov> ok, guys, sorry, we ran out of time
17:00:36 <xylan_kong> ok, i got
17:00:41 <_gryf> so, what's the point of discusing the script on the first place?
17:00:42 <NikolayM> no, I mean on gate that script is not used
17:00:46 <rakhmerov> xylan_kong: let's continue tomorrow in IRC
17:00:56 <xylan_kong> :-)
17:01:03 <_gryf> it;s role is to mock the lack of openstac, no?
17:01:12 <xylan_kong> rakhmerov, NikolayM, akuznetsova thanks all of you
17:01:18 <xylan_kong> for patience
17:01:32 <rakhmerov> _gryf:  we just need an ability to run tests w/o OpenStack
17:01:42 <rakhmerov> those that don't depend on OpenStack at all
17:01:47 <_gryf> rakhmerov, on the gate?
17:01:53 <rakhmerov> that's what that script does
17:01:58 <akuznetsova> _gryf, locally
17:02:00 <rakhmerov> no, not on the gate
17:02:03 <rakhmerov> locally
17:02:17 <_gryf> hm. ok.
17:02:28 <akuznetsova> cause mistral can work w/o OpenStack
17:02:30 <rakhmerov> ok, let's end the meeting. We're occupying the channel
17:02:47 <rakhmerov> thanks for joinging! see you tomorrow in IRC
17:02:50 <rakhmerov> bye
17:02:51 <^Gal^> bye have a good week
17:02:52 <xylan_kong> thanks guys, appreciate your explanation
17:02:54 <akuznetsova> bye
17:02:55 <_gryf> bye
17:02:56 <LimorStotland> bye
17:02:57 <rakhmerov> sure
17:03:03 <rakhmerov> #endmeeting