16:17:03 <rakhmerov> #startmeeting Mistral
16:17:04 <openstack> Meeting started Mon Nov 9 16:17:03 2015 UTC and is due to finish in 60 minutes. The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:17:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:17:08 <openstack> The meeting name has been set to 'mistral'
16:17:11 <rakhmerov> #topic Review Action Items
16:17:13 <rakhmerov> no action items
16:17:30 <rakhmerov> #topic Current status (progress, issues, roadblocks, further plans)
16:17:43 <NikolayM> hi everyone! Sorry, I'm late
16:17:48 <rakhmerov> please tell your status and your plans quickly
16:17:51 <rakhmerov> NikolayM: np
16:18:48 <melisha> I am working on https://bugs.launchpad.net/mistral/+bug/1513548 will push first patchset soon
16:18:48 <openstack> Launchpad bug 1513548 in Mistral "Workflow executed more than once when using cron-trigger with multiple engines" [Undecided,New] - Assigned to Moshe Elisha (melisha)
16:19:08 <LimorStotland> my status working on bp pagination-execution-mitralclient
16:19:22 <xylan_kong> i'm working on adding mistral specs repo, have patches for governance and project-config respectively, and will work on some bps assigned to me today, and as a liaison of release, I'll add reno support to mistral
16:19:29 <akuznetsova> I am testing mistral plugin for FUEL
16:19:31 <LimorStotland> https://blueprints.launchpad.net/python-mistralclient/+spec/pagination-execution-mitralclient
16:19:44 <NikolayM> my status: Fixed patch related to wf execution creation; fixed calculation of wf exexcution status when workflow has conditional transitions
16:19:53 <rakhmerov> my status: mostly involved in email exchanges on Mistral, after the summit a number of people started asking questions about Mistral. Also did some planning. I am going to take a couple of important bugs and working on them
16:20:00 <melisha> ^Gal^ is working on finishes in tasks and executions screens
16:20:10 <melisha> Liat is working on the BP for actions screen
16:21:22 <_gryf> I've started to identify gaps in mistral regading ha, the outcome would be bug reports and bp (possibly)
16:21:30 <rakhmerov> melisha: it's a really important bug, good luck!
16:21:56 <rakhmerov> xylan_kong: what is reno? briefly
16:22:01 <melisha> rakhmerov: -) Thanks
16:22:45 <xylan_kong> rakhmerov: generate release notes automatically
16:22:53 <rakhmerov> ok
16:23:05 <rakhmerov> _gryf: I also created a very high-level BP for Mistral working in HA mode
16:23:16 <_gryf> rakhmerov, ack, saw that
16:23:33 <rakhmerov> here it is: https://blueprints.launchpad.net/mistral/+spec/mistral-ha
16:23:58 <rakhmerov> so my vision is that we need to create sort of a spec first (using this new spec repository which will be ready soon I hope)
16:24:17 <rakhmerov> and create a roadmap for making Mistral work in HA
16:24:32 <rakhmerov> ok, thanks to everyone, let's move on
16:24:36 <_gryf> rakhmerov, Ok, cool.
16:24:48 <rakhmerov> #topic Scoping Mitaka and Mitaka-1
16:25:22 <rakhmerov> today we had a quick IRC meeting where the only thing we did is assigning BPs to Mitaka series
16:25:27 <rakhmerov> the whole cycle
16:25:48 <rakhmerov> the next thing we need to do is assign BPs and bugs to Mitaka-1
16:27:19 <rakhmerov> so according to the release schedule Mitaka-1 ends on Dec 3
16:27:21 <rakhmerov> https://wiki.openstack.org/wiki/Mitaka_Release_Schedule
16:27:41 <rakhmerov> which means we have 3 weeks left
16:27:58 <NikolayM> oh, just 3 weeks
16:28:03 <rakhmerov> yes
16:28:23 <rakhmerov> BPs assigned to Mitaka: https://blueprints.launchpad.net/mistral
16:28:29 <rakhmerov> ooh, sorry
16:28:41 <rakhmerov> https://blueprints.launchpad.net/mistral/mitaka
16:29:01 <rakhmerov> and BPs for Mitaka-1 milestone: https://launchpad.net/mistral/+milestone/mitaka-1
16:29:50 <rakhmerov> melisha: let's assign your bug to Mitaka-1?
16:29:55 <rakhmerov> about cron trigger
16:30:25 <melisha> rakhmerov: Sure. This should also be backported to Liberty
16:30:49 <rakhmerov> yes, once it's merged just leave a comment about that
16:30:59 <rakhmerov> or just let me know directly, I'll backport it
16:31:12 <melisha> rakhmerov: Cool. Thanks
16:31:45 <rakhmerov> ok, as far as BPs
16:32:02 <rakhmerov> https://blueprints.launchpad.net/mistral/+spec/mistral-py3 is about to be done, so I'd like it to be in M-1
16:33:25 <NikolayM> I think this one - https://blueprints.launchpad.net/mistral/+spec/add-ceilometer-actions should be in M-1 also, it is not so hard to add more actions :)
16:33:30 <rakhmerov> melisha: as far as UI stuff, do you think https://blueprints.launchpad.net/mistral/+spec/mistral-dashboard-executions-screen can be done in M-1?
16:33:49 <melisha> NikolayM: I agree.
16:33:58 <LimorStotland> this one is in progres https://blueprints.launchpad.net/python-mistralclient/+spec/pagination-execution-mitralclient to
16:34:05 <LimorStotland> +1 to NikolayM
16:34:09 <rakhmerov> NikolayM: agree. Let's also consider BPs from importance standpoint
16:34:17 <melisha> NikolayM: Noa has already have most of the code
16:34:38 <rakhmerov> LimorStotland: ok, I need to create M-1 first in Client LP
16:34:57 <rakhmerov> #action rakhmerov: create Mitaka series and milestone in python-mistralclient LP
16:34:59 <melisha> rakhmerov: I think so. It is mostly finishes and add the pagination
16:35:50 <rakhmerov> ok
16:36:24 <rakhmerov> melisha: what do you think about https://blueprints.launchpad.net/mistral/+spec/tasks-screen-improvments ?
16:36:40 <rakhmerov> I know that some work is already done but not sure what's left
16:37:01 <NikolayM> I've marked https://blueprints.launchpad.net/mistral/+spec/mistral-alternative-rpc for M-1 also, but I'm not sure it will be done at M-1
16:37:52 <melisha> rakhmerov: I think this is also next to finish. What is left is to improve the jumps from one screen (for example, tasks) to another (for example executions)
16:37:57 <rakhmerov> NikolayM: yes, I agree on that one. At least we can try to squeeze it into it
16:38:13 <rakhmerov> melisha: ok
16:38:14 <NikolayM> yes
16:39:11 <rakhmerov> Guys, a quick announcement!
16:39:38 <xylan_kong> ?
16:39:49 <rakhmerov> once we have xylan_kong's patches merged, we'll switch to the flow that all big projects have
16:40:17 <xylan_kong> :-)
16:40:32 <rakhmerov> first, we'll need to create a spec (in case of design/API/functionality changes), approve it, merge it into spec repository
16:40:41 <rakhmerov> and only then working on the code
16:40:53 <rakhmerov> so that we keep track of our specifications
16:41:19 <rakhmerov> so I suggest we have a discussion in ~2 weeks (before this M-1 ends) and plan M-2
16:41:52 <rakhmerov> we're running a little bit behind with planning (mostly my fault) and other stuff that we're supposed to do so we need to catch up
16:42:18 <rakhmerov> all big BPs like multi-region support should be clearly documented first in a spec before coding
16:42:31 <rakhmerov> not so hard to do but everyone would see what we're doing
16:42:39 <rakhmerov> ok, let's move on
16:43:12 <rakhmerov> I also want https://blueprints.launchpad.net/mistral/+spec/mistral-async-actions-doc in M-1
16:44:10 <melisha> rakhmerov: I can help with that from my expierience.
16:44:36 <rakhmerov> melisha: yes, thanks
16:44:43 <rakhmerov> appreciate that
16:44:56 <rakhmerov> xylan_kong: what do you think about https://blueprints.launchpad.net/mistral/+spec/mistral-osc-plugin ?
16:45:11 <rakhmerov> would it be a heavy thing to do?
16:45:33 <rakhmerov> I was asked several times why we're still not integrated with osc
16:45:42 <xylan_kong> rakhmerov: no, i think it's easy thing to do
16:45:54 <xylan_kong> rakhmerov: i'll cover it
16:46:00 <rakhmerov> will you take it for M-1?
16:46:02 <rakhmerov> ooh, ok
16:46:10 <xylan_kong> I'll try
16:46:19 <xylan_kong> just assign it to me
16:46:28 <melisha> #action melisha: Write docs about https://blueprints.launchpad.net/mistral/+spec/mistral-async-actions-doc in M-1
16:47:12 <xylan_kong> seems I'll have tons of tasks in M-1 :-)
16:48:07 <rakhmerov> xylan_kong: you'll get them all done, I'm confident about that )
16:48:20 <xylan_kong> rakhmerov: hehe
16:48:41 <rakhmerov> melisha: from your side, do you see anything else we could include in M-1
16:49:38 <rakhmerov> I know you're interested in multi-regiion support and we've mostly discussed it at the summit with your colleagues but I'd like that things like "Mistral HA" and "Multi-region support" are designed first in specs
16:50:02 <rakhmerov> so I'd like to do that during M-1 and then get to implementing them
16:50:05 <melisha> rakhmerov: We are now focused on QA and opening/fixing bugs. This is top prioirty for us as we need the important fixes in Liberty
16:50:20 <rakhmerov> yes, ok
16:50:45 <melisha> rakhmerov: This are indeed important stories for us but again those are for the next release. We are thinking about the one that will go to production soon :-)
16:50:53 <rakhmerov> so, my suggestion: on BPs, let's be conservative and limit a number of BPs for M-1 with what we already have
16:51:23 <melisha> rakhmerov: Sounds good to me. Thanks.
16:51:24 <rakhmerov> #action rakhmerov, melisha: design "Mistral HA" and "Multi-region sport" during M-1
16:51:47 <rakhmerov> melisha: let's quickly have a look at the bugs then
16:52:27 <rakhmerov> I actually would love to see https://bugs.launchpad.net/mistral/+bug/1505664 done in M-1
16:52:27 <openstack> Launchpad bug 1505664 in Mistral "Some DB queries are reported slow as no indices are used" [Undecided,New]
16:52:43 <rakhmerov> btw, Winson said he was ready to take this one
16:53:13 <rakhmerov> melisha: do you want to work on it yourself or we can give it to Winson?
16:53:32 <LimorStotland> rakhmerov : can i be part of the design "Mistral HA" and "Multi-region sport" action?
16:53:40 <rakhmerov> LimorStotland: sure!!
16:53:42 <melisha> rakhmerov: He can take it if he wish. No objection. If not we will most definitely do it anyway
16:54:16 <rakhmerov> melisha: ok, done
16:55:30 <rakhmerov> melisha: since we're running out of time can we have a chat tomorrow about bugs that you're mostly interested in?
16:55:54 <rakhmerov> we could spend 30-40 mins in our IRC channel and go over the bug list
16:56:10 <rakhmerov> everyone can join as well, of course
16:56:17 <melisha> rakhmerov: Sure. That will be great! Thanks!
16:56:53 <rakhmerov> I also see a lot of bugs "In progress" and I'd like to clarify their status, I guess not all of them are actually in progress
16:58:18 <melisha> rakhmerov: Thanks
16:58:19 <rakhmerov> #action: rakhmerov: ping melisha and look at the bugs together
16:58:55 <rakhmerov> the goal is to 1) assign bugs to M-1 2) create a list of changes that we need to backport to stable-liberty
16:59:09 <NikolayM> AFAIK bug changes its status to 'in progress' when first patch set is submitted
16:59:21 <rakhmerov> yeah
16:59:21 <NikolayM> no need to change the status manually
16:59:22 <rakhmerov> ok
16:59:27 <rakhmerov> 30 sec left
16:59:35 <rakhmerov> thanks to everyone for joining!
16:59:39 <rakhmerov> see you soon
16:59:42 <rakhmerov> bye
16:59:43 <NikolayM> bye!
16:59:46 <melisha> Bye. Thanks
16:59:46 <xylan_kong> bye
16:59:46 <_gryf> bye
16:59:54 <rakhmerov> #endmeeting