15:59:46 <nmakhotkin> #startmeeting Mistral
15:59:47 <openstack> Meeting started Mon Dec  7 15:59:46 2015 UTC and is due to finish in 60 minutes.  The chair is nmakhotkin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:59:50 <openstack> The meeting name has been set to 'mistral'
15:59:58 <nmakhotkin> hi everyone!
16:00:02 <^Gal^> hi
16:00:19 <nmakhotkin> glad to see you on our community meeting! :)
16:00:27 <nmakhotkin> hi, ^Gal^
16:00:30 <akuznetsova> hi
16:02:49 <LimorStotland> hi all
16:02:59 <dzimine> Hello!
16:04:43 <nmakhotkin> hi, LimorStotland, dzimine!
16:04:48 <nmakhotkin> let's start
16:04:54 <nmakhotkin> #topic Review action items
16:05:40 <nmakhotkin> 1. rakhmerov, melisha: design "Mistral HA" and "Multi-region support" during M-2
16:06:20 <melisha> Still need to be done. I will schedule a meeting with Renat
16:06:29 <nmakhotkin> ooh, ok
16:06:38 <nmakhotkin> I'll move it to next meeting
16:06:46 <melisha> Thanks!
16:06:49 <nmakhotkin> #action rakhmerov, melisha: design "Mistral HA" and "Multi-region support" during M-2
16:07:21 <nmakhotkin> 2. nikolaym: move incomplete bps to m-2
16:07:28 <nmakhotkin> it's done
16:08:14 <nmakhotkin> 3. mark https://blueprints.launchpad.net/mistral/+spec/mistral-ceilometer-actions as 'implemented'
16:08:34 <nmakhotkin> done
16:08:48 <nmakhotkin> 4. mark https://blueprints.launchpad.net/mistral/+spec/mistral-osc-plugin as 'implemented'
16:09:00 <nmakhotkin> done also
16:09:12 <nmakhotkin> 5. move https://blueprints.launchpad.net/mistral/+spec/mistral-alternative-rpc to m-2
16:09:24 <nmakhotkin> done too
16:09:52 <nmakhotkin> #topic Current status
16:10:13 <nmakhotkin> guys, let's share our statuses :)
16:10:38 <melisha> Working on bugfix https://review.openstack.org/#/c/253819/
16:10:41 <LimorStotland> my status: reviewing code and  working on internal alcatel issues
16:11:31 <nmakhotkin> my status: reviewing patches, all last week was busy with another activities not related to mistral
16:11:33 <^Gal^> I'm on execution screen auto refresh (UI side)
16:12:46 <nmakhotkin> melisha, does it really fix the problem? have you tested it somehow?
16:13:10 <mgershen> Working on bugfix https://review.openstack.org/#/c/252110/
16:13:30 <nmakhotkin> if it fixes affected env that will be very cool :)
16:14:03 <ddeja> nmakhotkin: I've applied melishas patches on my env and it fixed my problems (task stuck in running state)
16:14:16 <melisha> nmakhotkin: :-) I have tested it. I added some unit tests that reproduce the issue without the fix + I applied this patch on our prod like env and the issue did not reproduce
16:14:52 <melisha> ddeja: Thanks for the confirmation.
16:14:58 <nmakhotkin> melisha, ddeja, fine
16:15:47 <nmakhotkin> ok, let's move to the next topic
16:16:00 <nmakhotkin> #topic M-1 release
16:16:48 <nmakhotkin> Mistral M-1 (2.0.0.0b1) is released: https://review.openstack.org/#/c/253609/
16:17:14 <nmakhotkin> and mistralclient v1.2.0: https://review.openstack.org/#/c/252987,
16:19:24 <nmakhotkin> AFAIK, need to do a planning for the next dev cycle - M-2
16:21:28 <melisha> nmakhotkin: You want to do that now or a dedicated meeting?
16:22:08 <nmakhotkin> I think we'll do it on a separate meeting
16:22:23 <melisha> nmakhotkin: OK
16:22:36 <nmakhotkin> I need to discuss that with rakhmerov
16:23:21 <nmakhotkin> #action nmakhotkin: discuss with rakhmerov about M-2 planning and do planning
16:23:45 <nmakhotkin> I'll share the date and time on our regular channel
16:24:06 <nmakhotkin> move to open discussion
16:24:12 <nmakhotkin> #topic Open Discussion
16:24:33 <nmakhotkin> melisha, I have a question for you
16:24:51 <melisha> nmakhotkin: Sure
16:25:00 <nmakhotkin> you told about a new bug created by that fix
16:25:31 <melisha> nmakhotkin: I think it is an existing bug that my fix increases the changes to reproduce it
16:25:33 <nmakhotkin> could you describe what happen there?
16:25:56 <nmakhotkin> ooh
16:26:01 <melisha> nmakhotkin: Sure. I have sent Renat and you a detailed email about this.
16:26:13 <melisha> nmakhotkin: I can send it to the mailing list
16:28:23 <nmakhotkin> yes, please send :)
16:29:17 <nmakhotkin> also I'll review your patch again
16:29:58 <melisha> nmakhotkin: I just now sent it to the mailing list.
16:29:59 <melisha> Thanks
16:30:23 <melisha> nmakhotkin: Can I ask you something regarding pep8?
16:30:56 <nmakhotkin> yes, sure
16:31:11 <nmakhotkin> btw, I've received your email about this
16:31:50 <nmakhotkin> I try to reproduce and see what the reason is
16:31:51 <melisha> When we run "cd /opt/stack/mistral ; tox -e pep8" on our DevStacks - we get a lot of errors (like D100  Missing docstring in public module, D102  Missing docstring in public method, �)
16:32:13 <melisha> nmakhotkin: Oh. OK. Thanks.
16:32:15 <nmakhotkin> akuznetsova, could you help us? :)
16:32:44 <akuznetsova> nmakhotkin, I missed context
16:33:14 <nmakhotkin> a lot of errors with pep8 when running tox -epep8
16:33:22 <nmakhotkin> I'll send you an email
16:33:27 <melisha> nmakhotkin, akuznetsova: When we run pep8 on DevStack we get a lot of errors that are skipped / ignored in the gate-mistral-pep8
16:33:40 <melisha> nmakhotkin> akuznetsova: Thank you both
16:34:22 <melisha> nmakhotkin> akuznetsova: It seems that somehow I have a wrong rules file for pep8
16:34:30 <ddeja> melisha: I've got same on my devstack. It's due to flake8-docstrings package beeing installed
16:34:32 <akuznetsova> melisha, actually it is strange...
16:34:50 <ddeja> but I don't know why it is installed...
16:35:14 <melisha> ddeja: Did you resolve the issue?
16:35:28 <melisha> Can I simply remove that package?
16:35:44 <ddeja> melisha: i didn't try that
16:36:09 <ddeja> I've only checked that on other VM I don't have that package and pep8 test is OK
16:36:14 <nmakhotkin> melisha, you could try
16:37:29 <melisha> Trying now...
16:37:32 <nmakhotkin> melisha, pep8 could be run in venv and there should not be some additional packages
16:37:39 <melisha> Works!
16:37:46 <melisha> Interesting...
16:37:47 <nmakhotkin> cool
16:37:53 <melisha> ddeja: Thanks for the tip!
16:38:02 <ddeja> melisha: no problem
16:38:33 <ddeja> nmakhotkin: Whats interesting, I've run my tests in venv, but this package was still present
16:39:09 <nmakhotkin> ddeja, it seems some other package installs it
16:39:55 <nmakhotkin> need to add a bug in LP about that
16:41:17 <LimorStotland> I will open
16:42:13 <nmakhotkin> ok, thanks
16:43:55 <nmakhotkin> #action: LimorStotland: create the bug related to pep8 fails
16:44:20 <nmakhotkin> guys, do you have anything to discuss?
16:44:37 <nmakhotkin> otherwise I end the meeting
16:44:56 <nmakhotkin> 5
16:44:59 <nmakhotkin> 4
16:45:03 <nmakhotkin> 3
16:45:05 <nmakhotkin> 2
16:45:08 <nmakhotkin> 1
16:45:13 <LimorStotland> https://bugs.launchpad.net/mistral/+bug/1523590
16:45:13 <openstack> Launchpad bug 1523590 in Mistral "pep8 failed because flake8-docstrings" [Undecided,New]
16:45:21 <melisha> :-)
16:45:27 <nmakhotkin> you're fast :)
16:45:43 <LimorStotland> That me speedy :-)
16:45:50 <nmakhotkin> so, I end the meeting
16:45:57 <nmakhotkin> thanks guys for attending!
16:46:16 <melisha> Thanks! Bye
16:46:19 <nmakhotkin> bye!
16:46:20 <LimorStotland> Thanks Bey
16:46:27 <ddeja> bye
16:46:34 <nmakhotkin> #endmeeting