16:01:25 <NikolayM> #startmeeting Mistral
16:01:27 <openstack> Meeting started Mon Dec 14 16:01:25 2015 UTC and is due to finish in 60 minutes.  The chair is NikolayM. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:31 <NikolayM> hi everyone!
16:01:32 <openstack> The meeting name has been set to 'mistral'
16:01:48 <melisha> Hi
16:01:50 <lane_kong> NikolayM: hi, i'm here
16:01:52 <gpaz> Hi
16:02:06 <dzimine> Hi all!
16:02:10 <ddeja> hello
16:02:17 <m4dcoder> hi
16:02:40 <NikolayM> let's start
16:02:50 <NikolayM> #topic Review Action items
16:03:16 <NikolayM> 1. rakhmerov, melisha: design "Mistral HA" and "Multi-region support" during M-2
16:03:35 <NikolayM> there was a meeting earlier
16:03:35 <melisha> NikolayM: We had a meeting today
16:03:50 <NikolayM> but I couldn't attend to it, sorry
16:04:06 <lane_kong> i missed it, too
16:04:22 <melisha> We talked in general about the scope of these features.
16:04:30 <lane_kong> melisha: do you have a meeting minutes?
16:04:41 <melisha> Yes. Sorry for that but we will update - no decisions were done
16:04:42 <NikolayM> btw, was rakhmerov on the meeting?
16:04:59 <melisha> Yes rakhmerov was there
16:05:04 <melisha> We will send minutes
16:05:13 <NikolayM> ok
16:05:18 <melisha> Basically there are 2 BPs about these two issues and we said we will update them
16:05:38 <NikolayM> #action melisha: send "Mistral HA and multi-regional support" meeting minutes
16:05:47 <melisha> Cool. Thanks.
16:06:24 <NikolayM> next item
16:06:29 <NikolayM> 2. nmakhotkin: discuss with rakhmerov about M-2 planning and do planning
16:06:47 <NikolayM> I asked Renat about time for the planning
16:06:54 <hparekh> hi
16:07:14 <NikolayM> but he is unavailable now and tomorrow
16:07:17 <_gryf> hi
16:07:35 <NikolayM> so, I think it would be great to have this meeting on wednesday
16:07:48 <dzimine> hi hparekh, _gryf !
16:07:54 <NikolayM> hi!
16:07:55 <lane_kong> the m-2 release date will be Jun 13 or so
16:08:30 <NikolayM> lane_kong, yeah, we have enough time
16:08:59 <NikolayM> guys, what do you think about planning meeting on wednesday?
16:09:24 <m4dcoder> what time on wednesday?
16:09:37 <NikolayM> we can discuss the time
16:10:05 <NikolayM> what your options, m4dcoder?
16:10:27 <m4dcoder> current time is generally hard for me.  can we do US pacific evening time?
16:10:49 <NikolayM> for me it is 7 - 16 UTC
16:11:26 <melisha> ALU folks are at UTC+2
16:11:26 <hparekh> For me 7-14
16:11:43 <lane_kong> i'm at UTC+8
16:12:10 <hparekh> i am at UTC +9
16:12:11 <lane_kong> we can use tools to decide an appropriate time
16:12:19 <NikolayM> hmm, I guess 7-9 UTC would be good for all of us
16:13:53 <lane_kong> http://www.timeanddate.com/worldclock/meeting.html
16:14:31 <NikolayM> what should we do?
16:15:13 <lane_kong> or use Doodle like the meeting renat with ALU guys
16:15:40 <NikolayM> yes, sure
16:16:20 <NikolayM> #action NikolayM: discuss with Renat and confirm appropriate time for planning M-2 on wednesday Dec 16
16:16:28 <m4dcoder> i can join the meeting between 9 PM - 11 PM on Tuesday which is 5 AM - 7 AM UTC.
16:17:18 <NikolayM> m4dcoder, oh, I'll take to account that
16:17:29 <NikolayM> 3. LimorStotland: create the bug related to pep8 fails
16:17:37 <m4dcoder> NikolayM, thanks
16:17:48 <NikolayM> this one is done (on the previous meeting)
16:18:10 <NikolayM> #topic Current Status
16:18:41 <NikolayM> guys, let's tell your status as usually :)
16:19:15 <hparekh> I am working on two blueprints. one is for docker image creation and second one is for tempest plugin.
16:19:17 <melisha> ^Gal^ pushed auto refresh to Executions screen (waiting approval) and now starts working on pagination for Tasks screen
16:19:32 <melisha> LiatFried is owrking on bugs and features in Actions screen
16:19:47 <m4dcoder> 1) still waiting for review/approval for "fix join on branch error" bug 2) need to fix the spec format for "allow env update on task re-run" spec.
16:20:16 <lane_kong> - work on using UUID for workflow operations (spec and implementation); - discussed with hardik about building docker image for mistral; - regular review work.
16:20:19 <NikolayM> my status: reviewed a lot of patches, also looked and reviewed at patch related to disabling qpid and "ack after processing" in oslo.messaging (there were a lot of comments and considerations)
16:20:58 <NikolayM> m4dcoder, I'll try to review your patch asap
16:21:20 <m4dcoder> NikolayM, thanks!
16:21:20 <lane_kong> m4dcoder: me too, after you fix the format
16:21:22 <NikolayM> #action NikolayM: review patch "fix join on branch error"
16:21:37 <m4dcoder> lane_kong, thanks!
16:21:53 <lane_kong> m4dcoder :-)
16:22:37 <NikolayM> so, we could skip next topic "M-2 status and planning" (already discussed)
16:22:49 <NikolayM> and move right to open discussion
16:22:56 <NikolayM> #topic Open Discussion
16:23:52 <NikolayM> what would you like to discuss?
16:23:52 <melisha> What do you think about adding Mistral rules to pep8? Can we make it happen?
16:24:08 <melisha> It will save a lot of time for reviewers and committers
16:24:13 <NikolayM> melisha, I'm not sure on 100% about that
16:24:33 <lane_kong> melisha: what do you mean by 'mistral rules'?
16:24:57 <NikolayM> because our rules in mind are not so determinate
16:25:21 <melisha> I mean Mistral specific rules - like line break before return statement
16:25:32 <melisha> Or period at the end of a comment
16:26:02 <melisha> If a developer could fix that before pushing it will save a lot of time for everyone
16:26:13 <NikolayM> but we can add the rule for multiline method invoking
16:26:32 <NikolayM> absolutely agree
16:26:56 <NikolayM> melisha, are you aware how to do that?
16:26:59 <lane_kong> melisha: yes, i met with this confusion when i started mistral contribution
16:27:51 <melisha> NikolayM: I am not aware but if you will put together a list of rules in a doc - I can try to learn how to enforce them in pep8
16:28:17 <NikolayM> AFAIK it was done by akuznetsova
16:28:30 <NikolayM> there is a blueprint for that with the link to etherpad
16:28:37 <NikolayM> I try to find...
16:29:12 <lane_kong> we can put that in the dev guide for newcomers
16:29:16 <NikolayM> yes! here it is - https://blueprints.launchpad.net/mistral/+spec/add-custom-code-style-checks
16:29:27 <lane_kong> and try to make it automatically checked
16:29:36 <NikolayM> and etherpad link - https://etherpad.openstack.org/p/mistral-additional-codestyle-checks
16:29:54 <lane_kong> #link https://blueprints.launchpad.net/mistral/+spec/add-custom-code-style-checks
16:30:02 <lane_kong> #link https://etherpad.openstack.org/p/mistral-additional-codestyle-checks
16:30:09 <NikolayM> lane_kong, thanks!
16:30:39 <lane_kong> :-)
16:30:59 <melisha> NikolayM, lane_kong: Great! Thanks. I will try to implement one of those and see how it goes
16:31:16 <dzimine> that would be neet.
16:31:17 <NikolayM> melisha, cool!
16:31:53 <lane_kong> melisha: appreciate that
16:32:11 <m4dcoder> different topic, will folks here consider moving this weekly meeting to a different time or day? i prefer US evening time or if AM a different day like Tues/Wed.
16:32:54 <lane_kong> m4dcoder, NikolayM , maybe we need another Doodle poll for that
16:33:35 <melisha> lane_kong: Doodle will be best
16:33:44 <lane_kong> we have contributors from Israel, China, Japan, USA, Russia...
16:33:58 <lane_kong> all over the world
16:34:05 <lane_kong> really hard to decide a perfect tiime
16:34:22 <NikolayM> lane_kong, yup
16:34:46 <lane_kong> maybe after 1 month, we have another contributor from New Zealand :-)
16:35:36 <lane_kong> ok, another topic, hparekh is working on building docker image for mistral
16:35:50 <lane_kong> automatically on patch merge or by time interval
16:36:01 <lane_kong> do you guys familiar with that?
16:36:11 <NikolayM> m4dcoder, we could try to do something with that
16:36:30 <hparekh> lane_kong: Trying to find a way for on automatic patch merge on dockerhub
16:36:45 <m4dcoder> NikolayM, lane_kong, so i will set up a doodle poll and send to ML for folks to vote.
16:36:52 <NikolayM> m4dcoder, but it is hard to move meeting's time on general meeting channels
16:37:06 <NikolayM> m4dcoder, yes, it would be cool
16:37:09 <lane_kong> hparekh: did you reveieve the message i sent to you tonight?
16:37:27 <lane_kong> hparekh: the build job of rally Dockerfile is done within Mirantis internal CI infra.
16:37:37 <m4dcoder> NikolayM, will give it a try if too much resistance then will stick w/ current time.
16:37:39 <hparekh> lane_kong: sorry i am on diffenrent machine.
16:38:05 <lane_kong> hparekh: that's ok, just told you the result of the discussion with rally guys
16:38:28 <lane_kong> and the author of rally image build job
16:38:30 <hparekh> I have seen that but its for testing docker image is building correctly or not. i guess
16:39:05 <lane_kong> hparekh: https://github.com/redixin/rci-config/blob/42bdcffbcfb16834a8895beead0af45b6252bd1b/config.yaml#L277-L316
16:39:10 <dzimine> which repo is mistral dockerfile?
16:39:23 <NikolayM> hparekh, you want to create new job in zuul infra for mistral, is that right?
16:39:31 <hparekh> lane_kong: ok thanks
16:39:57 <lane_kong> dzimine: dockerfile will be in mistral repo
16:40:21 <lane_kong> NikolayM: that's right
16:40:24 <hparekh> NikolyM: yeah right. but afterdiscussed with lane_kong we think its better to have image on docker hub.
16:40:35 <hparekh> Still investigating on that
16:41:01 <NikolayM> yes, it could be updated shen build is success
16:41:06 <NikolayM> when*
16:41:11 <dzimine> is there a WIP review/PR to glance?
16:42:00 <lane_kong> but i don't want the build job to be run on each patch merged
16:42:37 <lane_kong> just run once everyday or some time inteval is enough to users
16:42:38 <NikolayM> lane_kong, why?
16:43:00 <lane_kong> NikolayM: think about if we merge a lot of patches each day
16:43:23 <lane_kong> the building job will be running over and over again
16:43:32 <m4dcoder> how long does this job takes to run?
16:44:14 <lane_kong> it'll download ubuntu image, apt-get update, install softwares and mistral itsefl
16:44:29 <lane_kong> it's not a short time i think
16:44:52 <hparekh> it takes 10 - 15 minutes on my machine
16:45:04 <lane_kong> depends on what's defined in dockerfile
16:45:11 <hparekh> ubntu is predownloaded
16:46:06 <lane_kong> hparekh: what's the progress with integration of Kolla?
16:46:17 <hparekh> i think we can add this script to periodic job of project-config
16:46:27 <m4dcoder> i don't have a preference to either. figuring out where to run this job probably is the blocker here.
16:46:27 <lane_kong> if it's too complex, we can just do Kolla related work
16:46:55 <lane_kong> m4dcoder: yes
16:47:12 <hparekh> lane_kong: There is already blueprint in kolla for that i will attend next kolla weekly meeting and discuss with them
16:47:53 <lane_kong> if integrated with Kolla, maybe we could only have dockerfile in mistral repo
16:48:07 <lane_kong> and tell users how to build image in our user guide
16:48:56 <hparekh> lane_kong: yeah.
16:49:15 <lane_kong> that's the last option
16:49:59 <lane_kong> but, anyway, a docker image will be very helpful for users who want to try mistral
16:50:18 <lane_kong> for me, i use keystone docker image to work with mistral
16:51:40 <lane_kong> so, hparekh, please go ahead to do that
16:52:01 <hparekh> lane_kong: yes thanks
16:52:34 <lane_kong> NikolayM: ok, nothing from my side :-)
16:52:46 <NikolayM> lane_kong, ok
16:53:00 <NikolayM> guys, any questions?
16:53:12 <NikolayM> otherwise I wrap up the meeting
16:53:41 <NikolayM> 5
16:53:44 <NikolayM> 4
16:53:47 <NikolayM> 3
16:53:50 <NikolayM> 2
16:53:53 <NikolayM> 1
16:53:56 <lane_kong> bye, guys
16:53:57 <NikolayM> ok
16:54:00 <NikolayM> bye!
16:54:02 <melisha> Bye
16:54:04 <m4dcoder> alright bye folks
16:54:12 <NikolayM> #endmeeting