16:04:50 <rakhmerov> #startmeeting Mistral
16:04:51 <openstack> Meeting started Mon Feb 29 16:04:50 2016 UTC and is due to finish in 60 minutes. The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:04:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:04:54 <rakhmerov> hi
16:04:55 <openstack> The meeting name has been set to 'mistral'
16:05:09 <nmakhotkin_> hi everyone!
16:05:14 <ddeja> hello
16:06:44 <rakhmerov> 1 sec
16:07:01 <rakhmerov> #topic Review Action Items
16:07:41 <rakhmerov> just one item
16:07:44 <rakhmerov> 1. rakhmerov: propose time slots for 2 different meetings (for 2 groups of people from completely different time zones)
16:07:47 <rakhmerov> not done
16:07:55 <rakhmerov> #action rakhmerov: propose time slots for 2 different meetings (for 2 groups of people from completely different time zones)
16:08:16 <rakhmerov> #topic Current status (progress, issues, roadblocks, further plans)
16:09:06 <rakhmerov> my status: still working on bug https://bugs.launchpad.net/mistral/+bug/1524477, reviewing patches (just a few), emails
16:09:06 <openstack> Launchpad bug 1524477 in Mistral "After-task logic runs multiple times if tasks run in parallel" [High,In progress] - Assigned to Renat Akhmerov (rakhmerov)
16:09:15 <rakhmerov> ^Gal^: you here?
16:09:30 <nmakhotkin_> my status: discussed with rakhmerov and akuznetsova steps for creating HA gate; revewing patches
16:10:19 <akuznetsova> hi there
16:10:26 <rakhmerov> nmakhotkin_: is there a way to finish you RPC patch before M-3 is over?
16:10:58 <rakhmerov> I know you want to create a functional test but maybe we could mock things up in order to have just unit tests?
16:11:02 <akuznetsova> my status is the same as nmakhotkin_
16:11:06 <nmakhotkin_> rakhmerov: the patch itself is ready
16:11:11 <rakhmerov> yes
16:11:13 <rakhmerov> I know
16:11:14 <nmakhotkin_> but it requires a test
16:11:18 <rakhmerov> right
16:11:24 <nmakhotkin_> and it should be a functional test
16:11:29 <rakhmerov> agree
16:11:35 <nmakhotkin_> to do this we need HA-gate :)
16:11:52 <ddeja> maybe merge before M-3 and launch lack of tests as a bug?
16:11:56 <rakhmerov> what I'm trying to say is: we may want to merge the patch with just a unit tests
16:12:12 <rakhmerov> if we can emulate multiple executors somehow
16:12:27 <nmakhotkin_> hmm
16:12:29 <rakhmerov> ddeja: that's an option too
16:12:50 <rakhmerov> here's my concern: that story with HA-gate may take long
16:13:01 <rakhmerov> but folks need that patch
16:13:15 <nmakhotkin_> yes, I try to create a unit-test for that
16:13:47 <akuznetsova> rakhmerov, we have a bp for HA gate, i am not sure that we need bug too
16:14:09 <akuznetsova> and yes, it will need time
16:14:13 <rakhmerov> akuznetsova: no, we are talking about a particular bug
16:14:32 <rakhmerov> that message acknowledgement thing
16:14:37 <akuznetsova> lack of HA tests?
16:14:48 <rakhmerov> for a particular issue
16:14:52 <rakhmerov> not in general
16:15:04 <akuznetsova> i see
16:15:05 <akuznetsova> ok
16:16:08 <ddeja> rakhmerov: Can this patch be merged after M-3, or it must be done in upcoming 3 days?
16:16:26 <rakhmerov> ddeja: since this is a bug it can be merged after M-3
16:16:45 <ddeja> that's a good thing
16:16:46 <rakhmerov> but I just don't want to have another excuse for deffering it
16:16:56 <ddeja> ok
16:18:07 <rakhmerov> ok
16:18:21 <rakhmerov> I wonder if we have anyone else on the meeting
16:18:30 <rakhmerov> Lingxian is not here
16:19:56 <rakhmerov> I wanted to review M-3 BPs and bugs but looks like it doesn't make a lot of sense now
16:20:53 <rakhmerov> about a half of our BPs will be done
16:21:22 <rakhmerov> a little bit better with bugs
16:21:50 <rakhmerov> ok, let's skip a detailed review
16:22:11 <rakhmerov> I was hoping that some of ALU folks would be here
16:22:40 <rakhmerov> we have some UI patches and they need to be rebased
16:22:48 <rakhmerov> I'll contact them separately
16:23:03 <rakhmerov> #action rakhmerov: ask ALU folks to rebase patches
16:23:10 <rakhmerov> ok
16:23:18 <rakhmerov> #topic Open Discussion
16:23:29 <rakhmerov> any specific questions?
16:23:43 <rakhmerov> I'd ask you to review patches actively this week
16:23:50 <nmakhotkin_> ok
16:23:54 <rakhmerov> we need to put as many patches as possible
16:23:55 <rakhmerov> yes
16:24:10 <rakhmerov> there's a few patches now with 1 +2 vote on review
16:24:30 <rakhmerov> so, if that's all then let's end the meeting
16:24:41 <rakhmerov> not many people today here
16:25:41 <rakhmerov> counting to 10 and finish
16:25:42 <rakhmerov> 1
16:25:43 <rakhmerov> 2
16:25:43 <rakhmerov> 3
16:25:45 <rakhmerov> 4
16:25:47 <rakhmerov> 5
16:25:49 <rakhmerov> 6
16:25:51 <rakhmerov> 7
16:25:53 <rakhmerov> 8
16:25:55 <rakhmerov> 9
16:25:57 <rakhmerov> 10
16:26:01 <rakhmerov> thanks, I'll see you online
16:26:10 <rakhmerov> bye
16:26:22 <rakhmerov> #endmeeting