16:01:33 <rakhmerov> #startmeeting Mistral
16:01:34 <openstack> Meeting started Mon Jun 20 16:01:33 2016 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:37 <openstack> The meeting name has been set to 'mistral'
16:01:40 <rakhmerov> hi all
16:01:42 <d0ugal> Hello!
16:01:46 <ddeja> rakhmerov: o/
16:01:48 <jpeeler> hi
16:02:07 <rakhmerov> hi
16:02:13 <mgershen> hi
16:02:22 <rakhmerov> d0ugal: just saw your conversation about meeting time
16:02:27 <d0ugal> :)
16:02:36 <rakhmerov> :)
16:02:51 <rakhmerov> there was an idea to have 2 meetings, bi-weekly
16:03:13 <mgershen> 2 meetings is a lot
16:03:14 <rakhmerov> but honestly I didn't get a lot of feedback on convenient time for different locations
16:03:43 <rakhmerov> no, I mean one week - for Asia/Europe and another week for North America
16:04:03 <rakhmerov> dunno, maybe we will make it
16:04:04 <mgershen> sorry
16:04:08 <rakhmerov> np
16:04:16 <d0ugal> This is fine, I might just need to leave a bit early today.
16:04:40 <rakhmerov> as we now have more people I would actually ask you to vote for convenient time slots
16:04:41 <rakhmerov> soon
16:04:43 <rakhmerov> d0ugal: np
16:04:49 <rakhmerov> ok, let's start then
16:05:21 <d0ugal> rakhmerov: k, maybe we can do a vote on the mailing list
16:05:25 <rakhmerov> first of all, I have to apologize again for not sending you a notice last time that we wouldn't have a meeting
16:06:04 <rakhmerov> d0ugal: yes, there's already a thread but it's kind of obsolete now, I'll need to check if the slots that I suggested ~ 2 months ago are still available
16:06:10 <rakhmerov> I'll check that
16:06:39 <rakhmerov> #action rakhmerov: check time slots for bi-weekly meetings again
16:06:44 <d0ugal> Thanks
16:07:28 <rakhmerov> #topic Current status (progress, issues, roadblocks, further plans)
16:08:37 <rakhmerov> my status: I spent last week mostly on reviews, IRC and doing some internal stuff, also researched a lot of Keystone stuff including Federation API and auth plugins
16:09:08 <rakhmerov> also finished Custom Actions API spec: https://review.openstack.org/#/c/325769/
16:09:12 <rakhmerov> so please review
16:10:01 <rakhmerov> as far as that spec, I don't think it's possible to fill it with more details at this stage so I guess particular method signatures etc. is out of its scope
16:10:01 <ddeja> my status: Write unit tests for kombu driver for alternative RPC API and fix some bugs while doing so - they are ready for review I guess + done some reviews (not a lot of unfortunately)
16:10:25 <rakhmerov> ddeja: finally, I'm gonna have time tomorrow to review these patches
16:10:58 <ddeja> rakhmerov: thanks
16:11:23 <mgershen> I have some bugs and blueprints on me, but I haven't started them (working on internal stuff). If anyone needs them and want to work on them now, just let me know.
16:11:40 <ddeja> I'd like to apologise that it took me this long...
16:12:04 <rakhmerov> ddeja: that's totally fine, the task is pretty hairy IMO
16:12:25 <rakhmerov> mgershen: do you expect to start with them any time soon?
16:12:52 <rakhmerov> if not too soon we may want to give part of your tasks to someone else
16:13:42 <rakhmerov> please let me know once you know
16:14:05 <mgershen> rakhmerov: it might take 2 weeks
16:14:15 <rakhmerov> ooh, ok
16:14:34 <rakhmerov> mgershen: let's talk offline tomorrow about that
16:14:41 <rakhmerov> jpeeler, d0ugal: any updates from your side guys?
16:14:48 <mgershen> rakhmerov: sure
16:14:56 <rakhmerov> d0ugal: I saw your patch today, left my comments
16:15:09 <d0ugal> I've mostly been working on the TripleO side of things, but I did manage to start on https://bugs.launchpad.net/mistral/+bug/1568541
16:15:09 <openstack> Launchpad bug 1568541 in Mistral "action-update API on non existing action - creates action instead of returning 404" [Medium,In progress] - Assigned to Dougal Matthews (d0ugal)
16:15:13 <rakhmerov> I guess we discussed that already
16:15:17 <d0ugal> I'll continue that and expect to have a new version soon
16:15:27 <rakhmerov> ok, awesome
16:15:27 <d0ugal> Yup, nothing else to say about my patch yet :)
16:15:30 <jpeeler> i haven't started working on mistral fully yet, so no direct status yet
16:15:48 <rakhmerov> ok
16:15:57 <d0ugal> jpeeler: You have been working on the TripleO workflows which is somewhat related :)
16:15:58 <rakhmerov> jpeeler: just for my records, what time zone are you in?
16:16:09 <rakhmerov> yeah :)
16:16:46 <jpeeler> d0ugal: true... it's sort of hard to know what's relevant to report
16:16:54 <d0ugal> indeed.
16:17:22 <jpeeler> i've been working on adding zaqar messaging to some of our workflows. since i'm pretty new still, this has been helpful in learning mistral in general.
16:17:29 <jpeeler> rakhmerov: EST
16:17:42 <rakhmerov> well, I'm personally also interested in those Mistral related activities
16:18:07 <rakhmerov> jpeeler: ok, so it's early morning for you now
16:18:09 <rakhmerov> got it
16:18:35 <jpeeler> ok that's good to hear. didn't want to assume anything. and it's 12:18 PM for me now, fwiw
16:18:46 <rakhmerov> yeah, I see
16:18:51 <rakhmerov> not too early
16:19:06 <ddeja> but in a lunch time ;)
16:19:18 <rakhmerov> let's move on to the next topics?
16:19:22 <d0ugal> +1
16:19:34 <rakhmerov> ooh, so is our meeting stealing your lunch? ;)
16:19:49 <rakhmerov> that's pretty bad :)
16:20:15 <rakhmerov> #topic Custom Actions API spec
16:20:34 <rakhmerov> https://review.openstack.org/#/c/325769/
16:21:14 <rakhmerov> so, again: I hope it's kind of finished although someone may want to see more details to be able to start working on it
16:21:23 <rakhmerov> but I'd like to review it again
16:21:40 <rakhmerov> hoping that we'll agree on it soon
16:21:48 * d0ugal adds to review list for tomorrow
16:22:07 <rakhmerov> once it happens I'd like to get you involved in helping with this
16:22:12 <jpeeler> yeah i'll read over it too
16:22:19 <rakhmerov> ok
16:22:38 <rakhmerov> so basically, I was going to ask who could be volunteers for this
16:22:59 <rakhmerov> I know that rbrady wants to help with this
16:23:08 <rakhmerov> not sure who else of you is directly interested
16:23:34 <rakhmerov> I see a number of work items that we could spread among us
16:23:45 <d0ugal> I would like to help
16:24:00 <ddeja> I *may* be able to help, but not sure how long I will be dealing with RPC API, so I do not want to declare anything right now
16:24:05 <rakhmerov> d0ugal: yeah, I think it's directly related to you
16:24:26 <d0ugal> rakhmerov: Yup :)
16:24:43 <rakhmerov> ddeja: thanks! Let's focus on RPC first, I hope we can knock it down soonish
16:25:01 <rakhmerov> the reason I'm paying that much attention to this topic is its importance
16:25:11 <rakhmerov> no need to repeat probably
16:26:02 <rakhmerov> ok, so rbrady, d0ugal and potentially ddeja are ready to help with Custom Actions API
16:26:08 <jpeeler> if it's a three person job, i could also help
16:26:13 <jpeeler> s/three/four
16:26:16 <rakhmerov> #info rbrady, d0ugal and potentially ddeja are ready to help with Custom Actions API
16:26:26 <rakhmerov> #info and jpeeler
16:26:27 <rakhmerov> :)
16:27:01 <rakhmerov> jpeeler: yeah, I think we could split it
16:27:34 <rakhmerov> even if we couldn't this kind of work requires as much feedback as possible anyway
16:28:07 <rakhmerov> we're working an API, it should be as thoughtfully designed as possible
16:28:15 <d0ugal> +1
16:28:30 <rakhmerov> we need to be posting a lot info on ML as well to get a wider feedback
16:29:06 <rakhmerov> so on one hand we need to be active with that, but not sacrificing quality at the same time
16:29:18 <rakhmerov> (trying to inspire you)
16:29:19 <rakhmerov> :)
16:29:26 <rakhmerov> (and myself, too)
16:29:34 <rakhmerov> ok
16:29:36 * ddeja feels inspired
16:29:40 <rakhmerov> :))
16:29:45 <rakhmerov> ddeja: thanks man!
16:30:07 <rakhmerov> ok, nothing else on this topic
16:30:27 <rakhmerov> #topic Automated testing for OpenStack actions
16:31:09 <rakhmerov> this is a topic that we wanted to discuss with hparekh but seems like he didn't make it to the meeting
16:31:39 <d0ugal> Sounds like an interesting topic
16:31:39 <rakhmerov> he had some ideas on how we can automate testing of the whole bunch of OpenStack actions that we have
16:31:43 <rakhmerov> yeah
16:32:13 <d0ugal> I would like a way to automate testing workflows, which is sort-of related :)
16:32:22 <rakhmerov> he wrote me an email about possible approaches (~ an hour ago), but I didn't read it yet
16:32:34 <rakhmerov> d0ugal: what workflows?
16:32:50 <rakhmerov> well, yes, that's the next level I guess
16:33:28 <d0ugal> rakhmerov: Just any workflows. There is no easy way to automate testing or even validating them
16:33:29 <rakhmerov> the reason it was brought up is because people keep coming in to our IRC and claiming that Mistral doesn't work!
16:33:34 <d0ugal> lol
16:34:02 <ddeja> rakhmerov: I kind of understand them... Remember my first time with mistral ;)
16:34:06 <rakhmerov> because they try some stuff and that really now always works, and in most cases it turns out that it's about not working OpenStack actiosn
16:34:16 <rakhmerov> not Mistral itself
16:34:29 <rakhmerov> ddeja: yep
16:34:36 <rakhmerov> I know
16:34:39 <d0ugal> ddeja: did it not work? :)
16:34:46 <rakhmerov> I clearly realize that's painful
16:35:07 <rakhmerov> you all know how these actions look like from implementation perspective
16:35:12 <ddeja> d0ugal: yup. Took me sometime to make it work despite the fact that I had some OpenStack background
16:35:31 <rakhmerov> they are dynamically generated with using those mapping.json file that we have to support manually
16:35:46 <rakhmerov> and if some APIs change we have to react
16:35:58 <rakhmerov> so
16:36:18 <rakhmerov> it would be really cool if we could test them automatically
16:36:27 <rakhmerov> at some gate
16:36:49 <rakhmerov> may be at least not on every commit, I don't know
16:37:01 <rakhmerov> because I can imagine how many tests that would be
16:37:25 <rakhmerov> or maybe we could create multiple gates, a gate per a service (e.g. for Nova)
16:37:43 <rakhmerov> or maybe we could take a representative subset of actions per service
16:37:48 <d0ugal> They should probably be non-voting gates
16:37:55 <rakhmerov> (just brainstorming now actually)
16:37:57 <ddeja> I guess the last one would be best
16:38:04 <rakhmerov> d0ugal: I think so, yes
16:38:18 <rakhmerov> ddeja: yep, maybe
16:38:25 <rakhmerov> one more important thing here
16:38:37 <ddeja> Just write some workflows that would use core openstack-clients and test them
16:38:45 <rakhmerov> at some point we will move OpenStack actions to a separate subproject
16:39:13 <rakhmerov> and I think it's ok if that subproject's gates will take long to complete
16:39:27 <rakhmerov> because it won't hard core Mistral development
16:39:41 <rakhmerov> ddeja: yes
16:40:16 <rakhmerov> d0ugal: btw, as far as workflow, do you mean some real-life workflows that use some OpenStack stuff?
16:40:26 <d0ugal> rakhmerov: Yup
16:40:33 <rakhmerov> or you're mostly talking about workflow capabilities?
16:41:09 <rakhmerov> if latter, that's covered well in unit tests and we also planned to write a number of functional tests
16:41:12 <d0ugal> rakhmerov: Real life workflows. We don't have a good approach to testing and validating them in TripleO
16:41:24 <rakhmerov> d0ugal: I see
16:41:32 <d0ugal> It is a tricky problem :)
16:41:37 <rakhmerov> I bet
16:42:02 <rakhmerov> well, the first thing that comes to my mind is standing up a production-like environment
16:42:19 <rakhmerov> but that is probably a hard thing to do
16:42:44 <d0ugal> rakhmerov: Yeah, we have that and it works quite well, but it will probably only ever cover the main path, lots of edge cases wont be tested
16:42:50 <rakhmerov> and run tests against it, but making sure we do a proper clean up after tests etc.
16:43:09 <rakhmerov> d0ugal: right, I see what you're saying
16:43:16 <rakhmerov> hm.. yeah
16:43:22 <d0ugal> ... but I don't want to side track the meeting :)
16:43:32 <d0ugal> it is just something I am thinking about
16:43:33 <rakhmerov> d0ugal: that's fine
16:43:55 <rakhmerov> d0ugal: share your ideas pls if you get them
16:44:25 <rakhmerov> one fundamental problem I see here is that most workflows take long
16:44:30 <d0ugal> rakhmerov: Will do. I'll find some time to write them to the list
16:44:55 <d0ugal> Ideally I would really like a way to run a workflow with mocked services
16:45:04 <rakhmerov> so that if we decide to test all various paths it'll be no good )
16:45:21 <rakhmerov> d0ugal: hm... that is interesting
16:46:50 <rakhmerov> d0ugal: I think it's actually a complex problem meaning that the ultimate goal is to have more confidence in workflows that we deal with and because of that it's not only automated tests but also other means that would help to have that confidence
16:47:13 <rakhmerov> validation tools, graphical tools that provide some assistance when designing them
16:47:14 <rakhmerov> etc. etc
16:47:40 <rakhmerov> more convenient ways to debug workflows and find errors
16:47:49 <rakhmerov> the last one is especially important
16:47:56 <d0ugal> +1
16:48:17 <d0ugal> rakhmerov: I spoke with rbrady about some of this, so maybe we can chat again about it at the meeting next week.
16:48:30 <rakhmerov> absolutely
16:48:40 <rakhmerov> yes, please guys share any ideas
16:49:07 <rakhmerov> I have a bunch of them in my head )
16:49:21 <d0ugal> haha, I'm sure :)
16:49:28 <rakhmerov> just don't know how to find resources to help with all that
16:49:52 <rakhmerov> but some of that is already in progress
16:50:17 <rakhmerov> it's kind of a mystery for you probably but hopefully we'll make an announcement relatively soon
16:50:19 <d0ugal> Should we move onto open discussion?
16:50:22 <d0ugal> I guess we already are :)
16:50:26 <rakhmerov> by "we" I mean Nokia
16:50:40 <rakhmerov> ok, yes
16:50:43 <d0ugal> oh, that sounds interesting
16:51:12 <rakhmerov> #action rakhmerov: read Hardik's email about testing OS actions and share with the team
16:51:24 <rakhmerov> #topic Open Discussion
16:52:19 <rakhmerov> d0ugal: yeah :) I saw a little myself but once finished it will be a bomb!
16:52:28 <rakhmerov> no kidding
16:53:00 <rakhmerov> I'm not allowed to tell more though atm
16:53:11 <d0ugal> hah, so you just tease us :)
16:53:15 <ddeja> I have one topic: Since alternative RPC layer is done (for better or worse) I would like to start working on tagging each message for processing type (at-least-once vs at-most-once). Are you guys OK with this?
16:53:17 <rakhmerov> yes!!
16:53:48 <rakhmerov> ddeja: yes, I'm ok
16:54:10 <rakhmerov> just be ready to fix something in your patches
16:54:14 <rakhmerov> if needed
16:54:21 <ddeja> rakhmerov: yeah, sure
16:55:50 <rakhmerov> I feel like I'm done for today, nothing else from my side
16:55:58 <ddeja> I'm also done
16:56:03 * d0ugal is done
16:56:12 <rakhmerov> mgershen, jpeeler?
16:56:19 <jpeeler> all good here
16:56:38 <rakhmerov> jpeeler: I hope you will still have your lunch :))
16:56:51 <rakhmerov> ok, guys
16:56:54 <jpeeler> ha, i'm going to go do that now!
16:56:59 <rakhmerov> thanks a lot for joining today
16:57:15 <rakhmerov> you have a great time during the week )
16:57:24 <rakhmerov> bye
16:57:27 <d0ugal> Thanks!
16:57:28 <ddeja> bye
16:57:32 <d0ugal> bte
16:57:35 <d0ugal> bte!
16:57:38 <d0ugal> bye!
16:57:42 * d0ugal is also done, he can't type
16:57:42 <rakhmerov> #endmeeting