16:00:12 <rakhmerov> #startmeeting Mistral
16:00:13 <openstack> Meeting started Mon Aug  8 16:00:12 2016 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:17 <openstack> The meeting name has been set to 'mistral'
16:00:18 <rakhmerov> hi
16:00:32 <mgershen> o/
16:00:33 <ddeja> hello
16:00:35 <d0ugal> Hey!
16:00:37 <hparekh_> hi
16:00:51 <rakhmerov> hi all
16:01:01 <rbrady> hi
16:01:06 <rakhmerov> hi
16:01:07 <rakhmerov> ok, let's go through our typical list of topics
16:02:28 <rakhmerov> #topic Review Action Items
16:02:30 <rakhmerov> 1. rakhmerov: find out with hparekh if "hparekh_: create a BP for YAQL functions API" is done
16:02:34 <rakhmerov> hparekh_: ?
16:02:43 <hparekh_> rakhmerov: done
16:02:46 <rakhmerov> ok )
16:02:50 <d0ugal> \o/
16:03:03 <rakhmerov> #topic Current status (progress, issues, roadblocks, further plans)
16:03:50 <rakhmerov> my status: making required changes in order to remove pessimistic locks from engine, really close, basically just 'with-items' left (almost done too)
16:04:05 <ddeja> My status: Only 3 days of regular work; mostly reviews.
16:04:13 <rakhmerov> other than that: reviews and other small bugs
16:04:21 <rakhmerov> ddeja: ok )
16:04:32 <rakhmerov> ddeja: how was your conf/meetup?
16:04:47 <d0ugal> Most of my time is taken up with getting TripleO to use Mistral. Otherwise I fixed my first bug with ddeja's help :)
16:04:51 <rbrady> status: I pushed up a WIP patch and sent email to the list.  Looking at adding some of the other util methods (e.g. get_execution_id, etc)
16:05:00 <hparekh_> my status: finished SSL support for mistral. little work is pending at client side. Reviewed some patches.
16:05:01 <rakhmerov> d0ugal: congrats!
16:05:03 <rakhmerov> :)
16:05:22 <d0ugal> ... and now I'm looking for other small-ish bugs I can work on while focusing on the TripleO work.
16:05:24 <d0ugal> rakhmerov: Thanks!
16:05:27 <ddeja> rakhmerov: It was OK. There was some people from Nokia Poland ;) Also some guys want to try Mistral for Automatic Evacuation, so it si good I guess
16:05:40 <rakhmerov> d0ugal: let's take it offline for tomorrow, ok?
16:05:54 <rakhmerov> ping me and we'll find something
16:05:56 <mgershen> I worked on the db migrations and now on adding rally tests to check workflow execution performance
16:06:08 <d0ugal> rakhmerov: sure, sounds good. I have one I am starting to look at too
16:06:12 <rakhmerov> ddeja: ok
16:06:19 <rakhmerov> d0ugal: ok
16:06:23 <ddeja> d0ugal: or you can ping me, I have one small item to fix :)
16:06:39 <d0ugal> rakhmerov, ddeja: I think you both might keep me very busy lol
16:07:03 <rakhmerov> :) np
16:07:04 <ddeja> we can try I guess ;)
16:07:33 <rakhmerov> mgershen: cool, keep in mind that we're waiting for a migration for 'unique_key' column ;)
16:07:47 <rakhmerov> especially folks from Red Hat
16:07:52 <d0ugal> and TripleO :)
16:08:12 <rakhmerov> yes
16:08:48 <rakhmerov> mgershen: so I would ask you to create a migration first and then switch back to Rally
16:08:50 <mgershen> I think it's in haha
16:09:05 <mgershen> https://review.openstack.org/#/c/352376/
16:09:10 <rakhmerov> mgershen: hm... what do you mean?
16:09:14 <rakhmerov> wait a sec..
16:09:50 <rakhmerov> oooh, you guys are really fast!
16:10:00 <rakhmerov> I didn't even have a chance to look at it :)
16:10:03 <rakhmerov> good, ok
16:10:09 <rakhmerov> mgershen: sorry, I missed it
16:10:23 <rakhmerov> please proceed with Rally
16:10:23 <d0ugal> mgershen: we very much appreciated it :)
16:10:28 <mgershen> np :)
16:10:45 <rakhmerov> mgershen: and I also assigned another bug to you today, you probably saw it
16:10:48 <d0ugal> Is there a way we can test the migrations to avoid that happening?
16:11:06 <d0ugal> I should maybe wait for open discussion to chat about it more...
16:11:07 <rakhmerov> d0ugal: we should, definitely
16:11:23 <rakhmerov> "not enough hands" is our main problem atm though )
16:11:26 <d0ugal> Right
16:11:26 <mgershen> yes, I did, I'll do after the rally test
16:11:56 <rakhmerov> other big projects test migrations automatically, yes
16:12:09 <d0ugal> rakhmerov: Okay, shall I create a bug? I could look into that.
16:12:23 <rakhmerov> d0ugal: it would be nice of you
16:12:29 <rakhmerov> please
16:12:39 <d0ugal> Sure, doing that :)
16:13:00 <rakhmerov> ok, so I don't actually have any specific topics for this meeting
16:13:10 <rakhmerov> let's go to open discussion
16:13:16 <rakhmerov> #topic Open Discussion
16:13:45 <d0ugal> rakhmerov: Do you know of an example project that is already doing the migration tests?
16:13:48 <rakhmerov> raise your topics, if any
16:13:54 <hparekh_> rakhmerov: Have you get chance to look at https://bugs.launchpad.net/mistral/+bug/1609335 ?
16:13:54 <openstack> Launchpad bug 1609335 in Mistral "Retry get executed even if action is success" [Undecided,New] - Assigned to Lucky samadhiya (lucky-samadhiya)
16:13:58 <mgershen> d0ugal: don't add the test yet, we still have need to migrate the data in executions table to the new ones
16:14:11 <rakhmerov> d0ugal: I believe any big project like Nova or Nuetron
16:14:12 <d0ugal> mgershen: ah, okay. I'll just start to look into it.
16:14:25 <d0ugal> rakhmerov: k, I'll take a look.
16:14:29 <rakhmerov> yep
16:14:37 <hparekh_> rakhmerov: Actually tacker folks use this.
16:14:40 <d0ugal> It would also be good to run the tests against real databases, I set this up in a previous project too
16:15:05 <rakhmerov> hparekh_: use what? automatic tests for migrations?
16:15:42 <hparekh_> No Its about 'on-continue' :)
16:15:50 <hparekh_> the link I shared
16:16:13 <rakhmerov> ooh, I still haven't looked at it
16:16:27 <rakhmerov> #action rakhmerov: look at https://bugs.launchpad.net/mistral/+bug/1609335
16:16:27 <openstack> Launchpad bug 1609335 in Mistral "Retry get executed even if action is success" [Undecided,New] - Assigned to Lucky samadhiya (lucky-samadhiya)
16:16:44 <rakhmerov> sorry, I've been too focused on my performance stuff
16:16:46 <hparekh_> rakhmerov: Thanks
16:16:51 <rakhmerov> forgot the names of my kids...
16:16:53 <rakhmerov> kind of
16:17:14 <rakhmerov> hparekh_: will do, no worries
16:17:33 <hparekh_> rakhmerov: Its Ok no issue :)
16:17:38 <rakhmerov> hparekh_: the semantics I told you lately in our channel is really what it does
16:17:46 <rakhmerov> however, I totally agree it's confusing
16:18:19 <rakhmerov> hparekh_: it came from a specific use case and I am not sure that it's ok in general
16:18:32 <rakhmerov> we'll need to clarify this, at least improve our docs
16:18:59 <rakhmerov> rbrady: how is your stuff going on?
16:19:00 <hparekh_> rakhmerov: Actually Its not working as we discuss. Also the description on blueprint and the one we discuss are conflicting each other
16:19:37 <rakhmerov> hparekh_: ok, maybe. I believe very few people use it and it may not be tested well
16:20:13 <rakhmerov> hparekh_: also, I'd recommend to hold off with that for now till I make fixes in 'with-items' (currently working on)
16:20:17 <rbrady> rakhmerov: added a patch and sent mail to list to solicit feedback about the approach.  Need to add a few more utility methods.
16:20:17 <rakhmerov> it's kind of related
16:20:30 <rakhmerov> rbrady: ok
16:20:34 <hparekh_> rakhmerov: Ok
16:20:58 <rakhmerov> #action rakhmerov: take a look at the patch sent by rbrady and ML message
16:21:58 <rakhmerov> ddeja: just noticed https://review.openstack.org/#/c/352480/
16:22:02 <rakhmerov> cool
16:22:37 <rakhmerov> is zmq something really demanded at Intel or you're just reaching for feature parity with o.m?
16:22:38 <ddeja> rakhmerov: no problem. It took me more time then I think it would thou
16:22:52 <ddeja> rakhmerov: well, not really
16:23:03 <rakhmerov> that's no problem, it took much less time that I thought it would take :)
16:23:15 <ddeja> the point is, get_rpc_info_from_oslo is run on start of every service
16:23:24 <rakhmerov> yes
16:23:48 <ddeja> so we do not want it to raise an exception when someone is using zmq at the start
16:23:59 <rakhmerov> right
16:24:08 <rakhmerov> totally agree
16:24:11 <rakhmerov> good job
16:24:22 <ddeja> it's just a fix so we do not break mistral+zmq in Newton
16:24:30 <rakhmerov> yes
16:25:03 <rakhmerov> ok, I don't have anything else from my side, targeting to finish my current stuff by the middle of the week (maybe tomorrow)
16:25:24 <rakhmerov> I'll send out an announcement in ML once it's done
16:26:27 <rakhmerov> anything else from you guys?
16:26:37 <ddeja> nothing from my side
16:26:39 <rakhmerov> if no, we can end the meeting
16:26:41 <d0ugal> Nothing from me
16:26:51 <d0ugal> rbrady: I will review you patch tomorrow
16:27:03 <rbrady> d0ugal: thanks
16:27:05 <rakhmerov> yeah, I'm looking forward to review it too
16:27:37 <rakhmerov> ok, let's finish earlier today and save some time
16:27:41 <rakhmerov> thanks for coming
16:27:50 <d0ugal> Thanks!
16:27:50 <rakhmerov> bye and have a great week
16:27:56 <hparekh_> thanks
16:27:56 <rbrady> thanks.  bye
16:27:59 <ddeja> thanks, bye
16:28:06 <rakhmerov> #endmeeting