16:01:15 <rakhmerov> #startmeeting Mistral
16:01:16 <openstack> Meeting started Mon Nov 21 16:01:15 2016 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:20 <openstack> The meeting name has been set to 'mistral'
16:01:31 <rakhmerov> hi
16:01:32 <ddeja> o/
16:01:37 <sharatss> rakhmerov: hi
16:01:43 <rakhmerov> hi-hi
16:01:47 <rakhmerov> how are you guys?
16:02:08 <sharatss> rakhmerov: i am fine. you?
16:02:14 <rakhmerov> ok
16:02:17 <ddeja> I'm very fine, thanks. How you doin?
16:02:17 <rakhmerov> still alive :)
16:02:35 <sharatss> ^^ :))
16:02:45 <rakhmerov> d0ugal said he'd be late
16:02:59 <mgershen> Hi
16:03:05 <rakhmerov> mgershen: hi Michal )
16:03:40 <rakhmerov> ok, let's start
16:03:52 <rakhmerov> maybe someone else will join as we go
16:03:56 <rakhmerov> #topic Review action items
16:04:46 <rakhmerov> 1. d0ugal to create a doodle poll for the meeting time and/or follow up on the list with the results of the etherpad
16:04:56 <rakhmerov> partially done
16:05:11 <rakhmerov> as it turns out the current time works for most people
16:05:34 <rakhmerov> we may just add an alternate time for other folks
16:05:42 <rakhmerov> he just wrote an email about it
16:06:10 <rakhmerov> 2. rakhmerov, rbrady, d0ugal: look at the StackStorm's implementation of actions to get more ideas and understanding of how it should be done
16:06:34 <rakhmerov> I haven't looked at it yet closely
16:06:44 <rakhmerov> only scratched the surface
16:07:08 <rakhmerov> not sure about d0ugal and rbrady, this is actually something I was hoping to discuss with them today
16:07:20 <rakhmerov> 3. d0ugal, rbrady: update the Custom Actions API spec
16:07:28 <rakhmerov> I believe this is WIP
16:07:51 <rakhmerov> 4. d0ugal, rbrady: summarize the challenges we have with the current approach (decomposition into different repos etc.)
16:08:31 <rakhmerov> We need info from d0ugal but I believe it's WIP too
16:08:39 <rakhmerov> #topic Current status
16:09:43 <ddeja> My status: Reviews. And thanks to you all guys I know how to proceed with workflow-precondition spec, so I'll enchance it this week
16:10:03 <mgershen> Working on the new tasks function with good progress
16:10:49 <rakhmerov> my status: fixed a number of small but urgent (for us) bugs, started working on https://bugs.launchpad.net/mistral/+bug/1622534, after that I'm planning to fix 'with-items concurrency' and multiple engines
16:10:49 <openstack> Launchpad bug 1622534 in Mistral "Incorrect launching of Mistral components" [High,Confirmed] - Assigned to Renat Akhmerov (rakhmerov)
16:11:15 <rakhmerov> ddeja: my fault, I still haven't looked at it yet
16:11:27 <rakhmerov> I will for sure, I'll have time time tomorrow
16:11:35 <rakhmerov> was busy all the time with something urgent
16:11:53 <ddeja> rakhmerov: you can wait till wednesday, tommorow I'll re-write it based on input from others
16:12:03 <rakhmerov> mgershen: awesome, any roadblocks?
16:12:17 <rakhmerov> ddeja: ok, then just ping me any time
16:12:21 <ddeja> ok
16:13:11 <mgershen> Going well, will send a new PS this week.
16:14:12 <rakhmerov> ok
16:14:38 <rakhmerov> d0ugal: on your way to the meeting? :)
16:15:36 <rakhmerov> btw, another thing: I should have repair our lost gate
16:15:41 <rakhmerov> for unit tests on postgres
16:15:51 <rakhmerov> but CI was down the whole day today
16:15:53 <rakhmerov> let me see
16:16:30 <rakhmerov> it is still down
16:16:49 <rakhmerov> but I see that the gate is back
16:16:53 <rakhmerov> which is good
16:17:06 <rakhmerov> I'm also planning to add a similar gate but for mysql
16:18:05 <rakhmerov> ook, I was actually planning to discuss updates on Custom Actions API with d0ugal and rbrady now
16:18:18 <rakhmerov> but not sure if they are here
16:18:18 <rbrady> o/
16:18:28 <rakhmerov> ooh, hi Ryan
16:18:32 <rakhmerov> how are you?
16:18:40 <rbrady> I'm doing well
16:18:42 <rbrady> thanks
16:18:44 <rakhmerov> ok
16:19:01 <rakhmerov> did you have a chance to do something on Mistral last couple of weeks?
16:19:38 <rbrady> I did not.  I took some time off and it reduced my bandwidth
16:20:04 <rakhmerov> ok
16:20:07 <rbrady> this is a short week for me as well with a US holiday, but next week I should be doing more with Mistral
16:20:29 <rakhmerov> what is that? Thanksgiving?
16:20:34 <rbrady> yes
16:20:40 <rakhmerov> ooh, cool!
16:20:47 <rakhmerov> ok, thanks
16:21:10 <rakhmerov> then I'm still hoping that d0ugal will join us soon
16:21:21 <rakhmerov> ok, guys, do you have anything else to discuss?
16:21:28 <rakhmerov> sharatss, ddeja, mgershen?
16:21:52 <ddeja> I have nothing
16:21:53 <rakhmerov> sharatss: I remember I promised to review your patch
16:21:56 <rakhmerov> I will
16:22:01 <mgershen> Nothing on my side
16:22:05 <sharatss> rakhmerov: i am mainly concentrating on the CLI part
16:22:15 <sharatss> rakhmerov: haha :) thanks
16:22:27 <rakhmerov> sharatss: what exactly are you doing in CLI?
16:22:30 <rakhmerov> so that we know
16:22:32 <d0ugal> Hey all - sorry I'm late!
16:22:45 * d0ugal reads up
16:22:48 <sharatss> rakhmerov: improving the --debug info
16:23:06 <rakhmerov> d0ugal: that's ok, seems like we just finished discussing all we had and wanted to move to your stuff
16:23:12 <rakhmerov> sharatss: ooh, this is good
16:23:33 <sharatss> rakhmerov: trying to bring in the cURL output when --debug is used
16:23:33 <rakhmerov> sharatss: do we have a BP/bug where you can track your progress?
16:23:53 <sharatss> rakhmerov: we do
16:23:55 <rakhmerov> I remember we had something that it was filed in 'mistral' project, not 'python-mistralclient'
16:23:55 <d0ugal> rakhmerov: cool, I am not sure I have that much stuff :)
16:24:13 <rakhmerov> if so, you need to file it in the right project
16:24:23 <sharatss> rakhmerov: https://blueprints.launchpad.net/mistral/+spec/improve-cli-debug-option
16:24:32 <rakhmerov> sharatss: yes, right
16:24:53 <rakhmerov> please close this one and file the same in 'python-mistralclient' and associate your commits on it with it
16:25:06 <rakhmerov> d0ugal: yeah, any updates from you?
16:25:27 <rakhmerov> d0ugal: I wanted to discuss any updates on actions, if you have them
16:25:27 <sharatss> rakhmerov: i am also trying to implement the i18n translation support for all our sub projects
16:25:42 <rakhmerov> sharatss: ok, good
16:25:55 <sharatss> rakhmerov: i will ping you the link soon
16:26:05 <d0ugal> rakhmerov: I started looking at the stackstorm code - but honestly I got a bit lost and couldn't really find our how their actions work.
16:26:17 <rakhmerov> sharatss: please also try to finish the patch with 'retry', it's a pretty serious bug, I'd like to see it fixed as soon as possible
16:26:18 <d0ugal> rakhmerov: but their code base is large, so I guess I just need to spend a bit more time on it
16:26:41 <rakhmerov> d0ugal: ok, I see
16:26:54 <sharatss> rakhmerov: i have fixed the test cases
16:26:55 <rakhmerov> d0ugal: I also looked at it just a little bit
16:27:00 <rakhmerov> ok
16:27:06 <sharatss> rakhmerov: https://review.openstack.org/#/c/383617/
16:27:06 <rakhmerov> sharatss: ok :)
16:27:08 <d0ugal> rakhmerov: so I'll continue doing that with rbrady
16:27:31 <rakhmerov> #action rakhmerov: look at https://review.openstack.org/#/c/383617/
16:27:40 <d0ugal> With many of my colleagues on holiday this week I should find some spare time :)
16:27:42 <rakhmerov> d0ugal: ok, please
16:27:55 <rakhmerov> yeah :)
16:28:11 <rakhmerov> but you can also have a turkey I guess )
16:28:18 <d0ugal> haha, sounds good!
16:29:49 <rakhmerov> ok, then seems like we discussed all we had
16:29:58 <rakhmerov> ok to close the meeting?
16:30:02 <d0ugal> rakhmerov: Did you manage to backport all the database transaction wor?
16:30:04 <d0ugal> work
16:30:10 <d0ugal> and was there a Newton release?
16:30:13 <rakhmerov> d0ugal: saw your email on time slots, will reply
16:30:19 <d0ugal> Thanks.
16:30:45 <rakhmerov> d0ugal: yes, I did backport all needed stuff (and some more) but I didn't make a new point release yet
16:30:49 <rakhmerov> in newton
16:30:51 <d0ugal> Right
16:31:04 <d0ugal> I guess it would be good to have that soon.
16:31:07 <rakhmerov> I want to make sure that all is included
16:31:11 <d0ugal> but at least it is backported
16:31:12 <d0ugal> suer
16:31:15 <d0ugal> sure, thanks
16:31:20 <rakhmerov> d0ugal: soon? you need it soon?
16:31:30 <d0ugal> Not for me, just for everyone :)
16:31:37 <rakhmerov> ooh, I see
16:31:40 <rakhmerov> yes
16:31:42 <rakhmerov> I agree
16:32:12 <rakhmerov> surprisingly, all these latest changes got into Red Hat's RPMs already )
16:32:13 <d0ugal> I think it was a big issue for Xavier Hardy
16:32:21 <d0ugal> rakhmerov: oh, cool
16:32:22 <rakhmerov> which is what we need at Nokia
16:32:30 <d0ugal> hah :)
16:32:36 <rakhmerov> d0ugal: it was a big issue for everyone!
16:32:45 <d0ugal> Indeed, but worse for postgres I think
16:32:50 <rakhmerov> d0ugal: btw, wanna remind you about the tests for that stuff
16:32:53 <rakhmerov> once you have time
16:33:06 <d0ugal> rakhmerov: right, I had a look into it but couldn't really figure out a nice way to do it
16:33:06 <rakhmerov> yeah
16:33:16 <rakhmerov> btw, postgres gate is back
16:33:17 <d0ugal> I'll add that to my list for this week, maybe we can chat about it sometime
16:33:19 <d0ugal> Great
16:33:29 <d0ugal> Did you find out what happened to it?
16:33:33 <rakhmerov> infra folks helped me to get it back
16:33:54 <rakhmerov> thanks to Andreas
16:34:15 <rakhmerov> d0ugal: yes, I did
16:34:35 <rakhmerov> d0ugal: yeah, let's discuss tests for those hanging transactions in IRC
16:34:47 <rakhmerov> I think I have some ideas how to implement them
16:35:16 <d0ugal> Great, thanks!
16:35:46 <rakhmerov> ok
16:35:53 <rakhmerov> so, anything else?
16:35:54 <d0ugal> Nothing else from me :)
16:35:56 <rakhmerov> ok
16:35:59 <sharatss> rakhmerov: i have something to ask not regarding the project but regarding the summit in Feb
16:36:09 <rakhmerov> sharatss: yes, go ahead
16:36:15 <rakhmerov> sharatss: I'm coming
16:36:17 <rakhmerov> :)
16:36:17 <sharatss> rakhmerov: regarding PTG
16:36:23 <rakhmerov> so are some other folks
16:37:10 <sharatss> rakhmerov: i am still confuised with the rules this time. Just wanted to make sure Mistral guys are there :P
16:37:53 <rakhmerov> yes, we will be there
16:37:59 <rakhmerov> we asked for space
16:38:19 <rakhmerov> but I did not register yet, will do soo
16:38:21 <rakhmerov> soon
16:38:35 <rakhmerov> sharatss: you are planning to come too?
16:38:49 <sharatss> rakhmerov: yes. if budget permits :P
16:38:58 <rakhmerov> that would be awesome
16:39:03 <rakhmerov> let's keep in touch on that
16:39:26 <sharatss> rakhmerov: i would love to meet the team :)
16:39:34 <rakhmerov> we could also have a couple of beers in Atlanta ;)
16:39:43 <rakhmerov> I know a good place in downtime haha :)
16:39:47 <rbrady> beer++
16:39:57 <rakhmerov> :)
16:40:13 <d0ugal> haha
16:40:15 <d0ugal> now I want to go!
16:40:35 <rakhmerov> yes, try to approve your budget :)
16:40:36 <rbrady> d0ugal: I can stream it to you on hangouts
16:40:45 <rakhmerov> :)
16:40:51 <rakhmerov> ok, sharatss, it would be cool if you could come
16:40:54 <rakhmerov> anything else guys?
16:40:58 <d0ugal> rbrady: thanks, you need to ship me beer so I can join in.
16:41:08 <rakhmerov> :))
16:41:34 <sharatss> pls ship me a beer even if i cannot come :(
16:41:41 <rakhmerov> haha
16:41:42 <rakhmerov> yeah
16:41:51 <rakhmerov> ok, let's finish?
16:41:56 <rakhmerov> if no objections
16:42:10 <sharatss> rakhmerov: no objections
16:42:14 <rakhmerov> ok
16:42:21 <mgershen> Ok
16:42:23 <rakhmerov> thanks for joining
16:42:32 <rakhmerov> I appreciate it
16:42:35 <rakhmerov> bye
16:42:36 <d0ugal> Thanks!
16:42:41 <rbrady> bye
16:42:43 <ddeja> thanks, bye!
16:42:43 <sharatss> thanks :)
16:42:43 <mgershen> Bye
16:42:48 <rakhmerov> #endmeeting