16:03:47 <rakhmerov> #startmeeting Mistral
16:03:48 <openstack> Meeting started Mon Jan 30 16:03:47 2017 UTC and is due to finish in 60 minutes. The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:52 <openstack> The meeting name has been set to 'mistral'
16:03:54 <rakhmerov> hi
16:03:58 <d0ugal> Hey!
16:04:21 <sharatss> Hi
16:04:47 <ddeja> o/
16:05:06 <rakhmerov> ok, hi everyone
16:05:38 <rakhmerov> 1 min
16:05:58 <rakhmerov> #topic Review Action Items
16:06:02 <rakhmerov> no action items
16:06:11 <rakhmerov> #topic Current Status
16:07:03 <rakhmerov> my status: sorting out blueprints and bugs at Launchpad after ocata 3 release, profiling Mistral in order to optimize it in case of big data stored in workflow context
16:07:24 <rakhmerov> sent one relatively simple patch
16:07:52 <rakhmerov> which is https://review.openstack.org/#/c/426704/
16:08:05 <rakhmerov> if you have updates please go ahead
16:08:27 <ddeja> My status: finished working on kombu driver multi thread and mulit rabbit support
16:08:35 <rakhmerov> I'm also planning PTG and summit activities
16:08:47 <rakhmerov> ddeja: is everything merged?
16:08:52 <ddeja> and thanks to Renat and Dougal it was merged before the O-3 freeze :)
16:08:53 <d0ugal> I don't really have anything to share this week :)
16:08:53 <rakhmerov> that you wanted
16:08:57 <ddeja> yup ;)
16:08:59 <rakhmerov> ok
16:09:01 <d0ugal> \o/
16:09:01 <sharatss> I have almost no status. Was on vacation last week.
16:09:14 <rakhmerov> d0ugal, sharatss: ok
16:09:27 <d0ugal> sharatss: oh, good reminder - I will be on vacation next week. So don't look for me :)
16:09:27 <sharatss> Had to test congress actions, couldn't :(
16:09:30 <rakhmerov> d0ugal: can I announce your new role on the project? :)
16:09:35 <d0ugal> rakhmerov: ha, sure
16:09:36 <ddeja> this week I'd like to double check if it works as expected and fix any bugs I will found in it
16:09:53 <rakhmerov> ddeja: yes, please
16:09:54 <d0ugal> rakhmerov: but that did make it sound more exciting than it is :)
16:10:22 <rakhmerov> so, d0ugal will be the liaison for Mistral documentation in Pike
16:10:23 <sharatss> d0ugal: i will miss you :))
16:10:53 <ddeja> congrats d0ugal :)
16:11:00 <d0ugal> Thanks :)
16:11:19 <rakhmerov> there's a plan in the community to start more active communication with the projects in order to improve docs in OpenStack
16:11:19 <d0ugal> Hopefully I can do the role justice ;)
16:11:34 <rakhmerov> so far I've been formally a liaison but I was a bad one
16:11:39 <rakhmerov> :)
16:11:57 <rakhmerov> yes, so we'll be counting on you :)
16:12:02 <rakhmerov> ok
16:12:22 <sharatss> d0ugal: congrats :)
16:12:37 <rakhmerov> I didn't have any special topics this week since I jumped into technical stuff and want to focus on it for now
16:13:13 <rakhmerov> my main goal though before the PTG is to prepare a good plan to discuss our topics we collected in the etherpad
16:13:37 <ddeja> I have one small topic: failing mysql/postgres gates
16:14:00 <rakhmerov> by a good plan I mean a more detailed list of topic and approximate time that we need to discuss it and when it's going to be
16:14:11 <rakhmerov> ddeja: yes, I was going to ask you about it actually
16:14:13 <rakhmerov> go ahead
16:14:19 <rakhmerov> share what you know
16:14:22 <ddeja> so, I spend some time looking on it
16:14:30 <rakhmerov> yep
16:14:34 <ddeja> i can reporduce it lokally using tox -e unit-mysql
16:14:45 <rakhmerov> ok
16:14:57 <ddeja> and I have a patch that fix it in a dummy way
16:15:23 <rakhmerov> ok, 1) what's the issue? 2) what's your fix that you call dummy?
16:15:47 <ddeja> https://review.openstack.org/#/c/426184/
16:15:52 <ddeja> so that's the patch
16:16:11 <ddeja> and it deletes the importing of muranoclient
16:16:18 <ddeja> that's why it is dummy
16:16:27 <d0ugal> so muranoclient is causing an issue?
16:16:31 <rakhmerov> but the gates are still failing on it
16:16:52 <ddeja> yes, since one or two tests requires the muronaclient
16:16:59 <ddeja> but most of the tests passes
16:17:09 <ddeja> on another patches, almost all tests not pass
16:17:32 <ddeja> so, the problem is with muronoclient, but I have no idea what the problem may be
16:17:53 <ddeja> If i use the python from .tox/unit-mysql/bin/python
16:18:07 <rakhmerov> hm...
16:18:13 <ddeja> and do importutils.load('python-muronoclient')
16:18:15 <ddeja> it just works
16:18:55 <tuan__> ddeja: murano :)
16:19:06 <ddeja> tuan__: yes
16:19:12 <ddeja> missclick ;)
16:19:18 <ddeja> but, what I can do for now
16:19:18 <tuan__> :D
16:19:35 <ddeja> is to put PBR inside the tests and see what the heck is happening when we use tox
16:19:42 <ddeja> I can try tommorow
16:20:01 <rakhmerov> yes, ok
16:20:05 <rakhmerov> interesting
16:20:07 <ddeja> that's all on this topic
16:20:17 <ddeja> the most interesting is what kong found
16:20:33 <ddeja> that it started to fail after we change the version of.... novaclient
16:21:14 <tuan__> after discussing ddeja problem
16:21:21 <tuan__> i have another one
16:21:22 <rakhmerov> ddeja: I'd suggest we write to openstack-dev
16:21:35 <tuan__> i think it should be discussed
16:21:47 <ddeja> rakhmerov: OK, I can send an email
16:21:50 <rakhmerov> seems like it makes sense to ask Murano team, they may know about it and be able to help
16:21:57 <ddeja> sure
16:22:07 <d0ugal> +1
16:22:14 <rakhmerov> #action ddeja: send an email to openstack-dev about the issue with the murano client
16:22:46 <d0ugal> Over time, I think it would be great if we could somehow isolate actions.
16:22:46 <rakhmerov> tuan__: what's your topic?
16:23:01 <rakhmerov> d0ugal: StackStorm did this
16:23:03 <tuan__> yeap, it is the topic of cacert
16:23:12 <rakhmerov> with using separate virtual envs
16:23:34 <rakhmerov> which also allows to use different dependencies
16:23:40 <d0ugal> rakhmerov: ah, interesting. I was wondering how well that would work. containers would be another interesting approach :)
16:23:43 <tuan__> can i explain my topic
16:23:48 <d0ugal> tuan__: please do
16:23:56 <tuan__> d0ugal: interetsing with docker
16:23:57 <tuan__> :D
16:24:00 <tuan__> ok
16:24:07 <tuan__> so, the problem like this
16:24:21 <rakhmerov> tuan__: sure, please do, it's just our regular way of having these meetings: we just keep telling our stuff no matter what others are doing :)
16:24:31 <tuan__> when we create pythonclient of other projects
16:24:48 <tuan__> in mistral i do not see the cacert that should be fetched
16:24:53 <tuan__> for instance
16:25:21 <tuan__> if inside workflow, i would like my novaclient talk to nova server by using cacert
16:25:38 <tuan__> and i do not see the cacert is fetched into novaclient in mistral
16:26:14 <tuan__> inside mistral/actions/openstack/actions.py
16:27:30 <rakhmerov> tuan__: ok, so the issue is that even though we can pass cacert from the client as --os-cacert parameter it doesn't get passed through to other OpenStack clients?
16:27:36 <rakhmerov> does that sound accurate?
16:28:45 <rakhmerov> because when I'm looking at the client code I see that we can pass it
16:28:56 <tuan__> we just pass it to mistralclient
16:29:07 <tuan__> how does mistralclient passes it to novaclient
16:29:18 <rakhmerov> no, I don't know yet
16:29:27 <rakhmerov> I'm just trying to clarify my understanding
16:29:28 <tuan__> of course we ccan do that by passing context of mistralclient
16:29:36 <tuan__> but i do not see it in the code
16:29:39 <rakhmerov> no, this is a bad way
16:29:45 <rakhmerov> ok, I understand
16:30:17 <rakhmerov> tuan__: please file a bug (look for an existing one) and change its priority to High
16:30:33 <tuan__> ok
16:30:50 <tuan__> we will talk to our team and file a bug ASAP
16:31:03 <tuan__> actually we did an implementation for this fix
16:31:04 <tuan__> :D
16:31:12 <rakhmerov> awesome
16:31:17 <tuan__> and now fixing unittest and testing it
16:31:19 <rakhmerov> is it already on review?
16:31:24 <tuan__> not yet
16:31:30 <rakhmerov> ok, cool
16:31:33 <tuan__> we are fixging unittest
16:31:39 <rakhmerov> but please have a bug report anyway
16:31:44 <tuan__> for sure
16:31:50 <rakhmerov> thanks
16:31:57 <rakhmerov> anything else folks?
16:32:13 <ddeja> I'm done
16:32:16 <rakhmerov> if no I'd like to keep this meeting short
16:32:22 <tuan__> ddeja: what about the kombu
16:32:23 <tuan__> ?
16:32:24 <rakhmerov> d0ugal?
16:32:48 <ddeja> tuan__: It's not that easy
16:33:00 <d0ugal> I have one question, but it can wait until tomorrow :) so nothing from me.
16:33:12 <ddeja> but I'll file an patch as soon as I get it done
16:33:19 <rakhmerov> tuan__, ddeja: what are you discussing about kombu?
16:33:35 <ddeja> we can re-use failover mechanisms from kombu library
16:33:50 <ddeja> instead of what I did - writing our own ;)
16:34:00 <ddeja> so I need to do a little refactor
16:34:05 <ddeja> so we can use those
16:34:13 <rakhmerov> hm.. not sure I'm following you
16:34:34 <rakhmerov> can you briefly tell what exactly you're going to refactor/replace?
16:34:35 <tuan__> yeap, but i think you can take a look to the oslo messaging that for you i think it is an easy stuff
16:34:41 <ddeja> right now in kombu driver you can pass a number of rabbitMQ servers
16:34:42 <tuan__> as you did before
16:34:52 <rakhmerov> ddeja: ack
16:35:03 <ddeja> and connect to one of them, in case of failure, connect to another etc.
16:35:09 <rakhmerov> yes
16:35:17 <rakhmerov> the patch we recently merged
16:35:17 <ddeja> and I've implemented the logic of catching the exception and reconnecting
16:35:23 <rakhmerov> with "HA" it its title
16:35:29 <rakhmerov> yes
16:35:37 <ddeja> but, such mechanism is implemented in kombu library
16:35:43 <rakhmerov> I see
16:35:55 <rakhmerov> yeah, it's good if you can reuse it
16:35:58 <ddeja> so with a little refactor, we can delete some code from mistral and rely on kombu
16:36:06 <rakhmerov> yep, good
16:36:12 <tuan__> ddeja: btw, your patch is still good
16:36:13 <tuan__> :D
16:36:16 <ddeja> tuan__: that is why I'm saing it's not easy, I need to refactor the kombu_server
16:36:30 <ddeja> for kombu client it's a one-line change
16:36:33 <tuan__> okay, i understand
16:36:53 <rakhmerov> tuan__: are you using Kombu based RPC in CBAM?
16:37:06 <rakhmerov> or oslo.messaging based? Default one
16:37:14 <ddeja> rakhmerov: oh, and tuan__ is a person who pointed me that there is a failover mechanism in kombu ;)
16:37:18 <rakhmerov> I'm just not aware
16:37:34 <rakhmerov> I see, thanks tuan__ :)
16:38:26 <rakhmerov> ok, ending the meeting?
16:38:29 <tuan__> rakhmerov: we use rabbitmq
16:38:30 <tuan__> :D
16:38:49 <rakhmerov> tuan__: ok, I asked a little different thing, let's talk tomorrow
16:38:57 <tuan__> yeap
16:39:03 <rakhmerov> Istvan can probably help us answer this
16:39:16 <rakhmerov> ok, thanks everyone for joining
16:39:22 <rakhmerov> have a good week
16:39:31 <rakhmerov> #endmeeting