16:01:10 <rakhmerov> #startmeeting Mistral
16:01:11 <openstack> Meeting started Mon Mar 13 16:01:10 2017 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:16 <openstack> The meeting name has been set to 'mistral'
16:01:18 <rakhmerov> hi all
16:01:20 <mgershen> o/
16:01:24 <rbrady> o/
16:01:30 <bobh> o/
16:01:33 <d0ugal> Hello!
16:01:36 <ddeja> o/
16:01:40 <thrash> o/
16:01:44 <d0ugal> o/
16:01:46 <toure> hello
16:01:52 <rakhmerov> ooh, a bunch of people today :)
16:02:05 <rakhmerov> this makes me happy
16:02:09 <apetrich> o/
16:02:41 <toure> DST is causing havoc on the calendar
16:02:56 <d0ugal> toure: hah, indeed :)
16:03:02 <rakhmerov> ook, the main thing I'd like to do today is sort of a small planning session but let's start with action items and current statuses first
16:03:14 <rakhmerov> #topic Review action items
16:03:34 <rakhmerov> ..checking if we had any AIs
16:04:03 <rakhmerov> 1. rakhmerov: send an invitation to team members to a weekly meeting
16:04:06 <rakhmerov> woops..
16:04:18 <rakhmerov> d0ugal: what was it supposed to be? Do you remember?
16:04:39 <d0ugal> rakhmerov: calendar invite
16:04:41 <rakhmerov> I probably forgot exactly because we decided not to send invitations anymore
16:04:46 <rakhmerov> aaah!! yes
16:04:51 <rakhmerov> ok
16:04:56 <rakhmerov> #action rakhmerov: send an invitation to team members to a weekly meeting
16:05:09 <rakhmerov> 2. rakhmerov: assign "Error analysis BP" to Toure
16:05:10 <rakhmerov> done
16:05:23 <rakhmerov> 3. d0ugal to find tests that change coverage randomly
16:05:33 <rakhmerov> d0ugal: I guess it's in progress, right?
16:05:42 <d0ugal> I spent some time looking into that, and I ran out of ideas.
16:05:54 <rakhmerov> and probably it's not supposed to be just in meeting action items, it's rather a bug or BP
16:05:55 <d0ugal> so I gave up
16:06:04 <d0ugal> Yeah, I should create a bug.
16:06:23 <rakhmerov> #action d0ugal: file a bug about finding tests changing coverage randomly
16:06:45 <rakhmerov> #topic Current status (what was done last week, roadblocks, plans)
16:06:48 <mgershen> d0ugal: what was the result of the automation?
16:07:10 <mgershen> d0ugal: did you remove all tests and coverage still failed?
16:07:32 <d0ugal> mgershen: yeah, so I think it is in the shared code between tests
16:07:47 <d0ugal> mgershen: it seems that it changed whatever tests were removed.
16:08:21 <rakhmerov> my status: housekeeping in Launchpad, partially done Workflow Global Context BP, fixed a bug about not overriding workflow json default input values, made refactoring of workflow/input validation
16:08:30 <mgershen> d0ugal: what do you mean "it seems that it changed whatever tests were removed."?
16:08:31 <rakhmerov> keep working on workflow global context
16:08:59 <rakhmerov> :)
16:09:02 <mgershen> my status: got pulled to do internal corporate stuff again...
16:09:24 <rakhmerov> ok, please share your statuses
16:09:36 <d0ugal> mgershen: well, I don't really know - but basically the script didn't work :-D I can run it again and show you after if you want.
16:09:40 <toure> status: Error analysis example draft report being put together
16:10:03 <rakhmerov> toure: need any assistance?
16:10:14 <toure> rakhmerov not yet
16:10:17 <rakhmerov> ok
16:10:20 <d0ugal> Nothing much to report for me, I have started looking into the openstack actions - I am going to propose a small spec that covers the move to mistral-extra. I should have a first draft up soon
16:10:29 <mgershen> d0ugal: I might want to after I finish the mistral client test (after I finish the internal stuff).
16:10:42 <rakhmerov> d0ugal: that's good
16:10:50 <d0ugal> mgershen: sure, it would be good to look at it with somebody else, I felt like I was going mad :)
16:11:25 <rakhmerov> d0ugal: np, please do go mad )
16:11:26 <apetrich> status: just joined the team. Did some benchmarking for the get parameters action and now setting some caching .
16:11:28 <rbrady> status: good discussion on ML re: custom actions.  Patch updating.  finishing up porting over serialization framework and tests.  plan to work on keystone_utils port to mistral-extra next
16:11:32 <toure> rakhmerov: thanks, working on coming up with a relational layout for the structure, will posted what I have today for review
16:11:45 <mgershen> d0ugal: I feel you. specially since other projects claim it is working fine for them.
16:12:06 <rakhmerov> apetrich: hey, not sure if we talked before?
16:12:13 <rakhmerov> apetrich: you're from Red Hat?
16:12:34 <mgershen> apetrich: welcome to mistral
16:12:43 <apetrich> rakhmerov, yeah. sorry if the status is a bit too tripleo specific
16:12:44 <rakhmerov> yes, welcome )
16:13:13 <apetrich> rakhmerov, aye red hatter
16:13:18 <rakhmerov> apetrich: that's totally ok, this is something that I'd like to know better actually
16:13:18 <apetrich> cheers
16:13:24 <rakhmerov> cool
16:13:46 <rakhmerov> rbrady, d0ugal: yeah, just one suggestion about mistral api thing
16:13:57 <d0ugal> rakhmerov: the custom actions api?
16:14:24 <thrash> no mistral-related status from me.
16:14:34 <rakhmerov> let's work on it iteratively, let's not be too picky about design etc. I'd prefer we let it in easier now, we'll have time to improve/refactor etc.
16:14:47 <rakhmerov> it doesn't mean though that we should merge really raw stuff
16:14:58 <rakhmerov> d0ugal: yeah
16:15:13 <rakhmerov> so yes, I just want we to keep moving with this
16:15:14 <d0ugal> rakhmerov: sure, makes sense - I'm always looking to get the smallest working this landed :)
16:16:00 <rakhmerov> yep, even if something is not ready and/or we have doubts let's merge and improve later
16:16:12 <rakhmerov> as long as it's experimental we're good
16:16:23 <d0ugal> true
16:16:30 <rakhmerov> once we're satisfied we'll make it official
16:16:37 <rbrady> rakhmerov: ack
16:16:43 <rakhmerov> ok
16:17:16 <rakhmerov> before we go to the next topic, is there anything urgent that you'd like to bring up to discussion?
16:17:37 <rakhmerov> not maybe even urgent, but important (in case you don't want to wait another 30 min)
16:18:17 <rakhmerov> ok
16:18:28 <rakhmerov> then let's do a little bit of planning
16:18:36 <rakhmerov> #topic Pike 1 planning
16:19:12 <rakhmerov> pike-1 page: https://launchpad.net/mistral/+milestone/pike-1
16:19:56 <rakhmerov> so this is the stuff I selected for pike-1 based on my vision only
16:20:09 <rakhmerov> we can change here anything we want
16:20:52 <rakhmerov> please take a look and see if tasks assigned to you seem feasible to do within a month
16:21:13 <rakhmerov> the deadline for pike-1 ends on April 14
16:21:36 <rakhmerov> another thing: is there something that you would like to include that's not there?
16:22:00 <rakhmerov> btw, I didn't really pay a lot of attention to bugs, mostly BPs. I'll probably remove some bugs from pike-1
16:22:27 <rakhmerov> and we need to do a bug triaging (separately, maybe next meeting)
16:22:51 <d0ugal> +1
16:23:11 <mgershen> rakhmerov: so soon?
16:23:12 <rakhmerov> so, pike-1 ends in just a month from now, then pike-2 will be 2.5 months long
16:23:25 <rakhmerov> mgershen: soon what? )
16:23:33 <rakhmerov> ooh, yes
16:23:34 <mgershen> pike-1 ends
16:23:51 <mgershen> do you have dates for pike-2 and etc?
16:24:04 <rakhmerov> yep, because it was actually started some time ago
16:24:16 <rakhmerov> here it is: https://releases.openstack.org/pike/schedule.html
16:24:32 <rakhmerov> yes, so, pike 2 and 3 will be long
16:25:52 <rakhmerov> d0ugal: please review all things assigned to you. I'm not sure if their real status is in LP
16:26:03 <d0ugal> rakhmerov: Yeah, I was just wondering about them too!
16:26:07 <d0ugal> will do
16:26:18 <rakhmerov> we actually all need to do this, please review all your tasks and update their statuses
16:26:25 <rakhmerov> ok
16:27:23 <rakhmerov> so, is the set of tasks looking good so far? :)
16:27:28 <rakhmerov> any comments maybe?
16:27:45 <rakhmerov> I guess I'm pretty confident about stuff assigned to me
16:27:58 <rakhmerov> ooh, btw, we can change assignment either
16:28:17 <rakhmerov> if you'd like to work on something that's not in the list pls let us know
16:29:04 <rakhmerov> rbrady: do you think we'll finish https://blueprints.launchpad.net/mistral/+spec/mistral-actions-api-main-entities in a month?
16:29:04 <d0ugal> I think it looks good, but I need to spend some time reviewing it
16:29:16 <d0ugal> rakhmerov: define "finished" :)
16:29:16 <rakhmerov> d0ugal: ok, np
16:29:58 <rakhmerov> d0ugal: well, on this particular BP, we need to have mistral-lib ready for action development
16:30:09 <rakhmerov> at least the first version of it
16:30:15 <d0ugal> Yup
16:30:27 <d0ugal> I can't speak for rbrady but I think it we will have the first version at least.
16:30:43 <rbrady> rakhmerov: I do.  I have incorporated all of the feedback thus far for the current patch.
16:30:53 <rakhmerov> I didn't assign other sub tasks of Actions API to pike 1, just want to be more or less conservative
16:31:05 <rakhmerov> I did assign them to pike 2 and 3
16:31:34 <rbrady> rakhmerov: enough we could start mistral depending on it
16:31:52 <rakhmerov> rbrady: great :) Then do you think we need to include into pike 1 anything else from Actions API?
16:32:04 <rakhmerov> say executor and/or engine changes?
16:32:12 <rakhmerov> OpenStack actions to mistral-extra?
16:32:20 <rakhmerov> ok
16:32:37 <rbrady> rakhmerov: openstackactions, keystone)utils port to mistral-extra
16:32:50 <rakhmerov> if we have some extra time in pike 1 I think we can discuss details of the future work
16:32:52 <d0ugal> rakhmerov: I'm not sure the OpenStack actions will have moved by then - I want to make progress, but there is lots of work to be done first.
16:32:52 <rakhmerov> mistral-extra etc
16:32:59 <d0ugal> yeah
16:33:07 <rakhmerov> d0ugal: agree fully
16:33:09 <rakhmerov> ok
16:33:31 <rakhmerov> d0ugal: it's good that you wanted to focus on the spec for mistral-extra, it's just a good time for that
16:33:47 <d0ugal> it will make it easier for me :)
16:33:57 <rakhmerov> d0ugal: maybe we should even file a blueprint for the spec so we could track the progress
16:34:59 <d0ugal> rakhmerov: I think there is a blueprint.
16:35:15 <rakhmerov> hm.. ok, maybe
16:35:16 <d0ugal> rakhmerov: https://blueprints.launchpad.net/mistral/+spec/mistral-actions-api-separate-openstack-actions
16:35:24 <rakhmerov> ooh, it's for the task itself
16:35:33 <rakhmerov> I meant for writing a spec specifically )
16:35:34 <d0ugal> oh, another blueprint to write a spec?
16:35:40 <d0ugal> ah, sure - if that is useful.
16:35:47 <d0ugal> I was just going to reference that blueprint
16:35:48 <rakhmerov> yeah, not sure though
16:35:56 <rakhmerov> I just wanted to track this work somehow
16:36:11 <rakhmerov> because spec work pretty often gets lost to be honest
16:36:20 <d0ugal> rakhmerov: We could asign that blueprint to me, change it to pike 1 and then we can move it to pike 2 later for the rest of the work?
16:36:33 <rakhmerov> someone is writing a spec and then it just disappears under the pile of comments
16:36:47 <rakhmerov> d0ugal: works for me
16:36:47 <d0ugal> hah
16:36:59 <d0ugal> rakhmerov: I think you need to assign it
16:37:40 <rakhmerov> done
16:37:48 <d0ugal> Thanks
16:39:05 <rakhmerov> I will also talk to Winson, he will take 1-2 BPs I guess
16:39:59 <rakhmerov> they are interested in 3 things: sensitive data issue, actions running by engine, task explicit params (aka branch specific shortcut for publish)
16:40:57 <rakhmerov> ok, so please should you have any additional comments/wishes on our priorities try to let me know sooner than later
16:41:34 <rakhmerov> d0ugal: would you like to bring up what you mentioned today?
16:41:38 <rakhmerov> about meeting time?
16:41:41 <d0ugal> Sure
16:42:24 <d0ugal> My motivation is very selfish, but in two weeks when the clocks change for daylight savings the meeting time will be less convenient for me.
16:42:45 <d0ugal> and I think it will be for others as it becomes an hour later
16:42:54 <d0ugal> so I'd like to propose we move it an hour earlier.
16:43:17 <d0ugal> If there are no objections here, I'll propose it on openstack-dev to check with people that couldn't make it today.
16:43:47 <rbrady> I have no objection
16:43:51 <rakhmerov> d0ugal: I have a different suggestion: let's decide it right now
16:43:59 <d0ugal> hah, sure
16:44:11 <toure> 1+
16:44:19 <rakhmerov> because seems like we have a good representation today, pretty much everyone who usually attends meetings
16:44:30 <rakhmerov> mgershen: how about you Michal?
16:44:31 <mgershen> it's fine by me, is the room available?
16:44:32 <d0ugal> is ddeja around?
16:44:39 <ddeja> d0ugal: \o
16:44:57 <rakhmerov> I'm also ok with the proposed change
16:44:59 <d0ugal> ddeja: we are talking about moving the meeting an hour earlier because of DST. Does that work for you? :)
16:45:07 <ddeja> d0ugal: yes
16:45:10 <d0ugal> mgershen: that is a good question - I think the room isn't.
16:45:13 <rakhmerov> d0ugal: do you want to change it in 2 weeks or starting the next meeting?
16:45:34 <d0ugal> rakhmerov: I don't mind - I am just trying to find out where the IRC availability is listed.
16:45:57 <rakhmerov> d0ugal: it should be possible to create a new room if we really need
16:46:03 <rakhmerov> afaik
16:46:15 <ddeja> we can even have meeting on #openstack-mistral
16:46:25 <ddeja> there is an openstack bot there
16:46:27 <rakhmerov> yeah :)
16:46:32 <rakhmerov> that's right
16:46:35 <d0ugal> oh, cool
16:47:03 <rakhmerov> btw, I wonder why we're not doing it yet )
16:47:19 <ddeja> I don't know
16:47:19 <rakhmerov> why do we need all those shared rooms? )
16:47:39 <rakhmerov> it seems mostly a traditional thing to me
16:47:45 <ddeja> I guess it's like in the experiment with monkeys, ladder and bananas
16:47:52 <mgershen> d0ugal: is this what you were lookin for: http://eavesdrop.openstack.org/
16:47:59 <d0ugal> rakhmerov: when projects get busy it can be confusing if a meeting is going on and other people are just coming to ask questions at the same time
16:48:08 <rakhmerov> apetrich: is it ok for you as well?
16:48:12 <d0ugal> but I think normally #openstack-mistral is quiet enough
16:48:28 <rakhmerov> d0ugal: at this time of the day yes
16:48:30 <rakhmerov> it is
16:48:33 <apetrich> rakhmerov, aye
16:48:35 <d0ugal> rakhmerov: I suspect an hour earlier is better for apetrich too, he is the closest person to me :)
16:48:42 <apetrich> :)
16:48:47 <rakhmerov> ooh, really? where?
16:49:09 <apetrich> rakhmerov, about one hour away by car. Also Scotland
16:49:16 <rakhmerov> awesome )
16:49:24 <apetrich> Dundee :)
16:49:30 <rakhmerov> I'd like to visit those places one day
16:49:47 <rakhmerov> alright :)
16:50:12 <rakhmerov> so, decided
16:50:32 <mgershen> it seem #openstack-meeting-3 is available at Monday at 1500 UTC
16:50:43 <rakhmerov> d0ugal: can you please send an announcement about the meeting time/room change?
16:50:57 <d0ugal> mgershen: that is the page I was looking for, but I don't understand how to read it lol
16:51:00 <d0ugal> rakhmerov: sure
16:51:11 <rakhmerov> ooh, btw
16:51:19 <rakhmerov> I just recalled something
16:51:19 <d0ugal> rakhmerov: I guess I need to find all the places to update it too
16:51:31 <d0ugal> rakhmerov: do you want it in #openstack-mistral or #openstack-meeting-3?
16:51:43 <rakhmerov> basically, we'll have to make a patch to some repo and CI will check the requested room's availability
16:51:51 <rakhmerov> :)
16:51:55 <mgershen> I just assumed the format of each meeting is the same and searched for "Monday at 1500 UTC" and then looked what rooms are free.
16:52:12 <rakhmerov> so not sure if #openstack-mistral will be ok from TC perspective
16:52:15 <mgershen> offical rooms listed here: https://wiki.openstack.org/wiki/Meetings
16:52:17 <rakhmerov> there's some governance around it
16:52:56 <d0ugal> okay, thanks - I'll try and find us an "official" meeting room then
16:52:59 <mgershen> rakhmerov: lets try moving to #openstack-meeting-3?
16:53:04 <d0ugal> +1
16:53:13 <rakhmerov> d0ugal: check availability of rooms for team meeting at 15.00 UTC
16:53:27 <rakhmerov> #action d0ugal: check availability of rooms for team meeting at 15.00 UTC and send an announcement
16:53:56 <rakhmerov> ok
16:54:24 <rakhmerov> so d0ugal, do you want to change it now or in 2 weeks?
16:54:47 <d0ugal> I don't mind.
16:55:06 <d0ugal> It might be confusing to change it the week before DST because then it will change again the next week
16:55:16 <rakhmerov> ok, for me earlier would be even better
16:55:27 <rakhmerov> ooh, makes sense )
16:55:36 <d0ugal> I am happy to change now.
16:55:49 <rakhmerov> but at least UTC won't change )
16:56:04 <d0ugal> indeed
16:56:24 <d0ugal> okay, so lets change now
16:56:28 <rakhmerov> yeah
16:56:30 <rakhmerov> thanks
16:56:37 <d0ugal> rakhmerov: and I guess you can send out the calendar invite for the new meeting time.
16:56:37 <rakhmerov> ok guys, is there anything else for today? 3 mins left
16:56:44 <d0ugal> Nothing from me.
16:56:45 <ddeja> I have one short
16:56:45 <rakhmerov> d0ugal: good point
16:56:49 <rakhmerov> I will
16:57:03 <rakhmerov> ddeja: go ahead
16:57:04 <ddeja> I'd just like to inform you, that I started working on another project in my company. So I'll be less active it Mistral developement and/or reviews.
16:57:17 <ddeja> as you propably noticed ;)
16:57:29 <rakhmerov> ddeja: sad to know, but thanks for letting us know
16:57:50 <rakhmerov> I'd be happy to have you back if you can and want
16:58:00 <d0ugal> ddeja: +1, that is a shame but hopefully the new project is fun :)
16:58:09 <rakhmerov> :)))
16:58:13 <ddeja> rakhmerov: I will see
16:58:26 <mgershen> +1
16:58:37 <rakhmerov> ddeja: if you don't mind I'd like to discuss a couple of things with you about the tasks that you worked on
16:58:48 <ddeja> rakhmerov: sure, I will have some time tommorow
16:58:55 <rakhmerov> not expecting any coding though, just want to clarify a few things
16:59:01 <rakhmerov> ok, thanks
16:59:02 <ddeja> yeah, sure
16:59:11 <rakhmerov> thanks Dawid
16:59:33 <ddeja> no problem
16:59:37 <rakhmerov> ddeja: just want to say a huge THANK YOU! :)
16:59:58 <ddeja> thanks :)
17:00:06 <rakhmerov> honestly, you did an amazing job on RPC thing, fixing bugs, reviews and investigating endless number of things with gates
17:00:32 <rakhmerov> ok, need to finish
17:00:40 <rakhmerov> thanks to everyone for joining
17:00:45 <rakhmerov> have a wonderful week
17:00:46 <rakhmerov> bye
17:00:48 <ddeja> thank you all
17:00:54 <rakhmerov> #endmeeting