15:11:27 <d0ugal> #startmeeting mistral
15:11:28 <openstack> Meeting started Mon Mar 27 15:11:27 2017 UTC and is due to finish in 60 minutes.  The chair is d0ugal. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:11:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:11:32 <openstack> The meeting name has been set to 'mistral'
15:11:44 <d0ugal> Hey - who is here for the Mistral meeting?
15:12:20 <toure> hello :)
15:12:23 <d0ugal> We are just waiting for rakhmerov to arrive before we start properly.
15:12:36 <d0ugal> so before he does, we can just chat about anything people have
15:12:54 <sharatss> me o/
15:13:29 <d0ugal> Hey sharatss
15:13:32 <rbrady> \o
15:13:45 <thrash> o/
15:13:53 <rbrady> I'll be here for the next 10 min
15:14:04 <thrash> same ^^
15:14:24 <d0ugal> cool, you can both entertain us until rakhmerov arrives :)
15:14:35 * thrash dances
15:14:40 <toure> hehe
15:16:32 <d0ugal> oh, cool, I see the Advanced Publishing spec landed.
15:16:43 <d0ugal> http://specs.openstack.org/openstack/mistral-specs/specs/pike/approved/advanced_publishing.html
15:16:53 <d0ugal> It is worth a read if you've not seen it yet - should be a useful addition.
15:17:25 <d0ugal> Jump to the examples at the end of the "Proposed change" for the TLDR
15:18:49 <d0ugal> rbrady: speaking of specs, do you if there is any ideas/info around for the securing sensitive information?
15:18:56 <d0ugal> I assume it came up at the PTG
15:19:43 <rbrady> yes...there was some initial ideas in the etherpad.  I'm not sure if anyone has started a spec for it yet.  if not, it's something I could start in the next couple of days
15:24:51 <d0ugal> cool, would be interesting to see.
15:26:15 <rbrady> #action rbrady start sensitive data spec
15:26:42 <rbrady> alright, my times up.  I will see you all in #openstack-mistral later
15:26:46 <d0ugal> cya
15:26:53 <d0ugal> I'm wondering if rakhmerov is going to make it :)
15:27:16 <d0ugal> Anyone got any bugs to discuss or review requests?
15:27:49 <d0ugal> I'll wait a bit longer and then we can run through the normal agenda - probably not that much to cover this week
15:30:53 <d0ugal> #topic Review action items
15:31:43 <d0ugal> Okay, so from last week we had two action items.
15:31:47 <d0ugal> 1. mgershen/team to talk with Renat about bug https://bugs.launchpad.net/mistral/+bug/1672379
15:31:48 <openstack> Launchpad bug 1672379 in Mistral "default task on error not running when task fail to evaluate input" [Undecided,Invalid]
15:32:01 <d0ugal> Since neither seem to be here, I'll just add that again so it isn't lost.
15:32:04 <d0ugal> #action mgershen/team to talk with Renat about bug https://bugs.launchpad.net/mistral/+bug/1672379
15:32:20 <d0ugal> 2. d0ugal to make a bug about using KeyStone sessions when we create OpenStack clients
15:32:29 <rakhmerov> d0ugal: I'm here
15:32:30 <rakhmerov> sorry
15:32:37 <d0ugal> rakhmerov: hey, no problem
15:32:58 <d0ugal> rakhmerov: I just started to go through the action items from last time - we have had a bit of open discussion initially just while we waited.
15:33:11 <rakhmerov> ooh, ok
15:33:13 <rakhmerov> sure
15:33:20 <rakhmerov> please keep going
15:33:24 <rakhmerov> I'll catch up
15:34:12 <d0ugal> I've not done my action item ^ - so I'll just quickly open the bug now
15:35:41 <rakhmerov> ok
15:36:06 <d0ugal> #link https://bugs.launchpad.net/mistral/+bug/1676485
15:36:06 <openstack> Launchpad bug 1676485 in Mistral "Use Keystone sessions to create Mistral clients" [Medium,Confirmed]
15:36:11 <d0ugal> Okay, that is that action item done now :)
15:36:47 <d0ugal> rakhmerov: Unless you want to discuss https://bugs.launchpad.net/mistral/+bug/1672379 now (but maybe better when mgershen is here) we are finished with the action items
15:36:47 <openstack> Launchpad bug 1672379 in Mistral "default task on error not running when task fail to evaluate input" [Undecided,Invalid]
15:37:13 <rakhmerov> Michal said she wouldn't be here today
15:37:20 <d0ugal> okay, np
15:37:33 <rakhmerov> yeah, well, we already had a quick chat about this bug
15:37:45 <rakhmerov> with her and my boss
15:37:57 <d0ugal> oh, cool - I see you commented on it recently.
15:38:12 <rakhmerov> it's not really a bug, I think I was able to explain her and she was going to create a BP
15:38:29 <rakhmerov> yeah, if details are needed I can provide them
15:38:42 <d0ugal> cool, thanks
15:38:55 <d0ugal> rakhmerov: okay, you can take over with the current status section now if you want :)
15:39:17 <rakhmerov> in a nutshell, this behavior was a result of long discussions and considerations and it's the way we designed it on purpose
15:39:44 <rakhmerov> d0ugal: is there actually anyone else on the meeting besides me and you? :)
15:39:49 <d0ugal> #chair rakhmerov
15:39:50 <openstack> Current chairs: d0ugal rakhmerov
15:40:02 <rakhmerov> #topic Current status
15:40:07 <d0ugal> rakhmerov: Good question. toure and sharatss might still be here.
15:40:21 <d0ugal> but rbrady-afk had to leave and I think thrash did too
15:40:32 <toure> I am catching up, had to step away for a sec
15:40:47 <rakhmerov> my status: was on sick leave most of the last week, working on advanced publishing (publishing to different scopes + defining it in 'on-xxx')
15:40:55 <rakhmerov> toure: ok
15:41:28 <rakhmerov> the task (advanced publishing) seems to be pretty hairy actually because it requires a serious refactoring first
15:41:39 <toure> status: working on finalizing POC for workflow error analysis will post a review today
15:41:44 <rakhmerov> to keep backwards compatibility
15:41:57 <d0ugal> status: looking for another review on the mistral-extra spec. https://review.openstack.org/446996
15:42:04 <rakhmerov> toure: you're working on an endpoint now?
15:42:25 <rakhmerov> toure: can you just remind what's going to be a part of the POC?
15:42:36 <toure> rakhmerov yeah, so I created a report endpoint
15:42:37 <sharatss> status: working on keystoneauth migration and mistral-congress integration. will commit in a day or two
15:42:55 <rakhmerov> d0ugal: I'll ask mgershen to review it tomorrow
15:42:56 <toure> this will include a controller backed by a service
15:43:04 <d0ugal> rakhmerov: thanks
15:43:07 <toure> rakhmerov ^^
15:43:13 <rakhmerov> toure: yep, ok
15:43:40 <toure> rakhmerov I have also the clientside roughly worked out, need some more work also
15:43:43 <rakhmerov> toure: I saw that the spec has -1 for some reason, so I didn't look at the latest version yet
15:44:03 <d0ugal> I think the -1 is mostly for small things
15:44:07 <toure> rakhmerov there were a few formatting concerns which I addressed
15:44:08 <rakhmerov> but if you think I need to review it now I'll do (early feedback kinda)
15:44:17 <rakhmerov> okay
15:44:19 <rakhmerov> got it
15:44:37 <rakhmerov> toure: ok, awesome
15:44:48 <rakhmerov> looking forward to seeing something working :)
15:44:49 <toure> rakhmerov I think I will pick up that other blueprint in regards to error seperation
15:44:57 <toure> rakhmerov thanks
15:45:45 <rakhmerov> toure: yes, feel free
15:45:51 <toure> https://blueprints.launchpad.net/mistral/+spec/mistral-error-separation
15:46:12 <toure> some of that wourk will be addressed in the other spec
15:46:14 <rakhmerov> and also keep that error info structuring in mind
15:46:36 <rakhmerov> stack trace stored in a different field etc.
15:46:41 <toure> yup
15:46:43 <rakhmerov> what we discussed at the PTG
15:47:15 <rakhmerov> ok
15:48:16 <rakhmerov> d0ugal: besides that spec (which seems to be good already), is there anything else you're now working on?
15:48:38 <rakhmerov> maybe you need help or something
15:48:53 <d0ugal> rakhmerov: I am going to start implementing it soon, but last week I focused on a few TripleO tasks.
15:49:02 <rakhmerov> ok
15:49:29 <d0ugal> rakhmerov: I did also spend a bit of time thinking how a "run-workflow" command would work - we talked about it before briefly
15:49:38 <rakhmerov> d0ugal: on a different topic, has anyone from other teams already contacted you on docs?
15:49:44 <d0ugal> but the idea was to have a way to run a workflow so you can test it out without having to do create/update etc :)
15:49:59 <rakhmerov> d0ugal: you're a doc liaison so I wonder if someone talks to you :)
15:50:33 <d0ugal> rakhmerov: not really, I had one email related to it - but if I remember it wasn't relevant to Mistral
15:50:37 <d0ugal> I'll check
15:50:43 <rakhmerov> ok
15:51:04 <rakhmerov> np, just reminding about it so that you might want to configure email etc. :)
15:51:12 <d0ugal> #action d0ugal to check for doc liaison tasks
15:51:23 <rakhmerov> d0ugal: yeah, that 'run-workflow' thing would be cool to have
15:51:30 <d0ugal> rakhmerov: yup, thanks - I do forget about it sometimes and then remember and wonder if I have missed something - so I'll look again
15:51:51 <rakhmerov> #action rakhmerov: ask Michal to review the spec about mistral-extra
15:52:12 <rakhmerov> sure, ok
15:52:22 <d0ugal> rakhmerov: I wasn't sure how it would work with the API - I think the best place would be to let the user pass a workflow file to execution creation, but that seemed a bit wrong.
15:53:24 <rakhmerov> d0ugal: yeah, that's hairy
15:53:42 <rakhmerov> d0ugal: if you want we can chat about it tomorrow in IRC
15:53:45 <d0ugal> sure
15:54:17 <rakhmerov> tasks like this always challenge design )
15:54:54 <d0ugal> Indeed :)
15:54:56 <rakhmerov> as far as storing workflows/workbooks and using them I believe our design might not be flexible enough
15:55:04 <rakhmerov> ok, we'll talk about it separately
15:55:39 <d0ugal> I did have one other big idea :)
15:55:40 <rakhmerov> I don't have much else actually :)
15:56:06 <rakhmerov> d0ugal: what was that?
15:56:07 <rakhmerov> )
15:56:11 <d0ugal> Do you know the Postgres query planner? I thought something like that for Mistral would be cool - so it would describe to you what a workflow would do
15:56:49 <rakhmerov> d0ugal: yeah, pretty much every decent RDBMS has something similar
15:56:53 <d0ugal> yeah
15:57:10 <rakhmerov> hm.. interesting
15:57:17 <d0ugal> I guess a first step would be to have something that shows you the workflow graph
15:57:24 <d0ugal> but that could get tricky to represent
15:57:33 <d0ugal> anyway, it is just an early idea for now :-D
15:57:34 <rakhmerov> I'm trying to imagine what a plan of WF should look like
15:57:46 <toure> +1 d0ugal's idea
15:58:38 <d0ugal> Compring with a query planner is maybe not the best idea
15:58:44 <rakhmerov> btw, a very cool graphical tool is being developed inside Nokia now, it already does a lot
15:58:51 <d0ugal> basically I am thinking about tools to help you understand and analyze workflows
15:58:57 <d0ugal> oh, nice
15:59:03 <rakhmerov> once we can we'll show a demo I guess
15:59:06 <d0ugal> rakhmerov: will that be open sourced? :)
15:59:48 <rakhmerov> d0ugal: yeah, that's really good. That's the direction that I'm mentally taking now in terms of development
15:59:54 <rakhmerov> being more usable
16:00:07 <d0ugal> awesome
16:00:17 <d0ugal> and that takes us to the end of our time
16:00:24 <rakhmerov> d0ugal: yes, that's the plan, it's planned to be open sourced
16:00:28 <d0ugal> great
16:00:28 <rakhmerov> yep
16:00:35 <rakhmerov> bye everyone
16:00:37 <d0ugal> Thanks all
16:00:46 <d0ugal> #endmeeting