15:01:28 <rakhmerov> #startmeeting Mistral
15:01:30 <openstack> Meeting started Mon Apr  3 15:01:28 2017 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:34 <openstack> The meeting name has been set to 'mistral'
15:01:37 <d0ugal> Hey all!
15:01:39 <mgershen> o/
15:01:42 <sharatss> hi
15:01:56 <akuznetsova> hi there
15:02:12 <rakhmerov> hi
15:02:16 <rbrady> o/
15:02:53 <rakhmerov> hi all
15:02:54 <rakhmerov> 1 sec
15:03:47 <rakhmerov> #topic Review Action items
15:03:50 <rakhmerov> 1. d0ugal to check for doc liaison tasks
15:03:59 <d0ugal> oops, I have not done this.
15:04:05 <rakhmerov> :)
15:04:09 <rakhmerov> #action d0ugal to check for doc liaison tasks
15:04:17 <toure> hello...
15:04:32 <rakhmerov> toure: hey
15:04:34 <rakhmerov> 2. rakhmerov: ask Michal to review the spec about mistral-extra
15:04:35 <rakhmerov> done
15:04:50 <rakhmerov> 3. mgershen/team to talk with Renat about bug https://bugs.launchpad.net/mistral/+bug/1672379
15:04:50 <openstack> Launchpad bug 1672379 in Mistral "default task on error not running when task fail to evaluate input" [Undecided,Invalid]
15:05:03 <d0ugal> rakhmerov: I think maybe that wasn't needed in the end
15:05:13 <rakhmerov> yes
15:05:28 <rakhmerov> we've kind of touched that, it's not an easy thing to solve now
15:05:48 <rakhmerov> 4. rbrady start sensitive data spec
15:06:02 <rakhmerov> it was done
15:06:08 <mgershen> about 3, should I open a blueprint?
15:06:12 <toure> hey rakhmerov once I finish fighting with gerrit I have the client code ready for review
15:06:14 <rakhmerov> it even has one +2
15:06:15 <toure> :)
15:06:28 <rakhmerov> toure: for error analysis?
15:06:32 <toure> yup
15:06:36 <rakhmerov> awesome )
15:06:41 <toure> merge conflicts
15:06:43 <d0ugal> #link https://review.openstack.org/450853
15:06:43 <toure> :(
15:06:50 <rakhmerov> mgershen: yes, please
15:06:57 <d0ugal> ^ that's the sensitive data spec
15:07:06 <rakhmerov> yes
15:07:30 <rakhmerov> ok
15:07:42 <mgershen> rakhmerov: do you want to add an action to make sure I won't forget?
15:08:16 <rakhmerov> #action mgershen: create a BP about "on-error" semantics
15:08:25 <rakhmerov> #topic Current status (quick info from team members)
15:09:43 <rakhmerov> my status: reviewing, working on advanced publishing (actually got stuck with lang changes unexpectedly, will probably have to do some serious refactoring first), investigating an issue introduced by new SQLAlchemy
15:09:53 <rakhmerov> the last one was finally fixed today
15:10:14 <rakhmerov> so please provide a short update if you have anything
15:10:39 <d0ugal> I'm now working on mistral-extra, and starting the ground work for moving the OpenStack actions over. The spec merged today (thanks for reviews!)
15:10:54 <mgershen> I will have almost no time in the next few weeks to work on mistral, but if something needs reviewing try to ping me.
15:10:55 <rakhmerov> that is great
15:11:11 <rakhmerov> mgershen: sure, understandable
15:11:53 <rakhmerov> just FYI: akuznetsova is now helping us with some tasks again (which is awesome)
15:12:10 <rakhmerov> akuznetsova: could you please tell a little bit about your activities?
15:12:39 <akuznetsova> yes, for the old times' sake
15:12:43 <rakhmerov> :)
15:12:52 <akuznetsova> I've published fixes for two bugs
15:13:14 * d0ugal needs to catch up with reviews.
15:13:23 <rakhmerov> d0ugal: yes! :)
15:13:25 <akuznetsova> and looked through the list of bugs in mistralclient, there were a lot of old bugs which I closed
15:13:39 <d0ugal> bug triage ++
15:14:08 <rakhmerov> d0ugal: yeah, I was actually going to do that today at the meeting )
15:14:29 <rakhmerov> but akuznetsova volunteered to do some pre-filtering
15:14:43 <d0ugal> great
15:14:55 <rakhmerov> akuznetsova: thanks a lot!
15:14:56 <mgershen> thank you akuznetsova :)
15:15:11 <apetrich> I'm working on moving some imports from mistral to mistral-lib mostly in tripleo-common (sorry for for the tripleo centric status)
15:15:14 <akuznetsova> rakhmerov, mgershen you are welcome
15:15:57 <d0ugal> apetrich: it is extremely valuable for Mistral to show this stuff working, it is all theoretical so far :)
15:16:05 <rakhmerov> mgershen, d0ugal: we got a bunch of patches passed through check queue today after we rebased them after merging an SQLA issue so please try to find some time to review them
15:16:34 <d0ugal> sure
15:16:52 <mgershen> rakhmerov: do you have links?
15:17:04 <rakhmerov> d0ugal, apetrich: this is very very good, the only thing I'm worried about is that isn't it too early? :)
15:17:13 <apetrich> d0ugal, I can see that
15:17:22 <rakhmerov> mgershen: there's too many of them, just look at gerrit pls
15:17:40 <d0ugal> rakhmerov: possibly - but we need to start some time and it'll help direct us what we need to do next. We wont land anything in tripleo yet.
15:17:41 <apetrich> rakhmerov, it is more of proof of concept and identify the early pitfalls
15:17:46 <d0ugal> +1
15:17:47 <rakhmerov> ooh, ok
15:17:55 <rakhmerov> if so then it's fine
15:18:10 <rakhmerov> because otherwise the APIs may not be stable yet etc.
15:18:48 <rakhmerov> then this is good really
15:18:49 <mgershen> rakhmerov: ok, I will.
15:18:52 <rakhmerov> ok
15:19:35 <rakhmerov> mgershen: I just usually look at "Watched Changes" tab and see patches that recently changed on the top
15:21:13 <rakhmerov> ok, is there anything else on that?
15:21:24 <rakhmerov> rbrady: do you have any updates today?
15:22:07 <rbrady> rakhmerov: thrash took care of the spec, I've only done reviews since last week
15:22:26 <rakhmerov> ok, thanks
15:22:27 <rakhmerov> good
15:22:58 <rakhmerov> rbrady: as far as mistral-lib, are you planning to make more changes in the near future?
15:23:18 <rakhmerov> rbrady: what do you think is now left?
15:23:28 <rakhmerov> from what we planned
15:23:32 <rbrady> rahkmerov: I think the next steps are the keystone_utils and the openstack actions
15:23:39 <d0ugal> We need Mistral to depend on msitral-lib and to pass the context
15:23:56 <d0ugal> rbrady: ^ I think we need that first maybe, but it is easy to hack in for testing :)
15:23:58 <rbrady> ^^ and what d0ugal said :)
15:24:28 <d0ugal> I have a patch locally that does it, I could put it up for review but we need mistral-lib in global-requirements first
15:24:43 <d0ugal> I'll post it as a starting point at least.
15:24:56 <rakhmerov> yes
15:24:58 <rakhmerov> agree
15:25:27 <rakhmerov> d0ugal: having it in global-requirements should not be a huge problem, right?
15:25:38 <rakhmerov> afaik
15:25:44 <d0ugal> rakhmerov: no, that should be easy
15:25:52 <d0ugal> I just need to find the process and follow it
15:26:04 <rakhmerov> ok
15:26:32 <d0ugal> and we need to figure out rpm packaging for the tripleo side - just adding the dep will break tripleos CI I think
15:26:44 <d0ugal> but again, that should be quite easy.
15:27:00 <rakhmerov> yep
15:27:26 <rakhmerov> so, we can probably go to an open discussion
15:27:46 <rakhmerov> I don't have any special topics today
15:28:03 <rakhmerov> if you do please bring them up
15:28:12 <rakhmerov> #topic Open Discussion
15:29:04 <rakhmerov> one thing I'd like to share about what I'm doing is that I stumbled on making changes in workflow language in the last few days
15:29:22 <rakhmerov> I found that it became very hard to make such changes
15:29:51 <d0ugal> What makes it so difficult?
15:29:52 <rakhmerov> this Spec class hierarchy became enormously complex
15:29:55 <d0ugal> ah
15:30:12 <d0ugal> The code in mistral.lang.*?
15:30:18 <rakhmerov> d0ugal: too many places to change in order to make even relatively small changes
15:30:21 <rakhmerov> yes
15:30:35 <d0ugal> Interesting, I wonder how we can make it easier
15:30:39 <rakhmerov> and then if you look at how to alter tests it's not easier )
15:30:53 <rakhmerov> d0ugal: yeah, that's what I'm thinking about now
15:31:04 <rakhmerov> I have some ideas, will try to implement them
15:31:31 <rakhmerov> one more thing related to that is we may want to have a new version of the language some time in the future
15:31:39 <rakhmerov> and I believe it may happen relatively soon
15:32:02 <rakhmerov> because we've been adding more and more feature into the language
15:32:36 <rakhmerov> they are all backwards compatible and hence we lose some opportunities to make the lang more concise and elegant
15:32:36 <d0ugal> Migrating workflows doesn't sound like fun :)
15:32:46 <rakhmerov> no, wait :)
15:32:50 <rakhmerov> I didn't mean that )
15:33:00 <d0ugal> haha, I know
15:33:09 <rakhmerov> what I meant is that we'll have to support more than one language version
15:33:18 <rakhmerov> I know, sounds scary
15:33:28 <d0ugal> yup, but even in that case we would want to upgrade older workflows over time.
15:33:37 <rakhmerov> and especially scary for me after I looked again at how it's now implemented :)
15:33:42 <d0ugal> lol
15:34:15 <rakhmerov> d0ugal: yeah, true we'll probably need to provide some aid to upgrade to a newer version
15:34:54 <rakhmerov> anyway, this is something that I've discussed with a number of people already and seems like this idea of the new lang version may not be that theoretical
15:35:11 <rakhmerov> so, that's just one thing I'm involved in now
15:35:28 <d0ugal> cool, it would be interesting to see those ideas.
15:35:31 <rakhmerov> ideally I'd like to improve it somehow
15:35:46 <rakhmerov> and btw, I found one thing that makes WF validation slower, I'll fix it soon
15:36:12 <rakhmerov> yeah, the mechanism is powerful but it became too heavy
15:36:49 <rakhmerov> that is all from my side
15:37:02 <d0ugal> I don't really have anything to discuss this week.
15:37:14 <rakhmerov> guys, next time let's sync on Pike-1 tasks
15:37:35 <d0ugal> sure
15:37:38 <toure> ack
15:37:49 <rakhmerov> please try to find time to check if you're going to meet the scope of Pike-1
15:38:39 <rakhmerov> another topic I'd like to bring up next week is something I discussed with my boss at Nokia recently
15:39:20 <rakhmerov> so essentially I set up 4 goals for 2017 regarding Mistral
15:39:30 <rakhmerov> mostly from our business perspective
15:39:58 <rakhmerov> but anyway, I think these goals reflect my vision of how Mistral should evolve in the next year
15:40:11 <rakhmerov> I'd be interested in discussing these goals with you
15:40:16 <d0ugal> cool
15:40:18 <toure> sounds good
15:40:20 <rakhmerov> so that we all understand the direction
15:40:29 <d0ugal> Sounds like it'll be a busy meeting :)
15:40:33 <rakhmerov> yes
15:41:13 <rakhmerov> my suggestion would be even to declare these goals (if we agree on them) somewhere, in the spec repo or a wiki (seriously outdated now btw)
15:41:26 <d0ugal> a spec?
15:41:33 <rakhmerov> maybe a spec, yes
15:42:11 <rakhmerov> so, just to be even more clear: I believe these goals is the 3-4 main things that we should be focusing on in order to make the project more successful
15:42:22 <rakhmerov> and attract more people to it (both users and contributors)
15:42:42 <rakhmerov> ok, details next time )
15:42:52 <rakhmerov> I am done for sure
15:42:55 * toure waits for details
15:42:55 <rakhmerov> now
15:42:56 <toure> :)
15:42:56 <d0ugal> look forward to it :)
15:43:04 <d0ugal> toure: haha, rakhmerov is teasing us!
15:43:11 <rakhmerov> :))
15:43:11 <toure> indeed
15:43:14 <toure> hehe
15:43:24 <rakhmerov> yeah, may be a little :)
15:43:37 <rakhmerov> I've been teasing d0ugal for a looong time with a UI tool :)
15:43:51 <rakhmerov> that is something I'd really love to demonstrate some time soon
15:44:10 <toure> cool
15:44:16 <toure> can't wait to see it
15:44:32 <d0ugal> +1
15:44:36 <rakhmerov> I'm going to bring that up soon with my management in order to find out when and how we're going to announce it
15:44:55 <rakhmerov> ok
15:45:04 <rakhmerov> anything else may be?
15:45:13 <d0ugal> not from me
15:45:16 <rakhmerov> or we can finish for today
15:45:20 <toure> nothing for me
15:45:28 <mgershen> nothing for me
15:45:31 <akuznetsova> nothing from my side
15:46:37 <rakhmerov> ok
15:46:49 <rakhmerov> thank you all for coming and for the interesting discussion
15:46:54 <rakhmerov> see you next week
15:46:59 <d0ugal> thanks all!
15:47:03 <toure> have a good one
15:47:05 <rakhmerov> have a wonderful week guys )
15:47:06 <akuznetsova> thanks, bye
15:47:11 <rakhmerov> bye
15:47:12 <toure> ta
15:47:16 <rakhmerov> #endmeeting