15:00:18 <rakhmerov> #startmeeting Mistral
15:00:19 <openstack> Meeting started Mon Apr 10 15:00:18 2017 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:22 <openstack> The meeting name has been set to 'mistral'
15:00:58 <d0ugal> hey!
15:01:03 <toure> hello
15:01:14 <rakhmerov> hey
15:01:15 <rbrady> hi
15:01:25 <sharatss> Hi
15:01:26 <rakhmerov> 1 sec..
15:01:29 <rakhmerov> sharatss: hi
15:02:05 <rakhmerov> sharatss: I looked at the new BP you created, I think we'll need to split it into several smaller BPs
15:02:30 <rakhmerov> ok, mgershen won't join today, she's on holidays
15:02:34 <rakhmerov> let's start
15:02:58 <rakhmerov> #topic Review Action Items
15:03:06 <sharatss> rakhmerov, ok. I will change it tomorrow
15:03:34 <rakhmerov> sharatss: leave it to me pls
15:04:00 <rakhmerov> instead, try to get your patches merged this week
15:04:06 <rakhmerov> 1. d0ugal to check for doc liaison tasks
15:04:07 <rakhmerov> :)
15:04:13 <sharatss> rakhmerov, sure :)
15:04:16 <rakhmerov> d0ugal: is there any update on that?
15:04:42 <rakhmerov> it's not that important but anyway..
15:05:03 <d0ugal> rakhmerov: yeah, so they want us to add Mistral to the installer docs
15:05:35 <d0ugal> most or all other projects are included in it - we are not yet :)
15:05:38 <rakhmerov> ooh, do you know details/guidelines on how to it?
15:05:50 <d0ugal> Not yet, I just know it is something we should look into doing
15:05:54 <rakhmerov> ..how to do it..
15:05:55 <d0ugal> I wasn't sure where to track this work.
15:06:12 <d0ugal> https://docs.openstack.org/project-install-guide/ocata/
15:06:14 <rakhmerov> ok, then pls try to find out more
15:06:17 <d0ugal> That is where we want to be included I think
15:06:18 <rakhmerov> ok
15:06:32 <d0ugal> Should I open a Mistral bug/blueprint for this?
15:06:37 <rakhmerov> yes, please
15:06:44 <rakhmerov> 2. mgershen: create a BP about "on-error" semantics
15:06:51 <rakhmerov> not done yet AFAIK
15:06:56 <rakhmerov> #action mgershen: create a BP about "on-error" semantics
15:07:11 <rakhmerov> #topic Current Status (by team members)
15:07:19 <rakhmerov> let's quickly share our updates
15:08:08 <d0ugal> https://blueprints.launchpad.net/mistral/+spec/mistral-os-install-docs
15:08:08 <rakhmerov> my status: last week I worked mostly on Java Mistral client for OpenStack4J (driven by internal tasks mostly) and advanced publishing (global, branch, atomic)
15:08:29 <rakhmerov> the latter is mostly done, will try to finish this week
15:08:48 <rakhmerov> d0ugal: thanks
15:09:07 <d0ugal> I made a few documentation improvements - they need a second +2: https://review.openstack.org/453542 https://review.openstack.org/454058 https://review.openstack.org/454057 https://review.openstack.org/453543
15:09:39 <rakhmerov> d0ugal: I tentatively assigned it to P-2 but we'll decide when to do it exactly later during planning
15:10:03 <d0ugal> Otherwise I have been working on making an rpm package for mistral-lib and I am working on mistral-extra, but I've not done much of that yet.
15:10:14 <rakhmerov> d0ugal: yeah, Michal is on holidays this week so please try to ping other cores (kong, ddeja etc.)
15:10:48 <rakhmerov> you've created a good spec though, this is a good progress IMO
15:11:17 <rakhmerov> rbrady, toure, sharatss: what about you guys?
15:11:40 <rbrady> I've done some reviews since last time, but have been otherwise engaged with work for other projects.
15:11:46 <rakhmerov> d0ugal: so you started moving OpenStack actions into mistral-extra?
15:11:57 <rakhmerov> rbrady: ok
15:12:31 <sharatss> rakhmerov, i have been trying to fix all the dashboard bugs which were pending from long time
15:12:40 <rakhmerov> rbrady: any progress on your brewery idea? :)
15:12:43 <d0ugal> rakhmerov: yeah, I am trying to - that is why I asked for the mistral-lib release, without those parts it is hard :)
15:12:59 <rakhmerov> sharatss: yeah, I saw, we'll try to merge them this week
15:13:03 <thrash|bbl> https://review.openstack.org/#/c/450853/ Looks like all comments have been addressed.
15:13:05 <rakhmerov> I'll ask people to review them
15:13:10 <rbrady> rakhmerov: I started rebuilding the main controller this weekend
15:13:19 <thrash|bbl> Still working on using mod_wsgi in devstack.
15:13:20 <toure> status: completed some reviews, working on the last bits of mistral engine changes for error analysis.
15:13:54 <rakhmerov> thrash|bbl: ok, I'll review it again tomorrow morning (your today's evening)
15:13:58 <rakhmerov> thanks
15:14:05 <rakhmerov> rbrady: cool :)
15:14:06 <toure> rakhmerov I took your suggestion and created a method to make calls into workflow_exec and task_exec inside db_api
15:14:28 <rakhmerov> ok
15:14:35 <toure> testing changes :)
15:14:49 <rakhmerov> toure: is there anything from that's pending review now?
15:14:56 <rakhmerov> ok, awesome :)
15:15:09 <rakhmerov> ..from you..
15:15:13 <toure> once it doesn't blow up :)
15:15:22 <toure> I have the client side up
15:15:26 <rakhmerov> ok
15:15:28 * toure grabs review
15:15:54 <toure> #link https://review.openstack.org/#/c/452901/
15:16:09 <rakhmerov> I mean please let us know once you post something new and we need to review it
15:16:12 <rakhmerov> ok
15:16:17 <toure> will do
15:16:39 <rakhmerov> I'll look into this tomorrow morning too
15:16:46 <rakhmerov> ok, thanks for updates
15:16:53 <toure> np
15:17:03 <rakhmerov> any roadblocks that you guys hit and need help maybe?
15:17:32 <rakhmerov> thrash|bbl: how's that apache wsgi thing going?
15:18:01 <rakhmerov> and could you pls tell a little bit what exactly you're planning to achieve
15:18:03 <rakhmerov> ?
15:18:41 <rakhmerov> ok, maybe later
15:19:06 <rakhmerov> let's move to the next topic
15:19:08 <d0ugal> :)
15:19:18 <rakhmerov> #topic Pike-1 progress
15:19:22 <d0ugal> I think the goal is to have a new gate that tests Mistal in a wsgi setup
15:19:49 <rakhmerov> yes, but what tests are we supposed to run there, what DB etc.
15:20:08 <rakhmerov> I kind of see the idea but would like to have more details
15:20:09 <d0ugal> ah, I see
15:20:16 <d0ugal> There is a patch for it, rbrady had the link earlier.
15:20:20 <rakhmerov> np, we can discuss that later
15:20:24 <rakhmerov> ok
15:20:35 <rakhmerov> so, the page for P-1: https://launchpad.net/mistral/+milestone/pike-1
15:20:41 <rbrady> https://review.openstack.org/#/c/454710/
15:20:45 <d0ugal> rbrady: thanks.
15:21:36 <rakhmerov> I've gone through the list of tickets today and updated some of them but I'd like you to look at it too and make sure your tasks are updated
15:21:58 <rakhmerov> for example, rbrady, d0ugal: do you think we can close https://blueprints.launchpad.net/mistral/+spec/mistral-actions-api-main-entities ?
15:22:09 <rakhmerov> to me it seems like yes but I'd like to run with you
15:22:32 <thrash> rakhmerov: The only coverage on apache wsgi is via the puppet jobs. I think it would be prudent to have both apache and non-apache devstack jobs. Once the initial part is done (which is the enabling of apache in the plugin) we can talk about how else to vary the jobs.
15:22:40 <d0ugal> rakhmerov: I would like to see the mistral-lib release happen first, but I don't mind if we close it first.
15:23:20 <rakhmerov> thrash: makes sense, I agree. I thought may be you already have a comprehensive plan (naive me)
15:23:21 <rbrady> rakhmerov: the work items in the BP suggest ensuring the mistral is using mistral-lib, but I don't have any objections to closing either
15:24:11 <thrash> rakhmerov: no comprehensive plan. Really just a means to an end ATM (running tempest on devstack with apache wsgi enabled)
15:24:13 <rakhmerov> wait a sec, not sure that mistral-lib should be used
15:24:26 <rakhmerov> it's just main entities in mistral-lib itself as far as I can tell
15:24:41 <rakhmerov> thrash: ok
15:24:49 <d0ugal> rakhmerov: what do you mean by "not sure that mistral-lib should be used"?
15:26:00 <rakhmerov> I mean IMO refactoring other components to use mistral-lib is out of this ticket scope
15:26:20 <rakhmerov> I wasn't clear enough
15:26:22 <d0ugal> rakhmerov: okay, fine with me
15:26:53 <rakhmerov> yeah, so it's the first step towards getting the task fully implemented
15:26:58 <rakhmerov> let's close it
15:27:24 <rakhmerov> of course, we'll be making tons of changes moving forward anyway
15:27:32 <d0ugal> yeah
15:28:45 <rakhmerov> on other things, d0ugal and toure: I know it might not be fair but how about creating separate BPs for specs related to your tasks (mistral-extra and workflow analysis) and moving existing BPs to P-2?
15:29:01 <rakhmerov> I'm just thinking how to track this work better
15:29:31 <rakhmerov> we've done work on these tasks but if we just move these BPs to the next milestone we'll not see a trace in LP
15:29:41 <rakhmerov> d0ugal, toure: what do you think?
15:30:18 <rakhmerov> I don't know, on the other hand it's kind of weird to create BPs for writing specs
15:30:20 <rakhmerov> :)
15:30:21 <d0ugal> rakhmerov: I have done very little work other than the spec itself - so I don't think there is anything worth tracking for P-1. Moving the blueprint to P-2 seems easiest.
15:30:39 <rakhmerov> then ok, let's do it
15:30:44 <d0ugal> Indeed, I see a one to one relationship between blueprints and specs
15:30:54 <rakhmerov> unless you make sure to finish it in P-1
15:30:54 <rakhmerov> :)
15:31:13 <toure> rakhmerov sounds good to me
15:31:13 <d0ugal> (there could be other dependant blueprints, but one main blueprint)
15:31:25 <rakhmerov> ok
15:31:32 <d0ugal> hah, I wont be finished for P-1!
15:31:40 <rakhmerov> yeah, d0ugal, I now remember that this was our plan
15:31:53 <rakhmerov> just to move it to the next milestone
15:31:56 <rakhmerov> :)
15:32:06 <toure> by sounds good, I mean moving it to p2 :)
15:32:18 <rakhmerov> ok
15:32:23 <rakhmerov> :)
15:32:24 <rakhmerov> got it
15:32:31 <toure> s/mean/meant
15:33:12 <rakhmerov> d0ugal: did you happen to send another patchset for https://blueprints.launchpad.net/mistral/+spec/mistral-engine-commands-docs today?
15:33:19 <rakhmerov> as we talked
15:33:32 <rakhmerov> this one is a good candidate to be closed soon
15:33:46 <d0ugal> rakhmerov: not yet, today has been a bit crazy for me. I'll do it soon.
15:33:52 <d0ugal> Maybe right after this meeting :)
15:33:59 <rakhmerov> ok, np
15:34:24 <rakhmerov> ok, so, again: please try to finish hanging patches this week
15:34:36 <rakhmerov> especially d0ugal and sharatss, you have a bunch of them )
15:34:48 <rakhmerov> I guess we just need to ask people for more reviews
15:35:02 <rakhmerov> thanks
15:35:02 <d0ugal> We need more core reviewers :)
15:35:19 <rakhmerov> d0ugal: yes, we do need them
15:35:32 <rakhmerov> it's a different topic though
15:36:05 <rakhmerov> ok, thanks
15:36:20 <rakhmerov> there's one more thing I'd like to discuss with you quickly
15:36:27 <rakhmerov> I mentioned it last week briefly
15:36:40 <rakhmerov> #topic Mistral Goals 2017
15:37:01 <rakhmerov> https://etherpad.openstack.org/p/mistral-goals-2017
15:37:41 <rakhmerov> I created this etherpad based on our internal discussions on how we see project goals for Mistral that we want to achieve in 2017
15:38:41 <rakhmerov> so, I spent time thinking about 3-4 goals that would make a difference for the project in general if we focus on them with the resources we have now
15:38:49 <rakhmerov> and here's what I came up with
15:39:10 <rakhmerov> you can omit "Definition of done" for now and just read quickly titles and descriptions
15:39:34 * d0ugal reads
15:40:10 <rakhmerov> basically, I think these goals reflect my vision of what's really missing now in Mistral
15:40:57 <rakhmerov> so IMO if we achieve them we'll be able to 1) attract more users 2) attract more contributors 3) extend use cases where Mistral can be used
15:41:08 <rakhmerov> and I'd add even one more: GUI
15:41:17 <rakhmerov> but I believe it'll go to the next year :)
15:41:41 <rakhmerov> especially, I'd say the two most important ones: Custom Actions API and Documentation
15:42:04 <rakhmerov> these two IMO should make Mistral more like a good product
15:42:07 * toure reads
15:42:41 <rakhmerov> on docs, we see lots of people coming to IRC and asking questions that they could read in docs but what they are looking for is not there pretty often
15:43:21 <d0ugal> rakhmerov: so you want to make workflows 50% faster?
15:43:24 <rakhmerov> also, even when it becomes comprehensive it's not structured well and there are not many examples and tutorials (almost none)
15:43:26 <d0ugal> is that the goal for number 3?
15:43:36 <rakhmerov> d0ugal: yes
15:43:51 <d0ugal> k, just checking I read it correctly
15:43:55 <d0ugal> Sounds good.
15:43:57 <rakhmerov> d0ugal: believe it or not the current Mistral performance is not really OK still for our internal purposes
15:44:03 <rakhmerov> and not only ours
15:44:22 <rakhmerov> d0ugal: yes, 50% seems achievable
15:44:28 <d0ugal> rakhmerov: oh, I believe it :) I've noticed it being quite slow at some things, but my main use-case it IO bound anyway, so speed isn't a huge issue for us.
15:44:36 <rakhmerov> and I know where to gain that extra performance
15:44:55 <rakhmerov> yes, I know
15:45:13 <rakhmerov> for you maybe, but for us and some other folks it's an issue
15:45:16 <d0ugal> Those goals sound good to me.
15:45:22 <rakhmerov> although it got much much better last year
15:45:37 <rakhmerov> ~50-70 times
15:46:14 <d0ugal> I would really like to improve the "on-boarding" expierence for new users - I think documentation improvements and the new custom actions API will make a huge difference here
15:46:18 <rakhmerov> yeah, Custom Actions API, in my opinion, will give a clear way to extend Mistral actions
15:46:25 <rakhmerov> which is missing now too
15:46:35 <d0ugal> but that is my personal goal, so I am particularly interested in #2 and #4 :)
15:46:41 <rakhmerov> d0ugal: exactly, that's what I have in mind
15:46:44 <rakhmerov> you got it
15:46:57 <rakhmerov> it's my personal goal too
15:47:08 <rakhmerov> I think we as a project are suffering a lot from this
15:47:11 <rbrady> is there a priority to these goals?
15:47:30 <rakhmerov> btw, d0ugal, what you've been doing in your blog could be a part of this work I believe
15:47:38 <rakhmerov> in fact, it already is
15:47:44 <toure> +Docs :)
15:48:02 <rakhmerov> rbrady: hm.. good question
15:48:11 <rakhmerov> I think Documentation and Actions API
15:48:13 <rakhmerov> top 2
15:48:22 <d0ugal> The funny thing is, I am really bad at writing, but I'll try and do more (and slowly improve) :)
15:48:32 <rakhmerov> that's ok
15:49:04 <rakhmerov> btw, seems like Nokia is ready to give tech writers for this purpose
15:49:13 <d0ugal> Great
15:49:14 <rakhmerov> but I'm not sure yet
15:49:25 <rakhmerov> anyway we'll need to help them with ideas/materials
15:49:31 <rakhmerov> rough materials
15:49:34 <d0ugal> I wonder if we have anyone that could help. I should ask.
15:49:46 <rbrady> d0ugal: rain
15:49:57 <rbrady> d0ugal: rleander I think
15:50:19 <rakhmerov> d0ugal: what you said is actually even a simpler form of what I want to do: "Easy Mistral contributor and user onboarding"
15:50:27 <rakhmerov> not it's not easy, we need to admit
15:50:34 <d0ugal> rbrady: true, there are quite a few people. Maybe I should have said ... s/could help/has time to help/ :)
15:51:49 <rakhmerov> as far as multi-node mode, there's a lot of things too but that's important for those who want high-availability and even greater performance
15:51:51 <rakhmerov> like us
15:52:14 <rakhmerov> and at least slowly we need to be moving in this direction
15:52:43 <rakhmerov> so, that's what I suggest we accept as project goals for this year kind of semi-officially
15:52:45 <rakhmerov> for our team
15:53:16 <rakhmerov> and that could be our bacon in the darkness when we need to make decisions
15:54:26 <rakhmerov> please take more time to review this list and leave your comments/suggestions, after that we can move these goals to WIKI (or somewhere else) so we could reference them if needed
15:54:30 <rbrady> rakhmerov: that needs to be an official mistral shirt: "bacon in the darkness"
15:54:40 <rakhmerov> yeah, :))
15:54:46 <d0ugal> LOL
15:54:47 <d0ugal> yum
15:54:57 <rakhmerov> I like poetry )
15:54:59 <toure> :)
15:55:31 <rakhmerov> If I get sick of programming (really possible ;) ) I'll be writing poems
15:55:40 <d0ugal> rakhmerov: I would put them somewhere more visible - Mistral readme or a special spec?
15:55:49 <rakhmerov> I believe I even write code like poems sometimes.. :)
15:55:56 <d0ugal> I would read more poetry if it was about bacon :)
15:56:06 <rakhmerov> d0ugal: yeah, that's what I'm thinking too
15:56:09 <toure> hehe
15:56:19 <rakhmerov> beacon!!!!!
15:56:22 <rakhmerov> gosh
15:56:34 <rakhmerov> just realized why it was so funny for you :)
15:56:36 <rakhmerov> haha
15:56:39 <d0ugal> lol
15:56:49 <rakhmerov> but yeah, "bacon" would be phenomenal!
15:57:00 <rakhmerov> lol
15:57:12 <toure> lol
15:57:21 <rakhmerov> :))))
15:57:37 <rakhmerov> ok, d0ugal: do you think README?
15:57:51 <d0ugal> rakhmerov: yeah, I think that would be good
15:57:53 <rakhmerov> d0ugal: let's think about it more
15:57:57 <d0ugal> I don't like the wiki :)
15:58:11 <rakhmerov> d0ugal: yes, we almost don't use it now actually
15:58:16 <toure> yeah wiki's tend to go stale
15:58:17 <rakhmerov> we used to but not anymore
15:58:19 <d0ugal> I always forget it exists
15:58:25 <rakhmerov> yep
15:58:36 <rakhmerov> ok, README probaly
15:58:44 <rakhmerov> or mistral-specs somewhere maybe
15:58:50 <rakhmerov> or/and
15:58:59 <rakhmerov> ok, let me take care of that
15:59:11 <rakhmerov> so, time to finish
15:59:18 <rakhmerov> thanks everyone for joining
15:59:23 <rakhmerov> it was fun
15:59:27 <d0ugal> thanks!
15:59:33 <toure> thanks,have a great week...
15:59:36 <rakhmerov> especially "bacon in the darkness" :)
15:59:36 <thrash> thanks o/
15:59:40 <toure> :)
15:59:41 <rakhmerov> bye!
15:59:46 <rakhmerov> #endmeeting