15:00:16 <rakhmerov> #startmeeting Mistral
15:00:18 <openstack> Meeting started Mon Jun  5 15:00:16 2017 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:19 <rakhmerov> hello
15:00:21 <openstack> The meeting name has been set to 'mistral'
15:00:23 <thrash> o/
15:00:28 <rakhmerov> hi )
15:00:32 <toure> hello
15:00:35 <fultonj> hi
15:00:37 <mgershen> o/
15:00:47 <d0ugal> Hey
15:01:14 <rakhmerov> hi all
15:01:25 <rakhmerov> #topic Review action items
15:01:31 <rakhmerov> 1. rakhmerov: review https://review.openstack.org/443217 again
15:01:38 <rakhmerov> I think it's done but let me check..
15:01:51 <rakhmerov> yes, done
15:01:57 <toure> yup
15:02:02 <rakhmerov> :)
15:02:06 <rakhmerov> #topic Current status (progress, issues, roadblocks, further plans)
15:02:58 <rakhmerov> my status: reviews, Java Client for Mistral (OpenStack4J), fixed a couple of small things, and started working on HA & Scalability
15:03:01 <toure> rakhmerov I think there may be a refactor of the cli name, but other than that it should be done
15:03:16 <rakhmerov> the spec was submitted today: https://review.openstack.org/#/c/470928/
15:03:21 <thrash> rakhmerov: I am discontinuing work on the securing secrets bp. There are some technical challenges to it that I don't have time right now to overcome.
15:03:39 <mgershen> status: Just created the next spec from creating and running a workflow within a namespace: https://review.openstack.org/#/c/470996/
15:04:06 <rakhmerov> toure: ok, please don't hesitate to remove [WIP] from your patches if you think they are ready
15:04:10 <d0ugal> Nothing to report from me, I have been tied up with TripleO tasks and have not had time to continue the mistral-lib/mistral-extra work. I hope to get back to it soon, but I am concerned about deadlines
15:04:21 <toure> rakhmerov ack, almost there
15:04:23 <rakhmerov> mgershen: ooh, I haven't seen it yet
15:04:31 <rakhmerov> #action rakhmerov: review https://review.openstack.org/#/c/470996/
15:04:53 <rakhmerov> d0ugal: ok
15:04:57 <thrash> rakhmerov: as I currently see it, it would be a bunch of work to effectively redact a secret in about 4 places in the code. And most of those places would involve doing a db lookup
15:05:02 <rakhmerov> d0ugal: what deadlines do you mean?
15:05:05 <rakhmerov> Pike-2?
15:05:12 <mgershen> I published it less than 15 minutes ago
15:05:13 <thrash> which seems rather pointless to me... A db lookup for a log message
15:05:27 <d0ugal> rakhmerov: yeah, originally I wanted to have the OpenStack actions ported for pike-2
15:05:52 <toure> status: Testing server side workflow error analysis changes, once done will remove WIP and let all take a look
15:05:55 <rakhmerov> thrash: have you left comments in the patch so we could see?
15:06:11 <rakhmerov> d0ugal: Pike-3 would be ok, no worries
15:06:24 <rakhmerov> but we need to do it in Pike
15:06:31 <rakhmerov> for many reasons
15:06:46 <d0ugal> rakhmerov: Yup, I am now aiming for that - but I have 2 weeks that I am away. I might see if I can recruit a helper :)
15:07:12 <thrash> rakhmerov: I have some made locally... I'll push it up...
15:07:19 <rakhmerov> thrash: at the moment, I'm now aware of these challenges although I would assume that the whole task is not easy to deal with
15:07:41 <thrash> rakhmerov: that it is. :D
15:07:48 <rakhmerov> thrash: yeah, please try to leave all needed info so that we could continue at least discussing it
15:08:12 <d0ugal> +1, some record of learnings would be useful.
15:08:12 <rakhmerov> d0ugal: ok )
15:08:17 <rakhmerov> yes
15:08:57 <rakhmerov> thrash: just to inspire you a little bit: I can remember 3-4 people who tried to tackle this task and all gave up )
15:09:12 <thrash> rakhmerov: That's depressing. :|
15:09:15 <d0ugal> haha
15:09:15 <rakhmerov> :))
15:09:22 <thrash> hehe
15:09:23 <toure> hahaha
15:09:27 <rakhmerov> I mean no worries )
15:09:33 <rakhmerov> we'll eventually get it done
15:09:35 <thrash> I guess I don't feel so stupid anymore. lol
15:09:39 <rakhmerov> no doubts :)
15:09:48 <rakhmerov> yeah, that's that I tried to do!
15:09:58 <rakhmerov> so that you don't feel stupid
15:10:13 <rakhmerov> ook
15:10:20 <rakhmerov> anything else in this part?
15:10:25 <rakhmerov> rbrady: ^
15:10:51 <rbrady> rakhmerov: I have been working with thrash and have come to the same conclusion
15:11:00 <rakhmerov> haha :))
15:11:04 <rakhmerov> got it
15:11:13 <rakhmerov> ok
15:11:25 <rakhmerov> ok
15:11:41 <rakhmerov> (why did I type it twice, hm...?)
15:11:49 <rakhmerov> let me see what's next
15:12:02 <rakhmerov> #topic Sync on Pike 2 progress
15:12:32 <rakhmerov> so, here basically I just would like to ask you to wrap up what's possible this week
15:12:43 <rakhmerov> and pay a little more attention to reviewing
15:12:59 <rakhmerov> and if you need help with something please don't be silent
15:13:38 <rakhmerov> and update statuses of you tasks please anyway so that we could see where we are
15:13:48 <rakhmerov> I did some of that today but not all
15:14:14 <rakhmerov> there's also a couple of BPs that I'd like to clarify with rbrady, d0ugal and apetrich
15:14:16 <rakhmerov> https://blueprints.launchpad.net/mistral/+spec/mistral-actions-api-fix-engine
15:14:23 <rakhmerov> https://blueprints.launchpad.net/mistral/+spec/mistral-actions-api-fix-executor
15:14:40 <rakhmerov> I asked apetrich to update them but he's off today I guess
15:14:51 <d0ugal> rakhmerov: I am not sure what "fix engine" means? Just to migrate them to mistral-lib?
15:14:57 <rakhmerov> so
15:15:06 <rakhmerov> those BPs were created long long ago
15:15:21 <rakhmerov> once upon a time... Renat created blueprints..
15:15:26 <d0ugal> https://github.com/openstack/mistral-specs/blob/master/specs/newton/approved/mistral-custom-actions-api.rst#work-items
15:15:40 <d0ugal> haha
15:15:55 <mgershen> haha
15:16:01 <rakhmerov> the idea was that after creating mistral-lib with all needed stuff we'd make changes on the server side whatever is needed
15:16:02 <rakhmerov> :)
15:16:08 <rakhmerov> in engine possible and executor
15:16:23 <rakhmerov> that was my understanding
15:16:23 <d0ugal> Right. I think at the time we expected mistral-lib to be much large (containing the context etc.)
15:16:28 <d0ugal> but I'm glad we didn't go down that route
15:16:35 <d0ugal> so I think we can consider these to be completed.
15:16:38 <rakhmerov> but I guess they may not be relevant anymore and we can close them
15:17:00 <rakhmerov> as far as engine, I left a comment in whiteboard
15:17:14 <rakhmerov> I found a patch that seems to implement this BP
15:17:21 <rakhmerov> for executor, I'm not sure
15:17:44 <rakhmerov> I remember that we inserted some condition to check if the action is from mistral-lib or not
15:17:54 <rakhmerov> d0ugal: was it you who made it?
15:18:11 <rakhmerov> so, I'm just wondering whether it's enough or not
15:18:14 <rakhmerov> for executor
15:18:18 <d0ugal> rakhmerov: the patch you linked? no, that was apetrich
15:18:22 <d0ugal> rakhmerov: but yes, I think it is enough
15:18:33 <rakhmerov> no-no, I'm now talking about executor
15:18:38 <rakhmerov> second..
15:19:21 <rakhmerov> d0ugal: this, https://github.com/openstack/mistral/blob/master/mistral/executors/default_executor.py#L109
15:19:36 <d0ugal> rakhmerov: right
15:19:38 <rakhmerov> does it seem all we had to do in there?
15:19:54 <d0ugal> rakhmerov: I believe so, we just need to leave that there until we can remove the old actions API
15:19:56 <rakhmerov> sorry, I just lost track of this work a little bit..
15:20:04 <rakhmerov> right
15:20:08 <d0ugal> I'm not sure how long the deprecation is for a change like that
15:20:19 <rakhmerov> which will happen in a couple of cycles I believe.. not earlier
15:20:35 <d0ugal> yup
15:20:36 <rakhmerov> first we need to gently deprecate old stuff and bring it to our lovely users
15:21:04 <rakhmerov> d0ugal: I would think it's in our interest to make it long )
15:21:17 <rakhmerov> but yes, we need to figure out
15:21:49 <rakhmerov> #action: rakhmerov, d0ugal: figure out for how long old actions should be deprecated before complete removal
15:22:07 <rakhmerov> okay
15:22:27 <rakhmerov> they I'm closing them? Marking "implemented"?
15:22:31 <rakhmerov> then..
15:22:39 <d0ugal> thanks
15:22:43 <rakhmerov> ok
15:22:47 <d0ugal> that works for me
15:23:18 <rakhmerov> with these two implemented the situation looks much more positive )
15:23:22 <rakhmerov> for Pike 2
15:23:30 <d0ugal> :-D
15:23:49 <rakhmerov> yeah, sorry, I just have this kind of mood today )
15:24:10 <apetrich> rakhmerov, d0ugal sorry. still sick.. I wasn't able to concentrate enough to read the blueprint
15:24:32 <rakhmerov> apetrich: we've discussed them a little bit and seems like they can be closed
15:24:46 <rakhmerov> but if you look at them tomorrow and disagree we can reopen them, np
15:24:59 <rakhmerov> thanks
15:25:24 <apetrich> rakhmerov, I only think that we have to move some Results from mistral to mistral_lib. I have those changes but didn't create a patch because the gates were still failing
15:25:29 <apetrich> but it is a simple change
15:25:41 <apetrich> on openstack actions
15:25:50 <rakhmerov> ok
15:25:56 <rakhmerov> the gates were fixed today
15:26:07 <rakhmerov> we had issues with docs but it's ok now
15:26:19 <rakhmerov> anything else on that?
15:26:46 <apetrich> rakhmerov, I don't think so. besides that I think we can close it
15:26:50 <rakhmerov> there's also a bunch of bugs, please take a look and see what can be quickly fixed (what's assigned to you) and what we need to move to P-3
15:27:02 <rakhmerov> apetrich: ok, thanks
15:27:42 <rakhmerov> d0ugal: like, for example https://bugs.launchpad.net/mistral/+bug/1664612
15:27:44 <openstack> Launchpad bug 1664612 in Mistral "tasks with a hyphen in their name don't work" [Undecided,Confirmed] - Assigned to Dougal Matthews (d0ugal)
15:27:57 <d0ugal> oh, wow. I forgot about that one
15:28:01 <rakhmerov> I might have asked you but it's worth checking again if it really exists
15:28:04 <d0ugal> I thought I fixed it actually, but I should check.
15:28:15 <rakhmerov> yeah, I'm not sure it exists but we need to update the status
15:28:17 <rakhmerov> at least
15:28:25 <rakhmerov> please go over them and check
15:28:34 <d0ugal> Will do
15:28:39 <rakhmerov> thanks
15:28:40 <rakhmerov> ok, let's move on
15:29:21 <rakhmerov> #topic Decide if new release model "cycle-with-intermediary" is ok for Mistral
15:29:43 <rakhmerov> yeah, so, there is a ML thread opened recently
15:29:57 <rakhmerov> about release model for several projects including Mistral
15:30:18 <rakhmerov> the problem is that 'mistral' is in reqiurements.txt in tripleO
15:30:31 <d0ugal> #link http://lists.openstack.org/pipermail/openstack-dev/2017-May/117658.html
15:30:32 <rakhmerov> d0ugal: right? (still trying to understand that myself)
15:30:44 <d0ugal> rakhmerov: yes, that is the problem
15:30:50 <rakhmerov> ok
15:31:03 <d0ugal> Mistral is in requirements, that means it is treated like a library but it is only released at the end of the cycle
15:31:18 <d0ugal> this means that the requirements in mistral limit the requirements in other projects
15:31:19 <rakhmerov> as a solution Thierry suggested us to switch to a different release model: cycle-with-intermediary
15:31:27 <rakhmerov> yes
15:31:30 <rakhmerov> exactly
15:31:55 <rakhmerov> cycle-with-intermediary does not assume having beta releases at all
15:32:04 <rakhmerov> like mistral-5.0.0.0b1
15:32:15 <rakhmerov> but only full releases (without letters)
15:32:23 <rakhmerov> which means all of them must be stable
15:32:24 <d0ugal> AFAICT with cycle-with-intermediary, we can release stable releases at any point
15:32:37 <rakhmerov> stable branch management remains the same, one per cycle, of course
15:32:45 <rakhmerov> yes
15:33:22 <rakhmerov> we talked today a little bit and it seems like the problem of having 'mistral' in TripleO dependencies may be gone soon
15:33:48 <rakhmerov> but anyway, we can make a decision to switch to this release model
15:34:01 <rakhmerov> 1) to me it seems more flexible
15:34:10 <d0ugal> so, if we made a release today, would it be 5.0?
15:34:11 <rakhmerov> 2) all our releases are considered stable
15:34:27 <rakhmerov> good question, probably yes
15:34:39 <d0ugal> and then after pike is released we would start to release 6.0
15:34:46 <rakhmerov> the thing is that this week is the last chance to make that decision
15:34:54 <rakhmerov> after pike-2 we'll have to wait till the next cycle
15:35:30 <d0ugal> I have one concern...
15:35:32 <rakhmerov> d0ugal: yes, the docs don't say anything about numbers for release but we can do something like that
15:35:36 <rakhmerov> d0ugal: yep?
15:35:47 <d0ugal> Mistral master is developed against KeyStone master for auth and all the other openstack projects
15:36:02 <d0ugal> so if we released 5.0 today, we might have a stable release that only works with unreleased projects
15:36:53 <d0ugal> so we release 5.0 today (or soon) which will be Pike but that needs to be tested against Ocata
15:37:15 <d0ugal> Does that make sense? I only just thought of it.
15:37:42 <rakhmerov> hm..
15:37:47 <rakhmerov> good question
15:38:47 <rakhmerov> but that's probably ok that intermediary releases work with keystone of full release of the previous cycle
15:38:57 <rakhmerov> what are other options?
15:39:18 <rakhmerov> in any case, we're supposed to make a normal release at the end of the cycle
15:39:38 <rakhmerov> but that release will be integrated with the latest changes in other projects
15:39:45 <rakhmerov> that's my understanding
15:39:55 <d0ugal> right
15:40:20 <d0ugal> I just think it will be confusing for our users if we tell them they need to install mistral, but not the latest version - the one that matches the latest OpenStack release
15:40:33 <d0ugal> we already need to tell them to avoit 2015.1 :(
15:40:34 <rakhmerov> well, yeah..
15:40:41 <rakhmerov> true
15:41:28 <d0ugal> I think it probably makes more sense to remove Mistral from requirements.txt - we will do that anyway
15:41:29 <rakhmerov> well, ok, maybe what we need to understand for now then is how critical it is for solving that dependency issue
15:41:47 <rakhmerov> if it's not I think we need to wait for next cycle
15:42:00 <d0ugal> right
15:42:08 <d0ugal> I guess I'll reply to the thread and ask some questions
15:42:17 <rakhmerov> d0ugal: yes, but the question is: how urgent is it?
15:42:26 <rakhmerov> and when can we do it in TripleO?
15:42:34 <rakhmerov> d0ugal: yes, let's do this
15:42:44 <rakhmerov> just not to rush with this..
15:42:45 <d0ugal> tripleo only needs it in requirements.txt for the unit tests :)
15:43:28 <rakhmerov> d0ugal: so, as far as I understand, it's not a risky change, you just need to make it? right?
15:43:35 <rakhmerov> I mean, technically there's no risk
15:43:49 <rakhmerov> all is clear
15:43:54 <d0ugal> rakhmerov: agreed, there is no risk.
15:43:58 <rakhmerov> ok
15:44:11 <rakhmerov> then please reply to the thread, I'd prefer not to rush
15:44:19 <d0ugal> ok
15:44:48 <rakhmerov> especially that I now remember Thierry saying that he'd prefer to give Mistral an exception of switching the model in the middle of the cycle )
15:45:05 <rakhmerov> usually it's forbidden, only in the beginning
15:45:14 <rakhmerov> before first milestone releaes
15:45:39 <rakhmerov> ok, deal
15:45:50 <rakhmerov> if there's no other thoughts..
15:47:19 <rakhmerov> so then
15:47:23 <rakhmerov> #topic Open Discussion
15:47:33 <rakhmerov> is there anything else from you?
15:47:58 <d0ugal> Not from me
15:48:08 <rbrady> not from me today
15:48:12 <mgershen> not from me
15:48:22 <rakhmerov> ok, many thanks
15:48:24 <thrash> no
15:48:34 <rakhmerov> please update the tickets
15:48:36 <rakhmerov> thanks
15:48:41 <rakhmerov> then let's finish
15:48:54 <rakhmerov> have a good week, thanks for being with us today
15:48:55 <rakhmerov> bye
15:48:59 <mgershen> Bye
15:49:03 <rakhmerov> #endmeeting