15:02:09 <rakhmerov> #startmeeting Mistral
15:02:10 <openstack> Meeting started Mon Jun 19 15:02:09 2017 UTC and is due to finish in 60 minutes. The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:13 <openstack> The meeting name has been set to 'mistral'
15:02:59 <mgershenzon> Hi
15:03:26 <d0ugal> Hey
15:03:41 <rakhmerov> hi
15:03:59 <rakhmerov> let's wait a minute
15:04:03 <toure> hello
15:04:06 <rakhmerov> hey
15:04:50 <apetrich> hiya
15:05:13 <rakhmerov> hi apetrich
15:05:20 <rakhmerov> #topic Review Action items
15:05:22 <rakhmerov> 1. rakhmerov: review https://review.openstack.org/#/c/470996/
15:05:22 <rakhmerov> done
15:05:26 <bobh> o/
15:05:34 <rakhmerov> 2. rakhmerov, d0ugal: figure out for how long old actions should be deprecated before complete removal
15:05:39 <rakhmerov> done, in R cycle
15:05:43 <rakhmerov> bobh: hi, welcome )
15:05:58 <d0ugal> I can't wait for R :-D
15:06:03 <rakhmerov> #topic Current status, plans
15:06:10 <rakhmerov> d0ugal: kidding me? :))
15:06:21 <d0ugal> I just like to delete stuff :)
15:06:35 <rakhmerov> d0ugal: but well, yeah, it will be a good thing to get into that crazy threading stuff again )
15:06:41 <rakhmerov> yes, agree
15:06:54 <rakhmerov> ok, so let's share our statuses and plans
15:07:15 <rakhmerov> after that we can discuss whatever we want, I don't have any specific agenda, just a couple of questions
15:07:23 <d0ugal> I don't have much to share, I have been busy with TripleO tasks. I did post this tiny review, which I need tho' https://review.openstack.org/475404
15:07:44 <mgershenzon> Working on adding a namespace for mistral workflos
15:07:56 <rakhmerov> my status: reviewing a lot, fixed one bug with trimming "state_info" (also backported it), working on HA (learhing OpenStack CI a little bit)
15:07:58 <mgershenzon> Workflows
15:08:03 <mgershenzon> https://review.openstack.org/#/c/470996/
15:08:18 <mgershenzon> Just uploaded a new PS
15:09:03 <rakhmerov> mgershenzon: cool, thanks
15:09:06 <apetrich> I'm changing mistral to use mistral-lib here https://review.openstack.org/#/c/474895/ but right now I'm dead end that is where is a good place to do serializer registration
15:09:22 <rakhmerov> d0ugal: please also participate in Michal's spec if you have a chance
15:09:25 <toure> status: I am at a point where I could use a pair of eye on my proposed change https://review.openstack.org/#/c/455447/ working out a small kink,
15:09:38 <apetrich> btw that patch is a bit old but I'm holding on changes to uplodad some changes
15:09:45 <d0ugal> rakhmerov: I will, I reviewed the previous version but not the new one yet
15:10:05 <rakhmerov> apetrich: yeah, you mentioned it in our channel. I have a couple of ideas but let me think more, I'll leave a comment with my thoughts
15:10:15 <apetrich> rakhmerov, cheers!
15:10:39 <apetrich> with that done. I have some changes to mistral-lib and then move more stuff there
15:11:02 <rakhmerov> apetrich: great
15:11:10 <rakhmerov> toure: what do you mean? You need help? )
15:11:29 <d0ugal> rakhmerov: I think toure just wants reviews.
15:11:34 <toure> rakhmerov reviews
15:11:38 <rakhmerov> ooh, ok
15:11:43 <mgershenzon> d0ugal, I approved the review you requested
15:11:59 <toure> :) my sqlalchemy battles are over I think
15:12:02 <rakhmerov> the reason I haven't reviewed its latest version yet is because it's still marked as WIP
15:12:03 <d0ugal> mgershenzon: thanks!
15:12:14 <toure> rakhmerov I removed it
15:12:24 <toure> it still has -1 workflow
15:12:24 <rakhmerov> toure: that's very good ) I'll review it
15:12:33 <toure> thanks
15:12:54 <rakhmerov> toure: yeah, just remove -1 Workflow once you think it's ready
15:13:02 <toure> k
15:13:04 <rakhmerov> that is usually a signal that it's ready for review
15:13:11 <toure> cool
15:13:17 <rakhmerov> yep, awesome
15:13:25 <rakhmerov> looking forward to reviewing it
15:13:58 <toure> yeah I was trying to get it ready for pike-2 but sqlalchemy was messing with me
15:14:01 <toure> :)
15:14:10 <rakhmerov> #action rakhmerov: talk to apetrich and decide where to put initialization of serialization stuff
15:14:21 <apetrich> :)
15:14:23 <rakhmerov> toure: no problem
15:14:33 <rakhmerov> yep, so
15:14:53 <rakhmerov> is there any topics you'd like to discuss?
15:15:20 <d0ugal> What do you think about a set of Mistral actions for creating and removing temp files/directories?
15:15:26 <rakhmerov> d0ugal: I'd like to ask you to check the status of that requirement problem
15:15:49 <d0ugal> rakhmerov: rbrady was helping me, because I was busy - but he isn't around today.
15:15:55 <d0ugal> so I'm not sure if anything changed
15:16:04 <rakhmerov> yeah, I see, that's why I'm asking :)
15:16:09 <d0ugal> Otherwise I should have time to get back to it tomorrow - I have some ideas for a hacky fix :)
15:16:22 <rakhmerov> because we haven't heard about it for a few days
15:16:30 <rakhmerov> yeah
15:16:51 <d0ugal> I'll find out and try and move it along faster.
15:16:56 <rakhmerov> I remember you asked me something (there was some problem with keystone again, right?) but don't remember exactly what it was
15:17:01 <rakhmerov> some decomposition stuff again
15:17:22 <rakhmerov> too much stuff going on..
15:17:33 <rakhmerov> but we can discuss, if needed
15:17:42 <rakhmerov> ok
15:17:57 <rakhmerov> d0ugal: on the new actions, can you elaborate?
15:18:04 <rakhmerov> #topic Open Discussion
15:18:15 <rakhmerov> temp files/directories where?
15:18:26 <rakhmerov> on the executors' hosts?
15:18:49 <d0ugal> rakhmerov: The problem was with the mistral config, the bit of code we import accesses the Mistral config - so moving it out gets tricky.
15:19:04 <d0ugal> rakhmerov: tempfiles - yeah, it would be on the executors hosts - but that would be a problem in a HA setup
15:19:07 <rakhmerov> aah, yeah, right
15:19:11 <d0ugal> so I am thinking it isn't a good idea now :)
15:19:31 <rakhmerov> what's your use case?
15:19:36 <d0ugal> it is a request I got from a tripleo dev, he needs to create a temp directory to pass to ansible
15:19:49 <rakhmerov> HA setup you mean when we have many executors on different hosts?
15:20:25 <d0ugal> yeah
15:20:31 <rakhmerov> yes, right
15:20:36 <d0ugal> meaning that the temp file might not exist on the host you need it on
15:20:49 <rakhmerov> however, there's one thing that not many probably use called "Task affinity"
15:21:01 <rakhmerov> or "task-executor affinity"
15:21:33 <rakhmerov> it's when you can mark a task with "target" attribute and its actions will always be routed to corresponding a executor
15:21:48 <d0ugal> right
15:22:07 <d0ugal> still, I think the tempfiles stuff could be a bit strange.
15:22:11 <rakhmerov> so potentially it might help if used with precaution
15:22:22 <d0ugal> yup
15:22:22 <rakhmerov> true
15:22:35 <d0ugal> it sounds a bit messy for me
15:22:41 <rakhmerov> we've never considered Mistral as a file system aware thing
15:22:45 <rakhmerov> yes
15:23:13 <rakhmerov> btw, I now remember that somebody already proposed a similar thing
15:23:16 <rakhmerov> I guess kong
15:23:26 <rakhmerov> there still should be a WIP in gerrit
15:23:30 <d0ugal> ah
15:23:33 <d0ugal> I'll take a look
15:23:37 <rakhmerov> may be we need to get back to reviewing it
15:23:38 <rakhmerov> yeah
15:23:59 <rakhmerov> ooh, it was something like "Run a script" action
15:24:12 <mgershenzon> Maybe openstack needs an object storage service. Do we have one?
15:24:13 <rakhmerov> that runs different types of scripts or binaries
15:24:18 <rakhmerov> depending on how it's configured
15:24:46 <rakhmerov> mgershenzon: well, we have Swift (S3-like) or Glance-Glare
15:25:12 <rakhmerov> Glare is a cool stuff which we still need to integrate with
15:25:43 <rakhmerov> d0ugal: yeah, but that patch got stuck in a long discussion. Lots of concerns were about security, as far as I remember
15:25:49 <d0ugal> yeah :)
15:26:12 <rakhmerov> kong was proposing it more for private cloud use cases
15:26:21 <d0ugal> mgershenzon: we might update it to work with Swift - the problem is the code currently expects a temp directory
15:26:25 <rakhmerov> where there's more control over infrastructure
15:26:32 <d0ugal> and for a moment it made sense that we had actions for tempfiles
15:26:39 <d0ugal> then I remembered about multiple executors :)
15:26:58 <rakhmerov> d0ugal: take a look at "target", it may really help
15:27:03 <mgershenzon> I see
15:27:17 <rakhmerov> that way we'll always know where a certain action will run
15:27:17 <d0ugal> rakhmerov: will do.
15:27:37 <rakhmerov> however, somebody reported recently that this feature is now broken :) Haha
15:27:55 <rakhmerov> I don't know if it's true (saw no evidence yet) but we'll need to check
15:28:39 <mgershenzon> Maybe if we group executors by VM and require tasks to run in a specific group it will work
15:28:47 <rakhmerov> d0ugal: one more question, do you think you'll have time soon to move OpenStack actions to mistral-extra?
15:29:10 <rakhmerov> mgershenzon: yes
15:29:34 <d0ugal> rakhmerov: I really want to, that task has the same problem that tripleo has. mistral-lib needs access to the mistral config.
15:29:48 <d0ugal> so once I have a solution for that, I can move both items forward.
15:29:55 <d0ugal> Suggestions are welcome :)
15:30:30 <rakhmerov> you mean the config problem?
15:31:24 <d0ugal> Yes
15:31:33 <rakhmerov> my solution: it requires a serious refactoring first, at least we need to decompose things properly first
15:31:47 <rakhmerov> it's now too entangled
15:32:26 <rakhmerov> #action rakhmerov: look at the config problem (some actions need Mistral config and can't be easily extracted)
15:32:47 <rakhmerov> ok, I'll have to look at it too
15:32:58 <rakhmerov> (gosh, so many things..)
15:32:59 <rakhmerov> :)
15:33:33 <rakhmerov> ok
15:33:44 <rakhmerov> is there anything else?
15:34:16 <rakhmerov> I'd also like to have a bug triaging session, maybe next meeting?
15:34:31 <rakhmerov> I believe we can close some of the bugs
15:35:03 <d0ugal> I think that is all from me
15:35:09 <d0ugal> A bug triage would be good.
15:35:32 <rakhmerov> ok
15:35:50 <rakhmerov> so let's end the meeting then?
15:35:58 <rakhmerov> thanks for coming
15:36:05 <rakhmerov> have a good week )
15:36:05 <mgershenzon> Fine by me
15:36:09 <rakhmerov> bye
15:36:12 <mgershenzon> Bye
15:36:12 <toure> have a good one
15:36:17 <rakhmerov> #endmeeting