15:02:44 <rakhmerov> #startmeeting Mistral
15:02:45 <openstack> Meeting started Mon Dec 11 15:02:44 2017 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:48 <openstack> The meeting name has been set to 'mistral'
15:02:51 <rakhmerov> hi
15:02:54 <thrash> o/
15:03:02 <d0ugal> Hey!
15:03:25 <toure> hello
15:03:59 <rakhmerov> ooh, 4 people )
15:04:01 <rakhmerov> not so bad
15:04:07 <rakhmerov> hi guys
15:04:36 <rakhmerov> I wonder for how long we haven't had any meetings
15:04:56 <rakhmerov> d0ugal: btw, did you have meetings in the last 2 weeks?
15:05:08 <d0ugal> rakhmerov: yup
15:05:11 <rakhmerov> ok
15:05:29 <rakhmerov> then maybe can you quickly update?
15:05:37 <rakhmerov> mostly myself I guess..
15:05:45 <rakhmerov> if there was anything important
15:06:00 <rakhmerov> I know about some CI problems and bugs that you pointed to last week
15:06:04 <d0ugal> rakhmerov: nothing important that I remeber, but I'd have to go and dig up the logs.
15:06:22 <rakhmerov> ok )
15:07:07 <rakhmerov> I have a couple topics to discuss with you but let's give quick updates maybe
15:07:09 <rakhmerov> as usually
15:07:17 <rakhmerov> #topic Current status
15:07:58 <apetrich> working on a yaql blueprint to add executions to the exported functions
15:08:02 <rakhmerov> my status: mostly doing reviews after my vacation, still have a few patches to review in my queue
15:08:13 <rakhmerov> apetrich: how is that going?
15:08:16 <apetrich> WIP here https://review.openstack.org/#/c/525926
15:08:18 <rakhmerov> close?
15:08:35 <apetrich> rakhmerov, missing the date range filters. Should have that ready for reviewing today
15:08:49 <apetrich> I want to get that in before we freeze freeze
15:08:56 <bobh> o/  sorry late
15:08:57 <rakhmerov> yep
15:09:03 <rakhmerov> bobh: hi, that's ok )
15:09:08 <rakhmerov> we just started
15:09:17 <rakhmerov> apetrich: ok, cool
15:09:20 <rakhmerov> very cool
15:09:31 <rakhmerov> bobh: if you have some updates, please share
15:09:46 <d0ugal> I have been working on tempest failures and the refactor of the mistral context is now starting to pass CI.
15:10:09 <rakhmerov> I'm also planning with my management what to do next since the most critical phase is finally over for us
15:10:20 <bobh> working on the task on-clause change, need to refine the on-clause spec definition
15:10:27 <rakhmerov> d0ugal: yep, I think we're close to merge what's needed
15:10:39 <rakhmerov> bobh: ok
15:10:44 <d0ugal> One more review needed on https://review.openstack.org/#/c/506185/
15:11:01 <toure> status: rerun execution still waiting on reviews 506652, 506653 and I have been working on porting ansible actions into mistral-extras
15:11:24 <rakhmerov> d0ugal: btw, when I was reviewing your patches I found myself on the thought that now we assume that our SecurityContext always reflects Keystone stuff
15:11:28 <thrash> zuul v3 native job definitions are almost complete.
15:11:36 <rakhmerov> whereas, in fact, we can also work with Keycloack
15:11:52 <d0ugal> toure: it is probably a good idea to remove [WIP] from reviews that are ready, people don't tend to look at them otherwise
15:12:03 <toure> d0ugal ack just did
15:12:04 <toure> :)
15:12:16 <rakhmerov> d0ugal: I understand it's a big change and not sure if we can adapt it for both but may be you've already thought about it
15:12:17 <d0ugal> toure: oh, cool. I'll take a look then.
15:12:18 <toure> I totally spaced on the description
15:12:35 <rakhmerov> #action rakhmerov: review https://review.openstack.org/#/c/506185/
15:12:47 <d0ugal> rakhmerov: I did think it was a bit strange, maybe we should have called it "context.keystone"?
15:13:09 <d0ugal> rakhmerov: but yeah, changing it now would be super painful.
15:13:15 <rakhmerov> yep
15:13:17 <rakhmerov> I know
15:13:48 <rakhmerov> hm... don't know maybe we could have some very generic base class for security context for now with just one implementation for Keystone
15:13:56 <d0ugal> True
15:14:05 <rakhmerov> but I know it's super painful
15:14:31 <d0ugal> rakhmerov: I really want to get this work merged, then we can look into refactoring/improving after?
15:14:41 <rakhmerov> absolutely, yes
15:14:43 <rakhmerov> I agree
15:15:02 <rakhmerov> let's merge it and during Q-3 we can potentially make some adjustements
15:15:07 <rakhmerov> (theoretically)
15:15:08 <d0ugal> Thanks
15:15:11 <d0ugal> :)
15:15:49 <rakhmerov> toure: hey, I thought 506652, 506653 are still WIPs, no?
15:15:56 <rakhmerov> or they are ready to be reviewed?
15:16:01 <rakhmerov> if so, I'll do it asap
15:16:34 <toure> rakhmerov they are ready for review I forgot to push the change for the commit message to remove WUP
15:16:37 <toure> **WIP
15:16:47 <rakhmerov> ooh, that explains a lot ;)
15:16:49 <rakhmerov> please do
15:16:51 <toure> :)
15:16:53 <toure> done
15:17:06 <rakhmerov> very few people will review until you remove WIP )
15:17:16 <rakhmerov> ok, good
15:17:32 <rakhmerov> thrash: question to you. You said "zuul v3 native job definitions are almost complete"
15:17:42 <thrash> rakhmerov: yes.
15:17:43 <rakhmerov> so what exactly are you working on there?
15:17:52 <rakhmerov> sorry, I'm just not in the loop honestly
15:17:57 <rakhmerov> been away for a while
15:18:10 <rakhmerov> or maybe you can point to something so that I could learn
15:18:11 <d0ugal> https://review.openstack.org/509428
15:18:25 <thrash> rakhmerov: the "legacy" jobs, which is what we have now, use a lot of shell, and don't take advantage of the zuul v3 stuff... Like being able to inherit from other jobs.
15:18:44 <rakhmerov> ooh, legacy jobs
15:18:55 <rakhmerov> ok
15:19:09 <rakhmerov> I'm asking because, for some reason, I thought it was all done already
15:19:09 <thrash> moving the job definitions into the repo was the first step. This gets rid of the legacy stuff, and uses far less boilerplate.
15:19:11 <rakhmerov> a while ago
15:19:24 <rakhmerov> ok, I see
15:19:26 <thrash> that was just the move into the repo. This is to make them better. :D
15:19:41 <rakhmerov> so this is supposed to the the final step towards the full migration, right?
15:19:46 <thrash> Yes
15:19:49 <rakhmerov> ok
15:19:52 <rakhmerov> good
15:19:55 <rakhmerov> thanks
15:20:15 <thrash> rakhmerov: for reference... https://docs.openstack.org/infra/manual/zuulv3.html#legacy-job-migration-details
15:20:24 <rakhmerov> ok
15:20:37 <rakhmerov> thank you
15:20:44 <rakhmerov> then let's move on
15:20:54 <rakhmerov> I'd like to discuss the following topic
15:21:02 <rakhmerov> #topic Do we need weekly meetings now?
15:21:08 <rakhmerov> :)
15:21:33 <d0ugal> rakhmerov: http://eavesdrop.openstack.org/meetings/mistral/2017/mistral.2017-12-04-15.00.log.html#l-76
15:21:43 <d0ugal> From last week :) see the 4th last line.
15:21:48 <rakhmerov> the reason I'd like to discuss it is because 1) I know some of the teams don't have these meetings anymore 2) in the last few months we skipped a lot of them
15:22:21 <rakhmerov> aah
15:22:37 <rakhmerov> d0ugal: what are these "office hours" exactly?
15:22:42 <rakhmerov> not sure I fully understand
15:23:07 <d0ugal> rakhmerov: I'm not sure exactly. But I think we just advertise somewhere when we are normally available in #openstack-mistral and encourage people to come and speak to us then
15:23:13 <d0ugal> so instead of telling them to come to the meeting
15:23:23 <d0ugal> For example this is how the TC does it: https://governance.openstack.org/tc/#office-hours
15:23:34 <rakhmerov> ok
15:23:36 <rakhmerov> let me see..
15:23:36 <bobh> keystone does as well I believe
15:23:42 <d0ugal> yup
15:23:50 <rakhmerov> yeah, I've seen that for keystone a lot
15:24:26 <rakhmerov> hah, interesting..
15:24:37 <rakhmerov> that looks good to me
15:24:58 <d0ugal> I'm not sure which days/times we pick.
15:25:10 <d0ugal> but I guess we can work that out with a poll or something
15:25:10 <rakhmerov> I just thought that maybe we need some known time windows when we could overlap ourselves, team members I think
15:25:23 <rakhmerov> to sync up and discuss relevant topics
15:25:31 <d0ugal> Right, I think we can use the office hours for that.
15:26:13 <rakhmerov> why does it have to be "#openstack-tc"?
15:26:19 <rakhmerov> can it be just our channel?
15:26:27 <d0ugal> rakhmerov: It doesn't - that is just where the TC have their office :)
15:26:31 <d0ugal> it should be our own channel
15:26:38 <rakhmerov> ok
15:26:40 <rakhmerov> yep
15:27:03 <rakhmerov> and I'm just concerned with 1 hour duration
15:27:14 <rakhmerov> I don't understand why it's just 1 hour
15:27:23 <rakhmerov> but I guess it's up to us, right?
15:27:24 <d0ugal> We can make it longer
15:27:28 <rakhmerov> yes, ok
15:27:40 <d0ugal> I don't think it is a gurantee, it just means "we will normall be around during there times"
15:27:43 <d0ugal> or, that is how I read it
15:27:50 <rakhmerov> I see
15:28:00 <d0ugal> I guess the TC is a bit different, because I assume they are usually busy doing other things
15:28:14 <rakhmerov> well, sounds good to me. In addition, I'd like to have a clear picture of when we could talk ourselves
15:28:18 <rakhmerov> somehow
15:28:33 <rakhmerov> it's pretty easy for folks whose time zones are close
15:28:42 <rakhmerov> like me, d0ugal and apetrich
15:28:54 <rakhmerov> but harder with North America, for example
15:28:54 <apetrich> :)
15:29:04 <d0ugal> aye
15:29:33 <rakhmerov> so office hours is mostly for non team members to talk to team members?
15:29:39 <d0ugal> I guess we can propose a number of different blocks and add/remove/change them over time.
15:29:52 <rakhmerov> or they can also be used as a replacement for this kind of meetings?
15:29:55 <d0ugal> I think office hours is for anyone that wants to talk, within the team or anyone else.
15:30:02 <d0ugal> but I'm not sure.
15:30:05 <rakhmerov> ok
15:30:19 <d0ugal> I think they are just the same as meetings, but without any structure and if there is nothing to talk about nothing happens
15:30:32 <rakhmerov> I see
15:30:42 <d0ugal> so, yes, I don't think we would need the meeting
15:31:07 <rakhmerov> so are there objections from anyone else?
15:31:19 <rakhmerov> I also think we don't need these regular meetings
15:31:36 <rakhmerov> pretty often they are almost empty (very few people)
15:31:47 <rakhmerov> I believe we need some flexibility here
15:32:00 <rakhmerov> bobh, toure, apetrich, thrash?
15:32:02 <toure> +1
15:32:13 <thrash> +1
15:32:20 <apetrich> +1
15:32:25 <rakhmerov> ok
15:32:53 <rakhmerov> then I can learn more about this "office hours" concept and try to apply to us
15:33:22 <rakhmerov> I guess we can communicate time slots over ML and/or some voting system
15:33:32 <d0ugal> Sounds good.
15:33:46 <toure> sounds good
15:33:53 <rakhmerov> ok
15:34:08 <rakhmerov> #action rakhmerov: learn about "office hours" and propose time slots
15:34:56 <rakhmerov> the other topic I wanted to discuss was already explained (ongoing CI work)
15:35:03 <rakhmerov> so I don't have much else
15:35:47 <rakhmerov> I'm planning to do some house keeping in launchpad this week and update statuses of the most important tickets
15:35:48 <bobh> +1
15:36:02 <rakhmerov> and pay attention to things that require it
15:36:31 <rakhmerov> bobh: like event notifications (mostly finished my review but was distracted today)
15:36:41 <rakhmerov> :)
15:36:49 <rakhmerov> anything else guys?
15:36:50 <bobh> :-)
15:37:22 <rakhmerov> one more thing, I know it's pretty early but please try to plan your participation in the PTG
15:37:41 <bobh> trying :-)
15:37:51 <rakhmerov> I already said "yes" to the question "Is Mistral team going to be at the PTG?"
15:37:52 <rakhmerov> :)
15:38:05 <d0ugal> great
15:38:39 <rakhmerov> ok
15:38:47 <rakhmerov> so ending the meeting?
15:39:00 <d0ugal> Nothing else from me
15:39:20 <rakhmerov> and I'd like to ask you very much: please go over all of your patches once in a while and make sure to address comments
15:39:26 <rakhmerov> and update their statuses
15:39:32 <rakhmerov> make them visible please
15:39:36 <rakhmerov> it helps a lot
15:40:10 <rakhmerov> ok, thanks to everyone!
15:40:20 <rakhmerov> have a good week )
15:40:24 <rakhmerov> bye
15:40:34 <d0ugal> Thanks!
15:40:38 <toure> have a good one
15:40:43 <bobh> bye
15:40:47 <rakhmerov> #endmeeting