08:01:57 <rakhmerov> #startmeeting Mistral
08:01:58 <openstack> Meeting started Wed May 22 08:01:57 2019 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:02:01 <openstack> The meeting name has been set to 'mistral'
08:02:32 <rakhmerov> d0ugal, vgvoleg, pgaxatte, apetrich: hi
08:02:38 <d0ugal> Hey
08:02:48 <rakhmerov> :)
08:03:07 <vgvoleg> hello
08:03:16 <rakhmerov> just want to check if we have at least a small crowd to chat about anything
08:03:20 <rakhmerov> d0ugal: how's it going?
08:03:39 <d0ugal> I'm good thanks :) Keeping busy with various things!
08:03:55 <d0ugal> Unfortunately no Mistral news from me.
08:04:26 <vgvoleg> #help
08:04:37 <vgvoleg> how's it should work
08:04:40 <rakhmerov> d0ugal: yep, ok )
08:04:40 <vgvoleg> ?
08:04:53 <rakhmerov> vgvoleg: what do you mean? :)
08:05:05 <vgvoleg> I've typed
08:05:11 <rakhmerov> "#help"?
08:05:13 <vgvoleg> "#help"
08:05:20 <d0ugal> lol
08:05:21 <vgvoleg> and nothing happended
08:05:22 <rakhmerov> aah, I don't know honestly
08:05:26 <d0ugal> Are you looking for meetingbot commands?
08:05:33 <rakhmerov> #help
08:05:43 <d0ugal> https://wiki.debian.org/MeetBot
08:05:57 <d0ugal> "#help - Add a "Call for Help" to the minutes. Use this command when you need to recruit someone to do a task. (Counter-intuitively, this doesn't provide help on the bot) "
08:06:10 <rakhmerov> yeah
08:06:32 <rakhmerov> it's like "#action" that puts an special entry into the meeting log
08:06:50 <pgaxatte> hello
08:07:04 <rakhmerov> vgvoleg: so these are basically some commands to make the meeting log good looking and more structured
08:07:11 <rakhmerov> pgaxatte: hey! How have you been?
08:07:43 <pgaxatte> good thanks rakhmerov
08:07:48 <rakhmerov> ok )
08:07:55 <pgaxatte> very busy on openstack-helm these days :D
08:08:02 <rakhmerov> I see
08:08:05 <rakhmerov> good
08:09:10 <vgvoleg> #idea guys what do you think about 'fail-on' policy on task, which read boolean expression and force fail task if it is True?
08:09:14 <rakhmerov> pgaxatte, vgvoleg, d0ugal: we used to have this kind of meetings on a regular basis but we've not had them I guess since Decemtber. So I'll try to renew this tradition so that we have some dedicated time to gather team members and chat
08:09:44 <rakhmerov> pgaxatte: please spread out this info across your colleagues who have something to do with Mistral
08:09:57 <pgaxatte> rakhmerov: i'm not actively working on mistral but i'll pass the word to the teams here so they can attend the meetings
08:10:01 <rakhmerov> we can brainstorm on stuff, triage bugs etc. etc., revisit BPs
08:10:09 <rakhmerov> pgaxatte: yes, please
08:10:11 <rakhmerov> thanks
08:10:33 <rakhmerov> vgvoleg: what's the use case for "fail-on"?
08:10:34 <pgaxatte> and anyway I'll keep an ear out :)
08:10:42 <rakhmerov> vgvoleg: can you describe?
08:10:51 <rakhmerov> pgaxatte: appreciate
08:10:52 <vgvoleg> We are actively use this policy in our Mistral fork, and I don't know if it is interesting for vanilla Mistral or not
08:11:18 <rakhmerov> it may be, but we need to know more on what you mean by that
08:12:06 <vgvoleg> For example, we use some action, that return any result. We can add e.g. 'fail-on: <% task().result <=4 %>' and fail a task if result is unsatisfactory
08:12:33 <vgvoleg> so we don't hide this logic in action code and make flow more readable
08:13:17 <rakhmerov> vgvoleg: Oleg, it seems like you can do it in a different way
08:13:21 <rakhmerov> so
08:13:49 <rakhmerov> 1) there's the notion of a error result for an action that can be actually used later in the workflow
08:14:08 <rakhmerov> that is, if your action finished with an error but still generated a result that you can use
08:14:17 <rakhmerov> and then you can do:
08:14:20 <rakhmerov> on-error:
08:14:38 <rakhmerov> - fail: <% task().result ... %>
08:14:48 <rakhmerov> if you also need to fail the entire workflow
08:15:09 <rakhmerov> maybe I don't fully understand your idea though
08:15:41 <rakhmerov> an example: std.http action may return a error status code and it will be considered an error result
08:15:57 <rakhmerov> in the workflow text you'll be able to use it in some conditions
08:16:03 <rakhmerov> via task().result
08:16:12 <rakhmerov> e.g. task().result.status_code
08:17:05 <rakhmerov> vgvoleg: what do you think?
08:17:26 <rakhmerov> I have to admit thought that it might not be well documented now )
08:17:32 <rakhmerov> as some other things
08:17:51 <vgvoleg> You talk about tasks with ERROR status
08:18:30 <rakhmerov> yes
08:18:42 <vgvoleg> I say about setting ERROR status to the task that was SUCCESS, but for some way it's result is unsatisfactory
08:19:10 <rakhmerov> do you necessarily need to fail the same task?
08:19:46 <rakhmerov> the semantics here is the following: if the action is successful then the task will be successful too (unless there are errors in YAQL, for example)
08:20:11 <rakhmerov> but we can always handle the action result via conditions in the on-success clause
08:20:29 <rakhmerov> and, for example, fail the entire workflow or reroute to another task
08:21:10 <rakhmerov> but you saying that we can extend this semantics and add one more thing to force fail the task...
08:21:11 <rakhmerov> hm..
08:22:06 <rakhmerov> well, ok
08:22:08 <vgvoleg> yes
08:22:11 <rakhmerov> it may make sense
08:22:24 <rakhmerov> vgvoleg: can you please file a blueprint for this?
08:22:29 <vgvoleg> It is more readable
08:22:38 <rakhmerov> with a detailed description
08:22:44 <vgvoleg> yes, sure
08:22:49 <rakhmerov> ok, thanks
08:22:58 <vgvoleg> I just wanted to know you opinion :)
08:23:04 <rakhmerov> also a note on the mailing list would be helpful
08:23:28 <rakhmerov> vgvoleg: I need to think. Seems like it's not going to harm anything
08:24:00 <rakhmerov> but let's try to think it over and look at it from different angles
08:24:41 <rakhmerov> #action vgvoleg: file a blueprint about the new "fail-on" policy to fail a task even if its action finished successfully
08:26:52 <rakhmerov> ok
08:27:03 <rakhmerov> we've got the first action item!
08:27:06 <rakhmerov> cool )
08:27:43 <rakhmerov> vgvoleg, d0ugal, pgaxatte: do you have anything else for now?
08:30:05 <rakhmerov> ok, if not, I'll close the meeting but we'll still be online for a while
08:30:12 <pgaxatte> rakhmerov: nope not for me. But as we discussed in Denver, we're trying to move our mistral deployments to K8s+Helm so when that is done I'll probably have some stuff to add in Mistral itself :D
08:30:48 <rakhmerov> yes, I remember, thanks Pierre
08:30:52 <rakhmerov> ok
08:31:04 <rakhmerov> thanks for coming :)
08:31:08 <rakhmerov> #endmeeting