06:03:16 <rakhmerov> #startmeeting Mistral M-2 planning
06:03:16 <openstack> Meeting started Wed Dec 16 06:03:16 2015 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:03:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
06:03:20 <openstack> The meeting name has been set to 'mistral_m_2_planning'
06:03:35 <LimorStotland> do you want to start ui or backend?
06:04:17 <rakhmerov> what do you mean?
06:04:32 <rakhmerov> start our discussion with ui or backend?
06:04:42 <LimorStotland> mistral-dashboard or the engine side?
06:04:50 <rakhmerov> #info Mitaka release schedule: http://docs.openstack.org/releases/schedules/mitaka.html
06:05:20 <rakhmerov> LimorStotland: I actually don't know, it doesn't matter in what order we'll be discussing BPs
06:05:28 <rakhmerov> to me at least
06:05:31 <rakhmerov> whatever you wish
06:05:38 <LimorStotland> Ok
06:05:41 <m4dcoder> hey
06:05:58 <rakhmerov> hi Winson, gland you joined!
06:06:00 <m4dcoder> meeting in this channel or over in openstack-meeting
06:06:01 <rakhmerov> glad
06:06:08 <rakhmerov> in this channel
06:06:23 <rakhmerov> we just started
06:06:42 <rakhmerov> LimorStotland: so in what order would you prefer to discuss our tasks?
06:07:26 <rakhmerov> alright, let's keep moving
06:07:30 <LimorStotland> let's go the bp order and i will update on the ui when we get there :-)
06:07:43 <rakhmerov> ok, thanks
06:08:00 <rakhmerov> so, as you see in the schedule M-2 needs to be released before 22nd Jan
06:08:11 <rakhmerov> we have just over a month
06:08:43 <rakhmerov> here's the page for M-2 in LP: https://launchpad.net/mistral/+milestone/mitaka-2
06:08:56 <rakhmerov> it currently contains BPs and bugs that were moved from M-1
06:09:15 <rakhmerov> btw, just a note: surprisingly in M-1 we were able to finish most of what we planned
06:09:17 <rakhmerov> :)
06:09:30 <rakhmerov> especially we fixed tons of bugs
06:09:39 <rakhmerov> including some very important bugs
06:09:45 <rakhmerov> so well done, team!
06:09:48 <rakhmerov> ok
06:10:33 <rakhmerov> here's the list of all BPs: https://blueprints.launchpad.net/mistral
06:10:58 <rakhmerov> lane_kong: for some reason I don't see Resource sharing BP assigned to any milestone
06:11:09 <rakhmerov> I thought it was assigned to M-1
06:11:14 <rakhmerov> can you clarify?
06:11:22 <_gryf> hi
06:11:26 <lane_kong> rakhmerov: https://blueprints.launchpad.net/mistral/+spec/mistral-resource-sharing
06:11:34 <rakhmerov> yep
06:11:57 <rakhmerov> _gryf: we're having a planning session right now, you can join if you'd like :)
06:12:10 <_gryf> ok :)
06:12:10 <lane_kong> rakhmerov: how can i set the milestone of it?
06:12:14 <rakhmerov> thinking what to work on during the next month :)
06:12:19 <rakhmerov> sorry for the late notice
06:12:45 <rakhmerov> lane_kong: you don't have permissions to change it?
06:12:48 <rakhmerov> weird
06:12:57 <NikolayM> I just moved it to M-2 and set progress
06:13:08 <lane_kong> i can't see milestone in Series goal
06:13:23 <NikolayM> that's strange
06:13:34 <rakhmerov> ok, let's figure out what's wrong with your permissions later
06:13:41 <rakhmerov> you're supposed to have all rights to do it
06:13:47 <lane_kong> rakhmerov: ooh, i saw that
06:13:51 <lane_kong> overlooked
06:13:54 <rakhmerov> :)
06:13:55 <rakhmerov> ok
06:14:04 <lane_kong> NikolayM: thanks
06:14:17 <rakhmerov> lane_kong: we also owe reviews for this
06:14:20 <rakhmerov> sorry man
06:14:28 <lane_kong> rakhmerov: that's fine :-)
06:14:34 <rakhmerov> no, that's not fine :)
06:14:39 <rakhmerov> we need to improve
06:14:47 <rakhmerov> ok, let's go on
06:14:59 <LimorStotland> rakhmerov: i don't see the multi region bp ? do we want to do in m2?
06:15:07 <rakhmerov> LimorStotland, gpaz: question to you
06:15:09 <rakhmerov> yes!
06:15:23 <rakhmerov> I just wanted to ask you if you're interested in some specific BPs for M-2
06:15:28 <rakhmerov> let's assign it
06:15:35 <LimorStotland> Ok moving it to m2
06:15:54 <rakhmerov> ooh, it is actually for M-3
06:16:03 <rakhmerov> but yes, we can try to do it in M-2
06:16:05 <gpaz> Thats fine I think
06:16:26 <LimorStotland> yes we are... the multi, HA and stability bugs
06:16:42 <rakhmerov> well, at least we can try to get it done in M-2 and see if we have some challenges with it
06:16:57 <LimorStotland> I move it if we have time we will do it if not it will be postponed to m3
06:17:16 <_gryf> ha is not even specified fully yet. It would be hard to make it on m-2
06:17:18 <openstackgerrit> hardik proposed openstack/mistral: Added engine to tempest plugin.  https://review.openstack.org/258276
06:17:22 <lane_kong> rakhmerov: please mark this one to m-2, https://blueprints.launchpad.net/mistral/+spec/mistral-docker-image, i think hparekh_  is working ont that
06:17:35 <LimorStotland> I see that some one add the multi cloud  then i think it should be started
06:17:48 <rakhmerov> lane_kong: he's effectively done it, I guess. We need to review it
06:18:07 <lane_kong> rakhmerov: yes, i'm keeping my eye on it
06:18:11 <rakhmerov> LimorStotland: multi cloud?
06:18:18 <rakhmerov> do we have a BP for this?
06:18:55 <LimorStotland> yes in the multi region i see this link (https://blueprints.launchpad.net/mistral/+spec/mistral-multicloud)
06:19:09 <LimorStotland> apparently so :-)
06:19:46 <rakhmerov> let's clarify this
06:19:56 <rakhmerov> because I'm not sure I 100% understand
06:20:16 <rakhmerov> is it a dependency of multi-region?
06:20:21 <LimorStotland> Ooo so the name got me confused... ok :-)
06:20:34 <rakhmerov> I see that this multi-cloud BP is for Heat actually
06:21:33 <rakhmerov> how is that related to Heat?
06:21:38 <LimorStotland> so we definitely need to decouple this 2 bp
06:21:45 <rakhmerov> I guess so
06:22:14 <rakhmerov> I kind of understand that if we use Heat in conjunction with Mistral then may be yes, we need to also consider that BP
06:22:35 <rakhmerov> but I'd like to decouple them and not consider them together
06:23:38 <LimorStotland> Ok, so i will removing this line from the bp
06:23:53 <rakhmerov> ok
06:23:57 <rakhmerov> let's move on
06:24:05 <rakhmerov> LimorStotland: anything else from your side?
06:24:35 <LimorStotland> yep...we have the ha and stability and from the ui :
06:25:22 <LimorStotland> gal and liat are working on pagination and auto refresh for the existing screens
06:25:24 <rakhmerov> as far as HA we have https://blueprints.launchpad.net/mistral/+spec/mistral-ha
06:25:36 <rakhmerov> but it's description is slightly outdated
06:25:47 <LimorStotland> and action executions and crontriggers
06:25:54 <rakhmerov> ok, good
06:26:05 <mgershen> and also keys security (engine) - maybe start using barbican.
06:26:22 <rakhmerov> do we have BPs for that in LP, I'm slightly behind of what's going on in UI
06:26:40 <rakhmerov> mgershen: BP for that? Do we have it?
06:27:16 <LimorStotland> I think i saw code review on adding the barbican actions
06:27:29 <mgershen> we didn't write one yet. we wanted to see what the community thinks first.
06:27:34 <rakhmerov> as far as https://blueprints.launchpad.net/mistral/+spec/mistral-ha, I assigned it to M-2 but we need to update its description and break down into several BPs
06:27:55 <rakhmerov> #action rakhmerov, akuznetsova, melisha: break down https://blueprints.launchpad.net/mistral/+spec/mistral-ha into several smaller BPs
06:28:21 <rakhmerov> mgershen: ok, please file a BP for that
06:28:42 <rakhmerov> #action mgershen, LimorStotland: file a BP for using Barbican for storing keys
06:29:00 <rakhmerov> I guess it could be assigned to M-3 may be
06:31:07 <LimorStotland> ok
06:31:37 <rakhmerov> LimorStotland: so please clarify on that UI work
06:32:05 <rakhmerov> the work that's going on, is it related with any active BPs?
06:32:15 <LimorStotland> gal and liat are working on pagination and auto refresh for the existing screens
06:32:24 <LimorStotland> new screens :action executions and crontriggers
06:33:00 <rakhmerov> for cron triggers we have this: https://blueprints.launchpad.net/mistral/+spec/mistral-dashboard-cron-trigger-screen
06:33:09 <rakhmerov> do we need to assign it to M-2 also?
06:33:31 <LimorStotland> yep
06:33:31 <rakhmerov> ok, I just did :)
06:33:35 <LimorStotland> :-)
06:33:54 <rakhmerov> I don't see a BP for action executions though
06:34:19 <LimorStotland> https://blueprints.launchpad.net/mistral/+spec/mistral-dashboard-executions-screen
06:34:34 <rakhmerov> ooh, ok
06:34:37 <rakhmerov> then we're fine
06:34:48 <rakhmerov> what about this one? https://blueprints.launchpad.net/mistral/+spec/actions-screen-improvements
06:34:54 <rakhmerov> is it being worked on?
06:35:09 <LimorStotland> yes i think it's yours :-)
06:35:39 <rakhmerov> hm.. what do you mean? :)
06:35:52 <rakhmerov> it's not assigned to me
06:36:07 <LimorStotland> I think that the currect bp is  https://blueprints.launchpad.net/mistral/+spec/actions-screen-improvements
06:36:13 <gpaz> Liat is working on that theses days
06:36:23 <gpaz> action screen
06:36:40 <rakhmerov> ok
06:36:45 <rakhmerov> thanks gpaz
06:37:31 <rakhmerov> ok
06:38:05 <rakhmerov> LimorStotland, gpaz: I would also ask you to just pick up the most important bugs and assign to M-2
06:38:10 <rakhmerov> it can be done offline
06:38:20 <LimorStotland> ok
06:38:27 <rakhmerov> this one is already assigned to M-2: https://bugs.launchpad.net/mistral/+bug/1524477
06:38:27 <openstack> Launchpad bug 1524477 in Mistral "After-task logic runs multiple times if tasks run in parallel" [High,New] - Assigned to Renat Akhmerov (rakhmerov)
06:38:35 <rakhmerov> I'll look at it
06:38:52 <gpaz> reaant, the bug that we discussed two days ago .. I m not how easy to fix but you said that you ll take a look
06:38:59 <gpaz> https://bugs.launchpad.net/mistral/+bug/1524477
06:39:22 <rakhmerov> yeah, that's the bug I'm talking about
06:39:24 <gpaz> oh yes :)
06:39:32 <rakhmerov> my guess is that should be easy to fix
06:39:50 <rakhmerov> I implemented that logic in the first place so I should fix it..
06:40:17 <rakhmerov> ok, is this all for now from ALU folks? LimorStotland, gpaz, mgershen?
06:40:38 <gpaz> AFAIK, yes
06:40:41 <rakhmerov> ok
06:40:42 <LimorStotland> i think so...
06:41:01 <rakhmerov> lane_kong, m4dcoder: is there anything specific you're interested in?
06:41:39 <m4dcoder> yes, the env update on task re-run which i'm working on
06:41:56 <rakhmerov> ok, where's the bug/BP for that?
06:41:58 <rakhmerov> do we have it?
06:42:11 <m4dcoder> hold on
06:42:17 <rakhmerov> https://blueprints.launchpad.net/mistral/+spec/mistral-rerun-update-env ?
06:42:26 <rakhmerov> is this the correct one?
06:42:27 <m4dcoder> https://blueprints.launchpad.net/mistral/+spec/mistral-rerun-update-env
06:42:28 <m4dcoder> yes
06:42:31 <rakhmerov> ok )
06:42:41 <rakhmerov> how is the progress with it btw?
06:42:45 <rakhmerov> any roadblocks?
06:42:55 <lane_kong> rakhmerov: i think https://blueprints.launchpad.net/mistral/+spec/mistral-resource-sharing and https://blueprints.launchpad.net/mistral/+spec/use-workflow-id-in-rest-api are sufficient for me to make them happen in M-2.
06:43:12 <rakhmerov> lane_kong: ok!
06:43:16 <NikolayM> I'll move bp related to env update to M-2
06:43:18 <m4dcoder> no i don't think so. just need to revisit the spec.  i already started implementing
06:43:27 <lane_kong> they are both sepecific to workflow, once they're done, we can spread them to other resources in mistral
06:43:46 <m4dcoder> also, i want to start https://blueprints.launchpad.net/mistral/+spec/mistral-priority-task-scheduler but likely won't complete until m3
06:44:37 <rakhmerov> lane_kong: my strong opinion that yes, it needs to be spread for all resources
06:44:58 <lane_kong> rakhmerov: that's my plan :-)
06:45:02 <rakhmerov> m4dcoder: yes, we can assign it to M-3 preliminarily
06:45:09 <m4dcoder> thanks
06:45:41 <rakhmerov> m4dcoder: like we discussed with you on Fri I'd like we to discuss this priority scheduler together with ALU team
06:46:09 <m4dcoder> yes. i'll start discussion in ML and put together a proper spec.
06:46:17 <rakhmerov> like I said: we touched that at the last summit but I guess I was unable to find enough reasoning to convince them that it's important to do
06:46:23 <rakhmerov> yep, thank you
06:47:14 <rakhmerov> _gryf: anything you're specifically interested?
06:47:22 <rakhmerov> in
06:47:36 <rakhmerov> some bugs, BPs
06:48:08 <_gryf> rakhmerov, yup, actually ddeja is currently strugling with the setup, on which we are planning to do some tests regarding HA
06:48:28 <rakhmerov> struggling? :)
06:48:32 <_gryf> so i think it to early to make a statement on submiting any bp or bugs
06:48:47 <_gryf> rakhmerov, yeah, hardware issues ;)
06:48:52 <adarshkoyya> Hi
06:48:56 <adarshkoyya> anyone there ?
06:48:56 <rakhmerov> ok, please feel free to file them as you go
06:49:09 <rakhmerov> adarshkoyya: hi! Yes, there's a lot of people here :)
06:49:32 <adarshkoyya> cool
06:49:34 <rakhmerov> adarshkoyya: how can we help you?
06:49:42 <_gryf> anyway, the plan is to make our use case up and running.
06:49:48 <adarshkoyya> i took the lates mistral and was doing data base migration
06:49:52 <adarshkoyya> and it was failing
06:49:53 <adarshkoyya> mistral-db-manage --config-file /etc/mistral/mistral.conf  upgrade head
06:49:58 <adarshkoyya> this command was failing
06:50:05 <rakhmerov> _gryf: you mean VM evacuation, right? I was gonna ask you how it is going
06:50:19 <_gryf> anything wrong around ha topic we would report either as a bugs or bp proposals
06:50:24 <rakhmerov> adarshkoyya: we need details of that
06:50:26 <_gryf> rakhmerov, right
06:50:37 <rakhmerov> adarshkoyya: please file a bug and put all the traces
06:50:46 <adarshkoyya> seems like issues with migration file
06:50:50 <rakhmerov> _gryf: ok
06:51:41 <rakhmerov> adarshkoyya: ok, it may be, please communicate all the details to us
06:51:46 <_gryf> rakhmerov, there was a bug - stopper for our workflow use case (as you probably remember)
06:51:55 <rakhmerov> adarshkoyya: we would appreciate any info
06:51:57 <adarshkoyya> yeah sure
06:52:11 <rakhmerov> _gryf: that oslo.messaging topic? :)
06:52:47 <adarshkoyya> if i remove this file it is working preperly https://github.com/openstack/mistral/blob/master/mistral/db/sqlalchemy/migration/alembic_migrations/versions/009_add_database_indices.py
06:52:54 <adarshkoyya> will report the bug in some time
06:52:56 <_gryf> no, the one with transaction clash
06:53:12 <rakhmerov> adarshkoyya: yes, please do, we'll fix it soon
06:53:21 <rakhmerov> or you can fix it yourself and send a patch
06:53:22 <_gryf> I think that melisha proposed alternative (more generic) fix for this issue
06:53:41 <rakhmerov> _gryf: ooh, I guess it's been fixed by Moshe, no?
06:53:49 <rakhmerov> or you mean a different one?
06:54:04 <_gryf> rakhmerov, this https://review.openstack.org/#/c/253819
06:54:08 <rakhmerov> _gryf: let's make sure we're aware of it and it is assigned
06:54:10 <rakhmerov> ok
06:54:51 <rakhmerov> _gryf: yes, that's the one that Moshe already fixed
06:54:56 <_gryf> rakhmerov, right
06:55:07 <rakhmerov> ooh, you mean there was a bug :)
06:55:12 <rakhmerov> not there is )
06:55:12 <rakhmerov> ok
06:55:17 <rakhmerov> gotcha
06:55:38 <_gryf> so the next step is to hardening our evacuation case
06:55:47 <rakhmerov> ok
06:56:16 <_gryf> and there is a strong possiblility that some other bugs shows up :)
06:56:23 <rakhmerov> yeah
06:56:27 <rakhmerov> is there anything else guys?
06:56:30 <rakhmerov> NikolayM: ?
06:56:39 <rakhmerov> nmakhotkin: ?
06:56:49 <NikolayM> yes
06:56:59 <NikolayM> I'll be working on RPC
06:57:06 <NikolayM> it is assigned to M-2
06:57:15 <rakhmerov> ok
06:57:21 <rakhmerov> as far as myself I also wonder when we'll be able to get to working on API v3 :)
06:57:40 <rakhmerov> I know it's a big topic but I would really like to get it done during Mitaka
06:58:10 <lane_kong> rakhmerov: what problems do you want to solve in v3?
06:58:21 <rakhmerov> ooh, there's a lot of them
06:58:45 <rakhmerov> starting from inconsistent naming and ending with lack of flexible filtering etc
06:59:01 <rakhmerov> but let's not discuss it now
06:59:18 <rakhmerov> my suggestion is to discuss it on the next meeting briefly again
06:59:27 <lane_kong> yeah, it's better we list those problems and have a discussion then
06:59:32 <rakhmerov> yep
06:59:51 <rakhmerov> I can try to come up with a spec for it during M-2
07:00:09 <lane_kong> great
07:00:10 <rakhmerov> #action rakhmerov: come up with a spec draft for API v3 during M-2
07:00:22 <rakhmerov> ok, thanks to everyone for joining!
07:00:30 <rakhmerov> let's end the meeting
07:00:33 <gpaz> Thank you
07:00:38 <_gryf> thanks!
07:00:40 <LimorStotland> thanks
07:00:41 <lane_kong> thanks all
07:00:44 <rakhmerov> #endmeeting