15:59:51 <tnurlygayanov> #startmeeting Mistral weekly meeting
15:59:53 <openstack> Meeting started Mon Jun  9 15:59:51 2014 UTC and is due to finish in 60 minutes.  The chair is tnurlygayanov. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:59:57 <openstack> The meeting name has been set to 'mistral_weekly_meeting'
15:59:59 <tnurlygayanov> Hi there!
16:00:20 <nmakhotkin> hi!
16:00:21 <tnurlygayanov> welcome to weekly Mistral meeting!
16:00:22 <gokrokve> Hi!
16:00:25 <m4dcoder> Hi
16:01:01 <tnurlygayanov> Renat on PTO now and I'm again will drive this meeting
16:01:09 <dzimine> hi there!
16:01:23 <tnurlygayanov> let's start from our report for the previous week
16:01:40 <tnurlygayanov> #topic Status Update
16:02:18 <tnurlygayanov> on this week we fixed our CI tests and now it works for all commits
16:02:55 <dzimine> did you flip it to be voting?
16:03:07 <tnurlygayanov> also I saw commits with migration to testr, and now we run all tests in parrallel
16:03:53 <tnurlygayanov> dzimine, yes, we commit this to infra
16:04:27 <tnurlygayanov> #info Mistral CI will voiting after merge of this commit: https://review.openstack.org/#/c/98799
16:05:22 <tnurlygayanov> dzimine, what about your progress on this week? I reviewed several commits from you
16:05:35 <dzimine> did prep steps to introduce the start task, will continue on.
16:05:58 <tnurlygayanov> m4dcoder, what about your progress on this week, could you please share details? :)
16:06:11 <nmakhotkin> I continue to fix bugs on API side and small fixes in engine
16:06:18 <tnurlygayanov> #info: <dzimine> did prep steps to introduce the start task, will continue on.
16:06:25 <tnurlygayanov> #info <nmakhotkin> I continue to fix bugs on API side and small fixes in engine
16:06:38 <tnurlygayanov> ok, cool
16:07:21 <tnurlygayanov> so, on this week we also discussed Mistral UI and what we want to have in this UI
16:07:30 <nmakhotkin> yes
16:07:57 <tnurlygayanov> nmakhotkin, could you please share some details about that?
16:09:37 <tnurlygayanov> hm... anybody also from Mistral team on this meeting?
16:09:39 <nmakhotkin> I have a discussion with one guy from Murano, and we decided how this UI will be look like
16:10:18 <tnurlygayanov> nmakhotkin I also suggest to dicuss it with dzimine and Renat now :)
16:10:19 <nmakhotkin> We discussed inks between namespace <-> actions <-> tasks
16:10:48 <tnurlygayanov> so, are we ready to describe our new vision on Mistral Wiki?
16:11:02 <tnurlygayanov> or with bp?
16:11:41 <dzimine> I know Kirill and Renat were also discussing this topic. How do you plan to capture all these discussions?
16:12:59 <nmakhotkin> here is the doc - https://docs.google.com/a/mirantis.com/document/d/19Q9JwoO77724RyOp7XkpYmALwmdb7JjoQHcDv4ffZ-I/edit
16:13:14 <tnurlygayanov> so, I know that Timur Sufiev(from Murano team) has a good UI expirience and he can help to create user friendly UI for Mistral
16:13:58 <tnurlygayanov> we can discuss all ideas and select the right way, based on our use cases and roadmap
16:15:05 <tnurlygayanov> dzimine, m4dcoder, gokrokve could you please review this doc? https://docs.google.com/a/mirantis.com/document/d/19Q9JwoO77724RyOp7XkpYmALwmdb7JjoQHcDv4ffZ-I/edit
16:15:28 <gokrokve> Sure. What is a deadline for that?
16:15:29 <tnurlygayanov> #info : new ideas for Mistral UI published in the doc (draft) https://docs.google.com/a/mirantis.com/document/d/19Q9JwoO77724RyOp7XkpYmALwmdb7JjoQHcDv4ffZ-I/edit
16:15:33 <dzimine> that’s interesting.
16:15:57 <dzimine> ok, let’s review and discuss offline on the mailing list.
16:16:09 <tnurlygayanov> gokrokve I'm not shure that we have a dedline for that, we can discuss this doc on the next weekly meeting
16:16:11 <dzimine> Are you guys plan to publish this to the mailing list for Heat/Solum/etc?
16:16:27 <gokrokve> ok.
16:16:39 <gokrokve> dzimine: yes. It s already shared with engineers from these teams.
16:16:53 <tnurlygayanov> dzimine, yes, but before that I suggest to discuss these ideas with Mistral team
16:16:54 <dzimine> link to the mailing list?
16:17:01 <tnurlygayanov> ou
16:17:05 <tnurlygayanov> cool
16:17:51 <m4dcoder> tnurlygayanov: i was afk. i still need to fix my two patch sets and resubmit. also studying the "refine engine-executor" bp and have some questions. but Renat is out of office.  i'll review the doc offline.
16:18:16 <tnurlygayanov> #info <m4dcoder> I still need to fix my two patch sets and resubmit. also studying the "refine engine-executor" bp and have some questions. but Renat is out of office.  i'll review the doc offline.
16:18:47 <tnurlygayanov> m4dcoder, could you please share the links to your patch sets, we will check them?
16:19:51 <tnurlygayanov> hm.... ok
16:20:11 <tnurlygayanov> so, let's discuss our plans for the next week
16:20:25 <tnurlygayanov> #topic Plans For The Next Week
16:22:31 <tnurlygayanov> I plan to review all new bugs on this week, and also I will review our AIs for preparation to incubation request
16:23:01 <tnurlygayanov> looks like on the next week we will have 'right' CI with voiting devstack gate
16:23:14 <tnurlygayanov> #info <tnurlygayanov> I plan to review all new bugs on this week, and also I will review our AIs for preparation to incubation request
16:23:42 <dzimine> I have two concerns: 1) organizational 2) technical
16:24:10 <nmakhotkin> My plan is to finish current patches and work on bp mistral-openstack-data-accessible-by-default
16:24:10 <dzimine> 1) organizational: we should be more open to the community and among ourselves.
16:24:18 <tnurlygayanov> dzimine, ok, let's discuss them
16:24:39 <tnurlygayanov> yes
16:25:03 <tnurlygayanov> #info <nmakhotkin> My plan is to finish current patches and work on bp mistral-openstack-data-accessible-by-default
16:25:16 <dzimine> e.g., CI - I know you had some internal planning, but no artifacts shared, so it’s difficult to even review without understanding the context.
16:25:44 <m4dcoder> i'll have to fix and resubmit them. https://review.openstack.org/#/c/94225/ and https://review.openstack.org/#/c/98275/
16:25:45 <gokrokve> dzimine: +1. We need to share such things
16:25:46 <tnurlygayanov> dzimine, yes, we want to discuss our CI on this week
16:26:11 <gokrokve> tnurlygayanov: Do you have any artifacts to share i.e. docs?
16:26:12 <dzimine> yes, I am just making the point that you first have done it, and now ready to discuss :)
16:26:13 <tnurlygayanov> ok, we can do this on todays meeting, on the 'free discussion' part
16:26:45 <tnurlygayanov> gokrokve right now not, we have just a code
16:26:50 <dzimine> Let’s not make the same with UI, and do some etherpad or blueprint to be open for intput, and have a decision point when we agree what we do.
16:27:09 <tnurlygayanov> gokrokve, it is good idea, we will describe our tests suites on the Mistral Wiki
16:27:21 <gokrokve> dzimine: For UI Timur S. is going to send this document to ML today\tomorrow.
16:27:34 <dzimine> guys sorry I can’t get my point across: it’s not about DESCRIBING what is already done.
16:27:43 <dzimine> It’s about deciding what to do and how to do this.
16:28:06 <gokrokve> dzimine: Yes. This document is a first draft of what can be done
16:28:43 <gokrokve> There is nothing implemented yet and this is a vision of the future framework which can be used by different projects
16:29:09 <dzimine> Like even little things: swithces to testr: it is 100% good idea I am sure but why not shoot email to mistral mailing list saying ‘we decided to go to testr because of a) & b) and c)
16:29:20 <gokrokve> Someone should draft the first version as otherwise it will be endless loop of e-mails with no actual design
16:29:27 <dzimine> else you look at the review, and all it says in the commit comment is ‘swithc to testr’.
16:30:20 <dzimine> I am fine with any reasonable form of sharing, and just asking for at the very least sharing the results of Mirantis’ internal decisions.
16:30:34 <dzimine> at the very least.
16:30:50 <tnurlygayanov> dzimine, about tesrt - this commit surprized me, yes, but it is cool - we have some problem and we have the commit which will fix this problem.
16:31:05 <tnurlygayanov> dzimine I'm agree that we should descuss this
16:31:33 <dzimine> even if not discuss to save on endless discussion, share teh decisions.
16:32:04 <tnurlygayanov> dzimine, I will discuss this doc with tsufiev and he will publish it in ML (if it's not published yet)
16:32:05 <dzimine> Let’s pracice this on this UI discussion: put proposal, post it out, make sure other people are looped in.
16:32:23 <dzimine> ok now is #2, technical, re CI.
16:32:39 <dzimine> There’s a lot of big refactoring coming.
16:33:03 <dzimine> it will definitely break the tests.
16:33:45 <dzimine> Two things that may help is 1) make a subset of tests runnable on dev machine without devstack. and 2) hold on making it voting till we stabilize.
16:33:46 <tnurlygayanov> dzimine, about the short commit messages: +1 for that, so, we can set -1/-2 for that and say 'need to discuss this feature first'
16:34:14 <tnurlygayanov> hm...
16:34:35 <dzimine> The refactoring is mainly on Renat, but to what I know it will break.
16:34:45 <tnurlygayanov> so, we can postpone 'voiting', no problem
16:35:25 <dzimine> Let’s wait till Renat comes back and has some plan on how to refactor.
16:36:52 <tnurlygayanov> but CI can help to save Mistral in working state
16:36:54 <dzimine> Let’ me hold on now, and Timur please go with the agenda, we’ll discuss CI tests in the open section at the end.
16:37:27 <tnurlygayanov> so, if we want to refactor some part of main functional or API, we should change our tests and after that they will pass
16:37:37 <tnurlygayanov> ok
16:38:04 <tnurlygayanov> dzimine, m4dcoder, what abour your plan on this week?
16:38:20 <dzimine> I plan to finish the ‘start task’
16:38:43 <tnurlygayanov> #info <dzimine> I plan to finish the ‘start task’
16:38:47 <tnurlygayanov> cool
16:38:50 <tnurlygayanov> so
16:39:00 <m4dcoder> fix the two open changes that I have
16:39:35 <tnurlygayanov> #info plan for this week: <m4dcoder> fix the two open changes that I have
16:39:45 <tnurlygayanov> ok
16:40:03 <tnurlygayanov> hm, we can start our free discussion now
16:40:11 <tnurlygayanov> #topic Free Discussion
16:41:15 <tnurlygayanov> about the discussion of different new ideas and technicall decissions
16:42:19 <tnurlygayanov> it is really hard to validate that we have the correct changes in patch set, if we don't discuss them with all core reviewers at least
16:42:38 <tnurlygayanov> I suggest ma
16:42:42 <tnurlygayanov> *sorry
16:43:45 <dzimine> member:tnurlygayanov: how do you mean?
16:44:00 <tnurlygayanov> I suggest to voite -2 for all commits with new big features, which we don't discuss with all Mistral team or if commit message has only one sentense and we can't understand why this patch set should be merged
16:45:19 <dzimine> this is too strict, but point taken. Get the discipline of writing and sharing anything big.
16:45:22 <dzimine> ok.
16:45:32 <tnurlygayanov> yes :)
16:45:53 <dzimine> Re CI: do all the devstack tests you guys want are already landed?
16:47:05 <tnurlygayanov> dzimine, looks like we have base coverage for integration tests now and we don't want to increase the number of this tests, if we plan significant refactoring
16:47:48 <tnurlygayanov> could you please share some details what we want to change in the nearest future?
16:48:19 <tnurlygayanov> for CI: I suggest to change tests in the same commit, if we changed something in code
16:48:37 <dzimine> start-task is #1: it’s small but will change all the API.
16:48:59 <dzimine> shouldn’t break integration tests as the start task parameter will be just ignonred in the post body.
16:49:12 <dzimine> and I’ll change the demo.yaml to add start-task.
16:49:42 <dzimine> The biggest is https://blueprints.launchpad.net/mistral/+spec/mistral-entities-accessibility-regardless-workbooks
16:49:43 <tnurlygayanov> dzimine, ok, we can just change our integration and unit tests for these changes
16:49:58 <dzimine> this has a potential to break a lot.
16:50:28 <tnurlygayanov> if we will do this with small commits, it will be not hard and I'm ready to help with any problems with tests/CI
16:50:41 <dzimine> we’ll know better when we design it (case in point we need to share desing first, etherpad will be ok)
16:51:25 <dzimine> I am not touching it this week, it’s just a head’s up.
16:51:46 <tnurlygayanov> dzimine, yes, so, I will dicuss patch set to infra about voiting Mistral devstack gate with Sergey and he will mark this commit as 'work in progress', and that should help
16:52:37 <tnurlygayanov> so, if we will have non-voiting all new changes can be easilly implemented with small pathches and tests can be fixed for each new patch set
16:52:42 <dzimine> The other big changing blueprint is https://blueprints.launchpad.net/mistral/+spec/deprecate-requires-in-dsl
16:53:01 <tnurlygayanov> ok, I want to write these ideas
16:53:01 <dzimine> Yes non-voting, with gradual changes will work.
16:53:39 <tnurlygayanov> #idea - what we want ot change - <dzimine> start-task is #1: it’s small but will change all the API.
16:53:53 <tnurlygayanov> #idea - what we want ot change - <dzimine> and I’ll change the demo.yaml to add start-task.
16:54:03 <dzimine> member:tnurlygayanov: can you find and document the way to run some of integration tests locally on dev machine?
16:54:12 <tnurlygayanov> #idea - what we want ot change - <dzimine> The biggest is https://blueprints.launchpad.net/mistral/+spec/mistral-entities-accessibility-regardless-workbooks
16:54:39 <tnurlygayanov> #info  - what we want ot change - <dzimine> The other big changing blueprint is https://blueprints.launchpad.net/mistral/+spec/deprecate-requires-in-dsl
16:54:43 <tnurlygayanov> hm...
16:54:55 <dzimine> E.g., demo.yaml now requires OpenStack, but for magority of API tests we can just use workflow based on echo task (and add async-echo there)
16:55:13 <tnurlygayanov> yes, it is simple, we use just nosetests <file_with_integrational_tests>
16:55:24 <dzimine> this will require big refactoring in API changes.
16:55:25 <dzimine> https://blueprints.launchpad.net/mistral/+spec/mistral-multiple-workflows
16:55:25 <tnurlygayanov> of course we should have the right configuration file
16:56:21 <tnurlygayanov> dzimine, ok, I can share the manual 'how to run Mistral integration tests on the dev environment' tomorrow, I will send the link to ML
16:56:33 <dzimine> cool.
16:56:54 <tnurlygayanov> #action  <tnurlygayanov> I can share the manual 'how to run Mistral integration tests on the dev environment' tomorrow, I will send the link to ML
16:57:15 <dzimine> and think about making some of these tests independent on devstack installation.
16:57:25 <dzimine> do you think it makes sense?
16:57:40 <tnurlygayanov> dzimine they are independent
16:58:24 <tnurlygayanov> we run these tests on different labs and I know that nmakhotkin runs them on his dev box
16:58:45 <dzimine> I am looking at api/v1/demo.yaml and it has Nova.create-vm
16:58:46 <tnurlygayanov> so, it is not based only on devstack scripts
16:58:52 <tnurlygayanov> yes
16:59:09 <dzimine> oh, but they require OpenStack.
16:59:26 <tnurlygayanov> yes, of course they are required OpenStack :)
16:59:32 <dzimine> I mean that most of these tests don’t require OpenStack connection
16:59:49 <dzimine> only keystone authentication needs to be testsed with OpenStack.
17:00:04 <tnurlygayanov> dzimine, it is integration tests, we want to test different scenaries
17:00:48 <tnurlygayanov> and our main use cases now is to deploy something. Using devstack gate we can deploy something on OpenStack
17:01:00 <dzimine> yes, I don’t disagree, I am just saying we can break them further and have some which are independent on OpenStack, marked somehow so taht we can skip OpenStack dependent.
17:01:25 <tnurlygayanov> if we don't want to use OpenStack, we can run simple integration tests, which are not required the OpenStack installation
17:01:44 <tnurlygayanov> hm..
17:01:49 <tnurlygayanov> it is interesting
17:02:13 <dzimine> how to run simple integration tests? May be that’s what I am looking for?
17:02:32 <sarob> Guys, it's time
17:02:36 <dzimine> Ok.
17:02:37 <tnurlygayanov> yes, sorry
17:02:42 <sarob> np
17:02:51 <tnurlygayanov> we can continue in #openstack-mistral
17:02:56 <tnurlygayanov> #endmeeting