15:00:13 <rhochmuth> #startmeeting monasca
15:00:14 <openstack> Meeting started Wed Sep 16 15:00:13 2015 UTC and is due to finish in 60 minutes. The chair is rhochmuth. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:19 <openstack> The meeting name has been set to 'monasca'
15:00:23 <rhochmuth> roll call
15:00:26 <rhochmuth> o/
15:00:29 <mroderus> o/
15:00:33 <witek> hi
15:00:39 <fabiog> o/
15:01:02 <rbak> o/
15:01:09 <ddieterly> o/
15:01:15 <rhochmuth> Here is the agenda that is listed:
15:01:16 <rhochmuth> Agenda for Wednesday September 16, 2015 (15:00 UTC)
15:01:16 <rhochmuth> 1. Update on Logging Plans
15:01:16 <rhochmuth> 2. Devstack
15:01:16 <rhochmuth> 1. to merge/enable monasca client in Rally we need to have monasca devstack plugin first
15:01:16 <rhochmuth> 3. Grafana update
15:01:16 <rhochmuth> 4. Tempest tests update
15:01:48 <rhochmuth> please add items to the etherpad at, https://etherpad.openstack.org/p/monasca-team-meeting-agenda
15:02:05 <rhochmuth> #topic logging
15:02:09 <ddieterly> is it just us 3 here today?
15:02:17 <rhochmuth> there are more
15:02:20 <bmotz> ah, I'm here too
15:02:22 <bmotz> o/
15:02:23 <tomasztrebski> hello guys :)
15:02:27 <tsv> \0/
15:02:30 <ddieterly> hi
15:02:42 <ddieterly> hands up if you're going to participate in the meeting, please
15:02:50 <rhochmuth> o/
15:02:51 <mroderus> tomasztrebski: could you give a brief update on your Python port of the logging API?
15:03:01 <fabiog> o.
15:03:12 <fabiog> I think we have a quorum,
15:03:16 <rhochmuth> we do
15:03:29 <rhochmuth> tomas, the floor is yours
15:03:29 <ddieterly> great
15:03:51 <rhochmuth> i <3 irc
15:04:03 <tomasztrebski> brief update ? hmm...well its on private github, so if anyone would like to take a peek, be my guest and as for the status
15:04:26 <mroderus> can you post the link?
15:04:35 <witek> here it is: https://github.com/kornicameister/monasca-log-api
15:04:45 <tomasztrebski> logic is pretty much ready, including kafka publisher, resource to receive logs, some service like stuff to validate requests and so on
15:05:11 <tomasztrebski> what I dont have is some unit tests (one major for kafka publisher), tox and general polishing
15:05:12 <rhochmuth> so, this is the python code
15:05:16 <rhochmuth> ?
15:05:20 <tomasztrebski> yes, it is python code
15:05:37 <tomasztrebski> similar to monasca-api you make
15:05:48 <tomasztrebski> as far as it goes for structure
15:06:15 <rhochmuth> there is also the monasca-log-api in stackforge at, https://github.com/stackforge/monasca-log-api
15:06:20 <rhochmuth> which is all have at the moment
15:06:27 <tomasztrebski> yes, but it is java only
15:06:38 <rhochmuth> is it possible to add the python to the java repo?
15:07:01 <rhochmuth> then everything will be under gerrit review
15:07:07 <witek> #https://github.com/kornicameister/monasca-log-api is a for of stackforge/monasca-log-api
15:07:17 <tomasztrebski> I believe it is, https://github.com/stackforge/monasca-api/tree/master/monasca_api, you have something like it in monasca-api
15:07:34 <tsv> Tom, what is the pre-requisite for running the python logging-api ? is it standalone ?
15:07:37 <rhochmuth> correct, the monasca-api has both the java and python code
15:08:04 <tomasztrebski> so the same thing we have in monasca-log-api, however it is my own fork
15:08:27 <rhochmuth> is it fully functional?
15:08:59 <tomasztrebski> nothing particular I guess, but I don't know what it would behave on server, I didn't have a chance to check that out
15:09:37 <tomasztrebski> pretty much, I am still working on some polishing and tests, but I managed to run it locally and post some data into the resource
15:10:05 <rhochmuth> cool, so it would be really good to get that merged back in the monasca-log-api repo so it is under gerrit review
15:10:22 <tsv> +1
15:10:23 <tomasztrebski> as for what @tsv asked for, I can only say for dev mode so the only requirement you'd have is to create virtenv install requirements and run server.py
15:10:27 <rhochmuth> this is an area that gets some scrutiny with the TC
15:10:58 <rhochmuth> we had our tempest tests in a separate repo, not merged in with the main tempest repo, and had some feedback to merge that in
15:10:59 <tsv> sounds good Tom, that sounds straight forward
15:11:11 <rhochmuth> so, i'm working on getting our tempest tests merged in
15:11:18 <rhochmuth> too
15:11:35 <tomasztrebski> +1
15:11:35 <rhochmuth> not to change the subject, just offering additional reasons why this could be important
15:12:07 <mroderus> ok, so shall we merge before you want to have a look at it?
15:12:20 <rhochmuth> so, we'll start taking a closer look at your work tomasz, in parallel with a merge
15:12:42 <mroderus> ok, makes sense
15:12:48 <rhochmuth> we'll look at things that are outside of gerritt too
15:13:00 <ddieterly> rhochmuth: shouldn't all new dev be done in the stackforge repos?
15:13:23 <rhochmuth> yes, that is the case.
15:14:02 <tomasztrebski> meaning to say, gerrit will be skipped for monasca-log-api and any repo under stackforge ? am i getting it right ?
15:14:30 <rhochmuth> gerrit should already be on the monasca-log-api in stackforge
15:14:30 <witek> no, we have to add it to stackforge/monasca-log-api
15:14:48 <witek> yes, it is
15:14:54 <tsv> and review it before it merges ?
15:15:09 <ddieterly> tsv: well, of course ;-)
15:15:23 <tsv> :)
15:15:26 <rhochmuth> ok, so i think we have a plan
15:15:32 <rhochmuth> will start to merge
15:15:40 <rhochmuth> to the monasca-log-api
15:15:52 <rhochmuth> also, others to start review the code, testing, ...
15:16:08 <rhochmuth> sound good?
15:16:11 <ddieterly> yea, i think we need to start enforcing more testing at this point
15:16:36 <mroderus> tomasztrebski: are you ok with that?
15:16:59 <rhochmuth> ddieterly: yes, i'm going to give an update on tempest, but there are also unit tests too
15:17:12 <tomasztrebski> basically yes, I just lost point about where python code should reside, should it be pushed to gerrit or left on github ?
15:17:45 <witek> #action tomasztrebski pushes initial draft of python monasca-log-api implementation to gerrit next week
15:18:00 <ddieterly> yes, gerrit
15:18:09 <tomasztrebski> I like that :)
15:18:22 <rhochmuth> :-)
15:18:47 <rhochmuth> ok, next topic
15:19:00 <rhochmuth> #topic devstack
15:19:17 <ddieterly> ok, i'm setting up devstack on a vm right now
15:19:27 <ddieterly> learning to spell 'devstack' basically
15:19:39 <rbak> So we are working on getting monasca into devstack?
15:19:39 <rhochmuth> who added the devstack topic
15:19:46 <rbak> That was me
15:19:47 <fabiog> ddieterly: that is a good exercise :-)
15:19:52 <ddieterly> i did this 1 year aga for the ceilometer interface, but forgot everything
15:20:12 <ddieterly> rbak: yea
15:20:12 <rhochmuth> rbak: awesome!!!
15:20:21 <rhochmuth> do you need any help
15:20:38 <rbak> Sorry, that was meant to be a question, not a statement.
15:21:03 <ddieterly> rbak: yea, 'we' are working on getting monasca into devstack
15:21:04 <rhochmuth> ohhh, a question in the form of a sentence
15:21:14 <rbak> Our QA team was trying to get Monasca into Rally, but was blocked by Monasca not being in devstack
15:21:21 <rhochmuth> yes, we are starting to do that
15:21:45 <rhochmuth> there are a lot of dependencies on devstack
15:22:00 <rbak> Alright, I think that's all we really needed to hear. I'll pass along that it's work in progress.
15:22:08 <rhochmuth> so, ddieterly will be starting on this, and i'll be helping too
15:22:36 <ddieterly> we will be doing the python api and perister
15:22:39 <rhochmuth> hopefully, we'll know a little more for next weeks meeting
15:22:52 <ddieterly> not sure if that helps twc at this point
15:23:03 <rbak> We were just wondering where that was
15:23:08 <rbak> I know it's come up before
15:23:30 <fabiog_> ddieterly: do you want to send patches to the ceilosca installation for testing?
15:23:51 <ddieterly> i don't know at this point
15:23:57 <fabiog_> ddieterly: it could be a easy environment for validating that devstack with your changes works
15:23:58 <ddieterly> not sure what that entails
15:24:02 <tomasztrebski> btw, if I may interrupt, do you have any guidelines for python code or should it follow openstack guidelines only without any mods ?
15:24:31 <rhochmuth> tomasztrebski: we follow the openstack guidelines
15:24:32 <ddieterly> tomasztrebski: openstack pep 8 standards
15:24:44 <rhochmuth> tomasztrebski: correct
15:24:45 <ddieterly> no funny business ;-)
15:25:23 <rhochmuth> fabiog: as soon as we have monasca integrated in devstack, we'll look into adding ceilosca too
15:25:34 <rhochmuth> will probably need help
15:25:37 <ddieterly> @fabiog_ i'll look into it
15:25:50 <rhochmuth> right now we're just getting up to speed on devstack and tempest
15:26:24 <rhochmuth> as soon as that is in reasonable shape we'll look at ceilosca too
15:26:53 <rhochmuth> ok, next topic?
15:27:02 <rhochmuth> #topic grafana
15:27:23 <rbak> I just wanted to bring this up again since it barely made it in the last meeting
15:27:30 <rhochmuth> ok
15:27:43 <rbak> I've started work on a monasca plugin for the latest grafana.
15:27:50 <rhochmuth> great!
15:28:00 <rhochmuth> how is it looking?
15:28:06 <fabiog_> +1
15:28:13 <rbak> It's not quite ready to share, but should be by next week I would think
15:28:20 <rhochmuth> awesome
15:28:34 <rbak> And with all the repo talk I should ask where we want to put this.
15:28:55 <rhochmuth> i would like to see this merged in with the grafana repo
15:29:13 <rbak> So are we alright with a private repo until that time?
15:29:16 <rhochmuth> i think this is fine to have outside in a separate repo, just like we have the current repo
15:29:36 <rbak> Alright, I'll plan on that
15:29:44 <rhochmuth> well, i think it woudl still be public, just not in gerrit review under openstack, since this is really another project
15:30:06 <rbak> That's what I meant.
15:30:19 <rhochmuth> i would start with a public fork of the grafana repo, then hopefully we can merge back to the Grafana project
15:30:31 <fabiog_> rhochmuth: I think in the future we should start engaging with the Grafana community and see if they allow us to be officially supported
15:30:45 <rhochmuth> yes, that was the plan all along
15:30:45 <rbak> Also, in case anyone missed it, the gnocchi project is also trying to merge their own plugin
15:30:54 <rbak> into grafana
15:31:21 <mroderus> rbak: if it's only a plugin, why do we have to merge it?
15:31:24 <rhochmuth> correct, i saw a post on that in openstack operators this week
15:31:51 <rhochmuth> i think wherever all the grafana plugins are stored these days, is where we should merge our code too
15:32:09 <rhochmuth> in grafana 1.X, this was in the grafana project
15:32:11 <rbak> mroderus: It's a datasource. Grafana isn't really easily plugable as far as I know
15:32:38 <rhochmuth> rbak: is it the similar to 1.X?
15:32:40 <mroderus> ok, I understand
15:32:53 <rhochmuth> all the data sources are in the Grafana repo
15:32:58 <rhochmuth> ?
15:33:05 <rbak> In the respect that the datasources are in the grafana project, yes
15:33:11 <rbak> There's a lot of other changes though
15:33:41 <rhochmuth> ok, so i think we are ok doing the development outside of gerrit in this case, as this is another openstack project
15:33:56 <rhochmuth> as grafana is not an openstack project
15:34:07 <rhochmuth> so the proper landing spot is the grafana repo
15:34:22 <rbak> Alright, I'll have it somewhere public and share it next week hopefully.
15:34:33 <rbak> And we can try to get it merged as we move forward
15:34:48 <fabiog_> rbak: is based on 2.1.x?
15:34:56 <rbak> yes
15:34:57 <rhochmuth> i know the founder of raintank which is where grafana is developed by
15:35:36 <rhochmuth> so, if we need help in adding to grafana then let me know and we can get a discussion arranged
15:35:48 <rbak> sounds good
15:36:28 <rhochmuth> ok, i think we are ready for next topic
15:36:32 <rhochmuth> #tempest
15:36:37 <rhochmuth> #topic tempest
15:36:45 <rhochmuth> this should be quick
15:36:59 <rhochmuth> i started on getting the tempest tests
15:37:11 <rhochmuth> a tester did the original development a while ago
15:37:24 <rhochmuth> but we never merged to openstack/tempest
15:37:37 <rhochmuth> so i'm getting that work going
15:37:57 <rhochmuth> i'm hoping this will get completed in a couple of weeks
15:38:08 <rhochmuth> or less
15:38:30 <rhochmuth> if anyone wants to help, please let me know
15:38:35 <tomasztrebski> I think some tempests might me done by us as well, regarding monasca log api as far as I know
15:38:45 <rhochmuth> that woud be great
15:38:50 <smialy> we based on yours https://github.com/hpcloud-mon/tempest adds some simple tests
15:39:08 <tomasztrebski> ok, @smialy is here so he can share the info about that with you
15:39:47 <smialy> we (mean: fujitsu) prepare some simple test for testing our changes
15:39:50 <smialy> https://github.com/FujitsuEnablingSoftwareTechnologyGmbH/tempest
15:40:09 <rhochmuth> and those are for the log api?
15:41:01 <rhochmuth> so, i'll try and get this first set through, and then we can start to get the log tests integrated too
15:41:03 <smialy> yes - we put some message in monasca-log-api and search it in elasticsearch
15:41:20 <rhochmuth> everything in tempest works via the api
15:41:41 <rhochmuth> so, if you are going around the api, i'm not sure that tempest would work with that
15:42:42 <tomasztrebski> but tempests for log-api are using log-api as far as I know, isn't that right @smialy?
15:42:48 <smialy> we use elasticsearch api :)
15:43:10 <smialy> yes
15:43:14 <mroderus> I think currently the API has only PUSH methods
15:43:29 <mroderus> I mean POST, sorry
15:43:33 <smialy> POST*
15:43:34 <smialy> :)
15:43:59 <smialy> for this moment only single log with json format
15:44:01 <rhochmuth> so, i think the initial log tests would just focus on POST, if that is all we have
15:44:15 <rhochmuth> eventually, we'll be able to query via API too
15:44:22 <rhochmuth> and then can add additioanl tests
15:44:24 <mroderus> eventually, yes
15:44:39 <smialy> log-api dont have endopont to search
15:45:34 <rhochmuth> ok, are there more topics?
15:45:50 <ddieterly> is brad k in the room?
15:45:50 <rhochmuth> Is there a performance update from TWC and the problem queries?
15:45:55 <ddieterly> right
15:46:07 <rhochmuth> bmotz: how are you doing
15:46:29 <rhochmuth> you seem to be finding misc bugs in the python api
15:46:48 <rhochmuth> but, nothing too bad yet
15:47:07 <witek> there are a couple of pending pull requests from us on https://github.com/hpcloud-mon
15:47:32 <rhochmuth> witek: ok, will take a look
15:47:35 <witek> could anyone take a look, please
15:47:37 <ddieterly> which repo exactly?
15:48:11 <tomasztrebski> monasca-keystone is the one I contributed to, but there are couple others
15:48:18 <tomasztrebski> just cant recall which one :(
15:48:30 <rhochmuth> ansible-monasa-keystone?
15:48:56 <rhochmuth> so, is this all for ansible related changes?
15:49:07 <witek> ddieterly: I send you a list
15:49:13 <witek> rhochmuth: mainly
15:49:15 <ddieterly> @tomasztrebski ping the core guys to push them along every now and then if you are not getting things looked at
15:49:29 <tomasztrebski> yes ansible-monasca-keystone
15:49:37 <tomasztrebski> sorry to ask, but could you give some names :)
15:49:55 * ddieterly roland
15:49:58 <rhochmuth> witek: ok, we'll take a look
15:50:43 <rhochmuth> ddieterly is core too
15:51:38 <rhochmuth> ok, unless anyone has more topics, updates or questions, we might be ending early
15:52:02 <tomasztrebski> while we on merges part, in monasca-log-api I made some changes that should be done in monasca-common (if we stick to 1:1 port to python, cause they are now in monasca-common)
15:52:28 <ddieterly> that's ok
15:52:35 <tomasztrebski> to be precise I am refering to this https://github.com/kornicameister/monasca-log-api/blob/master/monasca_log_api/common/services.py
15:53:20 <tomasztrebski> in java that is available here -> https://github.com/stackforge/monasca-common/tree/master/java/monasca-common-model/src/main/java/monasca/common/model
15:53:42 <ddieterly> rhochmuth: how about avro?
15:54:05 <ddieterly> we still thinking about doing something with that?
15:54:06 <rhochmuth> what is the services.py for?
15:55:39 <ddieterly> rhochmuth: ?
15:55:40 <tomasztrebski> @rhochmuth, in monasca-common [java] there are classes: ComputeServiceInfo, VolumeServiceInfo and ObjectStoreServiceInfo...I know there is monasca-common in python now, but it does not have those classes yet, so my question is should it this code be moved there or left i monasca-log-api for now
15:55:51 <tomasztrebski> services.py defines those classes
15:56:15 <rhochmuth> tomasztrebsk: i'll review off-line
15:56:33 <rhochmuth> in general, the code in monasca-common for the java and python is not 1:1
15:57:15 <rhochmuth> so, i'll need to get back to you on this
15:57:17 <tomasztrebski> ok, just leave me comment somewhere @ github or where you think is the best place to put it
15:57:39 <rhochmuth> ok
15:57:51 <tomasztrebski> thx
15:57:58 <tomasztrebski> that's all I wanted to say
15:57:58 <tomasztrebski> :)
15:58:52 <rhochmuth> i think that is all we have time for today
15:58:58 <witek> thank you Roland
15:59:18 <tomasztrebski> yep, thx...it was good chat :)
16:00:59 <rhochmuth> #endmeeting