15:00:09 <rhochmuth> #startmeeting monasca
15:00:09 <openstack> Meeting started Wed Oct 21 15:00:09 2015 UTC and is due to finish in 60 minutes.  The chair is rhochmuth. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:13 <openstack> The meeting name has been set to 'monasca'
15:00:22 <rhochmuth> role call
15:00:23 <ddieterly> o/
15:00:24 <rhochmuth> o/
15:00:33 <rhochmuth> hi ddieterly
15:00:40 <ddieterly> rhochmuth: hi
15:00:44 <rbak> o/
15:00:52 <rhochmuth> hi rbak
15:01:40 <bklei> o/
15:01:51 <rhochmuth> hi bklei
15:01:56 <bklei> good morning!
15:02:12 <rhochmuth> well, it looks a little light today on attendance
15:02:23 <rhochmuth> but we might as well get started
15:02:35 <mroderus> o/
15:02:37 <bmotz> o/
15:02:45 <rhochmuth> there they are
15:03:00 <mroderus> Hi all
15:03:04 <bmotz> Hi
15:03:14 <rhochmuth> hi mroderus and bmotz
15:03:22 <witek> hello
15:03:28 <rhochmuth> hi witek
15:03:38 <rhochmuth> i've updated the agend
15:03:51 <rhochmuth> someone had put on the session at the openstack summit without details
15:03:56 <rhochmuth> so i've been adding details
15:04:03 <witek> thank you
15:04:19 <rhochmuth> i'll try and get that completed so we all know what is going on while we are there
15:04:32 <witek> is the place for monasca meeting known?
15:04:49 <rhochmuth> will need fabio to provide details
15:04:55 <rhochmuth> i think i have in my emails somewhere
15:05:20 <rhochmuth> rbak have you made any further progress on grafana 2.0?
15:05:32 <rhochmuth> just checking in on that
15:05:35 <rbak> yep, it's mostly functional at this point
15:05:46 <rhochmuth> wow, that is awesome
15:05:54 <rbak> just needs some work on templating and then polish
15:06:08 <rhochmuth> is there any code that you've published to grafana-plugins?
15:06:19 <rbak> not yet
15:06:29 <rhochmuth> are you planning on this week or next
15:06:38 <rbak> I wanted to avoid making too many pull requests, so I was waiting until it was more stable
15:06:39 <rhochmuth> i could give an update on this during one of the talks
15:06:56 <rhochmuth> ok, please let me know if you get anything posted
15:07:02 <rbak> will do
15:07:02 <rhochmuth> i'll mention this work is in progress
15:07:15 <rhochmuth> but if it is avaialble, i'll put that one the slide
15:07:30 <rbak> If I get it up soon I'll let you know
15:07:34 <bklei> rhochmuth: you have a buddy to help push rbak's change upstream to grafana?
15:07:39 <rhochmuth> thx
15:07:50 <rhochmuth> we have some contacts at raintank
15:07:54 <bklei> the 'monasca backend'
15:07:55 <rhochmuth> i would try on your own first
15:08:01 <bklei> ok
15:08:20 <rhochmuth> but if there is push back we can talk to the founder
15:08:35 <rhochmuth> the lead developer of grafana works at raintank
15:08:44 <rhochmuth> i don't think you'll have problems
15:08:52 <rhochmuth> i'll actaully send him an email today
15:08:59 <rhochmuth> let him know that it is coming
15:09:32 <rhochmuth> bklei: would it be possible to get a more recent screen capture of your environment for one slide next week?
15:09:40 <rhochmuth> i know you don't want to show production
15:10:02 <rhochmuth> but if your test environemtn looks pretty cool then that would be good to have
15:10:33 <bklei> i'll check -- i think i could give you some staging screenshots
15:10:43 <rhochmuth> that would be great
15:11:10 <rhochmuth> i think i have enough specifics of your environment to fill in the rest
15:11:18 <rhochmuth> but i'll probably verify with you
15:11:32 <bklei> cool, will check and email you screenshots today if ok
15:11:43 <rhochmuth> that woudl be great
15:12:39 <rhochmuth> so, we have a random agenda, so i'll just continue on
15:12:50 <rhochmuth> devstack and tempest is up and running
15:13:04 <rhochmuth> ddieterly is wroking on ci integration
15:13:09 <rhochmuth> i might have said that last week
15:13:15 <rhochmuth> i can't remember
15:13:26 <rhochmuth> but we just merged the tempest tests on friday
15:13:34 <rhochmuth> so it is in good shape for others to work on
15:13:51 <rhochmuth> there are some directions to get started
15:14:15 <rhochmuth> also, just in case anyone didn't realize
15:14:31 <rhochmuth> all the github repos were migrated from stackforge to openstack over the weekend
15:14:51 <rhochmuth> there were a bunch of url changes as a result
15:15:12 <rhochmuth> hopefully they were all caught, but be on the lookout for anything that says stackforge
15:15:32 <rhochmuth> if you have a local repo that you are using then you'll need to change as wekk
15:15:55 <rhochmuth> For example,
15:15:56 <rhochmuth> git remote set-url origin https://git.openstack.org/openstack/monasca-api
15:15:57 <rhochmuth> git remote set-url gerrit ssh://roland-hochmuth-s@review.openstack.org:29418/openstack/monasca-api
15:16:02 <rhochmuth> for the monasca-api
15:16:34 <rhochmuth> so, are there reviews folks wnat looked at
15:16:47 <bklei> so current reviews -- any change needed there?
15:17:17 <tomasztrebski> just rebasing I guess, unless migration to openstack hasn't been submitted, right ?
15:17:17 <rhochmuth> well, i see the review for mulktiple inner joins is sitting there
15:17:42 <rhochmuth> https://review.openstack.org/#/c/235580/
15:17:49 <bklei> yeah, would love feedback on ^^
15:18:12 <rhochmuth> ok, we'll try and get reviewed
15:18:26 <bklei> cool -- and if ddieterly has time too?
15:18:32 <rhochmuth> tomasz, sorry, i didnt' understand the question
15:19:01 <ddieterly> bklei: the problem at this point, is that we don't have test coverage
15:19:08 <ddieterly> on those changes
15:19:20 <tomasztrebski> it's my bad I though @bklei was asking the question regarding migration to openstack, actually he had something in mind, so nevermind
15:19:28 <bklei> yean pretty lean unit tests on vertica stuff
15:19:31 <tomasztrebski> *something else
15:20:33 <rhochmuth> let me see if we can write some tempest tests for that review
15:20:55 <rhochmuth> the tempest tests should be independent of database
15:21:14 <bklei> the spin up a full stack -- or simulate the backend?
15:21:14 <rhochmuth> unless you want to take a look at it bklei
15:21:20 <bklei> s/the/they
15:21:40 <rhochmuth> i think the tempest tests in this case would be done in the devstack environment
15:21:47 <rhochmuth> or monasca-vagrant
15:21:53 <bklei> which is influxdb?
15:22:07 <rhochmuth> ohh yeah, devstack is influxdb
15:22:10 <bklei> :(
15:22:16 <rhochmuth> monasca-vagrant is vertica or influxdb
15:22:51 <rhochmuth> and the tempest tests run against any api
15:22:59 <rhochmuth> actually, they were all developed againast monasca-vagrant
15:23:29 <rhochmuth> anyway, we have an engineer that is working on tempest tests that i'll talk to in a few minutes
15:24:17 <rhochmuth> ok, are there other pressing reviews
15:24:33 <rhochmuth> we got a bunch reviewed over the past two days
15:24:33 <bklei> not from me
15:24:41 <rhochmuth> we had fallen behind
15:24:49 <rhochmuth> but we are getting caught up again
15:25:10 <tomasztrebski> I had one Deklan wanted to talk over
15:25:32 <rhochmuth> this one, https://review.openstack.org/#/c/226733/
15:25:32 <ddieterly> tomasztrebski: yes, can you explain what the problem was?
15:26:24 <tomasztrebski> ok, it is a little blur, but as far as I remember, I've received internal ticket that there's no option to move forward to next pages in alarm history
15:26:49 <tomasztrebski> turned out that influx we've had installed does not accept time as timestamp
15:27:06 <ddieterly> what version of influxdb?
15:27:55 <tomasztrebski> 0.9.1 as far as I remember, but I'd have to check tommorow at work to make sure
15:28:26 <witek> yes, it should be 0.9.1
15:28:28 <ddieterly> that is what we are using, so i'm surprised that this is an issue
15:29:00 <ddieterly> i think that someone needs to validate that there is a bug with alarm history paging using mini-mon
15:29:17 <tomasztrebski> as was me, I took a query and ran in influx console to confirm and basically query was not working
15:29:23 <ddieterly> i can try to get to that this week
15:30:30 <tomasztrebski> would be great, issue was surprising so having another pair of eyes is most welcome to confirm the change
15:30:44 <rhochmuth> tomasz: also, would be great to have a tempest test to go along with this problem
15:30:57 <rhochmuth> we have a very basic offset/limit test for alarm state hisory at, https://github.com/openstack/monasca-api/blob/master/monasca_tempest_tests/tests/api/test_alarms_state_history.py
15:31:19 <rhochmuth> but there is actually a much more offset limit test for something else
15:31:20 <rhochmuth> hold on
15:31:39 <ddieterly> #action validate and review https://review.openstack.org/#/c/226733/
15:31:54 <tomasztrebski> thx roland, good place to start with tempests for it
15:32:02 <rhochmuth> The test for measurements is much more sophisticated at, https://github.com/openstack/monasca-api/blob/master/monasca_tempest_tests/tests/api/test_measurements.py
15:32:45 <rhochmuth> i'd like to get all the other resources to have paging tests like the measurements resource
15:33:08 <rhochmuth> but, if you can write a test that demonstrate the problem, then we can validate too
15:33:23 <witek> #link https://github.com/openstack/monasca-api/blob/master/monasca_tempest_tests/tests/api/test_measurements.py Tempest tests for measurements
15:33:58 <tomasztrebski> but the tempest, right ? I think unit-test here wouldn't tell us much because influx would have to mocked anyway
15:34:08 <tomasztrebski> *have to be mocked
15:34:17 <rhochmuth> tempest tests are integration tests
15:34:24 <tomasztrebski> yeah, I know that
15:34:27 <rhochmuth> ok
15:35:01 <rhochmuth> i don't think unit tests would work well, if the problem is related to influxdb
15:35:13 <rhochmuth> there might be one that you come up with if the problem is in our code though
15:35:29 <tomasztrebski> that's also my opinion, just think that it is best thing to clarify some stuff
15:36:00 <tomasztrebski> that's all from my side
15:36:13 <rhochmuth> so what did we decide fo rthis review
15:36:24 <rhochmuth> should it get reviewed and merged
15:36:32 <rhochmuth> or do we need to test and validate further?
15:36:58 <ddieterly> we need to test and validate further, i think
15:37:14 <rhochmuth> ok
15:37:14 <tomasztrebski> IMHO, I am not the fan of merging something useless or not validated, so let's validate that
15:37:40 <rhochmuth> so shoudl we mark that review as a work in progress
15:37:56 <rhochmuth> or -1 until we know more
15:37:58 <ddieterly> i think we can leave it as is
15:38:07 <rhochmuth> ok
15:38:17 <ddieterly> it needs rebasing though
15:38:25 <ddieterly> tomasztrebski: could you please rebase it?
15:38:50 <tomasztrebski> ddieterly: of course, I wanted to discuss it first
15:38:54 <ddieterly> (sounds like we are cooking a turkey)
15:39:05 <tomasztrebski> I'll take care of it tommorow
15:39:11 <ddieterly> thanks
15:39:38 <rhochmuth> mroderus, do you need any slides from me
15:39:44 <rhochmuth> or diagrams
15:39:55 <ddieterly> tomasztrebski: the sooner the better so i can validate it
15:39:59 <rhochmuth> i have today, tomorrow and friday
15:40:09 <mroderus> rhochmuth: for now I'm fine. I'll send you an updated set later
15:40:16 <rhochmuth> i think we shoudl also get together on monday/tuesday
15:40:24 <rhochmuth> ok, please let me know what you need from me
15:40:33 <mroderus> ok, thanks
15:40:37 <rhochmuth> if you need changes, different colors, … let me know
15:41:18 <rhochmuth> ok, winding down here i think
15:41:21 <tomasztrebski> ddieterly: I know but I cannot do that today, personal reasons to take care
15:41:25 <mroderus> let's get together on Tuesday. On Monday we (fujitsu) will arrive late
15:41:35 <rhochmuth> sounds good
15:41:40 <bklei> rhochmuth: any updates on caching change in monasca-api?
15:41:41 <rhochmuth> i'll be in on Sunday
15:41:43 <ddieterly> tomasztrebski: ok, no problem
15:41:53 <rhochmuth> no updates on caching
15:42:16 <bklei> ok, probably won't get to it till a bit after tokyo?
15:42:25 <bklei> just wondering where it falls in your priorities
15:42:52 <ddieterly> roland is talking to someone in his cube, so there will be a slight delay...
15:43:02 <bklei> np
15:43:31 <rhochmuth> sorry,
15:44:29 <rhochmuth> i'm back
15:44:56 <rhochmuth> so, probably not going to get worked on right now
15:45:34 <bklei> ok -- if i get through pre-join projections task, i'll ping you to see if you've started, might take a stab at it.  big blocker for us at twc.
15:45:50 <rhochmuth> ok, and sorry
15:46:00 <rhochmuth> thought i would have more time to take a stab
15:46:08 <bklei> np
15:46:11 <rhochmuth> but didn't work out this last week
15:46:17 <rhochmuth> and won't get to it next week
15:46:35 <rhochmuth> we could do a mini design review
15:46:36 <bklei> sure
15:46:57 <bklei> cool, let's do that when one of us starts looking at it
15:47:02 <bklei> whoever gets there first
15:47:05 <rhochmuth> so, if you want to talk about that let me know
15:47:11 <bklei> k
15:47:25 <rhochmuth> i don't think the code will be difficult
15:48:02 <rhochmuth> so, anything else to discuss
15:48:47 <rhochmuth> that seems like we are done
15:48:50 <tomasztrebski> I dont know if anyone did that, but we've been checking influxdb newer version (the same you wanted to upgrade to) and it looks like
15:48:58 <tomasztrebski> either backup or restore dont work
15:49:12 <tomasztrebski> depends where you are in commit tree
15:49:26 <rhochmuth> we haven't been looking at it
15:49:34 <rhochmuth> but fabio has possibly
15:49:42 <rhochmuth> i would check with him
15:50:08 <tomasztrebski> just a hint then, anyway the speed new commits pop out in influxdb is...wow...
15:50:13 <tomasztrebski> the close one bug, make a new...
15:50:17 <tomasztrebski> *they
15:50:33 <ddieterly> yea, it's total whack-a-mole
15:50:49 <tomasztrebski> so basically, if fabio didn't do that, I believe it is useful to know
15:51:24 <tomasztrebski> tell me 'bout it...I dont think we can ever reach that dev speed they have...no brakes at all
15:51:30 <tomasztrebski> ok, I am out of topics :)
15:51:52 <rhochmuth> i saw fujitsu is presenting on tuesday
15:51:58 <rhochmuth> is there anythign monasca related to that
15:52:50 <rhochmuth> i see Monasca in the abstract
15:52:53 <rhochmuth> so i guess so
15:52:54 <rhochmuth> cool
15:53:05 <tomasztrebski> that's Witek's area, you there Witek ?
15:53:07 <witek> mroderus: do you know more about?
15:53:17 <rhochmuth> https://openstacksummitoctober2015tokyo.sched.org/event/c8181e87983356eec12981fd9ed1f3fe?iframe=yes&w=i:0;&sidebar=yes&bg=no#?iframe=yes&w=i:100;&sidebar=yes&bg=no
15:53:18 <witek> no, we're on thursday
15:53:28 <rhochmuth> https://openstacksummitoctober2015tokyo.sched.org/event/c8181e87983356eec12981fd9ed1f3fe?iframe=yes&w=i:0;&sidebar=yes&bg=no#?iframe=yes&w=i:100;&sidebar=yes&bg=no
15:53:57 <rhochmuth> Fujitsu- Introduction of Fujitsu's OpenStack Approach on Tuesday at 4:40
15:54:31 <witek> yes, but i'm not involved
15:54:35 <mroderus> Yes, this is the vendor session from Fujitsu. A Japanese manager is going to talk. He wants to mention Fujitsu's contributions to OpenStack projects, among these our activities in Monasca
15:54:43 <rhochmuth> cool
15:54:54 <mroderus> I will not be on the stage
15:55:03 <tomasztrebski> not cool
15:55:08 <rhochmuth> lol
15:55:15 <mroderus> I'm OK with that :)
15:55:27 <rhochmuth> ok, i think we're done
15:55:34 <rhochmuth> see some of you next week
15:55:39 <tomasztrebski> cool, thx and see you next time
15:55:40 <ddieterly> ciao!
15:55:48 <witek> servus
15:55:52 <bklei> cya -- will watch you guys on youtube
15:56:02 <mroderus> see you!
15:56:28 <rhochmuth> #endmeeting