13:00:14 <chaconpiza> #startmeeting monasca
13:00:15 <openstack> Meeting started Tue Jun  9 13:00:14 2020 UTC and is due to finish in 60 minutes.  The chair is chaconpiza. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:19 <openstack> The meeting name has been set to 'monasca'
13:00:22 <witek> hi
13:00:27 <adriancz> hello
13:00:34 <chaconpiza> Hi Witek
13:00:38 <chaconpiza> Hi Adrian
13:00:54 <chaconpiza> The agenda as usual https://etherpad.opendev.org/p/monasca-team-meeting-agenda
13:01:00 <piotrowskim> hi
13:01:08 <chaconpiza> Hi Michal
13:01:33 <chaconpiza> Let's start with the previous action items
13:01:37 <chaconpiza> Hi Matthias
13:01:47 <bandorf> Hello
13:02:18 <chaconpiza> Thanks Witek for: remove ujson traces from notificatin and persister. Done.
13:02:48 <chaconpiza> #action Update kafka in monasca/monasca-docker:  Still ToDo.
13:03:08 <witek> you're welcome, was a small change
13:03:48 <chaconpiza> #topic Admin permissions in https://github.com/monasca
13:04:55 <chaconpiza> I think that currently nobody from Fujitsu Lodz/Munich has admin permissions there.
13:05:13 <chaconpiza> Dobek had, but he moved to a different project.
13:05:51 <chaconpiza> Witek, could you provide me with admin permissions?
13:06:06 <witek> sure, just checking
13:07:15 <witek> sent an invitation
13:07:28 <chaconpiza> Thanks
13:07:34 <Wasaac> o/
13:07:45 <chaconpiza> Hi Isaac
13:08:15 <witek> chaconpiza: please let me know, if I've used the right account
13:08:36 <chaconpiza> in Github:  martinchacon
13:09:07 <witek> now then
13:09:14 <chaconpiza> thanks
13:09:20 <chaconpiza> #topic Shellcheck URL update (monasca/monasca-docker)
13:10:04 <chaconpiza> Recently I sent a PR to Fujitsu's Fork. The Travis CI was red because of old URL for bash shelchecker.
13:10:31 <chaconpiza> in upstream repo we use the same url
13:10:58 <chaconpiza> #action send a PR to monasca/monasca-docker with the updated url.
13:11:27 <witek> thanks chaconpiza
13:11:32 <chaconpiza> #topic Drop mock
13:11:50 <chaconpiza> https://review.opendev.org/#/q/(projects:openstack/monasca+OR+project:openstack/python-monascaclient)+topic:drop_mock
13:12:23 <chaconpiza> This is the 2nd set of changes related to use unittest, since PY2 is not supported anymore.
13:12:41 <chaconpiza> Most of the changes can be merged without issues.
13:13:36 <chaconpiza> As well this past week we received set of changes to remove the Future, same because of Py not supported anymore
13:14:08 <chaconpiza> #topic Strange behavior of Zuul in one test
13:14:28 <chaconpiza> In this change Zuul does not start, I can't find the reason
13:14:35 <chaconpiza> https://review.opendev.org/#/c/729279/
13:14:41 <chaconpiza> any ideas?
13:14:53 <witek> I think it's because there's no job defined to run
13:16:17 <chaconpiza> Strange because this one triggers Zuul https://review.opendev.org/#/c/725200/
13:17:09 <witek> but it also adds new jobs
13:17:09 <chaconpiza> is it because the definition of the job is part of the Michal's change?
13:17:17 <witek> right
13:17:19 <chaconpiza> "ach so"
13:17:25 <chaconpiza> ok
13:17:42 <piotrowskim> tests were turned off if i remember correctly to merge Arseni change
13:18:29 <witek> and tempest tests are not run on documentation changes
13:18:36 <chaconpiza> Michal, how are you doing with that change? Is any blocker?
13:19:33 <adriancz> log test are  defined in zuul file
13:19:36 <adriancz> https://github.com/openstack/monasca-kibana-plugin/blob/master/.zuul.yaml#L4
13:20:20 <piotrowskim> yeah, we have in package.json hardcoded paths to dependencies needed to create plugin, working on that, two tests are red cause they are using npm, i m trying to find if it is possible to run it with yarn
13:20:23 <piotrowskim> also
13:20:37 <adriancz> yes, witek you are right
13:21:11 <witek> build-monasca-kibana-plugin is green, does it run correctly?
13:21:18 <piotrowskim> on infra ajaeger wrote me that it is possible to run lint with different package manger, like yarn, but I need to add this job first for lint
13:21:37 <piotrowskim> yeah, cause on this job i just copy all things i need
13:21:44 <piotrowskim> to build plugin
13:22:11 <witek> so I guess we could merge configuration for `build-monasca-kibana-plugin` first
13:22:19 <witek> and skip linter tests for now
13:22:31 <adriancz> + 1
13:23:00 <piotrowskim> ok
13:23:16 <chaconpiza> #action merge configuration for `build-monasca-kibana-plugin` first
13:23:21 <chaconpiza> Thanks Michal
13:24:06 <chaconpiza> #topic vPTG
13:24:47 <chaconpiza> besides our two Monasca sessions, I went into the Automation-SIG session on Thursday
13:25:00 <witek> nice
13:25:16 <chaconpiza> Only Rico Lin and me were present. He gave me an introduction about the Autoscaling
13:25:30 <witek> :(
13:25:58 <chaconpiza> now self-healing project is merged with autoscaling
13:26:19 <chaconpiza> I have a lot to read
13:26:33 <witek> did he give any update on testing autoscaling changes?
13:26:53 <chaconpiza> not in detail
13:27:06 <chaconpiza> but showed me the repo
13:28:25 <witek> I've tested it in DevStack in January or Feb and has worked as expected
13:28:38 <witek> but there seems to be some issue in CI job
13:28:52 <chaconpiza> Yes, remember he mentioned it
13:29:24 <chaconpiza> Ok, in previous releases a StoryBoard for Monasca was created to keep track on the activities. I consider it is a good idea.
13:29:45 <chaconpiza> #action create a board for Victoria release.
13:30:14 <witek> +1
13:30:42 <chaconpiza> Those are all topics from the agenda.
13:30:56 <chaconpiza> #topic AOB
13:32:52 <chaconpiza> If there are not more topics, let's finish the meeting for today.
13:32:57 <witek> so you'll summarize the AI from PTG in StoryBoard?
13:33:18 <chaconpiza> Yes
13:33:41 <witek> sounds good
13:34:04 <witek> we could add/edit details in the individual Stories
13:35:01 <chaconpiza> I have not created a board there, but I don't thing is difficult.
13:35:46 <witek> no, it's not, as you don't try to make it automatic
13:36:10 <witek> automatic boards are very limited
13:36:35 <chaconpiza> Manual should be enough for us
13:36:41 <witek> +1
13:37:00 <chaconpiza> Al right, thanks for coming today and thanks for the long discussions on last Tuesday.
13:37:16 <witek> thank you, see you next week
13:37:21 <chaconpiza> See you next Tuesday. Bye.
13:37:23 <bandorf> Bye everybody, have a nice day
13:38:06 <chaconpiza> #endmeeting