13:00:03 <chaconpiza> #startmeeting monasca
13:00:04 <openstack> Meeting started Tue Jun 16 13:00:03 2020 UTC and is due to finish in 60 minutes.  The chair is chaconpiza. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:07 <openstack> The meeting name has been set to 'monasca'
13:00:19 <chaconpiza> Hello Isaac
13:00:25 <chaconpiza> hello Witek
13:00:31 <witek> hi Martin
13:01:20 <chaconpiza> Today I will be the only one from Fujitsu, my colleagues are on sick leave or could attend today.
13:01:34 <chaconpiza> The agenda as usual https://etherpad.opendev.org/p/monasca-team-meeting-agenda
13:01:53 <chaconpiza> Let's start with the Action items
13:02:04 <witek> oops, looks like epidemic
13:02:36 <chaconpiza> :)
13:03:07 <chaconpiza> Ok, in monasca/monasca-docker the Shellscript was fixed by updating the url
13:03:16 <chaconpiza> it is ready to be merged. https://github.com/monasca/monasca-docker/pull/533
13:03:33 <chaconpiza> Same change was done in our fork
13:04:08 <witek> looks straight forward, will have a look after the meeting
13:04:20 <chaconpiza> Thanks Witek
13:04:26 <witek> #action witek review https://github.com/monasca/monasca-docker/pull/533
13:04:59 <chaconpiza> I have created this Board: https://storyboard.openstack.org/#!/board/217
13:05:33 <chaconpiza> With the most important milestones. Similar to Ussuri's Board
13:05:51 <witek> The lanes are empty for me
13:06:10 <chaconpiza> Yes it is empty
13:06:38 <chaconpiza> And the priorities hasn't been set yet. https://specs.openstack.org/openstack/monasca-specs/priorities/
13:07:30 <witek> how should we proceed?
13:07:30 <Wasaac> Victoria-1 milestone in only 3 days
13:07:42 <chaconpiza> Let's go like in previous releases. With a spreadsheet to prioritize and assign. I will create it today.
13:07:51 <witek> nice, thanks
13:08:05 <chaconpiza> #action Priorities spreadsheet
13:08:31 <chaconpiza> Yes Isaac, I got the dates from here https://releases.openstack.org/victoria/schedule.html
13:09:09 <chaconpiza> Rest of action items aren't done yet.
13:09:34 <chaconpiza> #topic OpenInfra Labs discussion on cloud monitoring
13:09:51 <chaconpiza> Please Witek stage is yours
13:10:18 <witek> I have put together the references to some monitoring related discussions in the last two weeks
13:11:06 <witek> the first one is from the openinfralabs ML
13:11:42 <witek> they have had few threads about monitoring in the last months
13:11:54 <witek> you can look it up in the archive if interested
13:12:25 <witek> the last one is about collecting requirements for New England
13:12:25 <witek> Research Cloud monitoring infrastructure
13:13:31 <witek> Wasaac: are they also active in Scientific SIG?
13:13:58 <witek> http://lists.opendev.org/pipermail/openinfralabs/2020-June/000061.html
13:14:13 <Wasaac> Not personally involved in the scientific sig but I believe so
13:16:02 <witek> from what I read in the ML they're looking for Prometheus based solution, could be interesting to look at their requirements and see if Monasca can meet them
13:16:36 <witek> with the `new Prometheus direction` as discussed in PTG
13:17:46 <witek> that's all on this
13:17:47 <chaconpiza> witek, could you continue following this thread?
13:18:22 <chaconpiza> #topic Oslo metrics
13:18:23 <witek> yes
13:19:07 <witek> the first implementation of new library oslo.metrics has been published
13:20:23 <witek> the goal is to allow some instrumentation of OpenStack services
13:21:10 <witek> the effort was coordinated by the Large Scale SIG
13:22:44 <chaconpiza> How oslo.metrics is linked to Monasca?
13:23:31 <witek> it is not directly linked, it exposes Prometheus endpoint which can be scraped with Monasca agent plugin
13:24:29 <witek> another option could be to extend oslo.metrics and add mechanism of sending StatsD metrics
13:25:47 <witek> I think the first option should work well
13:26:19 <witek> after upstreaming StackHPC's plugin we could add documentation how to use oslo.metrics with Monasca
13:27:54 <chaconpiza> In the documentation we have: "Prometheus
13:27:54 <chaconpiza> The Monasca Agent supports scraping metrics from endpoints provided by Prometheus exporters or Prometheus instrumented applications."
13:28:03 <chaconpiza> https://github.com/openstack/monasca-agent
13:28:48 <witek> that's true, but the existing plugin is very Kubernetes centric
13:29:11 <chaconpiza> https://github.com/openstack/monasca-agent/blob/master/conf.d/prometheus.yaml.example
13:30:22 <chaconpiza> Is something blocking to add the StackHPC plugin into the upstream Monasca-Agent repo?
13:31:09 <witek> as I said, it should work already, the new agents adds some extra features
13:31:12 <witek> https://github.com/stackhpc/stackhpc-monasca-agent-plugins
13:31:54 <witek> I think only dougsz's bandwidth :)
13:31:55 <chaconpiza> it sounds great
13:32:51 <chaconpiza> Ok, let's ask him about it.
13:33:16 <chaconpiza> #topic Large Scale SIG
13:33:20 <dougsz> sorry, missed the start, I will propose it soon
13:33:37 <chaconpiza> Hello Doug
13:33:45 <chaconpiza> thanks
13:33:53 <witek> great, thanks
13:34:36 <witek> the next point is from the same meeting's notes
13:35:36 <witek> in the Scientific SIG's PTG came up the topic about billing which was cross-referenced here
13:36:44 <witek> Large Scale SIG wants to collect now information about how metrics/billing information is collected
13:36:52 <witek> https://etherpad.opendev.org/p/large-scale-sig-documentation
13:38:26 <witek> the last monitoring related discussion happened during TC vPTG
13:38:39 <witek> the summary has been presented here:
13:38:46 <witek> http://lists.openstack.org/pipermail/openstack-discuss/2020-June/015418.html
13:39:25 <witek> and some more notes in the etherpad
13:39:31 <witek> https://etherpad.opendev.org/p/tc-victoria-ptg
13:39:59 <witek> the discussion was mainly triggered by the state of Telemetry and Gnocchi projects
13:41:46 <witek> I think we should promote Monasca as a valid alternative for Gnocchi backend
13:43:30 <chaconpiza> I am not familiar with all the features of Telemetry and Gnocchi. What we are missing to cover that functionallity?
13:45:07 <witek> Gnocchi is the default TSDB for Ceilometer, it can be 1:1 replaced with Monasca API
13:45:56 <witek> Aodh is Telemetry alerting service, it can trigger alerts based on Oslo notifications
13:46:23 <witek> to my knowledge that's the only thing we cannot do
13:47:36 <chaconpiza> Isn't it the first part 'Gnocchi is the default TSDB for Ceilometer, it can be 1:1 replaced with Monasca API'  the goal of Ceilosca?
13:48:06 <witek> correct
13:49:47 <chaconpiza> I will add this topic in the spreadsheet
13:50:18 <witek> ok
13:51:17 <chaconpiza> Thanks for following all this ML and etherpads related to Monitoring
13:51:43 <chaconpiza> #topic AOB
13:53:19 <chaconpiza> Ok, then we can close the meeting for today.
13:53:31 <witek> thanks
13:53:36 <chaconpiza> Thanks Doug, Issac and Witek for joining today
13:53:54 <Wasaac> o/
13:53:58 <chaconpiza> o/
13:54:02 <witek> bye
13:54:15 <chaconpiza> bye
13:54:17 <chaconpiza> #endmeeting