13:00:36 <chaconpiza> #startmeeting monasca
13:00:37 <openstack> Meeting started Tue Jul 21 13:00:36 2020 UTC and is due to finish in 60 minutes.  The chair is chaconpiza. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:40 <openstack> The meeting name has been set to 'monasca'
13:00:56 <chaconpiza> Hello
13:01:02 <witek_> hi
13:01:06 <bandorf> Hello
13:01:25 <adriancz> hi
13:01:28 <chaconpiza> Hi Witek
13:01:32 <chaconpiza> Hi Matthias
13:01:36 <chaconpiza> Hi Adrian
13:01:39 <chaconpiza> The agenda as usual https://etherpad.opendev.org/p/monasca-team-meeting-agenda
13:02:12 <chaconpiza> Before to start with the agenda let's go for the previous action items
13:03:16 <chaconpiza> Thanks for the changes for "Set legacy_kafka_client_enabled = False on default"
13:03:48 <chaconpiza> they are being merged
13:04:37 <witek_> I guess I have to recheck https://review.opendev.org/740954
13:06:08 <chaconpiza> Zuul didn't start the gate job?
13:06:14 <witek_> no
13:07:08 <witek_> now, rerunning check job
13:07:22 <chaconpiza> Ok,
13:07:55 <chaconpiza> the next action item is related to https://review.opendev.org/#/c/722515/5
13:08:25 <chaconpiza> It fails because in Victoria py38 is voting
13:09:03 <chaconpiza> So, I removed the testcase that brakes it https://review.opendev.org/#/c/742167
13:09:12 <chaconpiza> and rebased on top of it
13:09:54 <witek_> fine with me if that works
13:09:55 <chaconpiza> Nevertheless it is taking too long the py38 check. Something is wrong there.
13:10:05 <chaconpiza> I will check it
13:11:01 <chaconpiza> The next action from last week came from Luigi: https://github.com/openstack/monasca-transform/blob/master/.zuul.yaml#L10
13:11:59 <witek_> it's mine, no progress yet
13:12:31 <chaconpiza> witek_, I am not sure how to removed it, whether all file or only lines 10-14
13:12:51 <witek_> I'll take care
13:13:04 <chaconpiza> Great, thanks
13:14:04 <chaconpiza> The next action  from two week ago is about the migration of CI/CD jobs to new Ubuntu LTS Focal. I will focus on this task this week.
13:15:04 <chaconpiza> Then let's start with today topics...
13:15:23 <bandorf> OK
13:15:26 <chaconpiza> #topic Issues with monasca-agent (Ussuri)
13:15:34 <chaconpiza> Thanks Matthias
13:15:40 <bandorf> As described in agenda, just short overview here:
13:16:04 <bandorf> I started to test with monasca-agent for Ussuri and came across a few issues.
13:16:40 <bandorf> When testing this with devstack (thanks, Martin and Witek), http_check was not running at all
13:17:05 <bandorf> The additional error in devstack (wrong config) has been fixed already.
13:17:28 <bandorf> However, finally my conclusion was: agent testing is not sufficient.
13:18:22 <bandorf> See 1.3 for some initial proposals.
13:18:42 <chaconpiza> *it is merged in Master ^^ and it is being merged the cherry-pick on Ussuri, Train is ok.
13:19:02 <bandorf> I forgot: Thanks, Martin, for providing the fix in devstack
13:19:59 <witek_> from my point of view, we could add two kinds of tests
13:20:31 <witek_> * unit tests - they should catch regexp issues with Python 3
13:21:35 <witek_> * functional tests - checking that provided configuration provides expected metrics on a given OpenStack deployment
13:22:23 <bandorf> Yes, agreed. Currently, the only Openstack service installed is keystone, I think
13:23:01 <witek_> in our CI, yes
13:23:04 <chaconpiza> ^^The only one OpenStack service using the vagrant file from monasca-api repo
13:23:06 <chaconpiza> yes
13:23:57 <chaconpiza> it should be enough for the test
13:24:14 <bandorf> Maybe, I don't know, should be checked
13:24:33 <witek_> we could check if running any tests with Kolla would be possible
13:25:36 <witek_> chaconpiza: optimally all core services should be tested
13:26:33 <chaconpiza> Yes, I see.
13:27:25 <chaconpiza> Other issue is causing troubles in our new deploy is reading from /proc
13:27:44 <chaconpiza> Matthias do you want me to introduce the topic?
13:28:28 <bandorf> Let's quickly finalize the testing topic. How to continue? Action item?
13:28:37 <chaconpiza> alright
13:29:08 <bandorf> My proposal:
13:29:40 <bandorf> I could work on the specification (as a first step). But not in the next 2-4 weeks.
13:30:09 <bandorf> Witek, could you explain your idea with "tests with Kolla"?
13:30:16 <bandorf> I don't understand this
13:30:23 <bandorf> Not necessarily now
13:30:45 <witek_> I was wondering if there's any Kolla CI job installing OpenStack including Monasca
13:31:05 <bandorf> Ah, ok. Could you check this part?
13:31:23 <witek_> if yes, we could write simple tests checking if API can return expected metrics at the end of the run of such CI job
13:31:53 <witek_> we could do the same with DevStack, but it's more far away from real deployment
13:32:07 <bandorf> Yes, I agree
13:33:20 <witek_> the first to start with, should be just adding unit tests
13:35:10 <bandorf> Yes. As said, I can work on this, but not in the next cpl. of weeks.
13:36:00 <witek_> do we have a bug report for this?
13:36:23 <chaconpiza> #action I will create the story about it and add it to the board
13:36:47 <chaconpiza> affected branches are master and ussuri
13:39:12 <bandorf> Of course, I will fix the bugs I detect. I mainly brought it up here to discuss the lack of testing
13:40:53 <witek_> reporting the bugs helps to share the effort, someone can pick it up
13:42:58 <chaconpiza> Alright lets move to the next part of the monasca-agent, the time is running away... ;)
13:43:05 <bandorf> ok
13:43:13 <chaconpiza> We noticed that in an OpenStack deployment where the services run bare-metal we end-up with users and groups created on the operating system, like cinder, keystone, etc.
13:43:36 <chaconpiza> those users are the owners of some directories in /proc
13:43:58 <chaconpiza> Then the mon-agent user (with the sudoers permissions) can read the info from /proc and generate the associated metrics.
13:44:17 <chaconpiza> But in a deploy where the OpenStack services run on containers
13:44:34 <chaconpiza> we found in /proc that there are directories without user/group but only with user ID.
13:45:16 <chaconpiza> The mon-agent can't read them even with sudoers permissions.
13:46:11 <chaconpiza> Is inside of each container  where the users/groups are created, like cinder for example.
13:46:44 <chaconpiza> We are wondering whether in the deploy with kolla-ansible they have a similar situation
13:46:45 <bandorf> Some additional info: the numeric user-id that can be seen on the host is the user-id of the related user in the container (e.g. cinder). But this user doesn't exist on the host
13:46:58 <bandorf> OK, sorry, you wrote it alread :-)
13:47:06 <chaconpiza> ;-)
13:47:49 <witek_> is it the user ID mapping issue, or general lack of permissions inside the container?
13:48:14 <bandorf> No, the issue is that the user doesn't exist on the host.
13:48:49 <chaconpiza> right, in the /proc directory inside the containers it is ok
13:50:13 <bandorf> The agent is reading from /proc, and I wouldn't like to change this...
13:50:59 <chaconpiza> (reading from the /proc in the bare-metal host)
13:53:23 <chaconpiza> One step forward maybe is to deploy at least once using Kolla-Ansible to get familiar with that.
13:53:51 <chaconpiza> Is not the same like TripleO, but both share the images
13:54:33 <witek_> that would be good in any case
13:55:22 <chaconpiza> #topic AOB
13:55:54 <chaconpiza> we still have few minutes for any other topic
13:56:07 <adriancz> i have one small topic
13:56:37 <adriancz> i created stable/pike branch in monasca/monasca-agents-installer repository
13:57:59 <chaconpiza> ^^ Because of specific changes using only master is not enough to create agents for the different branch releases
13:58:17 <adriancz> i created this branch because we still need to suport old version of monasca-log-agent installer base on old logstash version
13:58:43 <witek_> makes sense
13:59:23 <chaconpiza> Thanks for bringing the topic Adrian
13:59:32 <chaconpiza> Lets close the meeting
13:59:48 <chaconpiza> Thanks for coming today
13:59:55 <bandorf> Bye
14:00:08 <chaconpiza> bye
14:00:10 <adriancz> thank bye :  )
14:00:14 <witek_> thanks, bye
14:00:17 <chaconpiza> #endmeeting