13:00:04 <chaconpiza> #startmeeting monasca
13:00:05 <openstack> Meeting started Tue Aug 18 13:00:04 2020 UTC and is due to finish in 60 minutes.  The chair is chaconpiza. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:08 <openstack> The meeting name has been set to 'monasca'
13:00:18 <piotrowskim> hi
13:00:18 <chaconpiza> Hi Matthias
13:00:24 <chaconpiza> Hi Michal
13:00:48 <chaconpiza> The agenda as usual https://etherpad.opendev.org/p/monasca-team-meeting-agenda
13:01:02 <Wasaac> Hello!
13:01:09 <chaconpiza> Hi Isaac
13:01:37 <chaconpiza> Let's start with first topic
13:01:53 <chaconpiza> #topic Alarm-definition which breakes the Alarm view of Monasca-UI
13:02:22 <chaconpiza> Michal the stage is yours
13:02:50 <piotrowskim> It was noticed that defined alarm breaks alarm view, e.g count(process.pid_count{hostname=devstack}>4
13:03:43 <piotrowskim> It was exeption in for loop, cause in Python 2.x calling 'keys' makes a copy of the key that you can iterate over while modifying the dict. This doesn't work in Python 3.x because keys returns an iterator instead of a list.
13:04:08 <piotrowskim> so as a simple fix I just casted dictionary to tuple (could be list also)
13:05:18 <chaconpiza> The change is merged in monasca-ui project for master and stable/ussuri branches
13:05:28 <piotrowskim> true
13:06:35 <chaconpiza> Isaac, StackHPC should not be affected since you are not using Monasca-UI (Monasca Plugin for Horizon)
13:06:54 <Wasaac> Indeed
13:07:14 <Wasaac> We tend to use the monasca-grafana app
13:07:20 <chaconpiza> right
13:07:34 <chaconpiza> Thanks for the fix Michal
13:07:45 <piotrowskim> not a problem
13:07:50 <chaconpiza> Let's move to the next topic
13:08:04 <chaconpiza> #topic Changes for monasca-agent
13:08:30 <bandorf> Ok. This is a summary of the issues I found during the last weeks when testing monasca-agent (Ussuri-based)
13:08:37 <bandorf> Overall 3 issues:
13:09:16 <bandorf> 2.1 Remaining Python3-incompatibility: string handling. Solution was to convert to utf-8
13:11:19 <chaconpiza> This change 2.1 is quite similar to this other change from Doug https://github.com/openstack/monasca-agent/commit/7ff2c9cbd0324f04a96a9b115ded262ec2d7fa02
13:11:51 <bandorf> Sorry, I got disconnected
13:11:58 <bandorf> 2.2 A single quote in a help-text caused issues with baremetal-agent. I wanted to avoid any issues with escaping etc, thus I changed the help test so that quote is not needed any longer
13:12:33 <bandorf> 2.3 Just a minor issue, but not nice: For http_check, a pattern_matching can be defined.#
13:12:50 <bandorf> For cinder, this has been set to check if api-version is 1.
13:13:09 <bandorf> However, version 1 is not supported any longer (not even deprecated)
13:13:41 <bandorf> Solution was to simplay allow any API version that existed, i.e. all between 1 and 3
13:14:04 <bandorf> All these fixes have been done on master and cherry-picked to Ussuri
13:14:24 <bandorf> We applied for a new monasca-agent version (3.0.2) for Ussuri
13:14:47 <chaconpiza> https://review.opendev.org/#/c/746684/
13:15:35 <chaconpiza> Thanks Matthias
13:16:31 <chaconpiza> #topic Switch monasca-thresh and monasca-ui to cycle-with-rc
13:17:37 <chaconpiza> Sean McGinnis proposed to change these to projects from model cycle-with-intermediary to cycle-with-rc
13:17:51 <chaconpiza> https://releases.openstack.org/reference/release_models.html#cycle-with-rc
13:18:21 <bandorf> Could you pls. briefly explain what that exactly means?
13:20:20 <bandorf> OK, I checked the link
13:21:00 <chaconpiza> Ok, I was rephrasing the text
13:22:07 <bandorf> So, this means that only the release is checked by release mgmt. team, mnot the rc's, right?
13:22:17 <chaconpiza> I am not sure why in Monasca we have for some projects one model and for other the second model. I would like to ask Witek about it. If there is not a special reason, I would like to uniform them.
13:22:46 <bandorf> Exactly. Maybe, this model fits better with ther components as well?
13:22:56 <bandorf> ther=other
13:23:41 <chaconpiza> bandorf, not so sure. I will ask Sean for more details.
13:24:07 <bandorf> Ok. To me, the impact isn't totally clear yet
13:24:56 <chaconpiza> ok
13:25:07 <chaconpiza> #topic AOB
13:27:03 <chaconpiza> I just got the notification that Sean approved the Release Monasca-Agent 3.0.2 with the changes that Matthias commented above.
13:27:22 <bandorf> That went fast, really good news!
13:27:24 <chaconpiza> Soon it will be available in https://pypi.org/project/monasca-agent/
13:28:04 <chaconpiza> Ok, if there are not more topics let's close the meeting.
13:28:23 <bandorf> Thanks, good-bye everybody!
13:29:02 <chaconpiza> Thank you for your attendance, see you next week. Bye.
13:29:48 <tosky> uh! just a minute
13:29:57 <chaconpiza> Sure
13:30:00 <tosky> if I may, quick reminder about the zuulv3 goal
13:30:29 <tosky> maybe you are already working on it, but I haven't seen a patch for     legacy-tempest-dsvm-monasca-transform-python35-functional (monasca-transform)
13:30:33 <chaconpiza> Hi Luigi. You mean the monasca-transform, right?
13:30:40 <tosky> yep, that's the main one
13:31:18 <tosky> while rechecking the jobs, I've also noticed 3 other legacy jobs. They are not based on devstack, so they are slightly less urgent, but something to keep an eye on too
13:31:21 <tosky> namely:
13:31:27 <tosky> legacy-monasca-common-maven-build (monasca-common, <=master)
13:31:29 <tosky> legacy-monasca-persister-maven-build (monasca-persister, <=master)
13:31:31 <tosky> legacy-monasca-thresh-maven-build (monasca-thresh, <=master)
13:31:36 <chaconpiza> As far as I remember Witek want to check it internally at SUSE. He is on vacation right now, but is coming back soon.
13:32:47 <chaconpiza> Ok, thanks for the notice.
13:34:52 <tosky> thanks! Now that we are closer to Victoria, I guess you will hear more frequently from me :)
13:34:59 <tosky> (that's absolutely not a thread)
13:35:03 <tosky> threat*
13:35:12 <tosky> :)
13:35:20 <chaconpiza> :) Thanks for your colaboration in Monasca
13:36:25 <chaconpiza> #action Check java legacy jobs. I will check it.
13:37:07 <chaconpiza> alright, if there are no more topics let's close for today the meeting. Thanks.
13:38:14 <chaconpiza> #endmeeting