13:00:07 <chaconpiza> #startmeeting monasca
13:00:08 <openstack> Meeting started Tue Sep  1 13:00:07 2020 UTC and is due to finish in 60 minutes.  The chair is chaconpiza. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:11 <openstack> The meeting name has been set to 'monasca'
13:00:26 <chaconpiza> Hello
13:00:29 <chaconpiza> The agenda as usual https://etherpad.opendev.org/p/monasca-team-meeting-agenda
13:00:57 <Wasaac> Hello!
13:01:01 <ezech> hi
13:01:09 <chaconpiza> Hi Isaac
13:01:14 <chaconpiza> Hi ezech
13:01:40 <bandorf> Hi
13:02:04 <chaconpiza> before to start with the topics from the agenda, ezech would you like briefly to present your self and the project/firma you work?
13:02:08 <chaconpiza> Hi Matthias
13:02:32 <adriancz> Hi
13:02:40 <chaconpiza> Hi Adrian
13:04:00 <ezech> sure, I'm a devops-engineer from Poland, and I'm working on a r&d project for Comarch
13:04:18 <chaconpiza> What is your name?
13:04:23 <Wasaac> Welcome!
13:04:57 <ezech> chaconpiza, my name is Arkadiusz
13:05:13 <chaconpiza> Welcome Arek
13:05:35 <chaconpiza> For your info. Monasca has been contributed by many Poles
13:05:52 <chaconpiza> alright, lets start with the topics
13:06:11 <chaconpiza> #topic Template to deploy Monasca during Overcloud deployment
13:06:23 <chaconpiza> Arek, the stage is yours
13:06:57 <ezech> thanks, here is the setup: a triple-o ussuri on some blades
13:07:23 <ezech> what we want is to have monitoring solution for it
13:07:50 <ezech> to monitor ground up, for hardware, all virtualisation levels up to the applications running on top
13:08:41 <ezech> my team and I have made some progress with installing monasca on previous versions of openstack and monasca, using different approaches, and it looks nice to us
13:09:00 <ezech> now what we want is to have monasca be installed by triple-o deployment mechanism
13:09:38 <ezech> so when we write roles for our environment, we can add for example  OS :: TripleO :: Services :: MonascaApi
13:10:35 <ezech> my question is - do you know anyone who has done it before (couldn't find it) and what you think this sounds like - does it make sense to you
13:11:35 <chaconpiza> You mean that Monasca-API will run in a container?
13:12:13 <ezech> chaconpiza, yes, as with triple-o all services run in containers
13:12:16 <chaconpiza> I understand that TripleO uses the images created by Kolla project
13:12:59 <ezech> it does, we can also provide custom versions of images I believe
13:13:59 <ezech> also there are different modules for monasca and I'd see each one be defined as a triple-o service, so for different roles different services/modules be deployed
13:15:04 <chaconpiza> So far the deployment of Monasca is done fore Docker-Compose, Kubernetes, Kolla-Ansible, Devstack. But not yet for TripleO.
13:15:09 <ezech> perhaps there would be a Monasca role for all main modules (persister, api, notification) and existing roles (controller for example) would have only monasca-agent service
13:16:10 <chaconpiza> and adding Monasca into TripleO would bring the attention of the community to Monasca as well
13:20:09 <chaconpiza> Answering your question, I don't know anyone who has done it before. Maybe in TripleO docs there is info on how to create the templates and the definitions for adding new services
13:21:16 <chaconpiza> Have you asked about it in the TripleO channel?
13:22:07 <ezech> I haven't yet, we are in the progress of producing such services though and so far we manage to go forward using documentation
13:22:34 <ezech> it just occurred to me that perhaps it would be wise to ask for a second opinion at the source :)
13:24:13 <chaconpiza> I had the same situation, deploying TripleO Ussuri all-in-one and then deploying by hand monasca-agent, monasca-log-agent, adding by hand the Monasca-Horizon Plugin to the Horizon container, etc
13:24:35 <chaconpiza> And same situation with Redhat OSP-16
13:24:55 <chaconpiza> which containers are based on Train
13:25:48 <chaconpiza> Arek, let's keep it as an open topic.
13:26:00 <ezech> thanks chaconpiza
13:26:04 <tosky> for the record, there was an email about this a few days ago
13:26:14 <tosky> let me find it
13:26:16 <chaconpiza> Hi Luigi
13:26:31 <tosky> http://lists.openstack.org/pipermail/openstack-discuss/2020-August/016619.html
13:26:31 <ezech> I'll let you know if we succeed
13:26:54 <tosky> and the related bug https://bugs.launchpad.net/tripleo/+bug/1892072
13:26:55 <openstack> Launchpad bug 1892072 in tripleo "Missing manual for end-to-end third party integration" [High,Triaged]
13:28:56 <chaconpiza> Thanks for mentioning Luigi.
13:29:33 <chaconpiza> Let's move to the next topic
13:29:37 <chaconpiza> #topic Monasca-Persister Compatibility with py38
13:30:57 <chaconpiza> Today I have discussed with Adrian (adriancz) about the Cassandra tests which blocks the Zuul's check for py38
13:31:41 <chaconpiza> Those two test were usless actually.
13:33:09 <chaconpiza> I just rebase https://review.opendev.org/#/c/722515 on top of https://review.opendev.org/#/c/742167/ it should solved it.
13:33:47 <chaconpiza> #topic Broken URL http://monasca.io/
13:34:29 <chaconpiza> Today I found out that monasca.io is not accessible.
13:35:32 <chaconpiza> Same situation happened a year ago, it is because of the expiration of the domain.
13:35:53 <chaconpiza> it is registered, as far as I remember, by HP
13:36:59 <chaconpiza> #action I will contact them to see how we should proceed
13:37:58 <chaconpiza> The content is hosted in github https://github.com/monasca/monasca.github.io
13:38:53 <chaconpiza> #topic Remove deprecated YAML config (Monasca-Notification)
13:39:22 <chaconpiza> MichaƂ the stage is yours
13:39:42 <piotrowskim> last week I mentioned that it needs to be changed congfiguration for monasca-notification DOCKER part
13:40:00 <piotrowskim> in openstack/monasca-notification project of course
13:40:25 <piotrowskim> but we have also clone on github in monasca-docker repository
13:40:40 <piotrowskim> and I belive it should be changed there also
13:41:53 <chaconpiza> is there any blocker?
13:42:19 <piotrowskim> right now I dont see any
13:42:46 <chaconpiza> cool. Thanks
13:43:09 <chaconpiza> #topic AOB
13:45:26 <chaconpiza> Luigi, Witek is taking care about the Monasca-Transform deprecation. Today he is off-work, but next week should be present.
13:47:10 <chaconpiza> Alright, if there are no more topics, lets close todays meeting. Arek, welcome aboard.
13:47:11 <tosky> thanks!
13:47:30 <chaconpiza> Thanks, bye.
13:47:51 <adriancz> thanks
13:47:55 <adriancz> bye
13:48:09 <chaconpiza> #endmeeting